summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-battery-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-1.1.2.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-battery-plugin/Manifest b/xfce-extra/xfce4-battery-plugin/Manifest
index 31918738b73b..bbe08768ee1b 100644
--- a/xfce-extra/xfce4-battery-plugin/Manifest
+++ b/xfce-extra/xfce4-battery-plugin/Manifest
@@ -1,2 +1,3 @@
DIST xfce4-battery-plugin-1.1.0.tar.bz2 398621 BLAKE2B 461f32e07708c29f2157c8909ba48a43458c06c9622ec0835f4cf6abb0b1232bc35f23a7e945315eb2d49048b9c0023da3a27803cf95217374962531db986e97 SHA512 d3f5b6d3657abfba2c4c5cb3ab8ddc87f4862f24eb614cb91af48332b3082c3dce7f32eb2e3cb8a9d501ddb01c6259c4fbfbab8ed9c221633e47eb17c623cf09
DIST xfce4-battery-plugin-1.1.1.tar.bz2 465880 BLAKE2B 09f257226009de387b8965e8233aae9a0c756fa2c854f1bdf346e23638a0c55b7100c57eb33111c2f8e20908350baba2a608cf7e2a7046770d5dd4b758ce4e61 SHA512 15c0755f95cc03db95f8fe61faa87607dcdb24622c8de3a7941c254e15bf3d65b6683e5a0ff1fd96ca252afede6763f4440c8455665e346169b1107ad44d6651
+DIST xfce4-battery-plugin-1.1.2.tar.bz2 464077 BLAKE2B d3a8c661a96fae4992d89a9e0e7c313fc7a816bc6586443eb0490617f00a5afc81a2e4cdc0b7b3e3444ffb7342cc503f0fa1e84c967c0412ce287daaca41c950 SHA512 51778d00c34c41bdad234893c4a91f3bd562481df343d811e266719cb7903f60e1d56ba39f64f14ab882ce6419d0f0f4010aa112e9d0059133e7e4d30470f491
diff --git a/xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-1.1.2.ebuild b/xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-1.1.2.ebuild
new file mode 100644
index 000000000000..207fe3d2f3b5
--- /dev/null
+++ b/xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-1.1.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils linux-info xdg-utils
+
+DESCRIPTION="A battery monitor panel plugin for the Xfce desktop environment"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-battery-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~x86"
+IUSE="kernel_linux"
+
+RDEPEND=">=dev-libs/glib-2.24:2=
+ >=x11-libs/gtk+-3.16:3=
+ >=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
+ >=xfce-base/libxfce4util-4.8:=
+ >=xfce-base/xfce4-panel-4.12:="
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+pkg_setup() {
+ if use kernel_linux; then
+ CONFIG_CHECK="~ACPI_BATTERY"
+ linux-info_pkg_setup
+ fi
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ gnome2_icon_cache_update
+}