summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* app-emacs/d-mode: Version bump to 2.0.11Ulrich Müller2022-02-152-0/+20
| | | | | Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* app-emacs/csv-mode: Remove oldUlrich Müller2022-02-152-19/+0
| | | | | Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* app-emacs/csv-mode: Version bump to 1.18Ulrich Müller2022-02-152-0/+19
| | | | | Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* app-emacs/csharp-mode: Version bump to 1.1.1Ulrich Müller2022-02-152-0/+24
| | | | | Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* kde-frameworks/kimageformats: adjust to unslotted OpenEXR for 5.90.x tooSam James2022-02-151-0/+39
| | | | | Bug: https://bugs.gentoo.org/833158 Signed-off-by: Sam James <sam@gentoo.org>
* kde-frameworks/kimageformats: adjust to unslotted OpenEXRSam James2022-02-151-1/+1
| | | | | Bug: https://bugs.gentoo.org/833158 Signed-off-by: Sam James <sam@gentoo.org>
* media-libs/freeimage: support OpenEXR 3 / imathSam James2022-02-152-0/+266
| | | | | Bug: https://bugs.gentoo.org/833158 Signed-off-by: Sam James <sam@gentoo.org>
* media-gfx/mandelbulber: support OpenEXR 3 / imathSam James2022-02-152-0/+129
| | | | | Bug: https://bugs.gentoo.org/833158 Signed-off-by: Sam James <sam@gentoo.org>
* media-gfx/gmic: support OpenEXR 3 / imathSam James2022-02-152-0/+204
| | | | | Bug: https://bugs.gentoo.org/833158 Signed-off-by: Sam James <sam@gentoo.org>
* media-libs/opencv: support OpenEXR 3 / imathSam James2022-02-151-0/+578
| | | | | | | | | | We drop multilib for OpenEXR bits for now. Not clear that anything actually needs this and we don't have multilib support in imath right now (nor did it succeed when I tried to add it there). Bug: https://bugs.gentoo.org/833158 Bug: https://bugs.gentoo.org/830124 Signed-off-by: Sam James <sam@gentoo.org>
* media-gfx/povray: drop OpenEXR supportSam James2022-02-151-0/+143
| | | | | | | | | | - No activity upstream involving this, it seems - Fedora don't seem to be patching it but it doesn't seem to work here (silently ignored during build) - No reverse dependencies Bug: https://bugs.gentoo.org/833158 Signed-off-by: Sam James <sam@gentoo.org>
* media-libs/Field3D: support OpenEXR 3 / imathSam James2022-02-152-0/+274
| | | | | Bug: https://bugs.gentoo.org/833158 Signed-off-by: Sam James <sam@gentoo.org>
* media-libs/vigra: support OpenEXR 3 / imathSam James2022-02-152-27/+168
| | | | | Bug: https://bugs.gentoo.org/833158 Signed-off-by: Sam James <sam@gentoo.org>
* media-gfx/prusaslicer: support OpenEXR 3 / imathSam James2022-02-152-0/+154
| | | | | Bug: https://bugs.gentoo.org/833158 Signed-off-by: Sam James <sam@gentoo.org>
* media-libs/osl: adjust to unslotted OpenEXRSam James2022-02-153-257/+1
| | | | | | | | Bug: https://bugs.gentoo.org/833158 Bug: https://bugs.gentoo.org/831357 Bug: https://bugs.gentoo.org/832862 Bug: https://bugs.gentoo.org/821247 Signed-off-by: Sam James <sam@gentoo.org>
* media-gfx/openvdb: adjust to unslotted OpenEXRSam James2022-02-154-33/+5
| | | | | | | | Bug: https://bugs.gentoo.org/833158 Bug: https://bugs.gentoo.org/831357 Bug: https://bugs.gentoo.org/832862 Bug: https://bugs.gentoo.org/821247 Signed-off-by: Sam James <sam@gentoo.org>
* media-gfx/blender: adjust to unslotted OpenEXRSam James2022-02-154-98/+75
| | | | | | | | | | | | Bug: https://bugs.gentoo.org/833197 Bug: https://bugs.gentoo.org/828441 Bug: https://bugs.gentoo.org/833265 Bug: https://bugs.gentoo.org/833196 Bug: https://bugs.gentoo.org/833158 Bug: https://bugs.gentoo.org/831357 Bug: https://bugs.gentoo.org/832862 Bug: https://bugs.gentoo.org/821247 Signed-off-by: Sam James <sam@gentoo.org>
* media-libs/ilmbase: adjust to unslotted OpenEXRSam James2022-02-151-1/+2
| | | | | | | | Bug: https://bugs.gentoo.org/833158 Bug: https://bugs.gentoo.org/831357 Bug: https://bugs.gentoo.org/832862 Bug: https://bugs.gentoo.org/821247 Signed-off-by: Sam James <sam@gentoo.org>
* media-libs/opencolorio: adjust to unslotted OpenEXRSam James2022-02-152-79/+0
| | | | | | | | Bug: https://bugs.gentoo.org/833158 Closes: https://bugs.gentoo.org/831357 Closes: https://bugs.gentoo.org/832862 Closes: https://bugs.gentoo.org/821247 Signed-off-by: Sam James <sam@gentoo.org>
* media-libs/openimageio: adjust to unslotted OpenEXRSam James2022-02-152-320/+3
| | | | | | | | Bug: https://bugs.gentoo.org/833158 Closes: https://bugs.gentoo.org/833194 Closes: https://bugs.gentoo.org/831357 Closes: https://bugs.gentoo.org/832862 Signed-off-by: Sam James <sam@gentoo.org>
* dev-libs/imath: unslot OpenEXRSam James2022-02-151-12/+1
| | | | | | | | Bug: https://bugs.gentoo.org/833158 Bug: https://bugs.gentoo.org/831357 Bug: https://bugs.gentoo.org/832862 Bug: https://bugs.gentoo.org/821247 Signed-off-by: Sam James <sam@gentoo.org>
* media-libs/openexr: unslotSam James2022-02-151-0/+74
| | | | | | | | | | | | | | | | | | | | | | | | We've tried hard to make this work but it can't, for two reasons: 1. As time goes on, more and more packages port to OpenEXR 3 upstream, which means we have to fix more and more of them to use our special/different paths (e.g. OpenEXR-3, Imath-3); 2. ABI breakage. We _must_ have everything (or a significant portion of the stack for e.g. Blender, including OIIO and OCIO) built against the same major versions, or we hit both runtime and build-time breakages (depending on the situation). I've tried to keep fixing the avalanche of build failures but it's brittle and ultimately doesn't end up solving all the problems anyway. Indeed, this effort to unslot started after I did a sprint to fix the remaining issues, and then more popped up in their place. Most packages now support OpenEXR 3. Bug: https://bugs.gentoo.org/833158 Bug: https://bugs.gentoo.org/831357 Bug: https://bugs.gentoo.org/832862 Bug: https://bugs.gentoo.org/821247 Signed-off-by: Sam James <sam@gentoo.org>
* openib.eclass: treecleanDavid Seifert2022-02-151-158/+0
| | | | | Closes: https://bugs.gentoo.org/830999 Signed-off-by: David Seifert <soap@gentoo.org>
* distutils-r1.eclass: Use python_has_version in ...enable_sphinxMichał Górny2022-02-151-3/+1
| | | | Signed-off-by: Michał Górny <mgorny@gentoo.org>
* python-utils-r1.eclass: Add a verbose python_has_version() wrapperMichał Górny2022-02-151-0/+42
| | | | | | | | | | | Add a python_has_version() wrapper for convenient use in python_check_deps(). It includes: - verbose output - default "-b" root that's more suitable for build-time checks - forward compatibility for -b/-d/-r arguments in EAPI 6 Signed-off-by: Michał Górny <mgorny@gentoo.org>
* distutils-r1.eclass: Require explicit root for d_pep517_installMichał Górny2022-02-151-4/+4
| | | | Signed-off-by: Michał Górny <mgorny@gentoo.org>
* dev-php/xdebug: Add upstream to metadataBrian Evans2022-02-151-0/+3
| | | | Signed-off-by: Brian Evans <grknight@gentoo.org>
* dev-php/xdebug: Drop oldBrian Evans2022-02-154-177/+0
| | | | Signed-off-by: Brian Evans <grknight@gentoo.org>
* dev-php/xdebug: Version bump for 3.1.3Brian Evans2022-02-152-0/+59
| | | | Signed-off-by: Brian Evans <grknight@gentoo.org>
* dev-php/pecl-timezonedb: Drop oldBrian Evans2022-02-153-40/+0
| | | | Signed-off-by: Brian Evans <grknight@gentoo.org>
* dev-php/pecl-timezonedb: Version bump for 2021.5Brian Evans2022-02-152-0/+20
| | | | Signed-off-by: Brian Evans <grknight@gentoo.org>
* dev-php/xhprof: Update metadata with correct upstreamBrian Evans2022-02-151-1/+1
| | | | Signed-off-by: Brian Evans <grknight@gentoo.org>
* app-emacs/popup: Version bump to 0.5.8Ulrich Müller2022-02-152-0/+20
| | | | | Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* app-emacs/async: Version bump to 1.9.4Ulrich Müller2022-02-152-0/+25
| | | | | Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* app-emacs/adaptive-wrap: Version bump to 0.8Ulrich Müller2022-02-152-0/+18
| | | | | Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* app-editors/jove: Version bump to 4.17.3.7Ulrich Müller2022-02-152-0/+51
| | | | | | | | Upstream labels this as a pre-release, so it is _not_ a candidate for stabilisation. Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* www-client/chromium: fix building with gtk4Stephan Hartmann2022-02-152-0/+2
| | | | | | Closes: https://bugs.gentoo.org/832758 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Stephan Hartmann <sultan@gentoo.org>
* www-client/chromium: stable channel bump to 98.0.4758.102Stephan Hartmann2022-02-153-0/+1018
| | | | | | Bug: https://bugs.gentoo.org/832758 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Stephan Hartmann <sultan@gentoo.org>
* dev-python/distro: 1.7.0Sebastian Pipping2022-02-152-0/+21
| | | | | Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-3.0.30, Repoman-3.0.3
* dev-php/pecl-amqp: Drop old versionBrian Evans2022-02-152-25/+0
| | | | Signed-off-by: Brian Evans <grknight@gentoo.org>
* app-accessibility/orca: Keyword 41.2 alpha, #832222Matt Turner2022-02-151-1/+1
| | | | Signed-off-by: Matt Turner <mattst88@gentoo.org>
* app-accessibility/brltty: Keyword 6.4-r1 alpha, #832222Matt Turner2022-02-151-1/+1
| | | | Signed-off-by: Matt Turner <mattst88@gentoo.org>
* app-accessibility/speech-dispatcher: Keyword 0.11.1 alpha, #832222Matt Turner2022-02-151-1/+1
| | | | Signed-off-by: Matt Turner <mattst88@gentoo.org>
* games-misc/fortune-mod-all: Keyword 5 alpha, #828043Matt Turner2022-02-151-2/+2
| | | | Signed-off-by: Matt Turner <mattst88@gentoo.org>
* games-misc/fortune-mod: Keyword 3.12.0 alpha, #828043Matt Turner2022-02-151-1/+1
| | | | Signed-off-by: Matt Turner <mattst88@gentoo.org>
* app-text/App-XML-DocBook-Builder: Keyword 0.100.300-r1 alpha, #828043Matt Turner2022-02-151-1/+1
| | | | Signed-off-by: Matt Turner <mattst88@gentoo.org>
* dev-perl/Test-Trap: Keyword 0.3.4 alpha, #828043Matt Turner2022-02-151-1/+1
| | | | Signed-off-by: Matt Turner <mattst88@gentoo.org>
* dev-perl/Class-XSAccessor: Keyword 1.190.0-r1 alpha, #828043Matt Turner2022-02-151-1/+1
| | | | Signed-off-by: Matt Turner <mattst88@gentoo.org>
* x11-terms/rxvt-unicode: Keyword 9.30 alpha, #827470Matt Turner2022-02-151-1/+1
| | | | Signed-off-by: Matt Turner <mattst88@gentoo.org>
* dev-libs/libptytty: Keyword 2.0 alpha, #827470Matt Turner2022-02-151-1/+1
| | | | Signed-off-by: Matt Turner <mattst88@gentoo.org>