summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* */*: Clean PYTHON_COMPAT of obsolete implsMichał Górny2020-01-055004-9913/+9913
| | | | | Closes: https://github.com/gentoo/gentoo/pull/14246 Signed-off-by: Michał Górny <mgorny@gentoo.org>
* sys-apps/openrc: arm stable wrt bug #704600Agostino Sarubbo2020-01-051-1/+1
| | | | | | Package-Manager: Portage-2.3.79, Repoman-2.3.16 RepoMan-Options: --include-arches="arm" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* cmake.eclass: Fix the fatal typo fixAndreas Sturmlechner2020-01-051-1/+1
| | | | Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* gnome-base/gnome-menus: bump to 3.32.0Mart Raudsepp2020-01-052-0/+37
| | | | | | | | | | | | | Drop the ignore_kde_standalone.patch stuff, as it seems mostly legacy - there aren't dozens of X-KDE-settings-* desktop files anymore, only some external ones it seems that might not have gotten the memo to remove the category. If this is a problem, it should be fixed properly or worked around in other /etc/xdg/menus files too (gnome-flashback-applications.menu, xfce-applications.menu, etc) Package-Manager: Portage-2.3.79, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* net-print/cnrdrvcups-lb: new package for Canon laser printersJoonas Niilola2020-01-053-0/+196
| | | | | | | | | | Anyone using cndrvcups-common-lb and cndrvcups-lb will have to emerge --deselect these from world file before attempting to install. You'll also have to reconfigure your printer/scanner after emerging this driver package. Closes: https://bugs.gentoo.org/695896 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
* sci-libs/dcmtk: version bump 3.6.5 and prefix fixHorea Christian2020-01-052-0/+90
| | | | | | | Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Horea Christian <chr@chymera.eu> Closes: https://github.com/gentoo/gentoo/pull/13913 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
* sci-electronics/iverilog: bump to 10.3Huang Rui2020-01-053-10/+90
| | | | | | | | | | | | | | | | | | | | | | | | | | | | Bump iverilog version to 10.3 Follow these URL: * http://iverilog.icarus.com * https://github.com/steveicarus/iverilog Update LICENSE to LGPL-2.1 Rewrite ebuild to download file from iverilog official github repo Update maintainer list, add proxy-maint Add github upstream https://github.com/steveicarus/iverilog Bump the version with bugfixes Replace autoconf.sh to make it utilize the autotools eclass Fix upstream parallel compilation bug Add https://github.com/steveicarus/iverilog in HOMEPAGE array Happy new year 2020 Tested from my overlay: https://github.com/vowstar/vowstar-overlay/ Closes: https://bugs.gentoo.org/687080 Closes: https://bugs.gentoo.org/701122 Closes: https://bugs.gentoo.org/704344 Package-Manager: Portage-2.3.82, Repoman-2.3.20 Signed-off-by: Huang Rui <vowstar@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/14096 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
* dev-python/libsass: add two missing depsJoonas Niilola2020-01-051-2/+6
| | | | Signed-off-by: Joonas Niilola <juippis@gentoo.org>
* dev-python/qdarkstyle: A dark style sheet for QtWidgets applicationAndrew Ammerlaan2020-01-053-0/+57
| | | | | | | | | New dependency of dev-python/spyder-4.0.0 Bug: https://bugs.gentoo.org/702458 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
* dev-python/qtsass: Compile SASS files to Qt stylesheetsAndrew Ammerlaan2020-01-053-0/+32
| | | | | | | | Optional dependency of qdarkstyle Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
* dev-python/libsass: A straightforward binding of libsass for PythonAndrew Ammerlaan2020-01-054-0/+109
| | | | | | | | | Dependency of qtsass Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Package-Manager: Portage-2.3.84, Repoman-2.3.20 Closes: https://github.com/gentoo/gentoo/pull/14047 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
* media-gfx/gnofract4d: reformat use flagsJoonas Niilola2020-01-052-11/+16
| | | | Signed-off-by: Joonas Niilola <juippis@gentoo.org>
* media-gfx/gnofract4d: version bump to 4.0.1_p1Chris Mayo2020-01-053-1/+69
| | | | | | | | | | New help and video USE flags. Closes: https://bugs.gentoo.org/665576 Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Chris Mayo <aklhfex@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/9640 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
* ruby-ng.eclass: Include (-) in RUBY_TARGETS USE-dependenciesMichał Górny2020-01-051-4/+4
| | | | | | | Using 2-style USE dependencies on packages not having the flag in question is forbidden by PMS. Signed-off-by: Michał Górny <mgorny@gentoo.org>
* cmake.eclass: Fix fatal typoAndreas Sturmlechner2020-01-051-1/+1
| | | | | Thanks-to: Tomas Mozes <hydrapolic@gmail.com> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* dev-ruby/activesupport: remove vulnerable versionsHans de Graaff2020-01-056-360/+0
| | | | | Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
* dev-ruby/activemodel: remove vulnerable versionsHans de Graaff2020-01-056-219/+0
| | | | | Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
* dev-ruby/actioncable: remove vulnerable versionsHans de Graaff2020-01-056-230/+0
| | | | | Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
* dev-ruby/activejob: remove vulnerable versionsHans de Graaff2020-01-056-238/+0
| | | | | Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
* dev-ruby/actionview: remove vulnerable versionsHans de Graaff2020-01-056-289/+0
| | | | | Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
* dev-ruby/actionpack: remove vulnerable versionsHans de Graaff2020-01-056-285/+0
| | | | | Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
* dev-ruby/activestorage: remove vulnerable versionsHans de Graaff2020-01-056-298/+0
| | | | | Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
* dev-ruby/actionmailer: remove vulnerable versionsHans de Graaff2020-01-056-239/+0
| | | | | Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
* dev-ruby/activerecord: remove vulnerable versionsHans de Graaff2020-01-056-429/+0
| | | | | Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
* dev-ruby/actiontext: remove vulnerable versionsHans de Graaff2020-01-054-156/+0
| | | | | Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
* dev-ruby/actionmailbox: remove vulnerable versionsHans de Graaff2020-01-054-159/+0
| | | | | Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
* dev-ruby/railties: remove vulnerable versionsHans de Graaff2020-01-056-360/+0
| | | | | Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
* dev-ruby/rails: remove vulnerable versionsHans de Graaff2020-01-056-212/+0
| | | | | Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
* dev-ruby/sigar: add ruby27Hans de Graaff2020-01-051-2/+2
| | | | | Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
* net-analyzer/munin: add missing dep on munin-async userHans de Graaff2020-01-051-1/+2
| | | | | Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
* dev-ruby/rdoc: cleanup for bug 693028Hans de Graaff2020-01-053-188/+0
| | | | | Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
* dev-ruby/sigdump: add ruby27Hans de Graaff2020-01-051-2/+2
| | | | | Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
* dev-ruby/simplecov-html: add ruby27Hans de Graaff2020-01-051-2/+2
| | | | | Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
* dev-ruby/simple-rss: add ruby27Hans de Graaff2020-01-051-2/+2
| | | | | Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
* dev-ruby/slop: add ruby27Hans de Graaff2020-01-051-2/+2
| | | | | Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
* dev-python/pytest: Bump to 4.6.9Michał Górny2020-01-052-0/+76
| | | | Signed-off-by: Michał Górny <mgorny@gentoo.org>
* dev-python/pytest: Remove redundant versionsMichał Górny2020-01-055-286/+0
| | | | Signed-off-by: Michał Górny <mgorny@gentoo.org>
* dev-util/schroot: bump to 1.6.20_p7, with zfs supportGeorgy Yakovlev2020-01-043-0/+131
| | | | | Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
* profiles/arch/arm/package.use.mask: mask dev-util/schroot[zfs]Georgy Yakovlev2020-01-041-0/+4
| | | | Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
* profiles/arch/x86/package.use.mask: mask dev-util/schroot[zfs]Georgy Yakovlev2020-01-041-0/+4
| | | | Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
* dev-ruby/mocha: add 1.11.2Hans de Graaff2020-01-052-0/+34
| | | | | Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
* dev-ruby/mocha: cleanupHans de Graaff2020-01-053-68/+0
| | | | | Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
* media-video/bashnapi: Bump to 2.0.0Michał Górny2020-01-052-0/+51
| | | | Signed-off-by: Michał Górny <mgorny@gentoo.org>
* net-fs/nfs-utils: add metadata to cross-compile patchMike Frysinger2020-01-051-0/+19
| | | | Signed-off-by: Mike Frysinger <vapier@gentoo.org>
* dev-python/quixote: drop last-rited pkgAaron Bauman2020-01-044-63/+0
| | | | Signed-off-by: Aaron Bauman <bman@gentoo.org>
* profiles/package.mask: drop obsolete maskAaron Bauman2020-01-041-5/+0
| | | | Signed-off-by: Aaron Bauman <bman@gentoo.org>
* www-*/*: drop last-rited pkgsAaron Bauman2020-01-0410-261/+0
| | | | Signed-off-by: Aaron Bauman <bman@gentoo.org>
* sys-fabric/ibutils: drop last-rited pkgAaron Bauman2020-01-044-42/+0
| | | | Signed-off-by: Aaron Bauman <bman@gentoo.org>
* media-plugins/*: drop last-rited pkgsAaron Bauman2020-01-049-353/+0
| | | | Signed-off-by: Aaron Bauman <bman@gentoo.org>
* games-misc/*: drop last-rited pkgAaron Bauman2020-01-047-88/+0
| | | | Signed-off-by: Aaron Bauman <bman@gentoo.org>