summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
...
* Revert "app-misc/wyrd: Remove := slot op from || dep, #586304"Alexis Ballier2016-06-231-2/+2
| | | | | | | | | | | | | | | | | | | This reverts commit 09756db2fb6945d1b767b68f4017e6f1d4e6b66a. This commit is wrong in several aspects: - Such changes should come with a revbump - Removing := deps causes packages not to be rebuilt on upgrades, causing barely understandable build failures when upgrading, later on. Thanks to this commit, people that have installed those packages will likely experience those failures with the upcoming ocaml 4.03 unmask. - This is a non maintainer commit where no discussion at all happened with the maintainers during the 3 days between bug report and mass commit. Such discussion could have prevented the above mentioned breakage. Proper fix is to drop the backward compatibility part of the || () dep. This fix was slowly moving forward whenever possible and noticed. Main blocker for this is bug #463018 which requires taking extra care for not breaking the stable tree nor needlessly preventing future stabilization of packages.
* Revert "dev-util/coccinelle: Remove := op from || dep, #586304"Alexis Ballier2016-06-234-8/+8
| | | | | | | | | | | | | | | | | | | This reverts commit 23c0a5e66e44e35d9854ee94dc0e3b41a2f15035. This commit is wrong in several aspects: - Such changes should come with a revbump - Removing := deps causes packages not to be rebuilt on upgrades, causing barely understandable build failures when upgrading, later on. Thanks to this commit, people that have installed those packages will likely experience those failures with the upcoming ocaml 4.03 unmask. - This is a non maintainer commit where no discussion at all happened with the maintainers during the 3 days between bug report and mass commit. Such discussion could have prevented the above mentioned breakage. Proper fix is to drop the backward compatibility part of the || () dep. This fix was slowly moving forward whenever possible and noticed. Main blocker for this is bug #463018 which requires taking extra care for not breaking the stable tree nor needlessly preventing future stabilization of packages.
* Revert "sci-mathematics/coq: Remove := from || dep, #586304"Alexis Ballier2016-06-232-4/+4
| | | | | | | | | | | | | | | | | | | This reverts commit 84224f26f9c893299a487431e2ee005b1795f01c. This commit is wrong in several aspects: - Such changes should come with a revbump - Removing := deps causes packages not to be rebuilt on upgrades, causing barely understandable build failures when upgrading, later on. Thanks to this commit, people that have installed those packages will likely experience those failures with the upcoming ocaml 4.03 unmask. - This is a non maintainer commit where no discussion at all happened with the maintainers during the 3 days between bug report and mass commit. Such discussion could have prevented the above mentioned breakage. Proper fix is to drop the backward compatibility part of the || () dep. This fix was slowly moving forward whenever possible and noticed. Main blocker for this is bug #463018 which requires taking extra care for not breaking the stable tree nor needlessly preventing future stabilization of packages.
* Revert "dev-ml/*: Remove := slot ops from || deps, #586304"Alexis Ballier2016-06-2335-67/+67
| | | | | | | | | | | | | | | | | | | This reverts commit 2d4ac687fbf44588f764697c9dcb2b960a18d51b. This commit is wrong in several aspects: - Such changes should come with a revbump - Removing := deps causes packages not to be rebuilt on upgrades, causing barely understandable build failures when upgrading, later on. Thanks to this commit, people that have installed those packages will likely experience those failures with the upcoming ocaml 4.03 unmask. - This is a non maintainer commit where no discussion at all happened with the maintainers during the 3 days between bug report and mass commit. Such discussion could have prevented the above mentioned breakage. Proper fix is to drop the backward compatibility part of the || () dep. This fix was slowly moving forward whenever possible and noticed. Main blocker for this is bug #463018 which requires taking extra care for not breaking the stable tree nor needlessly preventing future stabilization of packages.
* eclass/myspell-r2.eclass: Fix typo in comment.Ulrich Müller2016-06-231-2/+2
|
* dev-vcs/fossil: Version BumpAaron W. Swenson2016-06-232-0/+54
| | | | | | Upstream released 1.35. Package-Manager: portage-2.2.28
* dev-util/vbindiff: Fix ncurses[tinfo] build, bump to EAPI 6, #558292Michał Górny2016-06-231-0/+23
|
* app-text/texlive: Migrate from LINGUAS to L10N.Ulrich Müller2016-06-234-316/+320
| | | | | | Bug: 586774 Package-Manager: portage-2.3.0_rc1
* x11-libs/libva: remove oldAlexis Ballier2016-06-2310-656/+0
| | | | Package-Manager: portage-2.3.0_rc1
* x11-libs/libva-intel-driver: remove oldAlexis Ballier2016-06-239-409/+0
| | | | Package-Manager: portage-2.3.0_rc1
* x11-libs/libva-intel-driver: bump to 1.7.1Alexis Ballier2016-06-232-0/+57
| | | | Package-Manager: portage-2.3.0_rc1
* x11-libs/libva: bump to 1.7.1Alexis Ballier2016-06-232-0/+87
| | | | Package-Manager: portage-2.3.0_rc1
* profiles: Add "mi" to l10n.desc.Ulrich Müller2016-06-231-0/+1
| | | | Needed for app-text/hunspell.
* www-apps/moodle: version bump to 3.1Anthony G. Basile2016-06-232-0/+129
| | | | Package-Manager: portage-2.2.28
* app-shells/bash: bashrc: back out clearing of default LS_COLORS #583814Mike Frysinger2016-06-231-23/+9
| | | | | | | | | The behavior of ls in the default case (when LS_COLORS isn't set) isn't documented well. The manual leads you to believe the defaults will be used when in reality they are not. A scan of the source shows this. So back out some the attempts to optimize the env and go back to exporting LS_COLORS all the time. We'll just have to live with incompat warnings when coreutils upgrades & changes behavior.
* app-shells/bash: version bump to 4.3_p46Mike Frysinger2016-06-233-0/+262
|
* app-shells/bash: bashrc: clean up ls_colors var too #572582Mike Frysinger2016-06-231-0/+1
|
* app-backup/bacula: Let bacula-dir start successful under systemd (Bug #584442)Thomas Beierlein2016-06-231-0/+410
| | | | | | | | Change systemd's bacula-dir.service so that bacula-dir is run as root:bacula. While not perfect from a security point it makes bacula under systemd compatible with OpenRC environment. Package-Manager: portage-2.3.0_rc1
* media-radio/fldigi: Maintenance releaseThomas Beierlein2016-06-232-0/+41
| | | | Package-Manager: portage-2.3.0_rc1
* sys-apps/man-pages: Migrate from LINGUAS to L10N.Ulrich Müller2016-06-233-36/+36
| | | | Package-Manager: portage-2.3.0_rc1
* app-admin/lastpass: remove last-rited packageGöktürk Yüksek2016-06-234-139/+0
|
* app-admin/logstash-bin: BumpPatrick Lauer2016-06-232-0/+65
| | | | Package-Manager: portage-2.3.0_rc1
* www-apps/wordpress: bump to 4.5.3 and drop older in the 4.5 seriesAnthony G. Basile2016-06-224-115/+1
| | | | Package-Manager: portage-2.2.28
* sys-apps/prctl: bump up to 1.6, keyworded for x86 and amd64Sergei Trofimovich2016-06-224-0/+55
| | | | | | Has got new mcekill knob, useful on x86/amd64 family. Package-Manager: portage-2.3.0_rc1
* profiles: Update l10n.desc.Ulrich Müller2016-06-221-1/+2
| | | | Use generic language tag "sa" instead of "sa-IN" for consistency.
* x11-libs/motif: Version bump.Ulrich Müller2016-06-222-0/+119
| | | | Package-Manager: portage-2.3.0_rc1
* sys-devel/byfl: fix deps (bug #586736)Christoph Junghans2016-06-224-19/+75
| | | | Package-Manager: portage-2.2.28
* media-gfx/gimp: CVE-2016-4994 (bug #586666)Sebastian Pipping2016-06-224-0/+598
| | | | Package-Manager: portage-2.2.28
* net-libs/phodav: Drop oldPacho Ramos2016-06-222-56/+0
| | | | Package-Manager: portage-2.3.0_rc1
* net-p2p/deluge: Add stable live ebuildPPed722016-06-223-4/+145
| | | | Also fixes some tabs vs spaces issues
* net-p2p/deluge: Sync live ebuild to latest changesPPed722016-06-221-21/+61
|
* net-p2p/deluge: Remove oldPPed722016-06-221-100/+0
|
* net-p2p/deluge: Make UI installation USE-conditionalPPed722016-06-223-2/+147
| | | | | | Gentoo-bug: 381837 New ebuild, EAPI=6, add local use flags and new languages to metadata.xml, fix patch for EAPI=6
* profiles/prefix/sunos/solaris/package.mask: net-misc/wget-1.18 linking was fixedFabian Groffen2016-06-221-4/+0
|
* net-misc/wget: fix linking wrt iconv on Darwin/Solaris, bug #585924Fabian Groffen2016-06-221-0/+6
| | | | Package-Manager: portage-2.2.28
* app-crypt/gnupg: fix remaining ebuilds building with ClangAustin English2016-06-222-3/+6
| | | | | | | | Gentoo-Bug: https://bugs.gentoo.org/458154 Reviewed-by: Robin H. Johnson <robbat2@gentoo.org> Package-Manager: portage-2.2.28
* app-emacs/yatex: Migrate from LINGUAS to L10N.Ulrich Müller2016-06-222-8/+8
| | | | Package-Manager: portage-2.3.0_rc1
* app-emacs/wanderlust: Migrate from LINGUAS to L10N.Ulrich Müller2016-06-222-8/+8
| | | | Package-Manager: portage-2.3.0_rc1
* app-emacs/semi: Migrate from LINGUAS to L10N.Ulrich Müller2016-06-221-4/+4
| | | | Package-Manager: portage-2.3.0_rc1
* app-emacs/riece: Migrate from LINGUAS to L10N.Ulrich Müller2016-06-222-6/+6
| | | | Package-Manager: portage-2.3.0_rc1
* app-emacs/mew: Migrate from LINGUAS to L10N.Ulrich Müller2016-06-222-8/+8
| | | | Package-Manager: portage-2.3.0_rc1
* app-emacs/lyskom-elisp-client: Migrate from LINGUAS to L10N.Ulrich Müller2016-06-221-4/+4
| | | | Package-Manager: portage-2.3.0_rc1
* app-emacs/emacs-wget: Migrate from LINGUAS to L10N.Ulrich Müller2016-06-221-3/+3
| | | | Package-Manager: portage-2.3.0_rc1
* app-emacs/emacs-w3m: Migrate from LINGUAS to L10N.Ulrich Müller2016-06-222-10/+10
| | | | Package-Manager: portage-2.3.0_rc1
* app-emacs/cmail: Migrate from LINGUAS to L10N.Ulrich Müller2016-06-221-3/+3
| | | | Package-Manager: portage-2.3.0_rc1
* app-emacs/auto-complete: Migrate from LINGUAS to L10N.Ulrich Müller2016-06-221-3/+3
| | | | Package-Manager: portage-2.3.0_rc1
* Revert "dev-python/bsddb3: move || dep to DEPEND only"Mike Gilbert2016-06-221-3/+2
| | | | This reverts commit 479faabd1ec6b0cb64d3b18dc9b8eca274f5d9b6.
* www-client/chromium: remove oldMike Gilbert2016-06-222-696/+0
| | | | Package-Manager: portage-2.3.0_rc1_p27
* www-client/chromium: stable channel bump (51.0.2704.103)Mike Gilbert2016-06-222-0/+697
| | | | Package-Manager: portage-2.3.0_rc1_p27
* dev-python/bsddb3: move || dep to DEPEND onlyMike Gilbert2016-06-221-2/+3
| | | | Package-Manager: portage-2.3.0_rc1_p27