summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
...
* dev-ml/lwt: drop Pierre & proxy maints from metadata. He is not maintaining ↵Alexis Ballier2016-06-231-8/+0
| | | | | | it anymore. Package-Manager: portage-2.3.0_rc1
* dev-ml/optcomp: drop backward comapt dep on camlp4Alexis Ballier2016-06-231-2/+2
| | | | Package-Manager: portage-2.3.0_rc1
* dev-ml/pipebang: remove oldAlexis Ballier2016-06-232-22/+0
| | | | Package-Manager: portage-2.3.0_rc1
* dev-ml/pa_bench: remove oldAlexis Ballier2016-06-233-51/+0
| | | | Package-Manager: portage-2.3.0_rc1
* sys-kernel/gentoo-sources: Linux patch 4.1.27Mike Pagano2016-06-232-0/+34
| | | | Package-Manager: portage-2.2.28
* dev-ml/pxp: drop backward compat dep on camlp4Alexis Ballier2016-06-231-0/+55
| | | | Package-Manager: portage-2.3.0_rc1
* sys-kernel/gentoo-sources: Linux patch 3.18.36Mike Pagano2016-06-232-0/+32
| | | | Package-Manager: portage-2.2.28
* dev-ml/core_bench: remove oldAlexis Ballier2016-06-233-83/+0
| | | | Package-Manager: portage-2.3.0_rc1
* kde-misc/yakuake: x86 stableMichael Palimaka2016-06-231-1/+1
| | | | | | Gentoo-bug: 584762 Package-Manager: portage-2.3.0_rc1
* kde-apps: stabilise 15.12.3 on x86Michael Palimaka2016-06-23208-208/+208
| | | | | | Gentoo-bug: 579992 Package-Manager: portage-2.3.0_rc1
* sci-astronomy/wcslib: x86 stableMichael Palimaka2016-06-231-1/+1
| | | | | | Gentoo-bug: 579992 Package-Manager: portage-2.3.0_rc1
* sci-libs/pgplot: x86 stableMichael Palimaka2016-06-231-2/+2
| | | | | | Gentoo-bug: 579992 Package-Manager: portage-2.3.0_rc1
* media-libs/mlt: x86 stableMichael Palimaka2016-06-231-2/+2
| | | | | | Gentoo-bug: 579992 Package-Manager: portage-2.3.0_rc1
* media-video/movit: x86 stableMichael Palimaka2016-06-231-2/+2
| | | | | | Gentoo-bug: 579992 Package-Manager: portage-2.3.0_rc1
* sci-libs/indilib: x86 stableMichael Palimaka2016-06-231-2/+2
| | | | | | Gentoo-bug: 579992 Package-Manager: portage-2.3.0_rc1
* net-libs/signond: x86 stableMichael Palimaka2016-06-231-1/+1
| | | | Package-Manager: portage-2.3.0_rc1
* net-libs/accounts-qt: x86 stableMichael Palimaka2016-06-231-1/+1
| | | | | | Gentoo-bug: 579992 Package-Manager: portage-2.3.0_rc1
* net-libs/libaccounts-glib: x86 stableMichael Palimaka2016-06-231-1/+1
| | | | | | Gentoo-bug: 579992 Package-Manager: portage-2.3.0_rc1
* kde-frameworks/kdelibs4support: remove oldMichael Palimaka2016-06-231-85/+0
| | | | Package-Manager: portage-2.3.0_rc1
* kde-frameworks/kxmlgui: remove oldMichael Palimaka2016-06-231-42/+0
| | | | Package-Manager: portage-2.3.0_rc1
* kde-frameworks/kglobalaccel: remove oldMichael Palimaka2016-06-231-31/+0
| | | | Package-Manager: portage-2.3.0_rc1
* kde-frameworks/kauth: remove oldMichael Palimaka2016-06-231-33/+0
| | | | Package-Manager: portage-2.3.0_rc1
* dev-cpp/eigen: x86 stableMichael Palimaka2016-06-231-1/+1
| | | | | | Gentoo-bug: 579996 Package-Manager: portage-2.3.0_rc1
* app-admin/puppetdb: bupMatthew Thode2016-06-232-0/+92
| | | | Package-Manager: portage-2.2.28
* package.mask: Mask media-video/subotage for removal (in bashnapi now)Michał Górny2016-06-231-0/+4
|
* media-video/bashnapi: Bump to 1.3.5Michał Górny2016-06-232-0/+60
|
* net-misc/aria2: Bump to 1.24.0Michał Górny2016-06-232-0/+150
|
* sys-fs/bedup: Bump to 0.10.1Michał Górny2016-06-232-0/+28
|
* dev-util/sysdig: Bump to 0.10.1Michał Górny2016-06-232-0/+86
|
* dev-util/abi-compliance-checker: Bump to 1.99.21Michał Górny2016-06-232-0/+30
|
* dev-cpp/catch: Bump to 1.5.6Michał Górny2016-06-232-0/+40
|
* app-admin/systemrescuecd-x86: Bump to 4.7.3Michał Górny2016-06-232-0/+64
|
* dev-lang/ekopath: Snapshot bumpMichał Górny2016-06-233-0/+138
|
* dev-ml/ocamlnet: bump to 4.1.2Alexis Ballier2016-06-232-0/+83
| | | | Package-Manager: portage-2.3.0_rc1
* dev-util/coccinelle: bump to 1.0.5.Alexis Ballier2016-06-232-0/+124
| | | | | | | Cleanup a bit ebuild. Remove backward compat dep for camlp4. Package-Manager: portage-2.3.0_rc1
* app-misc/wyrd: remove backward compat dep for camlp4; add slot + := dep on ↵Alexis Ballier2016-06-231-0/+35
| | | | | | ncurses Package-Manager: portage-2.3.0_rc1
* app-misc/wyrd: remove oldAlexis Ballier2016-06-234-99/+0
| | | | Package-Manager: portage-2.3.0_rc1
* dev-ml/lablgl: drop backward compat deps on labltk/camlp4, bug #586304Alexis Ballier2016-06-231-0/+95
| | | | Package-Manager: portage-2.3.0_rc1
* dev-ml/lablgl: remove oldAlexis Ballier2016-06-232-94/+0
| | | | Package-Manager: portage-2.3.0_rc1
* dev-ml/pomap: drop backward compat dep on camlp4; part of bug #586304Alexis Ballier2016-06-231-0/+31
| | | | Package-Manager: portage-2.3.0_rc1
* dev-ml/pomap: remove oldAlexis Ballier2016-06-233-64/+0
| | | | Package-Manager: portage-2.3.0_rc1
* dev-ml/utop: remove oldAlexis Ballier2016-06-234-180/+0
| | | | Package-Manager: portage-2.3.0_rc1
* dev-ml/utop: drop backward compat dep for camlp4Alexis Ballier2016-06-231-2/+2
| | | | Package-Manager: portage-2.3.0_rc1
* profiles: Drop mask for removed KDE ToysJohannes Huber2016-06-231-8/+0
|
* kde-apps/ktux: Remove last-rited pkgJohannes Huber2016-06-234-48/+0
| | | | Last rited on 2016/05/22.
* kde-apps/amor: Remove last-rited pkgJohannes Huber2016-06-234-42/+0
| | | | Last rited on 2016/05/22.
* kde-apps/kdetoys-meta: Remove last-rited pkgJohannes Huber2016-06-233-42/+0
| | | | Last rited on 2016/05/22.
* www-servers/ocsigenserver: depend on camldbm only since ocsigen is ~arch ↵Alexis Ballier2016-06-231-1/+1
| | | | | | only and camldbm is unmasked on relevant arches. Package-Manager: portage-2.3.0_rc1
* Revert "dev-ml/lablgl: Remove another := slot op from || dep"Alexis Ballier2016-06-231-1/+1
| | | | | | | | | | | | | | | | | | | This reverts commit 9675d96cfe244033e97dd7034b95c5af251405e3. This commit is wrong in several aspects: - Such changes should come with a revbump - Removing := deps causes packages not to be rebuilt on upgrades, causing barely understandable build failures when upgrading, later on. Thanks to this commit, people that have installed those packages will likely experience those failures with the upcoming ocaml 4.03 unmask. - This is a non maintainer commit where no discussion at all happened with the maintainers during the 3 days between bug report and mass commit. Such discussion could have prevented the above mentioned breakage. Proper fix is to drop the backward compatibility part of the || () dep. This fix was slowly moving forward whenever possible and noticed. Main blocker for this is bug #463018 which requires taking extra care for not breaking the stable tree nor needlessly preventing future stabilization of packages.
* Revert "dev-ml/ocamlnet: Remove another := slot op from || dep"Alexis Ballier2016-06-233-3/+3
| | | | | | | | | | | | | | | | | | | This reverts commit 3b1a4cc0f9b9a0a2c70d6bb53cb71bf059e2920e. This commit is wrong in several aspects: - Such changes should come with a revbump - Removing := deps causes packages not to be rebuilt on upgrades, causing barely understandable build failures when upgrading, later on. Thanks to this commit, people that have installed those packages will likely experience those failures with the upcoming ocaml 4.03 unmask. - This is a non maintainer commit where no discussion at all happened with the maintainers during the 3 days between bug report and mass commit. Such discussion could have prevented the above mentioned breakage. Proper fix is to drop the backward compatibility part of the || () dep. This fix was slowly moving forward whenever possible and noticed. Main blocker for this is bug #463018 which requires taking extra care for not breaking the stable tree nor needlessly preventing future stabilization of packages.