summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
...
* sys-auth/yubico-piv-tool: add self as maintainerMarek Szuba2020-09-061-1/+4
| | | | Signed-off-by: Marek Szuba <marecki@gentoo.org>
* sys-auth/yubico-piv-tool: only build tests when FEATURES=test is setMarek Szuba2020-09-062-1/+44
This means we no longer need dev-libs/check present even when one does not wish to run the test suite. Closes: https://bugs.gentoo.org/739040 Signed-off-by: Marek Szuba <marecki@gentoo.org>
* net-p2p/syncthing: remove oldMarek Szuba2020-09-052-391/+0
| | | | Signed-off-by: Marek Szuba <marecki@gentoo.org>
* sys-cluster/singularity: remove oldMarek Szuba2020-09-053-144/+0
| | | | Signed-off-by: Marek Szuba <marecki@gentoo.org>
* media-libs/gmmlib: remove oldMarek Szuba2020-09-054-128/+0
| | | | Signed-off-by: Marek Szuba <marecki@gentoo.org>
* dev-python/pytools: remove oldMarek Szuba2020-09-052-31/+0
| | | | Signed-off-by: Marek Szuba <marecki@gentoo.org>
* dev-python/ruamel-yaml: remove oldMarek Szuba2020-09-052-30/+0
| | | | Signed-off-by: Marek Szuba <marecki@gentoo.org>
* app-text/bibletime: remove oldMarek Szuba2020-09-052-48/+0
| | | | Signed-off-by: Marek Szuba <marecki@gentoo.org>
* net-libs/biblesync: remove oldMarek Szuba2020-09-053-52/+0
| | | | Signed-off-by: Marek Szuba <marecki@gentoo.org>
* app-backup/borgmatic: remove oldMarek Szuba2020-09-053-138/+0
| | | | Signed-off-by: Marek Szuba <marecki@gentoo.org>
* app-backup/burp: remove oldMarek Szuba2020-09-052-116/+0
Signed-off-by: Marek Szuba <marecki@gentoo.org>
* sys-cluster/singularity: bump to 3.6.2Marek Szuba2020-09-022-0/+74
Signed-off-by: Marek Szuba <marecki@gentoo.org>
* dev-lua/lua-zlib: Bump to 1.2 and EAPI-7Marek Szuba2020-09-012-0/+29
Signed-off-by: Marek Szuba <marecki@gentoo.org>
* sys-cluster/singularity: honour toolchain values of CC and CXXMarek Szuba2020-09-011-1/+5
| | | | | Closes: https://bugs.gentoo.org/725748 Signed-off-by: Marek Szuba <marecki@gentoo.org>
* profiles: Last-rite dev-go/siphashMarek Szuba2020-09-011-0/+6
Bug: https://bugs.gentoo.org/732130 Signed-off-by: Marek Szuba <marecki@gentoo.org>
* sys-apps/flashrom: support more programmers in the live ebuildMarek Szuba2020-08-312-0/+10
Suggested-by: Jakov Smolic <jakov.smolic@sartura.hr> Closes: https://github.com/gentoo/gentoo/pull/17019 Signed-off-by: Marek Szuba <marecki@gentoo.org>
* media-gfx/darktable: remove oldMarek Szuba2020-08-311-151/+0
| | | | Signed-off-by: Marek Szuba <marecki@gentoo.org>
* media-gfx/darktable-2.6.2: drop USE=pax_kernel supportMarek Szuba2020-08-312-13/+3
| | | | | | | | 2.6.2 isn't going anywhere for now because it's the last version supporting x86, therefore remove (deprecated) PaX support from this version as well. Signed-off-by: Marek Szuba <marecki@gentoo.org>
* media-gfx/darktable: drop KEYWORDS=x86 from 3.0.0+ and live ebuildMarek Szuba2020-08-314-4/+4
Since version 3.0.0 darktable only supports 64-bit little-endian architectures, or to be precise amd64, arm64 and ppc64; see src/is_supported_platform.h. Closes: https://bugs.gentoo.org/739682 Signed-off-by: Marek Szuba <marecki@gentoo.org>
* net-analyzer/nessus-agent-bin: handle version updates properlyMarek Szuba2020-08-281-0/+8
| | | | | | | | Nessus must be made aware of a new version of its core components having been installed. Do it the same way as upstream distro packages, i.e. use the undocumented nessuscli command 'install'. Signed-off-by: Marek Szuba <marecki@gentoo.org>
* net-analyzer/nessus-bin: handle version updates properlyMarek Szuba2020-08-281-6/+7
Nessus must be made aware of a new version of its core components having been installed. Do it the same way as upstream distro packages, i.e. use the undocumented nessuscli command 'install'. This is safe to do while nessusd-bin is running but it WILL be necessary to restart the service so that the dashboard is updated as well. In fact, Nessus UI will complain about the version discrepancy between the core and the dashboard until the service has been restarted. Closes: https://bugs.gentoo.org/739178 Signed-off-by: Marek Szuba <marecki@gentoo.org>
* net-p2p/syncthing: block go-1.15+Marek Szuba2020-08-273-0/+3
| | | | | | | | Builds but does not run, see https://github.com/syncthing/syncthing/issues/6889. Fix already committed upstream, 1.9.0 should be fine with new Go. Signed-off-by: Marek Szuba <marecki@gentoo.org>
* net-p2p/syncthing: remove oldMarek Szuba2020-08-274-1299/+0
Signed-off-by: Marek Szuba <marecki@gentoo.org>
* dev-perl/Bio-DB-HTS: remove oldMarek Szuba2020-08-273-69/+0
Signed-off-by: Marek Szuba <marecki@gentoo.org>
* profiles: last-rite deprecated dev-libs/hsa-ext-rocrMarek Szuba2020-08-262-7/+7
Bug: https://bugs.gentoo.org/739066 Signed-off-by: Marek Szuba <marecki@gentoo.org>
* dev-util/intel-graphics-compiler: block llvm-10.0.1Marek Szuba2020-08-251-1/+3
Causes compilation errors. Closes: https://bugs.gentoo.org/738934 Signed-off-by: Marek Szuba <marecki@gentoo.org>
* media-libs/gmmlib: bump to 20.2.5Marek Szuba2020-08-252-1/+1
| | | | Signed-off-by: Marek Szuba <marecki@gentoo.org>
* profiles: Deprecate dev-libs/hsa-ext-rocrMarek Szuba2020-08-251-0/+7
| | | | | | | No longer available upstream, recent versions of ROCm feature open-source OpenCL image support. Signed-off-by: Marek Szuba <marecki@gentoo.org>
* virtual/opencl: Do not mention dev-libs/hsa-ext-rocrMarek Szuba2020-08-251-7/+5
ROCm has had open-source OpenCL image support since 3.3, and since 3.7 it doesn't even try to use the proprietary library - which upstream has recently ceased to publish. Signed-off-by: Marek Szuba <marecki@gentoo.org>
* sys-cluster/singularity: bump to 3.6.1Marek Szuba2020-08-242-0/+70
| | | | Signed-off-by: Marek Szuba <marecki@gentoo.org>
* dev-python/pyopencl: bump to 2020.2.1Marek Szuba2020-08-242-0/+57
| | | | Signed-off-by: Marek Szuba <marecki@gentoo.org>
* dev-python/pytools: bump to 2020.4Marek Szuba2020-08-242-0/+26
| | | | Signed-off-by: Marek Szuba <marecki@gentoo.org>
* app-misc/gramps: bump to 5.1.3Marek Szuba2020-08-242-0/+1
| | | | Signed-off-by: Marek Szuba <marecki@gentoo.org>
* media-libs/gmmlib: bump to 20.2.4Marek Szuba2020-08-242-0/+47
| | | | Signed-off-by: Marek Szuba <marecki@gentoo.org>
* app-backup/borgmatic: bump to 1.5.10Marek Szuba2020-08-242-0/+69
| | | | Signed-off-by: Marek Szuba <marecki@gentoo.org>
* app-backup/burp: bump to 2.3.32Marek Szuba2020-08-242-0/+116
| | | | Signed-off-by: Marek Szuba <marecki@gentoo.org>
* app-text/bibletime: bump to 3.0Marek Szuba2020-08-242-0/+69
| | | | Signed-off-by: Marek Szuba <marecki@gentoo.org>
* dev-libs/level-zero: bump to 1.0.0Marek Szuba2020-08-242-0/+28
| | | | Signed-off-by: Marek Szuba <marecki@gentoo.org>
* net-libs/xrootd-ceph: bump to 5.0.1Marek Szuba2020-08-242-0/+37
| | | | Signed-off-by: Marek Szuba <marecki@gentoo.org>
* net-libs/xrootd: bump to 5.0.1Marek Szuba2020-08-242-0/+117
| | | | Signed-off-by: Marek Szuba <marecki@gentoo.org>
* net-p2p/syncthing: bump to 1.8.0Marek Szuba2020-08-242-0/+625
Signed-off-by: Marek Szuba <marecki@gentoo.org>
* net-analyzer/nessus-agent-bin: bump to 8.0.0Marek Szuba2020-08-242-1/+1
| | | | Signed-off-by: Marek Szuba <marecki@gentoo.org>
* net-analyzer/nessus-bin: bump to 8.11.1Marek Szuba2020-08-242-1/+1
Security update. Bug: https://bugs.gentoo.org/738638 Signed-off-by: Marek Szuba <marecki@gentoo.org>
* app-dicts/sword-GerHfaLex2002: correct the licence, add postinst msgMarek Szuba2020-08-031-1/+12
| | | | Signed-off-by: Marek Szuba <marecki@gentoo.org>
* app-dicts/sword-GerHfa2002: correct the licence, add postinst msgMarek Szuba2020-08-031-1/+12
| | | | Signed-off-by: Marek Szuba <marecki@gentoo.org>
* licenses: Add sword-GerHfa2002Marek Szuba2020-08-031-0/+10
| | | | Signed-off-by: Marek Szuba <marecki@gentoo.org>
* app-text/sword-modules: remove GerHfa2002 and GerHfaLex2002Marek Szuba2020-08-031-2/+0
These two modules are locked and I only included them by accident. Signed-off-by: Marek Szuba <marecki@gentoo.org>
* app-text/sword-modules: group packages by L10N valueMarek Szuba2020-07-313-147/+571
| | | | | | | | | | No real point in this pulling in every single SWORD module available... Grouping them by language makes more sense to me. This list includes all the modules which only got packaged for Gentoo earlier on today. Signed-off-by: Marek Szuba <marecki@gentoo.org>
* profiles/desc: Add L10N locales from app-dicts/sword-*Marek Szuba2020-07-311-0/+27
Signed-off-by: Marek Szuba <marecki@gentoo.org>
* app-dicts/sword-vlsJoNT: new packageMarek Szuba2020-07-313-0/+25
| | | | Signed-off-by: Marek Szuba <marecki@gentoo.org>