summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* app-backup/borgbackup: Stabilize 1.1.17-r1 amd64, #811381Sam James2021-10-121-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* app-backup/borgbackup: Stabilize 1.1.17-r1 x86, #811381Sam James2021-10-121-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* **/metadata.xml: Replace http by https in DOCTYPE elementUlrich Müller2021-09-111-1/+1
| | | | | Bug: https://bugs.gentoo.org/552720 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* app-backup/borgbackup: address bug #802225Anthony G. Basile2021-08-172-0/+2
| | | | | | | | We still need to look into whether or not distutils can be removed. Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
* app-backup/borgbackup: keyword 1.1.17 for ~riscvMarek Szuba2021-07-201-2/+2
| | | | | | | | | | | Builds, installs and handled daily backups of my test system just fine. I _have_ seen some test failures having run the test suite under tox/py39 which I do not see on amd64, that said they are limited to test_readonly_ (and for some scenarios only too) so I strongly suspect it might have less to do with the arch and more with the underlying file system. Signed-off-by: Marek Szuba <marecki@gentoo.org>
* app-backup/borgbackup: 1.1.17 bump with py10 target support.Piotr Karbowski2021-07-133-2/+45
| | | | Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
* app-backup/borgbackup: add Python 3.9Sam James2021-06-013-3/+3
| | | | | Closes: https://bugs.gentoo.org/788328 Signed-off-by: Sam James <sam@gentoo.org>
* app-backup/borgbackup: remove libressl supportMikle Kolyada2021-04-303-10/+4
| | | | | Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
* app-backup/borgbackup: fix whitespace on KEYWORDS lineSam James2021-03-311-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* app-backup/borgbackup: 1.1.16 version bump; drop old.Piotr Karbowski2021-03-284-92/+2
| | | | Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
* */*: Normalize metadata.xml filesMichał Górny2021-03-161-1/+1
| | | | | | | | | | | Normalize quoting, replace '>' with entities, replace unnecessary entities, remove trailing empty lines. Done via: find -name metadata.xml -exec xml ed -P -L -d //none {} + Signed-off-by: Michał Górny <mgorny@gentoo.org>
* app-backup/borgbackup: Keyword 1.1.15 arm64, #766525Sam James2021-02-211-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* app-backup/borgbackup: x86 stable wrt bug #768579Agostino Sarubbo2021-02-041-1/+1
| | | | | | Package-Manager: Portage-3.0.13, Repoman-3.0.2 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* app-backup/borgbackup: Stabilize 1.1.15 amd64, #768579Sam James2021-02-041-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* */*: Remove obsolete values from PYTHON_COMPATMichał Górny2021-01-314-4/+4
| | | | Signed-off-by: Michał Górny <mgorny@gentoo.org>
* app-backup/borgbackup: Keyword 1.1.15 arm, #766525Sam James2021-01-261-2/+2
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* app-backup/borgbackup: Stabilize 1.1.14 x86, #762005Sam James2021-01-051-2/+2
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* app-backup/borgbackup: Stabilize 1.1.14 amd64, #762005Sam James2020-12-271-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* app-backup/borgbackup: 1.1.15 bumpPiotr Karbowski2020-12-272-0/+45
| | | | Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
* app-backup/borgbackup: version bump to 1.1.14Anthony G. Basile2020-10-103-1/+46
| | | | | Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
* app-backup/borgbackup: x86 stable (bug #736738)Thomas Deutschmann2020-08-291-1/+1
| | | | | Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
* app-backup/borgbackup: amd64 stable wrt bug #736738Agostino Sarubbo2020-08-171-1/+1
| | | | | | Package-Manager: Portage-2.3.103, Repoman-2.3.23 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* app-backup/borgbackup: keyworded 1.1.13 for ppc64Sergei Trofimovich2020-06-151-1/+1
| | | | | | | | keyworded wrt bug #723778 Package-Manager: Portage-2.3.101, Repoman-2.3.22 RepoMan-Options: --include-arches="ppc64" Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
* app-backup/borgbackup: remove pyzmq dependency for -9999Anthony G. Basile2020-06-141-1/+0
| | | | | Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
* app-backup/borgbackup: remove unnecessary pyzmq dependencyFlorian Schmaus2020-06-142-2/+0
| | | | | | | | | | | | | | | The dev-python/pyzmq dependency was added with https://github.com/gentoo/gentoo/pull/5240, borgbackup actually required pyzmq, with 55e0c43c ("add zeromq dependency"), but that was only a brief period the case and the requirement got removed again with d0bed00e ("remove pyzmq package requirement, not used yet"). However this dependency was *never* required in a released version. Closes: https://bugs.gentoo.org/728208 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Florian Schmaus <flo@geekplace.eu> Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
* app-backup/borgbackup: drop 1.1.10-r1.Piotr Karbowski2020-06-072-53/+0
| | | | | | Closes: https://bugs.gentoo.org/713820 Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
* app-backup/borgbackup: 1.1.13 version bump; py38 support.Piotr Karbowski2020-06-073-1/+47
| | | | Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
* app-backup/borgbackup: remove unused patch(es)Michael Mair-Keimberger2020-05-021-110/+0
| | | | | | Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com> Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
* app-backup/borgbackup: remove older versionAnthony G. Basile2020-04-231-52/+0
| | | | | Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
* app-backup/borgbackup: x86 stable wrt bug #713822Agostino Sarubbo2020-04-161-1/+1
| | | | | | Package-Manager: Portage-2.3.89, Repoman-2.3.20 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* app-backup/borgbackup-1.1.11-r2: amd64 stable (bug 713822)Piotr Karbowski2020-04-151-1/+1
| | | | Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
* app-backup/borgbackup: fall back on bundled msgpack, bug #713820Anthony G. Basile2020-03-292-10/+46
| | | | | Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
* app-backup/borgbackup: use system msgpackAnthony G. Basile2020-03-112-2/+112
| | | | | Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
* app-backup/borgbackup: version bump to 1.1.11Anthony G. Basile2020-03-102-0/+53
| | | | | Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
* */*: Clean PYTHON_COMPAT of obsolete implsMichał Górny2020-01-052-4/+4
| | | | | Closes: https://github.com/gentoo/gentoo/pull/14246 Signed-off-by: Michał Górny <mgorny@gentoo.org>
* app-backup/borgbackup-1.1.10-r1: python 3.7 target added.Piotr Karbowski2019-12-051-1/+1
| | | | | Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
* app-backup/borgbackup: drop old.Piotr Karbowski2019-12-054-143/+0
| | | | | Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
* app-backup/borgbackup: amd64 stable wrt bug #699402Agostino Sarubbo2019-11-121-1/+1
| | | | | | Package-Manager: Portage-2.3.76, Repoman-2.3.16 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* app-backup/borgbackup: x86 stable wrt bug #699402Agostino Sarubbo2019-11-121-1/+1
| | | | | | Package-Manager: Portage-2.3.76, Repoman-2.3.16 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* app-backup/borgbackup: 1.1.10-r1, 9999: man pages added.Piotr Karbowski2019-08-252-0/+57
| | | | | | Closes: https://bugs.gentoo.org/639722 Package-Manager: Portage-2.3.72, Repoman-2.3.17 Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
* app-backup/borgbackup-9999: build time dependency on dev-python/pkgconfig.Piotr Karbowski2019-08-251-0/+2
| | | | | Package-Manager: Portage-2.3.72, Repoman-2.3.17 Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
* app-backup/borgbackup: x86 stable (bug #689218)Thomas Deutschmann2019-07-081-1/+1
| | | | | Package-Manager: Portage-2.3.68, Repoman-2.3.16 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
* app-backup/borgbackup: amd64 stable wrt bug #689218Agostino Sarubbo2019-07-081-1/+1
| | | | | | Signed-off-by: Agostino Sarubbo <ago@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11 RepoMan-Options: --include-arches="amd64"
* app-backup/borgbackup: adding myself as another maintainer.Piotr Karbowski2019-06-151-0/+4
| | | | | Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
* app-backup/borgbackup: 1.1.8: fixed msgpack version dependency.Piotr Karbowski2019-06-151-1/+1
| | | | | | | | | This is the same fix that has been applied to 1.1.9, as reported on bug 683012. Bug: https://bugs.gentoo.org/683012 Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
* app-backup/borgbackup: version bump to 1.1.10Anthony G. Basile2019-05-203-1/+49
| | | | | Signed-off-by: Anthony G. Basile <blueness@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
* */*: Remove python3_4 PYTHON_COMPAT correctlyMichał Górny2019-04-173-3/+3
| | | | Signed-off-by: Michał Górny <mgorny@gentoo.org>
* app-backup/borgbackup: 1.1.9: fixed msgpack version dependencyPiotr Karbowski2019-04-141-1/+1
| | | | | | | | | | Currently borgbackup does not support msgpack other than 0.5.6, with version checking hardcoded internally. The msgpack >=0.6 is supposed to be supported in borgbackup-1.2 that is yet to be released. Closes: https://bugs.gentoo.org/683012 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
* app-backup/borgbackup: Restrict msgpack versionPatrick Lauer2019-04-131-1/+1
| | | | | | | Otherwise it'll refuse to run. Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Patrick Lauer <patrick@gentoo.org>
* app-backup/borgbackup: remove older versionsAnthony G. Basile2019-02-123-94/+0
| | | | | Signed-off-by: Anthony G. Basile <blueness@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11