summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* app-emulation/lxd: Make dnsmasq dependency optionalVirgil Dupras35 hours2-2/+7
| | | | | | Gentoo-Bug: 624096 Package-Manager: Portage-2.3.8, Repoman-2.3.1
* app-emulation/lxd: remove oldVirgil Dupras35 hours6-315/+0
| | | | Package-Manager: Portage-2.3.8, Repoman-2.3.1
* app-emulation/lxd: bump to v2.18Virgil Dupras35 hours6-0/+315
| | | | Package-Manager: Portage-2.3.8, Repoman-2.3.1
* app-emulation/lxd: Fix the running of testsVirgil Dupras4 days1-3/+5
| | | | | | | | They still fail, but at least they run. This also removes our dependency on "golang-build" eclass. Closes:#5621 Package-Manager: Portage-2.3.6, Repoman-2.3.1
* app-emulation/lxd: add ipv6 USE flagVirgil Dupras4 days1-3/+3
| | | | | | | | Disabling this USE flag also disables it in dependencies Gentoo-Bug: 629744 Package-Manager: Portage-2.3.6, Repoman-2.3.1
* app-emulation/lxd: normalize initd wordingVirgil Dupras4 days1-1/+1
| | | | | | Gentoo-Bug: 628680 Package-Manager: Portage-2.3.6, Repoman-2.3.1
* app-emulation/lxd: Bump to v2.17Virgil Dupras4 days6-0/+311
| | | | | | | | | | | | | | | | Other than copying, 2 changes were made: 1. `EGO_VENDOR` update 2. Removal of `golang-build_src_install` The second change was necessary because the "client.go" file at the root of the project was removed. Also, I was already planning on removing it, after having consulted with WilliamH on IRC, because this step installed many, many useless files in /usr/lib/go-gentoo (pkg and src files, which are only needed when a package is used as a library by another go package, and it isn't LXD's case). Package-Manager: Portage-2.3.6, Repoman-2.3.1
* app-emulation/lxd: Remove PLOCALES definitionVirgil Dupras2017-09-021-18/+2
| | | | | | | | | as per mgorny's suggestion in https://github.com/gentoo/gentoo/pull/5483 I have tested that, after a merge of that ebuild, localizations still worked (at least the `fr` one). Closes: https://github.com/gentoo/gentoo/pull/5503 Package-Manager: Portage-2.3.6, Repoman-2.3.1
* app-emulation/lxd-2.16: Fix broken SRC_URIVirgil Dupras2017-08-203-17/+4
| | | | | | | | | | | | | My bump to 2.16 had a broken SRC_URI and I didn't notice it because I already had a local "lxd-2.16.tar.gz" distfile. Moreover, this file wasn't even the proper one. This commits fixes the problem, add a missing "zh" locale and removes a spurious patch. Bug: https://bugs.gentoo.org/628334 Closes: https://github.com/gentoo/gentoo/pull/5483 Package-Manager: Portage-2.3.6, Repoman-2.3.1
* app-emulation/lxd: version bump to 2.16.Virgil Dupras2017-08-197-0/+355
| | | | | Package-Manager: Portage-2.3.6, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/5457
* app-emulation/lxd: remove old versionsVirgil Dupras2017-08-1611-627/+0
| | | | | Closes: https://github.com/gentoo/gentoo/pull/5422 Package-Manager: Portage-2.3.6, Repoman-2.3.1
* app-emulation/lxd: add myself as a co-maintainer.Virgil Dupras2017-08-141-0/+8
| | | | | | | | | | | The current maintainer is unresponsive and I'd like to help keeping the package alive. I already have commits to the package, notably a major rewrite in 7c15f08e. Gentoo-Bug: https://bugs.gentoo.org/626042 Package-Manager: Portage-2.3.6, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/5347
* app-emulation/lxd: RDEPEND on lxc >= 2.0.7Virgil Dupras2017-07-301-1/+1
| | | | | | | | | | | | | | Previously and without a ~amd64 flag on app-emulation/lxc, we would end up with v1.0.8 installed and that's bad because LXD would constantly segfault. LXD's README (https://github.com/lxc/lxd#building-from-source) specifies that LXC 2.0+ is required, so that's what we should require. lxc 2.0.7 has been stabilized since I opened the bug, but I still think it's a good idea to be more specific in our dependency declaration. Bug: https://bugs.gentoo.org/show_bug.cgi?id=621830 Package-Manager: Portage-2.3.6, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/5142
* app-emulation/lxd: version bump to 2.14Virgil Dupras2017-06-087-0/+352
| | | | Package-Manager: Portage-2.3.6, Repoman-2.3.2
* app-emulation/lxd: fix file collision with vendor deps (bug 615444)Zac Medico2017-04-142-1/+22
| | | | | Bug: https://bugs.gentoo.org/show_bug.cgi?id=615444 Package-Manager: Portage-2.3.5, Repoman-2.3.2
* app-emulation/lxd: remove old versionsErik Mackdanz2017-03-199-590/+0
| | | | Package-Manager: Portage-2.3.5, Repoman-2.3.2
* app-emulation/lxd: version bump to 2.11Erik Mackdanz2017-03-196-0/+297
| | | | | | | Gentoo-Bug: 612170 Gentoo-Bug: 610718 Gentoo-Bug: 609146 Package-Manager: Portage-2.3.5, Repoman-2.3.2
* Drop remaining $Id$ and $Header$ from files.Ulrich Müller2017-02-283-3/+0
| | | | Bug: 611234
* Drop $Id$ per council decision in bug #611234.Robin H. Johnson2017-02-283-3/+0
| | | | Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
* app-emulation/lxd: bump to 2.8Erik Mackdanz2017-01-295-0/+299
| | | | Package-Manager: Portage-2.3.3, Repoman-2.3.1
* app-emulation/lxd: remove old versionsErik Mackdanz2017-01-0313-846/+0
| | | | Package-Manager: Portage-2.3.3, Repoman-2.3.1
* app-emulation/lxd: Bump to 2.7Erik Mackdanz2017-01-035-0/+299
| | | | Package-Manager: Portage-2.3.3, Repoman-2.3.1
* Revert "Temporarily remove Manifest files that were at risk of having broken ↵Michael Palimaka2016-10-311-0/+4
| | | | | | ChangeLog entries." This reverts commit 48b59c28052dbc9a1c410a8a5d93c1cc3c8c8d4b.
* Temporarily remove Manifest files that were at risk of having broken ↵Michael Palimaka2016-10-311-4/+0
| | | | | | | | | ChangeLog entries. This commit will be immediately reverted. The intention is to force the mtime to be bumped causing the updated Manifest to be propagated to mirrors. Gentoo-bug: 577722
* app-emulation/lxd: Bump to 2.5Erik Mackdanz2016-10-295-0/+295
| | | | Package-Manager: portage-2.3.2
* app-emulation/lxd: Bump to 2.4.1Erik Mackdanz2016-10-115-0/+295
| | | | Package-Manager: portage-2.3.1
* app-emulation/lxd: add einfo that fan is unsupportedErik Mackdanz2016-10-041-0/+3
| | | | Package-Manager: portage-2.3.1
* app-emulation/lxd: remove oldErik Mackdanz2016-10-049-512/+0
| | | | Package-Manager: portage-2.3.1
* app-emulation/lxd: bump to 2.3Erik Mackdanz2016-10-045-0/+292
| | | | | | | | Adds the network subcommand, and addresses a go version dep issue. Gentoo-Bug: 593044 Package-Manager: portage-2.3.1
* app-emulation/lxd: bump to 2.2Erik Mackdanz2016-09-155-0/+256
| | | | Package-Manager: portage-2.3.0
* app-emulation/lxd: bump to 2.1Erik Mackdanz2016-09-045-0/+256
| | | | Package-Manager: portage-2.3.0
* app-emulation/lxd: Drop oldPacho Ramos2016-08-2410-649/+0
| | | | Package-Manager: portage-2.3.0
* app-emulation/lxd: Revbump to add missing depErik Mackdanz2016-07-131-0/+156
| | | | | | Gentoo-bug: 588754 Package-Manager: portage-2.3.0
* app-emulation/lxd: Remove old versionsErik Mackdanz2016-07-1216-807/+0
| | | | Package-Manager: portage-2.3.0
* app-emulation/lxd: Bump to 2.0.3Erik Mackdanz2016-07-125-0/+255
| | | | | | EAPI=6 Package-Manager: portage-2.3.0
* app-emulation/lxd: bump to 2.0.2Erik Mackdanz2016-06-135-0/+247
| | | | | | Address CVE-2016-1581 and CVE-2016-1582 Package-Manager: portage-2.3.0_rc1
* app-emulation/lxd: Version bump to 2.0.1Erik Mackdanz2016-05-195-0/+247
| | | | Package-Manager: portage-2.2.28
* app-emulation/lxd: use #!/sbin/openrc-run instead of #!/sbin/runscriptAustin English2016-05-183-3/+3
|
* app-emulation/lxd: remove oldErik Mackdanz2016-04-136-271/+0
| | | | Package-Manager: portage-2.2.28
* app-emulation/lxd: Bump to 2.0.0Erik Mackdanz2016-04-136-0/+267
| | | | Package-Manager: portage-2.2.28
* app-emulation/lxd: Remove status="" from downstream maintainerMichał Górny2016-03-181-1/+1
| | | | | Remove the status="" attribute from downstream maintainer as it is invalid. GLEP 46 allows status="" for upstream maintainers only.
* app-emulation/lxd: remove oldErik Mackdanz2016-03-087-291/+0
| | | | Package-Manager: portage-2.2.27
* app-emulation/lxd: bump to 2.0.0_rc2Erik Mackdanz2016-03-086-0/+270
| | | | Package-Manager: portage-2.2.27
* app-emulation/lxd: remove oldErik Mackdanz2016-02-286-266/+0
| | | | Package-Manager: portage-2.2.27
* app-emulation/lxd: Version bump to beta 4Erik Mackdanz2016-02-286-0/+270
| | | | | | Removes dep on bridge-utils (uses iproute2 instead) Package-Manager: portage-2.2.27
* app-emulation/lxd: remove oldErik Mackdanz2016-02-206-266/+0
| | | | Package-Manager: portage-2.2.27
* app-emulation/lxd: bump to 2.0.0_beta3Erik Mackdanz2016-02-186-0/+271
| | | | Package-Manager: portage-2.2.27
* app-emulation/lxd: remove oldErik Mackdanz2016-02-036-266/+0
| | | | Package-Manager: portage-2.2.27
* app-emulation/lxd: bump to 2.0.0_beta1Erik Mackdanz2016-02-037-0/+291
| | | | Package-Manager: portage-2.2.27
* app-emulation/lxd: remove oldErik Mackdanz2016-01-246-264/+0
| | | | Package-Manager: portage-2.2.26