summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* Move {virtual -> app-alternatives}/yaccSam James46 hours1-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* app-emulation/vice: Keyword 3.6.1-r2 arm, #861008Sam James2022-10-291-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* app-emulation/vice: add media-libs/flac subslot depSam James2022-09-101-1/+1
| | | | | | media-libs/flac-1.4.0 breaks ABI. Signed-off-by: Sam James <sam@gentoo.org>
* app-emulation/vice: Keyword 3.6.1-r1 arm64, #861008Arthur Zamarin2022-07-291-1/+1
| | | | Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
* app-emulation/vice: EAPI7->8Ionen Wolkens2022-07-251-6/+6
| | | | | | | | Been meaning to clean this up after realizing could use QA_ for --disable-static. Also update jpeg/pulseaudio deps while revbumping. Trivial so straight-to-stable'ing. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* app-emulation/vice: depend on <ffmpeg-5Ionen Wolkens2022-02-281-1/+2
| | | | | | | | | | However, if left unresolved by upstream for too long, masking the USE sound like a better long term solution (this feature is not really essential). Albeit flag is disabled by default and shouldn't affect many. Bug: https://bugs.gentoo.org/834359 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* app-emulation/vice: drop 3.5-r1, 3.6Ionen Wolkens2022-02-053-371/+0
| | | | Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* app-emulation/vice: stabilize 3.6.1 for amd64, x86Ionen Wolkens2022-02-031-1/+1
| | | | | | Simple bugfix release. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* app-emulation/vice: add 3.6.1Ionen Wolkens2022-01-252-0/+193
| | | | | | | | Should've went with this bugfix release for next stable, giving it a few days and will fast stable. Nothing major but fixes some regressions/annoyance introduced in 3.6.0. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* app-emulation/vice: stabilize 3.6 for amd64, x86Ionen Wolkens2022-01-251-2/+2
| | | | Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* app-emulation/vice: add 3.6Ionen Wolkens2021-12-262-0/+194
| | | | | | | | | | | | | Upstream removed ffmpeg/lame bundled libs, they were already unused here but options to disable them are now unnecessary. Adds new IUSE=openmp, and new dep on libcap for IUSE=ethernet. html docs' Makefile.am no longer sets html files to be installed, but, while don't need the full website, the user manual is worthwhile so install it anyway alongside the new vim syntax files. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* app-emulation/vice: drop 3.4_p38553Ionen Wolkens2021-10-303-215/+0
| | | | Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* app-emulation/vice: stabilize 3.5-r1 for amd64, x86Ionen Wolkens2021-10-111-1/+1
| | | | | Closes: https://bugs.gentoo.org/814962 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* app-emulation/vice: enable midi support, tighten depsIonen Wolkens2021-10-031-30/+28
| | | | | | | | | | | | | | | | Midi support can work either through alsa or oss, so enable if one of these is set (no extra deps). While revbumping for this, adjusted deps a bit (notably fails to build without [X] on gtk+:3). Also removed IUSE=ipv6 (enabled by default). Not moving to EAPI-8 yet given econf tries to pass an unrecognized --disable-static (bug #814380) Closes: https://bugs.gentoo.org/815913 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* **/metadata.xml: Replace http by https in DOCTYPE elementUlrich Müller2021-09-111-1/+1
| | | | | Bug: https://bugs.gentoo.org/552720 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* app-emulation/vice: add cpuhistory flag, tidy ebuildIonen Wolkens2021-06-222-61/+71
| | | | | | | | Also fixed USE=debug and a configure-stage direct AR call. Thanks-to: Vedran Vrbanc Closes: https://bugs.gentoo.org/782571 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* app-emulation/vice: add sdl2-image depSam James2021-01-091-1/+4
| | | | | | Closes: https://bugs.gentoo.org/764530 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
* app-emulation/vice: Version bump to 3.5James Le Cuirot2021-01-072-0/+167
| | | | | | | | | This fixes building against musl. Closes: https://bugs.gentoo.org/761529 Closes: https://bugs.gentoo.org/764218 Package-Manager: Portage-3.0.12, Repoman-3.0.1 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
* app-emulation/vice: cleanup oldSam James2021-01-072-173/+0
| | | | | Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
* app-emulation/vice: Stabilize 3.4_p38553 x86, #764128Sam James2021-01-071-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* app-emulation/vice: Stabilize 3.4_p38553 amd64, #764128Sam James2021-01-071-2/+2
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* app-emulation/vice: Add missing x11-misc/xdg-utils dependencyJames Le Cuirot2020-09-261-0/+1
| | | | | | Closes: https://bugs.gentoo.org/744835 Package-Manager: Portage-3.0.6, Repoman-3.0.1 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
* app-emulation/vice: Add missing dos2unix dependencyJames Le Cuirot2020-09-181-0/+1
| | | | | | Closes: https://bugs.gentoo.org/743178 Package-Manager: Portage-3.0.6, Repoman-3.0.1 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
* app-emulation/vice: Drop old 3.4_p37605James Le Cuirot2020-09-173-206/+0
| | | | | Package-Manager: Portage-3.0.6, Repoman-3.0.1 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
* app-emulation/vice: Bump 3.4 to rev 38553James Le Cuirot2020-09-173-0/+213
| | | | | | | This now adds desktop icons. Package-Manager: Portage-3.0.6, Repoman-3.0.1 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
* app-emulation/vice: update homepage and use httpsMichael Mair-Keimberger2020-06-142-2/+2
| | | | | | | Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/16239 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
* app-emulation/vice: migrate from libavMikle Kolyada2020-04-252-10/+4
| | | | | Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
* app-emulation/vice: Drop old 3.1James Le Cuirot2020-04-145-260/+0
| | | | | Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
* app-emulation/vice: x86 stable wrt bug #716288Agostino Sarubbo2020-04-141-1/+1
| | | | | | Package-Manager: Portage-2.3.89, Repoman-2.3.20 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* app-emulation/vice: amd64 stable wrt bug #716288Agostino Sarubbo2020-04-081-1/+1
| | | | | | Package-Manager: Portage-2.3.89, Repoman-2.3.20 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* app-emulation/vice: Bump 3.4 to rev 37605, add SDL2 pkg-config patchJames Le Cuirot2020-04-053-0/+209
| | | | | | | | This includes GCC 10 fixes. Closes: https://bugs.gentoo.org/710990 Package-Manager: Portage-2.3.96, Repoman-2.3.20 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
* app-emulation/vice: Canonical variable orderDavid Seifert2020-02-221-3/+5
| | | | | Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
* app-emulation/vice: Bump to post 3.4 snapshot with multiple variantsJames Le Cuirot2020-02-223-0/+178
| | | | | | | | | | | The ebuild has been almost entirely rewritten. Many missing dependencies have been added. Multiple variants for GTK, SDL, and headless can now be installed simultaneously. Closes: https://bugs.gentoo.org/656722 Closes: https://github.com/gentoo/gentoo/pull/13504 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
* */*: Depend on >=x11-apps/mkfontscale-1.2.0 instead of x11-apps/mkfontdir.Arfrever Frehtes Taifersar Arahesis2019-10-161-2/+2
| | | | | Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org> Signed-off-by: Matt Turner <mattst88@gentoo.org>
* app-emulation/vice: Sort USE, DEPENDsAndreas Sturmlechner2018-11-291-26/+23
| | | | | Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* app-emulation/vice: Fix build with ffmpeg-4Andreas Sturmlechner2018-11-293-3/+89
| | | | | | | | | Rename PATCH to PATCHES (again!) and restore missing patch. Thanks-to: Adam Jones <adam@eidolon.org.uk> Closes: https://bugs.gentoo.org/670620 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* app-emulation/*: Update dependencies (x11-proto/* -> x11-base/xorg-proto).Arfrever Frehtes Taifersar Arahesis2018-04-261-6/+1
|
* app-emulation/vice: Drop oldPacho Ramos2018-03-289-957/+0
| | | | Package-Manager: Portage-2.3.26, Repoman-2.3.7
* app-emulation/vice: amd64 stable, bug #648890Pacho Ramos2018-03-281-1/+1
| | | | Package-Manager: Portage-2.3.26, Repoman-2.3.7
* app-emulation/vice: x86 stable (bug #648890)Thomas Deutschmann2018-03-261-1/+1
| | | | Package-Manager: Portage-2.3.24, Repoman-2.3.6
* app-emulation/vice: Version bump to 3.1David Seifert2018-01-212-0/+179
| | | | | Closes: https://bugs.gentoo.org/606534 Package-Manager: Portage-2.3.19, Repoman-2.3.6
* app-emulation/vice: Update Manifest hashes.Ulrich Müller2017-12-101-3/+3
|
* *games*/*: Dekeyword ppc/ia64/sparcDavid Seifert2017-07-085-5/+5
| | | | Closes: https://github.com/gentoo/gentoo/pull/4614
* Drop $Id$ per council decision in bug #611234.Robin H. Johnson2017-02-285-5/+0
| | | | Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
* app-emulation/vice: Fix compiling with '>=media-video/ffmpeg-3'.Jimi Huotari2017-01-262-1/+71
| | | | | | | | | | Add a patch to allow compiling '2.4.27-r2' with 'ffmpeg-3' installed. Backported from: https://sourceforge.net/p/vice-emu/code/31580/ Also change 'PATCH' to 'PATCHES'. Package-Manager: portage-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/2759
* app-emulation/vice: Version bump to 2.4.31.Jimi Huotari2017-01-262-0/+175
| | | | | Package-Manager: portage-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/2643
* app-emulation/vice: call xdg_environment_reset() in src_prepare() to avoid ↵Austin English2017-01-181-0/+179
| | | | | | | | sandbox violations Gentoo-Bug: https://bugs.gentoo.org/599576 Package-Manager: portage-2.3.2
* app-emulation/vice: remove broken vice-2.4.27-r1, superseded by vice-2.4.27-r2Austin English2016-10-141-174/+0
| | | | Package-Manager: portage-2.3.0
* app-emulation/vice: ensure that libraries are installed to /usr/lib64Austin English2016-10-141-0/+174
| | | | | | Gentoo-Bug: https://bugs.gentoo.org/595968 Package-Manager: portage-2.3.0
* app-emulation/vice: remove deprecated games eclassAustin English2016-07-011-0/+174
| | | | | | | | Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.2.28