summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* app-laptop/tp_smapi: drop 0.43-r1Mike Pagano12 days1-74/+0
| | | | Signed-off-by: Mike Pagano <mpagano@gentoo.org>
* app-laptop/tp_smapi: update EAPI 6 -> 8Mike Pagano12 days1-0/+74
| | | | | | Bumped with permission from maintainer (mjo) Signed-off-by: Mike Pagano <mpagano@gentoo.org>
* **/metadata.xml: Replace http by https in DOCTYPE elementUlrich Müller2021-09-111-1/+1
| | | | | Bug: https://bugs.gentoo.org/552720 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* app-laptop/tp_smapi: migrate to sys-apps/kmodMikle Kolyada2020-08-081-1/+1
| | | | | Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
* app-laptop/tp_smapi: [QA] Fix ${HOMEPAGE} in SRC_URIDavid Seifert2019-08-281-2/+2
| | | | | Package-Manager: Portage-2.3.73, Repoman-2.3.17 Signed-off-by: David Seifert <soap@gentoo.org>
* app-laptop/tp_smapi: remove "unused" tp_smapi-0.42-r1.ebuild.Michael Orlitzky2019-03-022-75/+0
| | | | | Signed-off-by: Michael Orlitzky <mjo@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
* app-laptop/tp_smapi: x86 stable (bug #678542)Thomas Deutschmann2019-03-021-1/+1
| | | | | Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
* app-laptop/tp_smapi: amd64 stable wrt bug #678542Mikle Kolyada2019-03-021-2/+2
| | | | | | Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11 RepoMan-Options: --include-arches="amd64"
* app-laptop/tp_smapi: new version 0.43.Michael Orlitzky2018-04-173-45/+1
| | | | Package-Manager: Portage-2.3.24, Repoman-2.3.6
* app-laptop/tp_smapi: new revision to fix the build with >= linux-4.15.Michael Orlitzky2018-01-292-0/+119
| | | | | Closes: https://bugs.gentoo.org/646096 Package-Manager: Portage-2.3.19, Repoman-2.3.6
* app-laptop/*: Update Manifest hashesMichał Górny2017-12-091-1/+1
|
* app-laptop/tp_smapi: remove unused version tp_smapi-0.41.Michael Orlitzky2017-07-232-64/+0
| | | | Package-Manager: Portage-2.3.6, Repoman-2.3.1
* Drop $Id$ per council decision in bug #611234.Robin H. Johnson2017-02-282-2/+0
| | | | Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
* app-laptop/tp_smapi: x86 stable wrt bug #596344Agostino Sarubbo2016-12-291-1/+1
| | | | | | Package-Manager: portage-2.3.0 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* app-laptop/tp_smapi: stabilize tp_smapi-0.42-r1 for amd64.Michael Orlitzky2016-12-191-1/+1
| | | | | | | | | | Maintainer stabilization: this package requires special hardware, which I possess for amd64. I've tested it there, but am unable to do so for x86. Gentoo-Bug: 596344 Package-Manager: portage-2.3.0
* app-laptop/tp_smapi: new revision that doesn't call pkg_pretend() directly.Michael Orlitzky2016-10-121-2/+10
| | | | | | Gentoo-Bug: 596622 Package-Manager: portage-2.3.0
* app-laptop/tp_smapi: new version 0.42.Michael Orlitzky2016-08-053-18/+18
| | | | | | | | | | | | | | | | | | | | This adds a new version 0.42, and updates the ebuild a bit. First, the ebuild was updated to EAPI=6. Then the RESTRICT=userpriv was removed, as it no longer seems to have any effect: I can install the package fine with FEATURES=userpriv. Next, an obsolete kernel version check was removed. Every version of every flavor of Linux sources we have in the tree is already newer than 2.6.19. Finally, einstalldocs (from EAPI=6) was used to install the current set of docs as well as a TODO that had been omitted. I have added myself as the maintainer of this package, since I still have hardware that it supports. Gentoo-Bug: 516570 Gentoo-Bug: 583206 Package-Manager: portage-2.2.28
* app-laptop/tp_smapi: remove tp_smapi-0.41-r1Austin English2016-04-261-75/+0
| | | | Package-Manager: portage-2.2.26
* app-laptop/tp_smapi: use #!/sbin/openrc-run instead of #!/sbin/runscriptAustin English2016-04-262-1/+76
| | | | | | Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=573846 Package-Manager: portage-2.2.26
* metadata.xml: Add maintainer-needed comment to packages without maintainer.Ulrich Müller2016-02-281-0/+1
| | | | Bug: 575810
* Remove explicit notion of maintainer-needed, for GLEP 67Michał Górny2016-01-241-3/+0
| | | | | | GLEP 67 removes the explicit notion of maintainer-needed@g.o being used for packages lacking maintainers, in favor of assuming maintainer-needed whenever the package has no maintainers.
* Unify quoting in metadata.xml files for machine processingMichał Górny2016-01-241-1/+1
| | | | | | | Force unified quoting in all metadata.xml files since lxml does not preserve original use of single and double quotes. Ensuring unified quoting before the process allows distinguishing the GLEP 67-related metadata.xml changes from unrelated quoting changes.
* app-laptop/tp_smapi: Filter -mssse3 (bug #492964)Sebastian Pipping2015-12-231-0/+1
| | | | Package-Manager: portage-2.2.26
* app-laptop/tp_smapi: Fix compilation (bug #492964)Sebastian Pipping2015-12-201-0/+74
| | | | Package-Manager: portage-2.2.26
* Add missing remote-id type=sourceforgeJustin Lecher2015-10-011-1/+2
| | | | Signed-off-by: Justin Lecher <jlec@gentoo.org>
* Revert DOCTYPE SYSTEM https changes in metadata.xmlMike Gilbert2015-08-241-1/+1
| | | | | | | repoman does not yet accept the https version. This partially reverts eaaface92ee81f30a6ac66fe7acbcc42c00dc450. Bug: https://bugs.gentoo.org/552720
* Use https by defaultJustin Lecher2015-08-241-1/+1
| | | | | | Convert all URLs for sites supporting encrypted connections from http to https Signed-off-by: Justin Lecher <jlec@gentoo.org>
* [QA] Remove executable bit from files, bug 550434.Ulrich Müller2015-08-091-0/+0
|
* proj/gentoo: Initial commitRobin H. Johnson2015-08-085-0/+190
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed