summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* app-office/gnumeric: Switch to PYTHON_MULTI_USEDEP APIMichał Górny8 days2-2/+5
| | | | Signed-off-by: Michał Górny <mgorny@gentoo.org>
* */*: Clean PYTHON_COMPAT of obsolete implsMichał Górny2020-01-052-4/+4
| | | | | Closes: https://github.com/gentoo/gentoo/pull/14246 Signed-off-by: Michał Górny <mgorny@gentoo.org>
* app-office/gnumeric: Add myself as maintainerDavid Seifert2020-01-031-10/+13
| | | | | | Package-Manager: Portage-2.3.84, Repoman-2.3.20 Acked-by: Mart Raudsepp <leio@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
* app-office: Remove *-fbsd KEYWORDSMichał Górny2019-10-113-3/+3
| | | | Signed-off-by: Michał Górny <mgorny@gentoo.org>
* app-office/gnumeric: Improve Python supportMichał Górny2019-09-062-12/+22
| | | | | | | | | | | Add missing PYTHON_REQUIRED_USE and PYTHON_DEPS for gi.overrides install. While at it, make it conditional to USE=introspection. Reduce deps for USE=python to Python 2 variants. Closes: https://bugs.gentoo.org/690552 Signed-off-by: Michał Górny <mgorny@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/12691 Signed-off-by: Michał Górny <mgorny@gentoo.org>
* */*: Remove python3_4 PYTHON_COMPAT correctlyMichał Górny2019-04-172-4/+4
| | | | Signed-off-by: Michał Górny <mgorny@gentoo.org>
* app-office/gnumeric: version bumpDennis Lamm2019-02-042-0/+78
| | | | Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org>
* app-office/gnumeric: remove oldMart Raudsepp2018-12-022-65/+0
| | | | | Signed-off-by: Mart Raudsepp <leio@gentoo.org> Package-Manager: Portage-2.3.52, Repoman-2.3.11
* app-office/gnumeric: x86 stable wrt bug #670024Mikle Kolyada2018-12-021-1/+1
| | | | | Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
* app-office/gnumeric: amd64 stable wrt bug #670024Mikle Kolyada2018-12-021-2/+2
| | | | | Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
* app-office/gnumeric: add missing DTD to DEPENDGilles Dartiguelongue2018-11-171-8/+20
| | | | | | | | | Delete unneeded SRC_URI. Make sure gobject-introspection can be installed for all supported python versions. Closes: https://bugs.gentoo.org/649390 Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Gilles Dartiguelongue <eva@gentoo.org>
* app-office/gnumeric: bump to 1.12.43Igor Mróz2018-11-172-0/+66
| | | | | | | Signed-off-by: Igor Mróz <mrozigor@wp.pl> Package-Manager: Portage-2.3.51, Repoman-2.3.11 Closes: https://github.com/gentoo/gentoo/pull/10318 Signed-off-by: Gilles Dartiguelongue <eva@gentoo.org>
* app-office/gnumeric: bump to 1.12.39Mart Raudsepp2018-05-072-0/+65
| | | | | | | | | | There's also a 1.12.40 released, but that needs more care for new python introspection overrides installing; configure.ac changes are no good out of the box for sandbox distro building (and potentially multiple python versions in the future, albeit python2 only for now it seems). Package-Manager: Portage-2.3.28, Repoman-2.3.9
* app-office/gnumeric: remove oldMart Raudsepp2018-04-292-65/+0
| | | | Package-Manager: Portage-2.3.28, Repoman-2.3.9
* app-office/gnumeric: amd64 stableAaron Bauman2018-04-261-1/+1
| | | | | Bug: https://bugs.gentoo.org/652976 Package-Manager: Portage-2.3.31, Repoman-2.3.9
* app-office/gnumeric: x86 stable (bug #652976)Thomas Deutschmann2018-04-261-1/+1
| | | | Package-Manager: Portage-2.3.31, Repoman-2.3.9
* app-office/gnumeric: version bump 1.12.35 → 1.12.38Gilles Dartiguelongue2018-02-082-0/+65
| | | | Package-Manager: Portage-2.3.24, Repoman-2.3.6
* app-office/gnumeric: remove oldMart Raudsepp2017-12-202-64/+0
| | | | Package-Manager: Portage-2.3.19, Repoman-2.3.6
* app-office/gnumeric: x86 stable (bug #635938)Thomas Deutschmann2017-12-191-1/+1
| | | | Package-Manager: Portage-2.3.19, Repoman-2.3.6
* app-office/gnumeric-1.12.35-r0: amd64 stableTobias Klausmann2017-12-161-1/+1
| | | | Gentoo-Bug: http://bugs.gentoo.org/635938
* app-office/*: Update Manifest hashesMichał Górny2017-12-091-2/+2
|
* app-office/gnumeric: remove oldMart Raudsepp2017-07-103-126/+0
| | | | Package-Manager: Portage-2.3.5, Repoman-2.3.2
* app-office/gnumeric: bump to 1.12.35Mart Raudsepp2017-07-102-0/+65
| | | | Package-Manager: Portage-2.3.5, Repoman-2.3.2
* app-office/gnumeric: Add slot operator to Perl dependency (links to libperl)Andreas K. Hüttel2017-03-173-6/+6
| | | | Package-Manager: Portage-2.3.5, Repoman-2.3.2
* Drop $Id$ per council decision in bug #611234.Robin H. Johnson2017-02-283-3/+0
| | | | Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
* app-office/gnumeric: x86 stable, bug 587010Pacho Ramos2016-10-011-1/+1
| | | | | Package-Manager: portage-2.3.0 RepoMan-Options: --include-arches="x86"
* app-office/gnumeric: amd64 stable, bug 587010Pacho Ramos2016-10-011-1/+1
| | | | | Package-Manager: portage-2.3.0 RepoMan-Options: --include-arches="amd64"
* app-office/gnumeric: version bump to 1.12.32Gilles Dartiguelongue2016-09-062-0/+65
| | | | Package-Manager: portage-2.3.0
* app-office/gnumeric: Version bumpPacho Ramos2016-07-022-0/+64
| | | | Package-Manager: portage-2.3.0_rc1
* app-office/gnumeric: Drop oldPacho Ramos2016-07-022-65/+0
| | | | Package-Manager: portage-2.3.0_rc1
* app-office/gnumeric: x86 stable, bug 584468Pacho Ramos2016-06-111-1/+1
| | | | | Package-Manager: portage-2.3.0_rc1 RepoMan-Options: --include-arches="x86"
* app-office/gnumeric: amd64 stable, bug 584468Pacho Ramos2016-06-111-1/+1
| | | | | Package-Manager: portage-2.3.0_rc1 RepoMan-Options: --include-arches="amd64"
* app-office/gnumeric: Version bumpPacho Ramos2016-05-282-0/+64
| | | | Package-Manager: portage-2.3.0_rc1
* app-office/gnumeric: Drop oldPacho Ramos2016-05-282-65/+0
| | | | Package-Manager: portage-2.3.0_rc1
* app-office/gnumeric: Version bumpPacho Ramos2016-04-032-0/+65
| | | | Package-Manager: portage-2.2.28
* app-office/gnumeric: Drop oldPacho Ramos2016-04-033-131/+0
| | | | Package-Manager: portage-2.2.28
* app-office/gnumeric: x86 stable wrt bug #427546Mikle Kolyada2016-03-061-1/+1
| | | | Package-Manager: portage-2.2.26
* app-office/gnumeric: amd64 stable, bug 566378Pacho Ramos2016-02-221-1/+1
| | | | | Package-Manager: portage-2.2.27 RepoMan-Options: --include-arches="amd64"
* app-office/gnumeric: Version bumpPacho Ramos2016-02-202-0/+65
| | | | Package-Manager: portage-2.2.27
* app-office/gnumeric: Drop oldPacho Ramos2016-02-202-65/+0
| | | | Package-Manager: portage-2.2.27
* Set appropriate maintainer types in metadata.xml (GLEP 67)Michał Górny2016-01-241-1/+1
|
* Replace all herds with appropriate projects (GLEP 67)Michał Górny2016-01-241-1/+4
| | | | | Replace all uses of herd with appropriate project maintainers, or no maintainers in case of herds requested to be disbanded.
* Unify quoting in metadata.xml files for machine processingMichał Górny2016-01-241-2/+2
| | | | | | | Force unified quoting in all metadata.xml files since lxml does not preserve original use of single and double quotes. Ensuring unified quoting before the process allows distinguishing the GLEP 67-related metadata.xml changes from unrelated quoting changes.
* app-office/gnumeric: Version bumpPacho Ramos2016-01-102-0/+65
| | | | Package-Manager: portage-2.2.26
* app-office/gnumeric: Version bumpPacho Ramos2015-12-262-0/+65
| | | | Package-Manager: portage-2.2.26
* app-office/gnumeric: Drop oldPacho Ramos2015-12-262-66/+0
| | | | Package-Manager: portage-2.2.26
* app-office/gnumeric: x86 stable wrt bug #565086Agostino Sarubbo2015-11-111-1/+1
| | | | | Package-Manager: portage-2.2.20.1 RepoMan-Options: --include-arches="x86"
* app-office/gnumeric: amd64 stable wrt bug #565086Agostino Sarubbo2015-11-101-1/+1
| | | | | Package-Manager: portage-2.2.20.1 RepoMan-Options: --include-arches="amd64"
* app-office/gnumeric: Drop oldPacho Ramos2015-10-172-66/+0
| | | | Package-Manager: portage-2.2.23
* app-office/gnumeric: Version bumpPacho Ramos2015-10-172-0/+66
| | | | Package-Manager: portage-2.2.23