summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* dev-lang/perl: Add Perl 5.34.0-RC1 for testing and preparationAndreas K. Hüttel7 days2-0/+817
| | | | | Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
* dev-lang/perl: drop s390 to ~s390 (unstable)Sam James2021-04-051-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* */*: Normalize metadata.xml filesMichał Górny2021-03-161-1/+1
| | | | | | | | | | | Normalize quoting, replace '>' with entities, replace unnecessary entities, remove trailing empty lines. Done via: find -name metadata.xml -exec xml ed -P -L -d //none {} + Signed-off-by: Michał Górny <mgorny@gentoo.org>
* dev-lang/perl: drop upstreamed Darwin patchSam James2021-02-131-4/+0
| | | | | Package-Manager: Portage-3.0.14-prefix, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
* dev-lang/perl: Fix dual versionsAndreas K. Hüttel2021-01-261-1/+1
| | | | | Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
* dev-lang/perl: Add 5.32.1. WIP, do not use yet. Masked.Andreas K. Hüttel2021-01-262-0/+822
| | | | | Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
* dev-lang/perl: drop x86-macosFabian Groffen2021-01-071-2/+2
| | | | | Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
* dev-lang/perl: drop x86-macosFabian Groffen2021-01-063-6/+6
| | | | | Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
* dev-lang/perl: Drop oldAndreas K. Huettel2020-12-311-661/+0
| | | | | Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Andreas K. Huettel <dilfridge@gentoo.org>
* dev-lang/perl: re-keyword 5.32.0-r1 (it's still masked though)Andreas K. Huettel2020-12-301-2/+1
| | | | | Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Andreas K. Huettel <dilfridge@gentoo.org>
* dev-lang/perl: Enable PERL_SINGLE_SLOT by defaultAndreas K. Huettel2020-12-301-0/+3
| | | | | Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Andreas K. Huettel <dilfridge@gentoo.org>
* dev-lang/perl: drop ~ppc-aix and ~m68k-mintFabian Groffen2020-12-265-15/+5
| | | | | Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
* dev-lang/perl: add missing darwin 20 patch, #757249Fabian Groffen2020-12-265-0/+196
| | | | | | Bug: https://bugs.gentoo.org/757249 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
* dev-lang/perl: fix flock on sparc-solarisFabian Groffen2020-12-264-4/+20
| | | | | Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
* dev-lang/perl: Add USE="minimal" for bootstrappersKent Fredric2020-10-193-15/+21
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Even though PDEPEND is "post" dependency, portage still *schedules* PDEPENDS to install *before* perl, where possible. This leads to a fun problem under cross/chroot/catalyst stuff, as it then necessitates you install perl-cleaner, and thus, portage-utils, before installing perl. And portage-utils in turn necessitates a lot of complexity by default, openmp, nettle, ... ssl... And if those fail, which is highly likely, portage doesn't try to install perl, even though it would compile just fine. And in reality, you don't actually need perl-cleaner to have a working perl interpreter. Its just strongly recommended and all systems should have it. Same goes for the virtuals and subsequent perl-core/ stuff, which also isn't strictly necessary for a working perl, at least, not when you're bootstrapping it, as this is mostly our safeguards against various security concerns. So pretty much 100% of what is in PDEPEND should be able to be turned off, if you're an adult and know what you're doing. Globally setting USE="minimal" is not officially supported, but bugs that result from it are welcome. Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
* dev-lang/perl: Remove unaligned access direction workaroundKent Fredric2020-08-112-16/+0
| | | | | | | | | | | | | | As its been indicated that this detection has been fixed upstream in perl since 5.31.5, and the workaround should no longer be needed Bug: https://bugs.gentoo.org/676062 Bug: https://bugs.gentoo.org/688432 Bug: https://github.com/Perl/perl5/issues/16828 Bug: https://github.com/Perl/perl5/issues/16680 Commit: https://github.com/perl/perl5/commit/ee9ac1cd8eb988fea70841eae211b11355711416 Commit: https://github.com/perl/perl5/commit/e8864dba80952684bf3afe83438d4eee0c3939a9 Package-Manager: Portage-2.3.103, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
* dev-lang/perl: Add dependency on libcryptKent Fredric2020-08-114-0/+4
| | | | | | | | As this is auto-linked to by perl, and will need rebuilding when libcrypt is updated. Package-Manager: Portage-2.3.103, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
* dev-lang/perl: Port my work-in-progress unkeyworded stuff to 5.32.0Kent Fredric2020-08-092-0/+819
| | | | | Package-Manager: Portage-2.3.103, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
* dev-lang/perl: Fix broken duallife handling for podchecker/pod2usageKent Fredric2020-08-091-0/+2
| | | | | | | | | | | | | | | | | | | | | | | | | | | Its understandable how this happened. Previously, Pod::Usage and Pod::Checker were both shipped with Pod::Parser back in Pod::Parser 1.51 However, *both* Pod::Usage and Pod::Checker were split out into their own CPAN distributions after Pod::Parser 1.51 And perl *only* removed Pod::Parser ``` Pod::Checker was first released with perl v5.6.0 v5.32.0 1.73 Pod::Parser was first released with perl v5.6.0 and removed from v5.31.1 Pod::Usage was first released with perl v5.6.0 v5.32.0 1.69 ``` Subsequently, removing the provision that was there initially for Pod-Parser breaks code when removed, as it, unbeknownst to us, became an over-application. Package-Manager: Portage-2.3.103, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
* dev-lang/perl: Pod-Parser was removed from coreAndreas K. Hüttel2020-08-081-1/+0
| | | | | Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
* dev-lang/perl: 5.30.3-r2 rework patching bundle logicKent Fredric2020-08-083-200/+131
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | This change reworks the patching logic entirely to avoid the use of a sequence file, instead, relying on directory sort order and numerically prefixed filenames. In addition to this change, work is done on the patchset authoring side to pre-extract important fields like "bugs" and "description" for the patches and puts them in easy to read files, in order to more clearly generate patchlevel_gentoo.h ( seen in Perl -V ) Perl -V now includes more verbose details, including fully qualified bug URLs. Additionally, its more straight forward to add records to the patch bundle within the ebuild, using the new "add_patch" helper, so that even files applied from ${FILESDIR} can be shown in `perl -V` Patches are fully re-rolled as git patches against perl v5.30.3 Sourcing from "mirror://gentoo" is now implicit, as this syntax is discouraged. Patch for Net::SNMP removed from bundle as it just now introduces redundant documentation. Patch for gentoo-libdirs now bundled, and properly rehashed to avoid failing in various porting tests. Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
* dev-lang/perl: re-add keywordsAndreas K. Hüttel2020-08-071-2/+1
| | | | | Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
* dev-lang/perl: Update dual versionsAndreas K. Hüttel2020-08-071-9/+9
| | | | | Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
* dev-lang/perl: remove unused patchMichael Mair-Keimberger2020-07-221-99/+0
| | | | | | | Closes: https://github.com/gentoo/gentoo/pull/16762 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com> Signed-off-by: Kent Fredric <kentnl@gentoo.org>
* dev-lang/perl: Remove oldAndreas K. Hüttel2020-07-155-2623/+0
| | | | | Package-Manager: Portage-2.3.99, Repoman-2.3.23 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
* dev-lang/perl: 5.32 version bump, WIP/no keywords/maskedAndreas K. Hüttel2020-07-152-0/+661
| | | | | Package-Manager: Portage-2.3.99, Repoman-2.3.23 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
* dev-lang/perl: 5.30.0-r2, fix QA issues MissingSlash+UnnessecaryStripKent Fredric2020-06-211-8/+8
| | | | | | | | | | | | - One instance of MissingSlash which pukes its brains over, thanks EAPI7 - Seven instances of unnecessary slash stripping I suspect the fixes I do for the slash-stripping might later barf about not adding an explict slash, which will be bonkers if that happens, because the variables in question have leading slashes! Joys. Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
* dev-lang/perl: Add unkeyworded -r2 version with WIP featuresKent Fredric2020-06-212-0/+887
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | This is a work in-progress experiment, hence, it is unkeyworded until I can get more eyes on the changes, and fully test the consequences at scale. Important Changes: - Convert to EAPI7 - Remove inherit on eutils - Replace calls to "epatch" to "eapply", but resulting in a loss of nice output - Add new hidden feature PERL_SINGLE_SLOT, which, when set, installs perl into a directory named after SUBSLOT (eg: 5.30) as opposed to one following the explicit name (eg: 5.30.2), which aims to pre-emptively solve (in both direction) the problem faced by shipping binpkg's, where the built perl has only one set of INC dirs (eg: 5.30.2), but a binpkg was built with a different, but compatible perl (eg: 5.30.1), and subsequently, installs to an @INC dir that is not visible to the built perl. Instead, all perl's that are defined to be inter-compatible share the same directory for both arch-dependent and arch-independent code, so binpkg's only need to be regenerated when: - Upgrading/downgrading between major revisions - Flipping USE="debug" or USE="ithreads". Under PERL_SINGLE_SLOT, directories that should be compatible, and are available, but built under the previous scheme, are also inhaled into @INC for ease of transition. The name of this flag is subject to change, and may become a USE flag. - Add a new hidden feature PERL_SUPPORT_SINGLE_SLOT, which builds perl the same way as in previous versions, but also probes for version'd directories generated by installing packages on perl's built with PERL_SINGLE_SLOT, as a fallback mechaism for transitioning away from a perl built with PERL_SINGLE_SLOT. The name of this flag is subject to change, and may become a USE flag - Add a patch to various parts of Configure, perl.c, and friends, to facilitate the above, which exposes itself as -Dgentoolibdirs=, and has the same syntax as -Dotherlibdirs, but doesn't pollute everything by adding its own arch-dirs when they weren't asked for. This patch may also later help facilitate building perl's without PERL_SINGLE_SLOT, but with other @INC dirs forced into place, for the same purpose, but implemented differently, as the previous mechanism, -Dinc_version_list is limited in that it: - Excludes internally directories that don't exist - Mangles directories sometimes trashing @INC entirely, throwing away litterally all the versions you passed. - Fixed a very embarrasing typo in the einfo code, ${EROO%/T} ... - Restructured the @INC discovery/cleanup logic into dedicated functions - Add more error handling in the discovery path, especially adding loud error output if directories that *need* to be traversed for compat discovery cannot be traversed, due to misconfigured permissions. - Fix an embarrasing bug in @INC list stripping, that due to inherently being a *substring* match, not a *fullstring* match, could have excluded 5.30.20 from the @INC path for 5.30.2, even though they're intercompatible. This became more obvious, when one was trying to strip '5.30' from a list that contained '5.30.1', '5.30.2', because it just ate everything! Questions: - Why do we have bzip2 in RDEPEND? Surely, that should be BDEPEND-only - Are we even using bzip2 anymore? - Should we migrate the patch ball to being a more-common-these-days set of numerically ordered patches, and potentially reduce the handling complexity in the ebuild as a result? Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
* dev-lang/perl: remove unused patchMichael Mair-Keimberger2020-06-141-13/+0
| | | | | | | Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/16231 Signed-off-by: Aaron Bauman <bman@gentoo.org>
* dev-lang/perl: bump to perl-cross-1.3.4Mike Gilbert2020-06-142-1/+2
| | | | | Bug: https://bugs.gentoo.org/685660 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
* dev-lang/perl: stable 5.30.3 for hppa, bug #723792Rolf Eike Beer2020-06-081-1/+1
| | | | | | | Package-Manager: Portage-2.3.99, Repoman-2.3.22 RepoMan-Options: --include-arches="hppa" Signed-off-by: Rolf Eike Beer <eike@sf-mail.de> Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
* dev-lang/perl: x86 stable wrt bug #723792Agostino Sarubbo2020-06-061-1/+1
| | | | | | Package-Manager: Portage-2.3.99, Repoman-2.3.22 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* dev-lang/perl: s390 stable wrt bug #723792Agostino Sarubbo2020-06-061-1/+1
| | | | | | Package-Manager: Portage-2.3.99, Repoman-2.3.22 RepoMan-Options: --include-arches="s390" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* dev-lang/perl: ppc64 stable wrt bug #723792Agostino Sarubbo2020-06-061-1/+1
| | | | | | Package-Manager: Portage-2.3.99, Repoman-2.3.22 RepoMan-Options: --include-arches="ppc64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* dev-lang/perl: ppc stable wrt bug #723792Agostino Sarubbo2020-06-061-1/+1
| | | | | | Package-Manager: Portage-2.3.99, Repoman-2.3.22 RepoMan-Options: --include-arches="ppc" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* dev-lang/perl: arm stable wrt bug #723792Agostino Sarubbo2020-06-061-1/+1
| | | | | | Package-Manager: Portage-2.3.99, Repoman-2.3.22 RepoMan-Options: --include-arches="arm" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* dev-lang/perl: stable 5.30.3 for sparc, bug #723792Rolf Eike Beer2020-06-051-1/+1
| | | | | | | Package-Manager: Portage-2.3.99, Repoman-2.3.22 RepoMan-Options: --include-arches="sparc" Signed-off-by: Rolf Eike Beer <eike@sf-mail.de> Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
* dev-lang/perl: Re-add toolchain improvementsAndreas K. Hüttel2020-06-051-0/+659
| | | | | Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
* dev-lang/perl: Stable for amd64Andreas K. Hüttel2020-06-051-1/+1
| | | | | | Bug: https://bugs.gentoo.org/723792 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
* dev-lang/perl: arm64 stable (bug #723792)Sam James (sam_c)2020-06-051-1/+1
| | | | | | Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Sam James (sam_c) <sam@cmpct.info> Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* dev-lang/perl: Version bumpAndreas K. Hüttel2020-06-012-0/+654
| | | | | | Bug: https://bugs.gentoo.org/723792 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
* dev-lang/perl: More TC love for nm/cpp/ranlib re bug #723734Kent Fredric2020-05-191-0/+659
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | While this won't fix the warnings about hints/linux.sh, as that is something too complex for me to trivially fix, it should mitigate the warnings about nm and cpp, and additonally, guards against a possible future where ranlib is also nuked and later tried to be used from $Config{ranlib} -r bump for compile propagation reasons, real delta: --- a/dev-lang/perl/perl-5.30.2-r1.ebuild +++ b/dev-lang/perl/perl-5.30.2-r2.ebuild @@ -502,11 +502,16 @@ src_configure() { # allow fiddling via EXTRA_ECONF, bug 558070 eval "local -a EXTRA_ECONF=(${EXTRA_ECONF})" + # setting -Dld= to tc-getLD breaks perl and all perl things + # https://github.com/Perl/perl5/issues/17791#issuecomment-630145202 myconf \ -Duseshrplib \ -Darchname="${myarch}" \ -Dcc="$(tc-getCC)" \ -Dar="$(tc-getAR)" \ + -Dnm="$(tc-getNM)" \ + -Dcpp="$(tc-getCPP)" \ + -Dranlib="$(tc-getRANLIB)" \ -Doptimize="${CFLAGS}" \ -Dldflags="${LDFLAGS}" \ -Dprefix="${EPREFIX}"'/usr' \ Bug: https://bugs.gentoo.org/723734 Bug: https://github.com/Perl/perl5/issues/17791#issuecomment-630123559 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
* dev-lang/perl: Enforce toolchain `ar` in ./configureKent Fredric2020-05-181-0/+654
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | This one neat trick convinces ./configure to use a correct, and specified "ar" during configure, as auto-detection completely fails when there is no binary named "ar" in $PATH, and despite completely failing to detect any "ar", configure just warns, and continues as normal, and then hardcodes that total failure of detection in Config_heavy.pl, indicating "hey, the 'ar' perl was built with was 'ar'", despite no such thing existing, and code afterwards will then try ( and fail ) to use that `ar` by consulting $Config{ar} This step compeletely side-steps auto-detection, so at very least, Config_heavy.pl contains a value that at least one time, probably worked, and as a result, large amounts of EUMM/MB XS stuff no longer tries to use a default `ar` that never existed. -r1 bump required, as the consequences of this change propagate into everything that compiles C code against Perl, and a failure to upgrade perl with this fix results in future failures compiling other stuff But otherwise this really is just a one line fix: ```diff --- perl-5.30.2.ebuild 2020-04-13 01:31:59.268561073 +1200 +++ perl-5.30.2-r1.ebuild 2020-05-18 16:46:13.972962817 +1200 @@ -507,4 +507,5 @@ -Darchname="${myarch}" \ -Dcc="$(tc-getCC)" \ + -Dar="$(tc-getAR)" \ -Doptimize="${CFLAGS}" \ -Dldflags="${LDFLAGS}" \ ``` Bug: https://bugs.gentoo.org/723264 Bug: https://bugs.gentoo.org/723154 Bug: https://github.com/Perl/perl5/issues/17791 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
* */*: downgrade m68k down to ~m68kSergei Trofimovich2020-04-211-1/+1
| | | | | | | | | m68k and ~m68k trees are inconsistent. Let's drop keywords down to ~m68k only. Profiles already accept both keywords: ACCEPT_KEYWORDS="m68k ~m68k" Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
* dev-lang/perl: Update perl-cross versionAndreas K. Hüttel2020-04-122-1/+2
| | | | | Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
* dev-lang/perl: Fix corelist version in 5.30.2Andreas K. Hüttel2020-04-111-1/+1
| | | | | Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
* dev-lang/perl: Version bump; masked, work in progressAndreas K. Hüttel2020-04-112-0/+654
| | | | | | | | run/locale.t test fails, but this is *not* a regression from 5.30.1 See also https://github.com/Perl/perl5/issues/17713 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
* */*: Drop stable ia64 keywordsMatt Turner2020-04-031-1/+1
| | | | Signed-off-by: Matt Turner <mattst88@gentoo.org>
* */*: Discontinue Gentoo SuperH portMikle Kolyada2020-03-261-1/+1
| | | | | | Package-Manager: Portage-2.3.89, Repoman-2.3.20 RepoMan-Options: --ignore-arches Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
* dev-lang/perl: drop reference to sys-freebsd/freebsd-mk-defsSergei Trofimovich2020-03-211-3/+1
| | | | | | | sys-freebsd/freebsd-mk-defs was removed from ::gentoo in October 2019. Package-Manager: Portage-2.3.94, Repoman-2.3.21 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>