summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* dev-libs/hyperscan: Maintainer retiredJonas Stein2022-02-101-4/+0
| | | | | | | Proxied maintainer retired due to inactivity. Bug: https://bugs.gentoo.org/633254 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Jonas Stein <jstein@gentoo.org>
* dev-libs/hyperscan: enable py3.10Petr Vaněk2022-02-051-2/+2
| | | | | | Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Closes: https://github.com/gentoo/gentoo/pull/24066 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
* **/metadata.xml: Replace http by https in DOCTYPE elementUlrich Müller2021-09-111-1/+1
| | | | | Bug: https://bugs.gentoo.org/552720 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* dev-libs/hyperscan: keyword 5.4.0 for -*Marek Szuba2021-09-031-2/+2
| | | | | | | No SSSE3 - no hyperscan. See https://intel.github.io/hyperscan/dev-reference/getting_started.html#hardware Signed-off-by: Marek Szuba <marecki@gentoo.org>
* dev-libs/hyperscan: drop 5.3.0Petr Vaněk2021-03-302-56/+0
| | | | | | Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Closes: https://github.com/gentoo/gentoo/pull/20122 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
* dev-libs/hyperscan: fix cpu_flags_* default (disable)Sam James2021-03-252-2/+6
| | | | | | | | | | | | | We shouldn't enable CPU_FLAGS_* by default. Users don't mask or explicitly disable flags they don't have, they just enable the ones they _do_ have. Even in this case, where we NEED SSSE3, it's wrong to default it on rather than making the user aware of the requirement. Reported-by: ggabriel Signed-off-by: Sam James <sam@gentoo.org>
* */*: Add proxied="yes" for non-@gentoo.org peopleMichał Górny2021-03-161-2/+2
| | | | | | | | | | | | Done via: find -name metadata.xml -exec xml ed -P -L \ -a '/pkgmetadata/maintainer[substring(email, string-length(email) - string-length("@gentoo.org") + 1) != "@gentoo.org"]' \ -t attr -n proxied -v yes {} + Signed-off-by: Michał Górny <mgorny@gentoo.org>
* */*: Add 'proxied="proxy"' for proxy-maint projectMichał Górny2021-03-161-1/+1
| | | | | | | | | | Done via: find -name metadata.xml -exec xml ed -P -L \ -a '//maintainer[email="proxy-maint@gentoo.org"]' \ -t attr -n proxied -v proxy {} + Signed-off-by: Michał Górny <mgorny@gentoo.org>
* */*: Normalize metadata.xml filesMichał Górny2021-03-161-1/+1
| | | | | | | | | | | Normalize quoting, replace '>' with entities, replace unnecessary entities, remove trailing empty lines. Done via: find -name metadata.xml -exec xml ed -P -L -d //none {} + Signed-off-by: Michał Górny <mgorny@gentoo.org>
* dev-libs/hyperscan: amd64 stable wrt bug #772086Agostino Sarubbo2021-02-261-1/+1
| | | | | | Package-Manager: Portage-3.0.13, Repoman-3.0.2 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* dev-libs/hyperscan: x86 stable wrt bug #772086Agostino Sarubbo2021-02-261-1/+1
| | | | | | Package-Manager: Portage-3.0.13, Repoman-3.0.2 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* dev-libs/hyperscan: restore CMAKE_BUILD_TYPE="Release" for nowSam James2021-02-251-0/+3
| | | | | | Bug: https://bugs.gentoo.org/772086 Package-Manager: Portage-3.0.15, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
* */*: Remove obsolete values from PYTHON_COMPATMichał Górny2021-01-312-2/+2
| | | | Signed-off-by: Michał Górny <mgorny@gentoo.org>
* dev-libs/hyperscan: tidy ebuildSam James2021-01-141-3/+1
| | | | | Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
* dev-libs/hyperscan: bump to 5.4.0Petr Vaněk2021-01-142-0/+55
| | | | | | | Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Closes: https://github.com/gentoo/gentoo/pull/19052 Signed-off-by: Sam James <sam@gentoo.org>
* dev-libs/hyperscan: clean oldPetr Vaněk2021-01-073-78/+0
| | | | | | | Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Closes: https://github.com/gentoo/gentoo/pull/18973 Signed-off-by: Sam James <sam@gentoo.org>
* dev-libs/hyperscan: Stabilize 5.3.0 x86, #760726Sam James2021-01-041-2/+2
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* dev-libs/hyperscan: Stabilize 5.3.0 amd64, #740184Sam James2020-09-051-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* dev-libs/hyperscan: port to py39Petr Vaněk2020-06-102-2/+2
| | | | | | | Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Closes: https://github.com/gentoo/gentoo/pull/15681 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
* dev-libs/hyperscan: bump to 5.3.0Petr Vaněk2020-06-102-0/+54
| | | | | | Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
* dev-libs/hyperscan: bug fixes: #674218, #707486, #722802Petr Vaněk2020-06-102-1/+34
| | | | | | | | | | | | | | | | | * support non-English locales; The patch is taken from https://github.com/intel/hyperscan/issues/217#issuecomment-583932263 * respect cpu_flags_x86 USE flags * respect -O flags * set release build type; CMAKE_BUILD_TYPE=Release disables -Werror flag which used to trigger false positive error in GCC-10. https://github.com/intel/hyperscan/issues/239 Closes: https://bugs.gentoo.org/674218 Closes: https://bugs.gentoo.org/707486 Closes: https://bugs.gentoo.org/722802 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
* dev-libs/hyperscan: add myslef as a proxy co-maintainerPetr Vaněk2020-04-041-0/+4
| | | | | | | Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Closes: https://github.com/gentoo/gentoo/pull/14894 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
* dev-libs/hyperscan: correct python dependenciesPetr Vaněk2020-04-041-6/+8
| | | | | | | | | | Python is build time dependency only. It works perfectly with python3 and there is no need to depend on Python2. Closes: https://bugs.gentoo.org/710218 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
* dev-libs/hyperscan: clean oldPetr Vaněk2020-04-044-117/+0
| | | | | | Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
* dev-libs/hyperscan: bump to 5.2.1Petr Vaněk2020-02-072-0/+43
| | | | | | | Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Closes: https://github.com/gentoo/gentoo/pull/14556 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
* dev-libs/hyperscan: update urlsPetr Vaněk2020-02-073-10/+9
| | | | | | | | | The official Hyperscan website has moved to hyperscan.io and source code is published in https://github.com/intel/hyperscan. Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
* */*: Switch proxy-maint to cmake.eclassAndreas Sturmlechner2020-01-193-8/+8
| | | | Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* dev-libs/hyperscan: Fix EAPI + BDEPSAlexey Shvetsov2019-10-083-5/+5
| | | | | Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Alexey Shvetsov <alexxy@gentoo.org>
* dev-libs/hyperscan: Fix build for gcc9.xAlexey Shvetsov2019-10-082-2/+14
| | | | | | | | Closes: https://bugs.gentoo.org/685618 Closes: https://bugs.gentoo.org/691384 Closes: https://bugs.gentoo.org/696856 Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Alexey Shvetsov <alexxy@gentoo.org>
* dev-libs/hyperscan: Fix pkgcheck warningAlexey Shvetsov2019-10-072-4/+4
| | | | | Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Alexey Shvetsov <alexxy@gentoo.org>
* dev-libs/hyperscan: Version bump to 5.1.1 and 5.2.0Christian Roessner2019-10-063-0/+68
| | | | | | Signed-off-by: Christian Roessner <c@roessner.co> Closes: https://github.com/gentoo/gentoo/pull/12757 Signed-off-by: Alexey Shvetsov <alexxy@gentoo.org>
* dev-libs/hyperscan: Clean old upMichał Górny2019-08-123-62/+0
| | | | Signed-off-by: Michał Górny <mgorny@gentoo.org>
* dev-libs/hyperscan: Add missing PYTHON_REQUIRED_USEMichał Górny2019-08-121-1/+2
| | | | Signed-off-by: Michał Górny <mgorny@gentoo.org>
* dev-libs/hyperscan: Version bump 5.1.0David Heidelberg2019-02-222-0/+37
| | | | | | | | | | Closes: https://github.com/gentoo/gentoo/pull/9863 Closes: https://bugs.gentoo.org/674220 Original author: Christian Rößner Signed-off-by: David Heidelberg <david@ixit.cz> Closes: https://github.com/gentoo/gentoo/pull/10864 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* dev-libs/hyperscan: remove old versionsDirkjan Ochtman2018-03-214-79/+0
| | | | Package-Manager: Portage-2.3.24, Repoman-2.3.6
* dev-libs/hyperscan: version bump to 4.7.0Dirkjan Ochtman2018-03-212-0/+31
| | | | Package-Manager: Portage-2.3.24, Repoman-2.3.6
* dev-libs/*: Update Manifest hashesMichał Górny2017-12-091-3/+3
|
* dev-libs/hyperscan: version bump to 4.6.0 (fixes bug 635148)Christian Roessner2017-10-292-0/+31
| | | | Package-Manager: Portage-2.3.8, Repoman-2.3.3
* dev-libs/hyperscan: version bump to 4.5.2Dirkjan Ochtman2017-07-262-0/+31
| | | | Package-Manager: Portage-2.3.6, Repoman-2.3.1
* metadata: update email address for Christian RoessnerDirkjan Ochtman2017-07-261-1/+1
|
* dev-libs/hyperscan: Use correct distfile nameAngelo G. Del Regno2017-05-303-3/+3
| | | | | Update SRC_URI to rename the distfile correctly. Closes: https://github.com/gentoo/gentoo/pull/4786
* Globally add missing remote ID references to metadata.xmlJustin Lecher2017-04-291-1/+4
| | | | Signed-off-by: Justin Lecher <jlec@gentoo.org>
* dev-libs/hyperscan: bump to 4.4.1-r1, fix 616626Christian Roessner2017-04-261-0/+30
| | | | Gentoo-Bug: 616626
* dev-libs/hyperscan: Revert "drop invalid maintainer"Michał Górny2017-04-261-0/+4
| | | | | | The maintainer has resolved the problem. Reverts: 005ea696f18016562b1864601eb12193d538ba06.
* dev-libs/hyperscan: drop invalid maintainerMike Gilbert2017-04-261-4/+0
| | | | Package-Manager: Portage-2.3.5_p31, Repoman-2.3.2_p61
* dev-libs/hyperscan: set REQUIRED_USE to require SSSE3Christian Roessner2017-04-251-0/+3
|
* dev-libs/hyperscan: fix minor syntax error in ebuildDirkjan Ochtman2017-04-221-1/+0
| | | | Package-Manager: Portage-2.3.3, Repoman-2.3.1
* dev-libs/hyperscan: add proxy maintainers projectDirkjan Ochtman2017-04-221-0/+4
| | | | Package-Manager: Portage-2.3.3, Repoman-2.3.1
* dev-libs/hyperscan: New ebuild version 4.4.1Christian Roessner2017-04-223-0/+24