summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* **/metadata.xml: Replace http by https in DOCTYPE elementUlrich Müller2021-09-111-1/+1
| | | | | Bug: https://bugs.gentoo.org/552720 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* dev-libs/libffi-compat: add libffi.so.7 compat slotSergei Trofimovich2021-07-279-0/+409
| | | | | | Bug: https://bugs.gentoo.org/804660 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org> Package-Manager: Portage-3.0.20, Repoman-3.0.3
* */*: s/pax_kernel/pax-kernel/gMarek Szuba2021-07-012-3/+3
| | | | Signed-off-by: Marek Szuba <marecki@gentoo.org>
* dev-libs/libffi-compat: eutils--, multilib--, toolchain-funcs--Sam James2021-04-161-1/+1
| | | | | Signed-off-by: Sam James <sam@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
* dev-libs/libffi-compat: drop x86-macosFabian Groffen2021-01-061-2/+2
| | | | | Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
* dev-libs/libffi-compat: drop ppc-aix m68k-mintFabian Groffen2020-12-271-1/+1
| | | | | Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
* */*: Discontinue Gentoo SuperH portMikle Kolyada2020-03-261-2/+2
| | | | | | Package-Manager: Portage-2.3.89, Repoman-2.3.20 RepoMan-Options: --ignore-arches Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
* dev-libs/libffi-compat: RESTRICT="!test? ( test )"Sergei Trofimovich2019-11-061-0/+2
| | | | | Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
* dev-libs/libffi-compat: x86 stable wrt bug #698458Agostino Sarubbo2019-10-251-1/+1
| | | | | | Package-Manager: Portage-2.3.76, Repoman-2.3.16 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* dev-libs/libffi-compat: amd64 stable wrt bug #698458Agostino Sarubbo2019-10-251-1/+1
| | | | | | Package-Manager: Portage-2.3.76, Repoman-2.3.16 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* dev-libs: Remove *-fbsd KEYWORDSMichał Górny2019-10-111-1/+1
| | | | Signed-off-by: Michał Górny <mgorny@gentoo.org>
* dev-libs/libffi-compat: new package, provides libffi.so.6Sergei Trofimovich2019-10-0111-0/+395
There are still a few binary-only packages out there that rely on 'libffi.so.6' presence. This package provides these libraries. No development headers here. Thus this library can co-exist with dev-libs/libffi:0/7 package. Ebuild is based on dev-libs/libffi. We can fast-stabilize it if in-tree stable packages do rely on libffi.so.6 (they should not). The patch is almost entirely by Timo Rothenpieler. I renamed a package and made a few minor tweaks. Fix-by: Timo Rothenpieler Reported-by: Timo Rothenpieler Closes: https://bugs.gentoo.org/695964 Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>