summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* dev-libs/libpeas: enable py3.10Mart Raudsepp10 days1-1/+1
| | | | | Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* dev-libs/libpeas: keyword ~riscvYixun Lan2021-09-241-1/+1
| | | | | Package-Manager: Portage-3.0.23, Repoman-3.0.3 Signed-off-by: Yixun Lan <dlan@gentoo.org>
* **/metadata.xml: Replace http by https in DOCTYPE elementUlrich Müller2021-09-111-1/+1
| | | | | Bug: https://bugs.gentoo.org/552720 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* dev-libs/libpeas: PYTHON_MULTI_USEDEP -> PYTHON_USEDEPDavid Seifert2021-07-171-2/+2
| | | | Signed-off-by: David Seifert <soap@gentoo.org>
* dev-libs/libpeas: remove unused patchMichael Mair-Keimberger2021-06-011-41/+0
| | | | | | Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Matt Turner <mattst88@gentoo.org>
* dev-libs/libpeas: Drop old versionsMatt Turner2021-05-302-86/+0
| | | | Signed-off-by: Matt Turner <mattst88@gentoo.org>
* dev-libs/libpeas: Stabilize 1.30.0 amd64, #792327Sam James2021-05-291-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* dev-libs/libpeas: Stabilize 1.30.0 x86, #792327Sam James2021-05-291-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* dev-libs/libpeas: Drop old versionsMatt Turner2021-04-122-84/+0
| | | | Signed-off-by: Matt Turner <mattst88@gentoo.org>
* dev-libs/libpeas: x86 stable (bug #774927)Thomas Deutschmann2021-04-011-1/+1
| | | | | Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
* dev-libs/libpeas: drop old versionConrad Kostecki2021-03-262-156/+0
| | | | | | | Dropping old version, which does not support slotted lua. Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
* dev-libs/libpeas: Version bump to 1.30.0Matt Turner2021-03-212-0/+85
| | | | Signed-off-by: Matt Turner <mattst88@gentoo.org>
* dev-libs/libpeas: Stabilize 1.28.0-r100 amd64, #774927Mikle Kolyada2021-03-121-1/+1
| | | | Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
* */*: Remove obsolete values from PYTHON_COMPATMichał Górny2021-01-314-4/+4
| | | | Signed-off-by: Michał Górny <mgorny@gentoo.org>
* dev-libs/libpeas: Stabilize 1.26.0-r100 x86, #766528Sam James2021-01-231-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* dev-libs/libpeas: Stabilize 1.26.0-r100 amd64, #766528Sam James2021-01-231-2/+2
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* dev-libs/libpeas: Version bump to 1.28Matt Turner2021-01-054-0/+206
| | | | | Closes: https://bugs.gentoo.org/759283 Signed-off-by: Matt Turner <mattst88@gentoo.org>
* dev-libs/libpeas: migrate to lua-single.eclassMarek Szuba2020-12-091-0/+83
| | | | | | | | | Simple enough, was even able to re-use the Lua-related patch used by the unmigrated version. Supports lua5-1 and luajit as per upstream specs for Lua plug-ins, builds fine against both. Closes: https://bugs.gentoo.org/752918 Signed-off-by: Marek Szuba <marecki@gentoo.org>
* dev-libs/libpeas: remove oldMart Raudsepp2020-04-254-136/+0
| | | | | Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* dev-libs/libpeas: x86 stable wrt bug #717144Agostino Sarubbo2020-04-201-1/+1
| | | | | | Package-Manager: Portage-2.3.89, Repoman-2.3.20 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* dev-libs/libpeas: amd64 stable wrt bug #717144Agostino Sarubbo2020-04-201-1/+1
| | | | | | Package-Manager: Portage-2.3.89, Repoman-2.3.20 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* dev-libs/libpeas: bump to 1.26.0Mart Raudsepp2020-03-173-0/+167
| | | | | Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* dev-libs/libpeas: fix python:3.8 compatibilityMart Raudsepp2020-02-162-7/+36
| | | | | | | | | | | Looks like the addition of 3.8 to libpeas and almost all of its consumers months ago was completely untested; fix it up in straight-to-stable because all of those consumers already have 3.8 in their stable versions PYTHON_COMPAT. Closes: https://bugs.gentoo.org/702810 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* dev-libs/libpeas: Switch to PYTHON_MULTI_USEDEP APIMichał Górny2020-02-091-1/+4
| | | | Signed-off-by: Michał Górny <mgorny@gentoo.org>
* */*: Clean PYTHON_COMPAT of obsolete implsMichał Górny2020-01-051-2/+2
| | | | | Closes: https://github.com/gentoo/gentoo/pull/14246 Signed-off-by: Michał Górny <mgorny@gentoo.org>
* dev-libs/libpeas: enable python3.8Matt Turner2019-12-041-1/+1
| | | | Signed-off-by: Matt Turner <mattst88@gentoo.org>
* dev-libs: Remove *-fbsd KEYWORDSMichał Górny2019-10-111-1/+1
| | | | Signed-off-by: Michał Górny <mgorny@gentoo.org>
* */*: Remove python3_4 PYTHON_COMPAT correctlyMichał Górny2019-04-171-2/+2
| | | | Signed-off-by: Michał Górny <mgorny@gentoo.org>
* dev-libs/libpeas: remove oldMart Raudsepp2018-12-022-86/+0
| | | | | Signed-off-by: Mart Raudsepp <leio@gentoo.org> Package-Manager: Portage-2.3.52, Repoman-2.3.11
* dev-libs/libpeas: x86 stable wrt bug #670024Mikle Kolyada2018-12-021-1/+1
| | | | | Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
* dev-libs/libpeas: amd64 stable wrt bug #670024Mikle Kolyada2018-12-021-1/+1
| | | | | Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
* dev-libs/libpeas: add explicit build dep on glib-utilsMart Raudsepp2018-10-032-2/+4
| | | | | | Fixes: https://bugs.gentoo.org/667626 Signed-off-by: Mart Raudsepp <leio@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.11
* dev-libs/libpeas: bump to 1.22.0Mart Raudsepp2018-08-282-0/+85
| | | | Package-Manager: Portage-2.3.48, Repoman-2.3.10
* dev-libs/libpeas: Enable py3.7Michał Górny2018-07-241-2/+2
|
* dev-libs/libpeas: USE=jit -> USE=luajitMichał Górny2018-03-261-4/+4
| | | | Closes: https://bugs.gentoo.org/648188
* dev-libs/libpeas: Drop oldPacho Ramos2017-12-091-97/+0
| | | | Package-Manager: Portage-2.3.16, Repoman-2.3.6
* dev-libs/libpeas: Add support for newer pythonPacho Ramos2017-12-091-1/+1
| | | | Package-Manager: Portage-2.3.16, Repoman-2.3.6
* dev-libs/*: Update Manifest hashesMichał Górny2017-12-091-1/+1
|
* dev-libs/libpeas: keyword ~arm64Alexis Ballier2017-07-141-1/+1
| | | | Package-Manager: Portage-2.3.6, Repoman-2.3.2
* dev-libs/libpeas: x86 stable wrt bug #615406Agostino Sarubbo2017-04-271-1/+1
| | | | | | Package-Manager: Portage-2.3.3, Repoman-2.3.1 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* dev-libs/libpeas: amd64 stable wrt bug #615406Agostino Sarubbo2017-04-231-1/+1
| | | | | | Package-Manager: Portage-2.3.3, Repoman-2.3.1 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* dev-libs/libpeas: Port to python-single-r1David Seifert2017-04-171-0/+84
| | | | | Package-Manager: Portage-2.3.5, Repoman-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/4434
* dev-libs/libpeas: remove oldMart Raudsepp2017-04-022-98/+0
| | | | Package-Manager: Portage-2.3.5, Repoman-2.3.1
* dev-libs/libpeas: x86 stable wrt bug #611134Agostino Sarubbo2017-04-011-1/+1
| | | | | | Package-Manager: Portage-2.3.3, Repoman-2.3.1 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* dev-libs/libpeas: amd64 stable wrt bug #611134Agostino Sarubbo2017-04-011-1/+1
| | | | | | Package-Manager: Portage-2.3.3, Repoman-2.3.1 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* Drop $Id$ per council decision in bug #611234.Robin H. Johnson2017-02-282-2/+0
| | | | Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
* dev-libs/libpeas: dropped ~ia64-linux ~x86-freebsd ~x86-interixFabian Groffen2017-01-292-4/+4
| | | | Package-Manager: portage-2.3.3
* global: Drop dead implementations from PYTHON_COMPATMichał Górny2016-11-012-2/+2
|
* dev-libs/libpeas: cleanup old revisionGilles Dartiguelongue2016-11-012-97/+0
| | | | Package-Manager: portage-2.3.2
* dev-libs/libpeas: version bump 1.18.0 → 1.20.0Gilles Dartiguelongue2016-11-012-0/+99
| | | | Package-Manager: portage-2.3.2