summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* dev-python/botocore: drop Python 3.5 supportThomas Deutschmann6 days3-3/+3
| | | | | Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
* dev-python/botocore: bump to v1.14.7Thomas Deutschmann6 days3-1/+61
| | | | | Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
* dev-python/botocore: drop oldThomas Deutschmann6 days13-720/+0
| | | | | Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
* dev-python/botocore: bump to v1.13.50Thomas Deutschmann6 days2-0/+60
| | | | | Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
* dev-python/botocore: bump to v1.13.46Thomas Deutschmann2020-01-062-0/+60
| | | | | Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
* */*: Clean PYTHON_COMPAT of obsolete implsMichał Górny2020-01-0514-28/+28
| | | | | Closes: https://github.com/gentoo/gentoo/pull/14246 Signed-off-by: Michał Górny <mgorny@gentoo.org>
* dev-python/botocore: bump to v1.13.44Thomas Deutschmann2019-12-222-0/+60
| | | | | Package-Manager: Portage-2.3.82, Repoman-2.3.20 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
* dev-python/botocore: bump to v1.13.36Thomas Deutschmann2019-12-112-0/+60
| | | | | Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
* */*: [QA] Fix trivial cases of MissingTestRestrictMichał Górny2019-12-118-0/+8
| | | | | | | | | | | | | | | | | | The result was achieved via the following pipeline: pkgcheck scan -c RestrictTestCheck -R FormatReporter \ --format '{category}/{package}/{package}-{version}.ebuild' | xargs -n32 grep -L RESTRICT | xargs -n32 sed -i -e '/^IUSE=.*test/aRESTRICT="!test? ( test )"' The resulting metadata was compared before and after the change. Few Go ebuilds had to be fixed manually due to implicit RESTRICT=strip added by the eclass. Two ebuilds have to be fixed because of multiline IUSE. Suggested-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/13942 Signed-off-by: Michał Górny <mgorny@gentoo.org>
* dev-python/botocore: bump to v1.13.28Thomas Deutschmann2019-11-292-0/+60
| | | | | Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
* dev-python/botocore: v1.13.19Thomas Deutschmann2019-11-172-0/+60
| | | | | Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
* dev-python/botocore: [QA] Fix MissingTestRestrictMichał Górny2019-11-102-0/+2
| | | | Signed-off-by: Michał Górny <mgorny@gentoo.org>
* dev-python/botocore: bump to v1.13.14Thomas Deutschmann2019-11-102-0/+59
| | | | | Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
* dev-python/botocore: add Whissi to maintainersAndrey Utkin2019-10-251-0/+4
| | | | | | | | In agreement with him, honouring his regular and timely version updates to this package. Package-Manager: Portage-2.3.66, Repoman-2.3.16 Signed-off-by: Andrey Utkin <andrey_utkin@gentoo.org>
* dev-python/botocore: add new version 1.13.2Andrey Utkin2019-10-252-0/+59
| | | | | | | | | | | Cloned from 9999 ebuild verbatim. Version caps on few deps, which have been added by Whissi in botocore-1.12.251.ebuild, are thus abandoned, which has been agreed with Whissi. Package-Manager: Portage-2.3.66, Repoman-2.3.16 Signed-off-by: Andrey Utkin <andrey_utkin@gentoo.org>
* dev-python/botocore: bump to v1.12.251Thomas Deutschmann2019-10-172-0/+59
| | | | | Package-Manager: Portage-2.3.77, Repoman-2.3.17 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
* dev-python/botocore: bump to v1.12.223Thomas Deutschmann2019-09-062-0/+59
| | | | | Package-Manager: Portage-2.3.75, Repoman-2.3.17 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
* dev-python/botocore: bump to v1.12.210Thomas Deutschmann2019-08-162-0/+59
| | | | | Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
* dev-python/botocore: bump to v1.12.205Thomas Deutschmann2019-08-102-0/+59
| | | | | Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
* dev-python/botocore: x86 stable wrt bug #685212Agostino Sarubbo2019-06-051-1/+1
| | | | | | Signed-off-by: Agostino Sarubbo <ago@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11 RepoMan-Options: --include-arches="x86"
* dev-python/botocore: amd64 stable wrt bug #685212Agostino Sarubbo2019-06-051-1/+1
| | | | | | Signed-off-by: Agostino Sarubbo <ago@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11 RepoMan-Options: --include-arches="amd64"
* */*: Remove python3_4 PYTHON_COMPAT correctlyMichał Górny2019-04-174-5/+5
| | | | Signed-off-by: Michał Górny <mgorny@gentoo.org>
* dev-python/botocore: drop old versionsAndrey Utkin2019-03-274-174/+0
| | | | | Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andrey Utkin <andrey_utkin@gentoo.org>
* dev-python/botocore: add new version 1.12.122Andrey Utkin2019-03-272-0/+59
| | | | | Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andrey Utkin <andrey_utkin@gentoo.org>
* dev-python/botocore: 9999: update copyright lineAndrey Utkin2019-03-271-1/+1
| | | | | | | To avoid extra diff hunk after cloning into release ebuilds. Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andrey Utkin <andrey_utkin@gentoo.org>
* dev-python/botocore: bump to v1.12.81Thomas Deutschmann2019-01-182-0/+59
| | | | | Package-Manager: Portage-2.3.56, Repoman-2.3.12 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
* dev-python/botocore: amd64 stable wrt bug #667974Mikle Kolyada2018-11-301-1/+1
| | | | | Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
* dev-python/botocore: x86 stable (bug #667974)Thomas Deutschmann2018-11-271-2/+2
| | | | | Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
* dev-python/botocore: add python3_7Andrey Utkin2018-09-192-1/+59
| | | | Package-Manager: Portage-2.3.48, Repoman-2.3.10
* dev-python/botocore: drop old versionsAndrey Utkin2018-09-153-116/+0
| | | | Package-Manager: Portage-2.3.48, Repoman-2.3.10
* dev-python/botocore: add new version 1.12.4Andrey Utkin2018-09-152-0/+59
| | | | Package-Manager: Portage-2.3.48, Repoman-2.3.10
* dev-python/botocore: EAPI=7Andrey Utkin2018-09-151-1/+1
| | | | Package-Manager: Portage-2.3.48, Repoman-2.3.10
* dev-python/botocore: 9999: add urllib3 to RDEPENDAndrey Utkin2018-09-141-0/+1
| | | | | | | Since 1.11.0 botocore depends on `urllib3`. Before, it used bundled patched versions of `requests` and `urllib3`. Package-Manager: Portage-2.3.48, Repoman-2.3.10
* dev-python/botocore: x86 stable (bug #657664)Thomas Deutschmann2018-06-261-1/+1
| | | | Package-Manager: Portage-2.3.40, Repoman-2.3.9
* dev-python/botocore: amd64 stableJason Zaman2018-06-241-1/+1
| | | | | Gentoo-bug: 657664 Package-Manager: Portage-2.3.40, Repoman-2.3.9
* dev-python/botocore: add new version 1.10.35Andrey Utkin2018-06-102-0/+58
| | | | Package-Manager: Portage-2.3.40, Repoman-2.3.9
* dev-python/botocore: drop old non-stabilized ebuildsAndrey Utkin2018-05-133-123/+0
| | | | Package-Manager: Portage-2.3.36, Repoman-2.3.9
* dev-python/botocore: add new version 1.10.19Andrey Utkin2018-05-132-0/+58
| | | | Package-Manager: Portage-2.3.36, Repoman-2.3.9
* dev-python/botocore: drop ranges from deps notationAndrey Utkin2018-05-131-9/+5
| | | | | | | | | | | | Drop version range requirements, as all requirements are satisfied by all ebuilds currently present in Gentoo tree. The ranges originally come from upstream's requirements.txt and setup.{cfg,py}, but upstream developers don't tend to update these ranges, which makes them irrelevant and even harmful to Gentoo (e.g. by blocking removal of outdated version of dependencies). Package-Manager: Portage-2.3.36, Repoman-2.3.9
* dev-python/botocore: amd64 stable wrt bug #650598Mikle Kolyada2018-03-191-1/+1
| | | | Package-Manager: Portage-2.3.24, Repoman-2.3.6
* dev-python/botocore: add new version 1.9.6Andrey Utkin2018-03-112-0/+62
| | | | Package-Manager: Portage-2.3.24, Repoman-2.3.6
* dev-python/botocore: Update maintainer due to bug #502560Pacho Ramos2018-03-101-4/+0
| | | | Package-Manager: Portage-2.3.24, Repoman-2.3.6
* dev-python/botocore: add new version 1.8.41Andrey Utkin2018-02-152-0/+62
| | | | Package-Manager: Portage-2.3.24, Repoman-2.3.6
* dev-python/botocore: depend on jsonschema for testAndrey Utkin2018-02-151-0/+1
| | | | | | | Reflecting upstream change 526dfa42fbb4 ("Validate waiters against schema") Package-Manager: Portage-2.3.24, Repoman-2.3.6
* dev-python/botocore: don't require specific dev-python/mock versionAndrey Utkin2018-02-151-2/+2
| | | | Package-Manager: Portage-2.3.24, Repoman-2.3.6
* dev-python/botocore: remove old ebuildsAndrey Utkin2018-01-0510-489/+0
| | | | | | Removed excessive stable and unstable ebuilds. Package-Manager: Portage-2.3.17, Repoman-2.3.6
* dev-python/botocore: amd64 stable wrt bug #641180Mikle Kolyada2017-12-291-1/+1
| | | | Package-Manager: Portage-2.3.13, Repoman-2.3.3
* dev-python/botocore: add 9999 live ebuildAndrey Utkin2017-12-261-0/+60
| | | | | | | As described in previous commit message, botocore release frequency is very high. Package-Manager: Portage-2.3.17, Repoman-2.3.6
* dev-python/botocore: add live ebuild logicAndrey Utkin2017-12-261-3/+8
| | | | | | | | | botocore is released very often - 1.8.0 to 1.8.20 in one month. So it makes sense to allow users to opt in to being up to date, free from ebuild bumps delay. Git master branch is always at latest release, so should be reasonably safe to use. Package-Manager: Portage-2.3.17, Repoman-2.3.6
* dev-python/botocore: simplify *DEPEND declarationAndrey Utkin2017-12-261-3/+2
| | | | | | Don't use extra temporary variable CDEFINE as it's just RDEPEND. Package-Manager: Portage-2.3.17, Repoman-2.3.6