summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* dev-python/pypy: Bump to 7.1.1Michał Górny5 days2-0/+287
| | | | Signed-off-by: Michał Górny <mgorny@gentoo.org>
* dev-python/pypy: Bump to 7.1.0Michał Górny2019-03-282-0/+287
| | | | Signed-off-by: Michał Górny <mgorny@gentoo.org>
* dev-python/pypy: Restore Gentoo path patchMichał Górny2019-02-163-0/+60
| | | | Signed-off-by: Michał Górny <mgorny@gentoo.org>
* dev-python/pypy: Sync live ebuildMichał Górny2019-02-141-15/+11
| | | | Signed-off-by: Michał Górny <mgorny@gentoo.org>
* dev-python/pypy: Bump to 7.0.0Michał Górny2019-02-142-0/+284
| | | | | | | | | | | Bump to the new 7.0.0 release, and update CPython patchset. Upstream has apparently started using /usr/lib/pypy2.7 as package location independently of prefix, so our patches stopped being necessary (but we need subslot bump to move everything). Thanks to Sander Sweers for the early notification and research on the new release. Bug: https://bugs.gentoo.org/677398 Signed-off-by: Michał Górny <mgorny@gentoo.org>
* dev-python/pypy: Remove 5.10.0Michał Górny2019-01-052-276/+0
| | | | Signed-off-by: Michał Górny <mgorny@gentoo.org>
* dev-python/pypy: Disable more problematic testsMichał Górny2018-08-012-2/+24
| | | | Bug: https://bugs.gentoo.org/654242
* dev-python/pypy: Fix reenabling byte-compilation for testsMichał Górny2018-08-012-4/+4
| | | | Bug: https://bugs.gentoo.org/654242
* dev-python/pypy: Drop <5.10.0Michał Górny2018-04-292-282/+0
|
* dev-python/pypy: Bump to 6.0.0Michał Górny2018-04-272-0/+276
|
* dev-python/pypy: Remove half-broken USE=docMichał Górny2018-01-082-16/+4
| | | | | | | | | | The doc building code is currently broken as it is subject to Sphinx version mismatch, and given that we would need separate logic to select interpreter for the PyPy build, and for the sphinx call, it's better to remove the doc building altogether and possible reintroduce it as a separate package in the future. Closes: https://bugs.gentoo.org/643046
* dev-python/pypy: Clean old upMichał Górny2018-01-063-282/+0
|
* dev-python/pypy: Bump to 5.10.0Michał Górny2017-12-272-0/+282
|
* dev-python/*: Update Manifest hashesMichał Górny2017-12-091-4/+4
|
* dev-python/pypy: Fix mtimes between generated and source filesMichał Górny2017-11-162-0/+4
| | | | | | | Ensure to preserve file mtimes while copying them from the source tree to the installation image. This ensures that the generated files are newer than source files, and that PyPy does not attempt to rewrite them at runtime.
* dev-python/pypy: Inline deps and include dev-python/pycparser depMichał Górny2017-11-112-2/+24
| | | | | | | | | | | Replace the autogenerated || dependency with an inlined version, and include dev-python/pycparser in it when using CPython 2.7 (it is built-in in dev-python/pypy, through CFFI). Enforce the dependency only when USE=-low-memory, since otherwise CPython is not used, and we can't enforce the dependency on PyPy anyway as it would cause circular deps. Closes: https://bugs.gentoo.org/634306
* dev-python/pypy: Generate caches earlier, in compileMichał Górny2017-11-052-70/+74
| | | | | | Generate the caches in compile phase since they are needed for tests. Closes: https://bugs.gentoo.org/636490
* dev-python/pypy: Remove incorrect pytest depMichał Górny2017-11-052-4/+2
|
* dev-python/pypy: Remove unnecessary LD_LIBRARY_PATHMichał Górny2017-11-052-2/+0
| | | | The pypy executable has $ORIGIN-based rpath.
* dev-python/pypy: Fix cross-phase function callsMichał Górny2017-10-153-60/+66
| | | | Closes: https://bugs.gentoo.org/596624
* dev-python/pypy: Drop oldMichał Górny2017-10-157-1294/+0
|
* dev-python/pypy: Update low-memory docMichał Górny2017-10-151-3/+2
| | | | | The translation and compilation are now completely separate, so the remark about additional memory usage is obsolete now.
* dev-python/pypy: Remove inactive maintainerMichał Górny2017-10-151-4/+0
|
* dev-python/pypy: Bump to 5.9.0Michał Górny2017-10-094-2/+282
|
* dev-python/pypy: Sync the live ebuildMichał Górny2017-06-101-3/+1
|
* dev-python/pypy: Bump to 5.8.0Michał Górny2017-06-103-0/+655
|
* dev-python/pypy: Bump to 5.7.1 (based on cpy 2.7.13)Michał Górny2017-04-252-0/+269
|
* dev-python/pypy: Remove unused --make-jobs optionMichał Górny2017-04-251-2/+1
| | | | | The --make-jobs option is no longer relevant since we are calling emake directly. It was only used to pass -j to make when called by rpython.
* dev-python/pypy: Disarm implicit -flto (in 9999)Michał Górny2017-04-252-0/+29
|
* dev-python/pypy: Bump 9999 to EAPI 6Michał Górny2017-04-252-11/+11
|
* dev-python/pypy: Update the distutils-cxx patch for upcoming 5.7.1Michał Górny2017-04-252-1/+389
|
* dev-python/pypy: Switch 9999 to cpy2.7.13 patchsetMichał Górny2017-04-252-3/+5
| | | | | | | Use the patchset from CPython 2.7.13 to avoid keeping old patches around. Disable the Turkish locale patch since it now alters the C sources of CPython -- we need to figure out if pypy needs similar alteration at all, and port it if necessary.
* dev-python/pypy: Upstream deprecated asmgc, and defaults to shadowstackMichał Górny2017-04-251-2/+1
|
* dev-python/pypy: Use usession*-0 rather than -currentMichał Górny2017-04-082-4/+4
|
* dev-python/pypy: Split translation and compile phasesMichał Górny2017-03-082-14/+36
| | | | | | | | | Use the --source option to disable automatic compiling of generating C sources, and build them manually afterwards. Most importantly, this significantly reduces memory use because pypy failed to free memory that was used for the translation, and that is no longer needed when the compilation is started. Furthermore, it makes resuming compilation possible.
* dev-python/pypy: Sync the live ebuildMichał Górny2017-03-083-8/+11
|
* Drop $Id$ per council decision in bug #611234.Robin H. Johnson2017-02-282-2/+0
| | | | Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
* dev-python/pypy: Clean up old versionsMichał Górny2017-02-179-2113/+0
|
* dev-python/pypy: Bump to 5.6.0, #599918Michał Górny2016-12-093-0/+597
| | | | | Bump to 5.6.0 release. Includes an updated C/C++ compiler support patch by Jan Ziak.
* dev-python/pypy: Bump to 5.4.1Michał Górny2016-09-072-0/+257
|
* dev-python/pypy: Adjust subslot to match ABI ver on 5.4.0Michał Górny2016-09-071-1/+2
| | | | | | | | Set subslot on pypy-5.4.0+ to match upstream ABI version, to avoid unnecessary rebuilds on ABI-compatible upgrades. I was planning to do this for quite some time but waited for next major bump to avoid needless rebuilds. Sadly, with each bump I forgot again. Therefore, let's do this in place while 5.4.0 is still fresh.
* dev-python/pypy: Bump to 5.4.0Michał Górny2016-09-032-0/+256
|
* dev-python/pypy: Remove unnecessary PDEP on python-updaterMichał Górny2016-07-296-6/+0
|
* dev-python/pypy: Bump to 5.3.1, minor fixesMichał Górny2016-07-032-0/+257
|
* dev-python/pypy: Bump to 5.3.0Michał Górny2016-06-092-0/+257
|
* dev-python/pypy: Add missing resource CFFI buildMichał Górny2016-06-092-2/+4
|
* dev-python/pypy: Bump to 5.1.1, #578598Michał Górny2016-06-062-0/+256
|
* dev-python/pypy: add libressl supportAnthony G. Basile2016-06-033-6/+9
| | | | Package-Manager: portage-2.2.28
* dev-python/pypy: INSDESTTREE -> custom var, #582982Michał Górny2016-05-143-51/+54
|
* dev-python/pypy: Fix pax-marking in src_compile()Michał Górny2016-05-143-6/+6
|