summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* dev-qt: Add Qt 5.12.5Andreas Sturmlechner4 days2-0/+136
| | | | | Package-Manager: Portage-2.3.75, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* dev-qt/qtwebengine: Fix build with >=linux-headers-5.2Andreas Sturmlechner2019-09-022-0/+28
| | | | | | | Tested-by: Aaron Bauman <bman@gentoo.org> Closes: https://bugs.gentoo.org/692352 Package-Manager: Portage-2.3.74, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* */*: Depend on media-libs/mesa[X(+)]Philipp Ammann2019-08-172-2/+2
| | | | | | | | | This changes any package that depends on media-libs/mesa (though not virtual/opengl) to depend on media-libs/mesa[X(+)] instead. Bug: https://bugs.gentoo.org/560096 Signed-off-by: Philipp Ammann <philipp.ammann@posteo.de> Signed-off-by: Matt Turner <mattst88@gentoo.org>
* dev-qt: Add Qt 5.12.4Andreas Sturmlechner2019-07-065-0/+229
| | | | | Package-Manager: Portage-2.3.68, Repoman-2.3.16 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* dev-qt: Drop Qt 5.11.3Andreas Sturmlechner2019-06-064-264/+0
| | | | | Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* dev-qt/qtwebengine: arm64 stableAaron Bauman2019-05-241-1/+1
| | | | | | Signed-off-by: Aaron Bauman <bman@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.12 RepoMan-Options: --include-arches="arm64"
* dev-qt/qtwebengine: arm stable wrt bug #685260Mikle Kolyada2019-05-231-1/+1
| | | | | | Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11 RepoMan-Options: --include-arches="arm"
* dev-qt/qtwebengine: x86 stable wrt bug #685260Mikle Kolyada2019-05-211-1/+1
| | | | | | Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11 RepoMan-Options: --include-arches="x86"
* dev-qt/qtwebengine: amd64 stable wrt bug #685260Mikle Kolyada2019-05-211-1/+1
| | | | | | Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11 RepoMan-Options: --include-arches="amd64"
* dev-qt/qtwebengine: stable on armAnthony G. Basile2019-04-261-1/+1
| | | | | Signed-off-by: Anthony G. Basile <blueness@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
* dev-qt/qtwebengine: remove unused dependencyMichael Palimaka2019-04-251-1/+0
| | | | | | Closes: https://bugs.gentoo.org/610836 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Michael Palimaka <kensington@gentoo.org>
* dev-qt/qtwebengine: Block broken sys-devel/binutils-2.31.1-r5Andreas Sturmlechner2019-04-241-0/+1
| | | | | | | Thanks-to: Arfrever Frehtes Taifersar Arahesis <arfrever.fta@gmail.com> Closes: https://bugs.gentoo.org/683794 Package-Manager: Portage-2.3.64, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* dev-qt: Drop Qt 5.12.2Andreas Sturmlechner2019-04-212-140/+0
| | | | | Package-Manager: Portage-2.3.64, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* dev-qt: Add Qt 5.12.3Andreas Sturmlechner2019-04-212-0/+141
| | | | | Package-Manager: Portage-2.3.64, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* dev-qt: Drop Qt 5.12.1Andreas Sturmlechner2019-03-192-140/+0
| | | | | Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
* dev-qt: Add Qt 5.12.2Andreas Sturmlechner2019-03-172-0/+140
| | | | | Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* dev-qt: Add Qt 5.12.1Andreas Sturmlechner2019-03-013-0/+238
| | | | | Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* dev-qt: Drop Qt 5.11.1Andreas Sturmlechner2019-02-146-324/+0
| | | | | Package-Manager: Portage-2.3.60, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* dev-qt/qtwebengine: Restrict to <media-libs/libvpx-1.8Andreas Sturmlechner2019-02-111-0/+1
| | | | | | Bug: https://bugs.gentoo.org/677612 Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* dev-qt/qtwebengine: x86 stable wrt bug #670864Mikle Kolyada2019-01-091-1/+1
| | | | | Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
* dev-qt/qtwebengine: amd64 stable wrt bug #670864Mikle Kolyada2019-01-091-2/+2
| | | | | Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
* dev-qt: Drop Qt 5.11.2Andreas Sturmlechner2018-12-082-141/+0
| | | | | Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* dev-qt: Drop Qt 5.9.6Andreas Sturmlechner2018-12-085-288/+0
| | | | | | | | | | | | | 5.11.1 is stable for some time, with 5.11.3 already being prepared. We did not bother to bump 5.9.7 anymore, and there are several sec fixes in these later versions. Depends on app-misc/geoclue:0 to be removed from repo. Does not build against >=OpenSSL-1.1. Does not build against >=ffmpeg-4. Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* dev-qt: Add Qt 5.11.3Andreas Sturmlechner2018-12-052-0/+141
| | | | | | Bug: https://bugs.gentoo.org/670864 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* dev-qt/qtwebengine: Add missing DEPENDAndreas Sturmlechner2018-11-131-0/+1
| | | | | | Bug: https://bugs.gentoo.org/669642 Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* dev-qt/qtwebengine: Update paxmark-mksnapshot patches for 5.11.{1,2}Andreas Sturmlechner2018-11-104-2/+84
| | | | | | | | | Reported-by: Han <jkmls@outlook.com> Thanks-to: Attila Tóth <atoth@atoth.sote.hu> Thanks-to: Miroslaw Mieszczak <gentoo@mieszczak.com.pl> Closes: https://bugs.gentoo.org/670852 Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* dev-qt/qtwebengine: Fix x86 build with GCC-8 (again)Andreas Sturmlechner2018-10-241-0/+1
| | | | | | Closes: https://bugs.gentoo.org/657124 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
* dev-qt/qtwebengine: Re-drop net-libs/libsrtp DEPENDAndreas Sturmlechner2018-10-191-1/+0
| | | | | Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.50, Repoman-2.3.11
* dev-qt: Add Qt 5.11.2Andreas Sturmlechner2018-10-183-0/+141
| | | | | Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
* dev-qt/qtwebengine: x86 stable (bug #664566)Thomas Deutschmann2018-10-181-1/+1
| | | | | Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
* dev-qt/qtwebengine: amd64 stable wrt bug #664566Mikle Kolyada2018-10-161-2/+2
| | | | | Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.11
* dev-qt/qtwebengine: Drop net-libs/libsrtp DEPENDAndreas Sturmlechner2018-09-131-1/+0
| | | | | | It is currently not supported to unbundle from chromium source. Package-Manager: Portage-2.3.49, Repoman-2.3.10
* dev-qt: Drop Qt 5.9.4Andreas Sturmlechner2018-09-083-144/+0
| | | | | | Closes: https://bugs.gentoo.org/609752 Closes: https://bugs.gentoo.org/652508 Package-Manager: Portage-2.3.49, Repoman-2.3.10
* dev-qt/qtwebengine: Raise system-icu dependency to >=ICU-60.2Andreas Sturmlechner2018-07-151-1/+1
| | | | | Closes: https://bugs.gentoo.org/660418 Package-Manager: Portage-2.3.41, Repoman-2.3.9
* dev-qt/qtwebengine: x86 stable (bug #655664)Thomas Deutschmann2018-07-151-1/+1
| | | | Package-Manager: Portage-2.3.42, Repoman-2.3.9
* dev-qt/qtwebengine: amd64 stable wrt bug #655664Mikle Kolyada2018-07-131-1/+1
| | | | Package-Manager: Portage-2.3.40, Repoman-2.3.9
* dev-qt/qtwebengine: Drop unused dependencyAndreas Sturmlechner2018-07-122-2/+0
| | | | | | | | (Unfortunately) it currently uses chromium's bundled protobuf. Thanks-to: Arfrever Frehtes Taifersar Arahesis <arfrever.fta@gmail.com> Bug: https://bugs.gentoo.org/660586 Package-Manager: Portage-2.3.41, Repoman-2.3.9
* dev-qt/qtwebengine: Restrict to <ffmpeg-4Andreas Sturmlechner2018-07-121-1/+1
| | | | | Closes: https://bugs.gentoo.org/654744 Package-Manager: Portage-2.3.41, Repoman-2.3.9
* dev-qt/qtwebengine: Drop 5.9.6 (r0)Andreas Sturmlechner2018-06-271-130/+0
| | | | Package-Manager: Portage-2.3.40, Repoman-2.3.9
* dev-qt/qtwebengine: Disable GPU when using nouveauAndreas Sturmlechner2018-06-271-0/+1
| | | | | | | | | Kindly borrowed from opensuse (disable-gpu-when-using-nouveau-boo-1005323.diff). Bug: https://bugs.gentoo.org/609752 Bug: https://bugs.gentoo.org/609752 Package-Manager: Portage-2.3.40, Repoman-2.3.9
* dev-qt/qtwebengine: Add missing mesa[egl] use depAndreas Sturmlechner2018-06-271-0/+130
| | | | Package-Manager: Portage-2.3.40, Repoman-2.3.9
* dev-qt/qtwebengine: Fix x86 build with GCC-8Andreas Sturmlechner2018-06-273-0/+26
| | | | | Closes: https://bugs.gentoo.org/657124 Package-Manager: Portage-2.3.40, Repoman-2.3.9
* dev-qt: Drop Qt 5.11.0_rc2Andreas Sturmlechner2018-06-273-189/+0
| | | | Package-Manager: Portage-2.3.40, Repoman-2.3.9
* dev-qt: Add Qt 5.11.1 (masked)Andreas Sturmlechner2018-06-276-0/+382
| | | | Package-Manager: Portage-2.3.40, Repoman-2.3.9
* dev-qt/qtwebengine: adjust USE="designer" descriptionJimi Huotari2018-06-231-1/+2
| | | | | | This will describe the purpose of the flag more accurately. Package-Manager: Portage-2.3.40, Repoman-2.3.9
* dev-qt/qtwebengine: Add "designer" USE flagArfrever Frehtes Taifersar Arahesis2018-06-233-2/+11
| | | | Bug: https://bugs.gentoo.org/652508
* dev-qt: Drop Qt 5.9.5Andreas Sturmlechner2018-06-202-127/+0
| | | | Package-Manager: Portage-2.3.40, Repoman-2.3.9
* dev-qt: Add Qt 5.9.6Andreas Sturmlechner2018-06-132-0/+126
| | | | Package-Manager: Portage-2.3.40, Repoman-2.3.9
* dev-qt/qtwebengine: fix dependencieskermeat2018-05-251-1/+1
| | | | | | | | skip build if mesa without egl: "khronos development headers appear to be missing (mesa/libegl1-mesa-dev)" Package-Manager: Portage-2.3.24, Repoman-2.3.6 Closes: https://github.com/gentoo/gentoo/pull/7683
* dev-qt: Drop Qt 5.11.0_rc (1)Andreas Sturmlechner2018-05-183-233/+0
| | | | Package-Manager: Portage-2.3.38, Repoman-2.3.9