summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* dev-util/cutter: improve configurationPetr Vaněk7 days1-2/+5
| | | | | | | | | | | - Introduce graphviz use flag - Set CUTTER_USE_ADDITIONAL_RIZIN_PATHS=OFF; This should be disabled if rizin is installed as a proper system library according to an option description, otherwise it may search it in /usr/local, for example. Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Closes: https://github.com/gentoo/gentoo/pull/20346 Signed-off-by: John Helmert III <ajak@gentoo.org>
* dev-util/cutter: bump to 2.0.1John Helmert III10 days2-1/+1
| | | | | Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: John Helmert III <ajak@gentoo.org>
* dev-util/cutter: keyworded 2.0.0 for x86Sergei Trofimovich2021-04-061-1/+1
| | | | | | | | keyworded wrt bug #780492 (KEYWORDREQ) Package-Manager: Portage-3.0.18, Repoman-3.0.3 RepoMan-Options: --include-arches="x86" Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
* dev-util/cutter: change radare2 to rizin in descriptionPetr Vaněk2021-04-061-1/+1
| | | | | | Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Closes: https://github.com/gentoo/gentoo/pull/20277 Signed-off-by: John Helmert III <ajak@gentoo.org>
* dev-util/cutter: bump to 2.0.0John Helmert III2021-04-052-0/+62
| | | | | Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: John Helmert III <ajak@gentoo.org>
* */*: reassign my packages to me@g.oJohn Helmert III2021-02-211-5/+1
| | | | Signed-off-by: John Helmert III <ajak@gentoo.org>
* */*: Remove obsolete values from PYTHON_COMPATMichał Górny2021-01-311-1/+1
| | | | Signed-off-by: Michał Górny <mgorny@gentoo.org>
* dev-util/cutter: drop oldSergei Trofimovich2020-10-182-55/+0
| | | | | Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
* dev-util/cutter: Bump to 1.12.0Petr Vaněk2020-09-032-0/+55
| | | | | | Package-Manager: Portage-3.0.4, Repoman-2.3.23 Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
* dev-util/cutter: specify stricter dependency on radare2Joonas Niilola2020-07-251-1/+1
| | | | Signed-off-by: Joonas Niilola <juippis@gentoo.org>
* dev-util/cutter: update HOMEPAGEJoonas Niilola2020-07-251-1/+1
| | | | Signed-off-by: Joonas Niilola <juippis@gentoo.org>
* dev-util/cutter: remove old broken 1.10.3Joonas Niilola2020-07-253-93/+0
| | | | Signed-off-by: Joonas Niilola <juippis@gentoo.org>
* dev-util/cutter: Add version 1.11.0John Helmert III2020-07-252-0/+55
| | | | | | | | | | This drops a patch that is added in 1.11.0. Closes: https://bugs.gentoo.org/733324 Closes: https://bugs.gentoo.org/733806 Package-Manager: Portage-3.0.0, Repoman-2.3.23 Signed-off-by: John Helmert III <jchelmert3@posteo.net> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
* dev-util/cutter: Add proxied maintainerJohn Helmert III2020-07-251-4/+11
| | | | | Signed-off-by: John Helmert III <jchelmert3@posteo.net> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
* dev-util/cutter: put to m-nJoonas Niilola2020-07-241-8/+1
| | | | Signed-off-by: Joonas Niilola <juippis@gentoo.org>
* dev-util/cutter: cleanupGergely Nagy2020-07-207-226/+0
| | | | | | | | | Versions before 1.10.3 are only working with older dev-util/radare2 versions which were already removed from Gentoo. Signed-off-by: Gergely Nagy <ngg@ngg.hu> Closes: https://github.com/gentoo/gentoo/pull/16593 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
* dev-util/cutter: Bump to 1.10.3Gergely Nagy2020-07-014-0/+129
| | | | | | | Closes: https://bugs.gentoo.org/721106 Signed-off-by: Gergely Nagy <ngg@ngg.hu> Closes: https://github.com/gentoo/gentoo/pull/15850 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
* dev-util/cutter: Drop older than 1.8.2Andreas Sturmlechner2020-05-2111-385/+0
| | | | | Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* dev-util/cutter: Bump to 1.10.1Gergely Nagy2020-03-093-0/+69
| | | | | | | Closes: https://bugs.gentoo.org/708886 Signed-off-by: Gergely Nagy <ngg@ngg.hu> Closes: https://github.com/gentoo/gentoo/pull/14667 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
* dev-util/cutter: remove unused patchMichael Mair-Keimberger2019-11-181-31/+0
| | | | | | Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/13694 Signed-off-by: Aaron Bauman <bman@gentoo.org>
* dev-util/cutter: version bump to 1.9.0Tact Yoshida2019-10-103-0/+92
| | | | | | | | Closes: https://bugs.gentoo.org/696680 Signed-off-by: Tact Yoshida <otakuto.gentoo@gmail.com> Package-Manager: Portage-2.3.66, Repoman-2.3.11 Closes: https://github.com/gentoo/gentoo/pull/13207 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
* dev-util/cutter: Add missing PYTHON_REQUIRED_USEMichał Górny2019-08-122-2/+4
| | | | Signed-off-by: Michał Górny <mgorny@gentoo.org>
* dev-util/cutter: version bump to 1.8.2Azamat H. Hackimov2019-07-072-0/+60
| | | | | | | | | | | | | dev-util/radare2-3.4.1 changed API which breakes compilation of cutter (#684446). This breakage fixed in 1.8.1. Update EAPI to 7. Closes: https://bugs.gentoo.org/684446 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Package-Manager: Portage-2.3.62, Repoman-2.3.11 Closes: https://github.com/gentoo/gentoo/pull/11988 Signed-off-by: Michał Górny <mgorny@gentoo.org>
* dev-util/cutter: bumpRick Farina2019-03-273-0/+93
| | | | | | | | | roughly seems to work, messages during build claim python support is disabled but it appears to link to python anyway so probably just need to patch the message if anyone cares Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
* dev-util/cutter: version bump to 1.7.4.Tact Yoshida2019-02-033-0/+77
| | | | | | | Signed-off-by: Tact Yoshida <otakuto.gentoo@gmail.com> Package-Manager: Portage-2.3.52, Repoman-2.3.12 Closes: https://github.com/gentoo/gentoo/pull/10900 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* dev-util/cutter: version bump to 1.7.Tact Yoshida2018-08-203-0/+77
| | | | | Package-Manager: Portage-2.3.44, Repoman-2.3.9 Closes: https://github.com/gentoo/gentoo/pull/9622
* dev-util/cutter: bump to 1.6Tact Yoshida2018-07-173-0/+67
| | | | | Package-Manager: Portage-2.3.40, Repoman-2.3.9 Closes: https://github.com/gentoo/gentoo/pull/9257
* dev-util/cutter: bump to version 1.4Tact Yoshida2018-07-084-0/+71
| | | | | Package-Manager: Portage-2.3.40, Repoman-2.3.9 Closes: https://github.com/gentoo/gentoo/pull/9141
* dev-util/cutter: new packageTakuto Yoshida2018-01-253-0/+49
A Qt and C++ GUI for radare2 reverse engineering framework. Closes: https://github.com/gentoo/gentoo/pull/6472 Package-Manager: Portage-2.3.16, Repoman-2.3.6