summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* dev-util/gnome-builder: Drop old versionsMatt Turner2021-05-302-179/+0
| | | | Signed-off-by: Matt Turner <mattst88@gentoo.org>
* dev-util/gnome-builder: Stabilize 3.40.2 amd64, #792327Sam James2021-05-291-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* dev-util/gnome-builder: Stabilize 3.40.2 x86, #792327Sam James2021-05-291-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* dev-util/gnome-builder: Drop old versionsMatt Turner2021-05-053-368/+0
| | | | Signed-off-by: Matt Turner <mattst88@gentoo.org>
* dev-util/gnome-builder: Version bump to 3.40.2Matt Turner2021-05-062-0/+184
| | | | Signed-off-by: Matt Turner <mattst88@gentoo.org>
* dev-util/gnome-builder: Version bump to 3.40.1Matt Turner2021-04-302-0/+184
| | | | Signed-off-by: Matt Turner <mattst88@gentoo.org>
* dev-util/gnome-builder: Raise glib dependencyMatt Turner2021-04-281-1/+1
| | | | | Closes: https://bugs.gentoo.org/785454 Signed-off-by: Matt Turner <mattst88@gentoo.org>
* dev-util/gnome-builder: Version bump to 3.40.0Matt Turner2021-04-182-0/+184
| | | | | Closes: https://bugs.gentoo.org/738932 Signed-off-by: Matt Turner <mattst88@gentoo.org>
* dev-util/gnome-builder: Drop old versionsMatt Turner2021-04-123-357/+0
| | | | Signed-off-by: Matt Turner <mattst88@gentoo.org>
* dev-util/gnome-builder: x86 stable (bug #774927)Thomas Deutschmann2021-04-011-1/+1
| | | | | Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
* dev-util/gnome-builder: Stabilize 3.38.2 amd64, #774927Mikle Kolyada2021-03-121-1/+1
| | | | Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
* dev-util/gnome-builder: bump to 3.38.2Mart Raudsepp2021-02-062-0/+179
| | | | | Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* */*: Remove obsolete values from PYTHON_COMPATMichał Górny2021-01-312-2/+2
| | | | Signed-off-by: Michał Górny <mgorny@gentoo.org>
* dev-util/gnome-builder: bump to 3.38.1Mart Raudsepp2020-12-082-0/+179
| | | | | Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* dev-util/gnome-builder: remove oldMart Raudsepp2020-11-075-264/+0
| | | | | Package-Manager: Portage-2.3.103, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* dev-util/gnome-builder: Stabilize 3.36.1 amd64, #738728Sam James2020-08-301-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* dev-util/gnome-builder: x86 stable (bug #738728)Thomas Deutschmann2020-08-301-1/+1
| | | | | Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
* dev-util/gnome-builder: add subslot operator dep := for dev-util/gladeMart Raudsepp2020-08-142-2/+2
| | | | | Package-Manager: Portage-2.3.103, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* dev-util/gnome-builder: remove oldMart Raudsepp2020-08-142-184/+0
| | | | | Package-Manager: Portage-2.3.103, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* dev-util/gnome-builder: add subslot operator dep := for libgit2Mart Raudsepp2020-07-281-1/+1
| | | | | Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* dev-util/gnome-builder: bump to 3.36.1Mart Raudsepp2020-06-272-0/+178
| | | | | Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* dev-util/gnome-builder: bump to 3.36.0+patchesMart Raudsepp2020-06-182-0/+184
| | | | | | Closes: https://bugs.gentoo.org/715662 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* dev-util/gnome-builder: fix compat with libgit2:0/1.0Mart Raudsepp2020-06-012-0/+27
| | | | | Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* dev-util/gnome-builder: fix missing build dep for USE=docMart Raudsepp2020-05-191-1/+2
| | | | | | Closes: https://bugs.gentoo.org/720738 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* dev-util/gnome-builder: remove oldMart Raudsepp2020-04-203-219/+0
| | | | | Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* dev-util/gnome-builder: x86 stable wrt bug #717144Agostino Sarubbo2020-04-201-1/+1
| | | | | | Package-Manager: Portage-2.3.89, Repoman-2.3.20 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* dev-util/gnome-builder: amd64 stable wrt bug #717144Agostino Sarubbo2020-04-201-1/+1
| | | | | | Package-Manager: Portage-2.3.89, Repoman-2.3.20 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* dev-util/gnome-builder: remove oldMart Raudsepp2020-04-173-186/+0
| | | | | Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* dev-util/gnome-builder: x86 stable wrt bug #717076Agostino Sarubbo2020-04-131-1/+1
| | | | | | Package-Manager: Portage-2.3.89, Repoman-2.3.20 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* dev-util/gnome-builder: amd64 stable wrt bug #717076Agostino Sarubbo2020-04-131-1/+1
| | | | | | Package-Manager: Portage-2.3.89, Repoman-2.3.20 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* dev-util/gnome-builder: fix USE=-git to be honoredMart Raudsepp2020-03-141-3/+2
| | | | | Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* dev-util/gnome-builder: bump to 3.34.1Mart Raudsepp2020-03-123-0/+236
| | | | | Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* dev-util/gnome-builder-3.32: USE=sysprof requires sysprof-2.pc (subslot 0)Mart Raudsepp2020-02-291-1/+1
| | | | | Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* dev-util/gnome-builder: Enable py3.8Mart Raudsepp2020-02-161-1/+1
| | | | | Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* dev-util/gnome-builder: add missing deps for USE=gtk-docMart Raudsepp2020-02-111-0/+2
| | | | | | Closes: https://bugs.gentoo.org/709270 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* dev-util/gnome-builder: Switch to PYTHON_MULTI_USEDEP APIMichał Górny2020-02-092-4/+8
| | | | Signed-off-by: Michał Górny <mgorny@gentoo.org>
* dev-util/gnome-builder: re-enable spellcheck plugin optionMart Raudsepp2020-02-051-5/+4
| | | | | | | | Now that we have enchant:2, the spellcheck plugin can be restored; this time via a USE flag (used to be hard required before). Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* dev-util/gnome-builder: bump to 3.32.4Mart Raudsepp2020-01-264-0/+217
| | | | | | Closes: https://bugs.gentoo.org/702442 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* */*: Clean PYTHON_COMPAT of obsolete implsMichał Górny2020-01-051-2/+2
| | | | | Closes: https://github.com/gentoo/gentoo/pull/14246 Signed-off-by: Michał Górny <mgorny@gentoo.org>
* */*: [QA] Fix trivial cases of MissingTestRestrictMichał Górny2019-12-111-0/+1
| | | | | | | | | | | | | | | | | | The result was achieved via the following pipeline: pkgcheck scan -c RestrictTestCheck -R FormatReporter \ --format '{category}/{package}/{package}-{version}.ebuild' | xargs -n32 grep -L RESTRICT | xargs -n32 sed -i -e '/^IUSE=.*test/aRESTRICT="!test? ( test )"' The resulting metadata was compared before and after the change. Few Go ebuilds had to be fixed manually due to implicit RESTRICT=strip added by the eclass. Two ebuilds have to be fixed because of multiline IUSE. Suggested-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/13942 Signed-off-by: Michał Górny <mgorny@gentoo.org>
* dev-util/gnome-builder: remove oldMart Raudsepp2019-05-185-384/+0
| | | | | Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* dev-util/gnome-builder: x86 stable wrt bug #685254Mikle Kolyada2019-05-101-1/+1
| | | | | | Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11 RepoMan-Options: --include-arches="x86"
* dev-util/gnome-builder: amd64 stable wrt bug #685254Mikle Kolyada2019-05-081-1/+1
| | | | | | Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11 RepoMan-Options: --include-arches="amd64"
* */*: Remove python3_4 PYTHON_COMPAT correctlyMichał Górny2019-04-172-2/+2
| | | | Signed-off-by: Michał Górny <mgorny@gentoo.org>
* dev-util/gnome-builder: remove oldMart Raudsepp2019-03-308-608/+0
| | | | | Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* dev-util/gnome-builder-3.24: json-glib[introspection] is required for buildMart Raudsepp2019-03-301-2/+2
| | | | | | | | | | | | | | In 3.24 jsonrpc-glib is not a split out separate package, thus the global introspection enabling on gnome-builder affects it as well (not optional). jsonrpc-glib GIR requires json-glib GIR, thus add the missing introspection USE dep on json-glib to ensure successful builds. This is not a problem 3.26 and onwards, as jsonrpc-glib introspection support is controlled by USE flag and there are proper conditional USE deps in place in the external package on json-glib already there. Fixes: https://bugs.gentoo.org/682060 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* dev-util/gnome-builder: bump to 3.30.3Mart Raudsepp2019-01-132-0/+182
| | | | | | | | | Most of what's in 3.30.3 was already included in our patchset on top of 3.30.2, except some of the gdb integration improvements (and french/spanish translation updates). Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* dev-util/gnome-builder: bump to 3.30.2Mart Raudsepp2018-12-172-0/+188
| | | | | Signed-off-by: Mart Raudsepp <leio@gentoo.org> Package-Manager: Portage-2.3.52, Repoman-2.3.11
* dev-util/gnome-builder: add glib-utils build depMart Raudsepp2018-09-241-1/+2
| | | | Package-Manager: Portage-2.3.49, Repoman-2.3.11
* dev-util/gnome-builder: x86 keyworded (bug #664922)Thomas Deutschmann2018-09-121-1/+1
| | | | Package-Manager: Portage-2.3.49, Repoman-2.3.10