summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* dev-util/spirv-llvm-translator: add test restrictionsMarek Szuba8 days1-0/+2
| | | | | | | As recommended by pkgcheck. Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Marek Szuba <marecki@gentoo.org>
* dev-util/spirv-llvm-translator: remove oldMarek Szuba9 days3-111/+0
| | | | | Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Marek Szuba <marecki@gentoo.org>
* dev-util/spirv-llvm-translator: pass $LLVM_MAX_SLOT to get_llvm_prefix()Marek Szuba9 days1-0/+55
| | | | | | | | | | | When invoked without max_slot, get_llvm_prefix() iterates over *all* LLVM slots known to llvm.eclass - including those exceeding LLVM_MAX_SLOT. As a consequence, an ebuild can e.g. end up getting installed into llvm:9 directories in spite of having been linked against llvm:8. Closes: https://bugs.gentoo.org/696048 Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Marek Szuba <marecki@gentoo.org>
* dev-util/spirv-llvm-translator: bump to 8.0.1.2Marek Szuba2019-10-012-0/+56
| | | | | Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Marek Szuba <marecki@gentoo.org>
* dev-util/spirv-llvm-translator: Clean old versions upMichał Górny2019-08-304-199/+0
| | | | Signed-off-by: Michał Górny <mgorny@gentoo.org>
* dev-util/spirv-llvm-translator: have FEATURES=test require USE=toolsMarek Szuba2019-07-081-0/+2
| | | | | | | | | | | A lot of the tests call the command-line translator so it must be present if tests are to be run. Conversely, no point in making llvm-spirv installation mandatory for people who do not care about tests. Closes: https://bugs.gentoo.org/689402 Signed-off-by: Marek Szuba <marecki@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
* dev-util/spirv-llvm-translator: streamline installation of cmdline toolMarek Szuba2019-07-042-0/+58
| | | | | | | | | | | | 1. Use the LLVM_BUILD_TOOLS flag from the CMake module AddLLVM to control whether to build and install llvm-spirv or not. This should also take care of the "insecure RUNPATHs" QA warning; 2. Make the above conditional upon USE=tools. Closes: https://bugs.gentoo.org/689242 Signed-off-by: Marek Szuba <marecki@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
* dev-util/spirv-llvm-translator: bump to version 8.0.1-1 and EAPI-7Marek Szuba2019-07-032-0/+66
| | | | | Signed-off-by: Marek Szuba <marecki@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
* dev-util/spirv-llvm-translator: support new OpenCL block representationMarek Szuba2019-05-032-0/+68
| | | | | | | | | | | | | | | | Without this patch, offline compilation of certain kernels used by dev-libs/intel-neo unit tests fails with "LLVM ERROR: unknown argument number for an object"; some real-world kernels would presumably be affected as well. The patch has been retrieved from https://github.com/intel/opencl-clang/blob/ocl-open-80/patches/spirv/0001-Update-LowerOpenCL-pass-to-handle-new-blocks-represn.patch (commit 912a9cc8d30b773372ce58d4fc17bf38fd388692 i.e. latest version as of 2019-05-02). See-Also: https://github.com/intel/compute-runtime/issues/156 Signed-off-by: Marek Szuba <marecki@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
* dev-util/spirv-llvm-translator: new packageMarek Szuba2019-05-014-0/+96
Third-order dependency of Intel Graphics Compute Runtime. Signed-off-by: Marek Szuba <marecki@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11