summaryrefslogtreecommitdiff
path: root/eclass
Commit message (Collapse)AuthorAgeFilesLines
* vala.eclass: Skip SLOT=0.38 in dependency generationMart Raudsepp2019-02-221-1/+2
| | | | | | | | | We never had 0.38 in main tree, so don't generate "dependency unknown" spam for this. We still do it for 0.44, as overlays want to use it, but that will solve itself once we get around to adding 0.43 or 0.44 to main tree too ourselves. Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* eclass: Move cpu optimization patch for older kernels.Mike Pagano2019-02-211-3/+2
| | | | | | See bug #678498 Signed-off-by: Mike Pagano <mpagano@gentoo.org>
* eclass/webapp.eclass: fix install with EAPI=7Conrad Kostecki2019-02-211-7/+7
| | | | | | | | | | | Starting with EAPI=7 the ROOT variable does not contain any trailing slash anymore, so it need's to be adjusted to work with EAPI=7, while maintaining compatibility with older EAPI. Closes: https://bugs.gentoo.org/671258 Signed-off-by: Conrad Kostecki <conrad@kostecki.com> Closes: https://github.com/gentoo/gentoo/pull/11112 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* xorg-2.eclass: Remove use of prune_libtool_filesMatt Turner2019-02-201-1/+1
| | | | Signed-off-by: Matt Turner <mattst88@gentoo.org>
* xorg-2.eclass: Drop support for EAPI 3Matt Turner2019-02-201-4/+4
| | | | | | No ebuilds inheriting xorg-2 are EAPI=3. Signed-off-by: Matt Turner <mattst88@gentoo.org>
* eclass: Fix kernel dependency for gcc v8 patch in kernel-2.eclassMike Pagano2019-02-181-2/+2
| | | | Signed-off-by: Mike Pagano <mpagano@gentoo.org>
* eclass: Update cpu optimization support in kernel-2.eclassMike Pagano2019-02-181-9/+14
| | | | | | | | | | This patch clean's up the logic when applying or dropping the cpu optimization patch. This patch will also support the applying of the gcc v8 patch which will eventually be in genpatches and applied also via the 'experiemental' use flag after this support is enabled. Signed-off-by: Mike Pagano <mpagano@gentoo.org>
* eclass: Update mysql dependency in emboss-r2Brian Evans2019-02-181-2/+2
| | | | | | | | | | | | | | | | | | | | | | Closes: https://bugs.gentoo.org/show_bug.cgi?id=677592 Closes: https://bugs.gentoo.org/show_bug.cgi?id=666016 Closes: https://bugs.gentoo.org/show_bug.cgi?id=666018 Closes: https://bugs.gentoo.org/show_bug.cgi?id=666020 Closes: https://bugs.gentoo.org/show_bug.cgi?id=666022 Closes: https://bugs.gentoo.org/show_bug.cgi?id=666024 Closes: https://bugs.gentoo.org/show_bug.cgi?id=666026 Closes: https://bugs.gentoo.org/show_bug.cgi?id=666028 Closes: https://bugs.gentoo.org/show_bug.cgi?id=666030 Closes: https://bugs.gentoo.org/show_bug.cgi?id=666032 Closes: https://bugs.gentoo.org/show_bug.cgi?id=666034 Closes: https://bugs.gentoo.org/show_bug.cgi?id=666036 Closes: https://bugs.gentoo.org/show_bug.cgi?id=666038 Closes: https://bugs.gentoo.org/show_bug.cgi?id=666040 Closes: https://bugs.gentoo.org/show_bug.cgi?id=666042 Closes: https://bugs.gentoo.org/show_bug.cgi?id=666044 Closes: https://bugs.gentoo.org/show_bug.cgi?id=666046 Closes: https://bugs.gentoo.org/show_bug.cgi?id=666048 Signed-off-by: Brian Evans <grknight@gentoo.org>
* distutils-r1.eclass: Fix pypy prefix check for new pathsMichał Górny2019-02-161-1/+10
| | | | Signed-off-by: Michał Górny <mgorny@gentoo.org>
* kernel-2.eclass: Fix LICENSE for Linux 4.14 and later.Ulrich Müller2019-02-151-5/+6
| | | | | | | | | | | | Starting with version 4.14, the whole firmware tree has been dropped from the kernel: https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=b38923a068c10fc36ca8f596d650d095ce390b85 Therefore including "linux-firmware" in LICENSE is no longer accurate. Closes: https://bugs.gentoo.org/677756 Reviewed-by: Mike Pagano <mpagano@gentoo.org> Reviewed-by: Alice Ferrazzi <alicef@gentoo.org> Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* toolchain.eclass: never pass --enable-libvtv to ./configureSergei Trofimovich2019-02-151-2/+5
| | | | | | | | | | | gcc treats --enable-libvtv as an override on top of autodetection. It it never what we want. Happens to break at least powerpc64 cross-compilers: https://bugs.gentoo.org/661252 Reported-by: Ilia Mirkin Closes: https://bugs.gentoo.org/661252 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
* kde5.eclass: Drop gnome2_icon_cache_update (now duplicate in EAPI-6)Andreas Sturmlechner2019-02-151-7/+0
| | | | Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* kde5.eclass: Cleanup functions rented from xdg.eclassAndreas Sturmlechner2019-02-151-123/+5
| | | | | | This reverts 16e6b9bc. Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* flag-o-matic.eclass: whitelist -mstackrealign for 'strip-flags'Sergei Trofimovich2019-02-131-0/+7
| | | | | | | | | | Allow '-mstackrealign' in ebuilds like glibc to force stack realignment. That will allow running ancient (or foreign) binaries that don't maintain 16-byte stack alignment. See bug #677852 for example. Reported-by: Michael Huss Closes: https://bugs.gentoo.org/677852 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
* mozconfig-v6.60.eclass: set correct update channel for ESR versionsThomas Deutschmann2019-02-121-0/+5
| | | | | Closes: https://bugs.gentoo.org/677722 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
* vala.eclass: actually raise VALA_MAX_API_VERSION to 0.44Mart Raudsepp2019-02-111-1/+1
| | | | | | | | commit 38ad00e3d43 intended to raise MAX to 0.44, but actually changed it to 0.42 only; fix this. Fixes: 38ad00e3d4318b3e7f915b7ac835ac6b8ac6cb5d Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* vala.eclass: raise VALA_MAX_API_VERSION to 0.44Gilles Dartiguelongue2019-02-111-1/+1
| | | | | | | | Last stable release is 0.42 but we want overlays to be able to work on upcoming 0.44 without having to modify eclass locally. Signed-off-by: Gilles Dartiguelongue <eva@gentoo.org> Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* vala.eclass: export VALADOC when requestedGilles Dartiguelongue2019-02-111-0/+3
| | | | | Signed-off-by: Gilles Dartiguelongue <eva@gentoo.org> Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* vala.eclass: add function to generate supported atoms with USEGilles Dartiguelongue2019-02-111-4/+22
| | | | | Signed-off-by: Gilles Dartiguelongue <eva@gentoo.org> Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* gnome.org.eclass: BDEPEND for xz-utils with EAPI-7Mart Raudsepp2019-02-111-1/+5
| | | | Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* gnome2-utils: enable EAPI 7Mart Raudsepp2019-02-111-2/+2
| | | | Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* gnome2-utils: adapt env_reset for EAPI-7Mart Raudsepp2019-02-111-1/+1
| | | | Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* gnome2-utils: Don't inherit eutils with EAPI-7Mart Raudsepp2019-02-111-1/+2
| | | | Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* gnome2-utils: Remove sed DEPEND, it's guaranteed by PMSMart Raudsepp2019-02-111-2/+0
| | | | | | | | sed is always guaranteed to be there by PMS and @system, don't depend on it for the regular sedding purposes at build time. Avoids having to worry about DEPEND vs BDEPEND. Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* gnome2-utils: Don't provide icon cache functions with EAPI-7Mart Raudsepp2019-02-111-22/+28
| | | | | | | They are in xdg-utils now, so EAPI-7 bump is a good time to move over to the xdg versions by those that need it. Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* xdg-utils: Clarify icon cache comment to not suggest GTK onlyMart Raudsepp2019-02-111-2/+2
| | | | Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* gnome.org.eclass: keep inheriting versionator.eclass for older EAPIMart Raudsepp2019-02-111-1/+2
| | | | | | Some ebuilds rely on it still and fail to inherit it themselves. Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* xdg.eclass: enable EAPI 7Marty E. Plummer2019-02-111-3/+3
| | | | | | Package-Manager: Portage-2.3.51, Repoman 2.3.11 Signed-off-by: Marty E. Plummer <hanetzer@startmail.com> Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* xdg.eclass: use ED and don't export variablesMarty E. Plummer2019-02-111-5/+3
| | | | | | Package-Manager: Portage-2.3.51, Repoman 2.3.11 Signed-off-by: Marty E. Plummer <hanetzer@startmail.com> Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* xdg-utils: use path based lookup instead of hardcoded pathsMarty E. Plummer2019-02-111-33/+14
| | | | | | Package-Manager: Portage-2.3.51, Repoman 2.3.11 Signed-off-by: Marty E. Plummer <hanetzer@startmail.com> Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* gnome2.eclass: move icon handling code to xdg.eclassMarty E. Plummer2019-02-112-16/+26
| | | | | | Package-Manager: Portage-2.3.51, Repoman 2.3.11 Signed-off-by: Marty E. Plummer <hanetzer@startmail.com> Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* gnome2-utils: move icon functions into xdg-utilsMarty E. Plummer2019-02-112-55/+52
| | | | | | | | | Kept some dummy stub functions in place in order to maintain functionality of existing ebuilds. Package-Manager: Portage-2.3.51, Repoman 2.3.11 Signed-off-by: Marty E. Plummer <hanetzer@startmail.com> Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* gnome.org.eclass: use eapi7-verMarty E. Plummer2019-02-111-3/+3
| | | | | Signed-off-by: Marty E. Plummer <hanetzer@startmail.com> Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* toolchain-glibc.eclass: disable stack protector on m68kSergei Trofimovich2019-02-101-0/+5
| | | | | | | setjmp() clobbers 'a5' register by stack protector prologue. Bug: https://sourceware.org/PR24202 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
* www-client/firefox: doesn't support >=media-libs/libvpx-1.8 yetThomas Deutschmann2019-02-101-1/+4
| | | | | | | Closes: https://bugs.gentoo.org/677604 Closes: https://bugs.gentoo.org/677662 Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
* toolchain.eclass: prepare to rename USE=regression-test->testSergei Trofimovich2019-02-101-5/+13
| | | | | | | Starting from gcc-8.3.0 FEATURES=test USE=test will be enough to run gcc's testsuite. Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
* tmpfiles.eclass: fix @SUPPORTED_EAPISWilliam Hubbs2019-02-081-1/+1
| | | | Signed-off-by: William Hubbs <williamh@gentoo.org>
* tmpfiles.eclass: add eapi 7 supportWilliam Hubbs2019-02-081-1/+1
| | | | Signed-off-by: William Hubbs <williamh@gentoo.org>
* toolchain-glibc.eclass: ignore USE=headers-only for native case, bug #677474Sergei Trofimovich2019-02-071-1/+1
| | | | | | | | Let's not allow users to deinstall native glibc. Reported-by: Toralf Förster Bug: https://bugs.gentoo.org/677474 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
* qt5-build.eclass: move the 's/optimize_full//' sed where it belongsDavide Pesavento2019-02-071-3/+5
| | | | | Signed-off-by: Davide Pesavento <pesa@gentoo.org> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* qt5-build.eclass: remove obsolete instruction sets workaroundJimi Huotari2019-02-071-5/+0
| | | | | | | | | | | | | | This has seemingly been broken since 2017-08-02, where things were moved around [1], and now causes build failures as the directory has been removed completely [2]. 1. https://code.qt.io/cgit/qt/qtbase.git/commit/?id=f54f7d84 2. https://code.qt.io/cgit/qt/qtbase.git/commit/?id=73b87697 Bug: https://bugs.gentoo.org/552942 Bug: https://bugs.gentoo.org/672946 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* meson.eclass: raise meson dependency to 0.48.2William Hubbs2019-02-071-1/+1
| | | | Signed-off-by: William Hubbs <williamh@gentoo.org>
* golang-vcs.eclass: add eapi 7 supportWilliam Hubbs2019-02-071-2/+2
| | | | Signed-off-by: William Hubbs <williamh@gentoo.org>
* golang-vcs-snapshot.eclass: add eapi 7 supportWilliam Hubbs2019-02-071-2/+2
| | | | Signed-off-by: William Hubbs <williamh@gentoo.org>
* golang-build.eclass: add eapi 7 supportWilliam Hubbs2019-02-071-2/+2
| | | | Signed-off-by: William Hubbs <williamh@gentoo.org>
* golang-base.eclass: add eapi 7 supportWilliam Hubbs2019-02-071-4/+10
| | | | Signed-off-by: William Hubbs <williamh@gentoo.org>
* meson.eclass: remove unnecessary eapi checksWilliam Hubbs2019-02-071-1/+1
| | | | | | | This eclass dies for all eapis other than 6 or 7, so we don't need to test for eapis other than 6 or 7 anywhere else in the eclass. Signed-off-by: William Hubbs <williamh@gentoo.org>
* meson.eclass: remove meson_auto_dependWilliam Hubbs2019-02-071-23/+4
| | | | Signed-off-by: William Hubbs <williamh@gentoo.org>
* kde5.eclass: Fork needed xdg.eclass functions pending EAPI-7 portingAndreas Sturmlechner2019-02-071-5/+123
| | | | Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* kde5.eclass: Relocate KDE_INSTALL_DOCBUNDLEDIR to /usr/share/helpAndreas Sturmlechner2019-02-071-4/+9
| | | | | | | | | | | | | | | | | | | | | | | | These are handbook files installed by hundreds of packages to a central location, to be accessed by KDE Helpcenter application, with compressed index cache files. This leads to the following QA issues on every package w/ USE handbook: * The ebuild is installing to one or more unexpected paths * One or more compressed files were found in docompress-ed directories We'll use the EAPI-7 transition to move the location from previously /usr/share/doc/HTML to /usr/share/help [1]. Transition for khelpcenter will be seemless as kde-frameworks/kdoctools can be easily patched to accept both locations, until eventually /usr/share/doc/HTML is empty. As a side-effect, we will be able to drop the workaround for disabling auto compression of files beneath /usr/share/doc together with EAPI-6. [1] See also: https://www.freedesktop.org/wiki/Specifications/help-system/ It is also the path upstream intends to migrate to in the future. Bug: https://bugs.gentoo.org/667138 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>