summaryrefslogtreecommitdiff
path: root/eclass
Commit message (Collapse)AuthorAgeFilesLines
* kde4-base.eclass: Cleanup SRC_URIsAndreas Sturmlechner2016-07-031-10/+0
|
* Bugfix: libbitcoinconsensus depends on univalue/boost only with USE=testLuke Dashjr2016-07-011-1/+8
| | | | Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
* eclass/toolchain-funcs: add clang version functionsAustin English2016-07-011-0/+33
|
* eclass/toolchain-funcs: avoid backticksAustin English2016-07-011-1/+1
|
* flag-o-matic.eclass: Add -fplugin* (bug #519462).Ryan Hill2016-06-301-1/+1
|
* flag-o-matic.eclass: Add -mthumb/-marm (bug #586846).Ryan Hill2016-06-301-1/+1
|
* eclass/openib.eclass: Clean up ancient versionsAlexey Shvetsov2016-06-301-11/+3
| | | | Also move to sys-fabric category
* eclass: initial cargo support eclassDoug Goldstein2016-06-291-0/+85
| | | | | | | Base eclass for cargo that handles setting up the cargo registry and provides a way to fetch crates. Signed-off-by: Doug Goldstein <cardoe@gentoo.org>
* java-vm-2.eclass: Drop support for EAPI <5James Le Cuirot2016-06-291-16/+6
|
* chromium-2.eclass: convert from LINGUAS to L10NMike Gilbert2016-06-281-29/+13
|
* chromium-2.eclass: drop phase functionsMike Gilbert2016-06-281-70/+1
|
* chromium-2.eclass: copy from chromium.eclassMike Gilbert2016-06-281-0/+258
|
* toolchain-funcs.eclass: Remove code that has become redundant.Ulrich Müller2016-06-271-3/+1
| | | | | | After commit 81c226e451be564a545696f93fc5880ebc160812, type cannot be "kern" in these two places, so ninj would always return its second argument, i.e. it can be replaced by simple echo.
* eclass/tests: Remove KV_* functions from tests-common.shMichał Górny2016-06-271-41/+0
|
* toolchain-funcs.eclass: tc-ninja_magic_to_arch, remove old KV supportMichał Górny2016-06-272-20/+3
| | | | | | | | Remove the support for old kernel versions that are no longer used in Gentoo, and rely on KV_to_int() function. This functions is provided by Portage but not listed in PMS. Furthermore, for a long time Portage replaced it with 'return 1' in global scope, so they did not really work as expected anyway.
* toolchain-funcs.eclass: Add helpful tc-is-{gcc,clang} wrappersMichał Górny2016-06-262-0/+40
|
* toolchain-funcs.eclass: Add tc-get-compiler-type()Michał Górny2016-06-262-0/+62
| | | | | | | | | | | Add a tc-get-compiler-type() function that can be used to identify the compiler being used, using the preprocessor defines. Alike gcc-*version() routines, it uses CPP (which in turn uses CC). The major usage would be applying compiler-specific quirks and limiting gcc version checks to compilers that actually are gcc, since e.g. clang reports gcc version 4.2 -- which would incorrectly cause numerous gcc version checks in ebuilds to fail.
* toolchain-funcs.eclass: Assume CPP="$(tc-getCC) -E" when unset, #582822Michał Górny2016-06-261-2/+2
| | | | | | | | | | | | | Modify the tc-getCPP and tc-getBUILD_CPP functions to use "$(tc-getCC) -E" (i.e. the C compiler's preprocessing call) instead of falling back to 'cpp'. This ensures that in environment with CC (and CXX) overriden the correct compiler is used rather than the one selected by gcc-config, which in turn fixes gcc version queries. The alternative would be to always override CPP along with CC & CXX. However, that is uncommon and is known to break some packages. Bug: https://bugs.gentoo.org/show_bug.cgi?id=582822
* toolchain-funcs.eclass: Fix _tc-getPROG with multi-parameter defaultsMichał Górny2016-06-261-5/+5
| | | | | | Fix _tc-getPROG function to account correctly for default values that contain program name along with arguments, e.g. the default for CPP containing "$(CC) -E".
* gnatbuild.eclass: legacy fixes for older versions and bug 558346.Stephen L Arnold2016-06-251-51/+104
| | | | | | See virtual/gnat changes and ebuild updates. Signed-off-by: Stephen L Arnold <nerdboy@gentoo.org>
* eclass/vala.eclass: max version is now 0.32Pacho Ramos2016-06-251-2/+2
|
* dev-qt: upstream respun 5.6.1 tarballsMichael Palimaka2016-06-241-1/+6
| | | | | | | qtdeclarative was revbumped due to the inclusion of an important patch. All other modules had either trivial or no changes. Gentoo-bug: 586646
* eclass/myspell-r2.eclass: Fix typo in comment.Ulrich Müller2016-06-231-2/+2
|
* toolchain-binutils.eclass: [QA] Remove USE=multislot, #584610Michał Górny2016-06-211-2/+1
| | | | | | | | The USE=multislot was used only to control build-time blocker on previous versions of binutils. However, there is no technical reason not to have multiple binutils versions installed at build time (or run time). Considering that the flag does not control the installed files or the package in any other way, it is an invalid use of USE flags.
* toolchain.eclass: [QA] Remove meaningless USE=multislot, #584610Michał Górny2016-06-211-5/+1
| | | | | | | | | | | | | | | The USE=multislot as defined partially by toolchain.eclass and partially by sys-devel/gcc was used for two purposes: - enabling build-time (only) blockers on old gcc versions -- which do not make any sense because they are build-time only and there is no technical reason for two gcc version ranges not to be installed at the same time, both at build time and at run time, - changing behavior of post-install wrt conditional gcc-config calls. Both cases are invalid use of USE flags, considering that the flag does not affect the installed files in any way.
* java-vm-2.eclass: Remove unused nsplugin codeJames Le Cuirot2016-06-181-111/+3
|
* kde5.eclass: >=Plasma-5.7 depends on >=Frameworks-5.23Andreas Sturmlechner2016-06-171-0/+1
|
* kde5.eclass: >=Plasma-5.6.5 depends on >=Qt-5.6.1Andreas Sturmlechner2016-06-171-0/+9
|
* kde5.eclass: remove KDE_DOXYGEN and KDE_DOX_DIRMichael Palimaka2016-06-171-37/+0
| | | | | kgenapidox was removed from kapidox in bb4063f5d9f9015b86dbc3a48a424c8cb1a8193f and there does not appear to be a suitable replacement (for us).
* kde5.eclass: Add handling of building plugins for Qt5DesignerAndreas Sturmlechner2016-06-171-0/+22
| | | | KDE_DESIGNERPLUGIN toggles dependencies and configure with USE=designer
* kde4-base.eclass: use https for default EGIT_MIRRORMichael Palimaka2016-06-171-1/+1
|
* kde5.eclass: use https for default EGIT_MIRRORMichael Palimaka2016-06-171-1/+1
|
* kde5-functions.eclass: Improve punt_bogus_depAndreas Sturmlechner2016-06-171-1/+1
| | | | | The variable holding the min version requirement can be named anything. This should catch most cases, most importantly Qt5 modules.
* cmake-utils.eclass: echo ctest argumentsMichael Palimaka2016-06-171-0/+1
| | | | | This mirrors the behaviour during src_configure where cmake and its arguments are printed for clarity.
* cmake-utils.eclass: do not pass CMAKE_INSTALL_DO_STRIP in EAPI 6 and laterMichael Palimaka2016-06-171-1/+1
| | | | | CMAKE_INSTALL_DO_STRIP does not appear to be widely used, so this is a good opportunity to get rid of it.
* kernel-2.eclass: add Prefix support.Benda Xu2016-06-151-25/+25
| | | | | | | | A few quotes and dies are updated. https://archives.gentoo.org/gentoo-dev/message/8a1c67b1d1145e55447c65c7b213dce9 Bug: 478436
* mozcoreconf-v4.eclass: fix typo in '@DESCRIPTION' tagIan Stakenvicius2016-06-141-3/+3
| | | | Bug: http://bugs.gentoo.org/585922
* qt5-build.eclass: tweak sed expression to also apply to 5.6.1 and laterDavide Pesavento2016-06-131-1/+1
|
* python-any-r1.eclass: Ensure not to emit := in || () depsMichał Górny2016-06-121-2/+4
|
* eclass/enlightenment.eclass: Fix keywording #342185Patrick Lauer2016-06-121-7/+0
|
* mysql-cmake/mysql-multilib eclasses: set STACK_DIRECTION to fix cross-compilesMike Frysinger2016-06-113-1/+23
|
* qt5-build.eclass: switch to using system proxy settings by defaultDavide Pesavento2016-06-121-5/+3
| | | | | | | But only in 5.6 and later, we don't want to touch stable 5.5.1. Upstream is switching to this new setting in 5.8, see qtbase commit 6d9f648d0ed591a0afba018adfbb089871f67b38.
* qt5-build.eclass: initial configure support for Qt 5.8 (current dev branch)Davide Pesavento2016-06-091-5/+6
|
* Mozilla eclass changes for new versions and to improve cross-buildsIan Stakenvicius2016-06-078-1240/+387
| | | | | | | | | | | | - mozcoreconf-v4 introduced to centralize toolchain and related build settings, and improve configuration settings related to toolchain usage. - mozconfig-v6.45 modified to inherit new mozcoreconf-v4 - mozconfig-v6.47 introduced, also inheriting mozcoreconf-v4 - removed old versions of mozconfig related to mozilla versions no longer in repo
* python-utils-r1.eclass: Add additional .opt-1 compilation for py3.5+Michał Górny2016-06-061-0/+6
|
* Add jemalloc-4.2.0 update, drop force-gtk2 useflag from mozconfig-v6.46.eclassJory A. Pratt2016-06-051-8/+8
|
* distutils-r1.eclass: Do not modify the HOME variableMike Gilbert2016-06-051-6/+0
| | | | | This was only necessary when we ran phases in parallel. Also, PMS says this variable should not be modified.
* distutils-r1.eclass: Move creation of .pydistutils.cfg to esetup.pyMike Gilbert2016-06-051-5/+10
| | | | | | | | | | | | | Also remove .pydistutils.cfg from HOME before returning. This config should only be needed when we are invoking setup.py. The esetup.py wrapper provides a normalized way for doing this; if ebuilds call setup.py without the wrapper, they are now also responsible for setting the build directory if necessary. This change allows us to stop overriding the HOME variable, and prevents leakage of eclass-specifc configuration to the general ebuild environment.
* distutils-r1.eclass: Strip the trailing slash from DMike Gilbert2016-06-051-2/+2
| | | | This just looks nicer in build logs.
* vdr-plugin-2.eclass: added vdr_ prefix to make function exclusiv for eclassJoerg Bornkessel2016-06-051-4/+3
|