summaryrefslogtreecommitdiff
path: root/eclass
Commit message (Collapse)AuthorAgeFilesLines
* Merge eclass/.gitignore into the top-level one.Ulrich Müller2017-03-021-1/+0
|
* eclass: new eclass php-pear-r2 to replace php-pear*Brian Evans2017-03-021-0/+122
|
* eclass/ros-catkin.eclass: Add CATKIN_IN_SOURCE_BUILD support.Alexis Ballier2017-03-021-0/+20
|
* ruby-fakegem.eclass: Drop stale CVS $Revision$ keywordUlrich Müller2017-03-011-3/+3
| | | | Acked by graaff.
* python-any-r1.eclass: Move PYTHON_USEDEP doc before globalsMichał Górny2017-03-011-19/+19
|
* openib.eclass: switch HOMEPAGE to httpsMike Frysinger2017-02-281-1/+1
|
* Drop $Header$ per council decision in bug #611234.Robin H. Johnson2017-02-281-1/+0
| | | | Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
* Drop $Id$ per council decision in bug #611234.Robin H. Johnson2017-02-28237-237/+0
| | | | Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
* app-leechcraft: use Qt5, modernize the eclass and ebuilds0xd34df00d2017-02-261-34/+8
| | | | Closes: https://github.com/gentoo/gentoo/pull/4079
* gnatbuild.eclass: Fix header.Ulrich Müller2017-02-251-1/+1
|
* ruby-ng.eclass: use the default src_prepare in EAPI 6Hans de Graaff2017-02-251-13/+30
| | | | | | | | This removes the need for inheriting eutils in EAPI 6. It also use the standard PATCHES support instead of RUBY_PATCHES, which was introduced to handle arrays on patches at the time. The default phase also handles eapply_user to handle user patches.
* ruby-ng.eclass: add support for EAPI=6Hans de Graaff2017-02-251-4/+10
|
* mozcoreconf-v4.eclass: change 'eval unset' to 'unset'Ian Stakenvicius2017-02-231-1/+1
|
* mozilla eclasses: remove old mozcoreconf and mozlinguasIan Stakenvicius2017-02-233-850/+0
|
* eclass/ros-catkin.eclass: Regenerate devel environment before running tests. ↵Alexis Ballier2017-02-231-0/+5
| | | | PYTHONPATH is not set properly otherwise and we end up testing the installed version, not the version we just built.
* eclass/java-utils-2.eclass: Convert the few remaining bits to EAPI 6.Patrice Clement2017-02-221-5/+5
|
* mysql*.eclass: remove built_with_use function in pkg_configBrian Evans2017-02-223-10/+4
|
* gnat.eclass: Mark @DEADMichał Górny2017-02-221-1/+4
|
* *.eclass: Drop Ada eclasses to maintainer-neededMichał Górny2017-02-223-3/+3
|
* user.eclass: Remove retired maintainersMichał Górny2017-02-221-2/+0
|
* multilib-minimal.eclass: Reown to multilib@Michał Górny2017-02-221-1/+1
|
* fcaps.eclass: Remove retired co-maintMichał Górny2017-02-221-1/+0
|
* eutils.eclass: Remove retired co-maintMichał Górny2017-02-221-2/+0
|
* confutils.eclass: Mark maintainer-neededMichał Górny2017-02-221-1/+1
|
* depend.php.eclass: Remove @DEAD eclassMichał Górny2017-02-221-258/+0
| | | | The eclass is @DEAD for a long time, and no longer used by any package.
* libtool.eclass: elibtoolize: add ppc64le handling #580792Leno Hou2017-02-213-1/+58
| | | | | | | | | | | | | | | | | | 1) We faced unable read SONAME from ${lib} when emerge below packages platform pacakge elibtoolized ppc64le app-text/opensp no ppc64le dev-libs/expat yes ppc64le net-firewall/iptables yes ppc64le net-libs/libmnl no ppc64le sys-apps/acl yes ppc64le sys-apps/attr yes ppc64le sys-libs/gdbm yes ppc64le sys-process/procps no 2) The problem is due to the wrong $LD="ld -m elf64ppc" when link. This patch sets $LD="ld -m elf64lppc" in m4/libtool.m4 on ppc64le. URL: https://debbugs.gnu.org/23348
* python.eclass: Mark @DEAD for removalMichał Górny2017-02-211-1/+4
|
* subversion.eclass: Fix error messages in subversion_bootstrap() and ↵Arfrever Frehtes Taifersar Arahesis2017-02-211-3/+3
| | | | | | | subversion_src_prepare(). ${FUNCNAME[1]} is name of direct parent function, but name of current function (${FUNCNAME[0]} or ${FUNCNAME}) is needed here.
* flag-o-matic.eclass: Add -fno-stack-check to ALLOWED_FLAGSJoshua Kinard2017-02-201-1/+1
| | | | | | | The -fno-stack-check flag is equivalent to -fstack-check=no, so support both in ALLOWED_FLAGS. Signed-off-by: Joshua Kinard <kumba@gentoo.org>
* eclass/oasis.eclass: Drop compat for non-split ocamlbuild now that ocaml ↵Alexis Ballier2017-02-201-1/+1
| | | | versions including it are gone.
* sci-biology/emboss: Remove oldDavid Seifert2017-02-191-134/+0
| | | | | Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/3937
* emboss-r2.eclass: Make EAPI=6 only, simplifyDavid Seifert2017-02-191-0/+164
| | | | Closes: https://github.com/gentoo/gentoo/pull/3937
* golang-base.eclass: raise go version to 1.7 for #607086William Hubbs2017-02-191-1/+1
|
* python-single-r1.eclass: Always output use-cond in PYTHON_DEPSMichał Górny2017-02-191-1/+1
| | | | | | | | Output a USE conditional in PYTHON_DEPS even when using only a single target. While this does not make a strict difference since the target flag is in REQUIRED_USE anyway, it results in more unified output and makes it easier to catch mistakes if someone plays with the eclass in the future.
* distutils.eclass: Mark @DEAD for removalMichał Górny2017-02-181-1/+4
|
* python-single-r1.eclass: Remove EAPI=4 exceptionsMichał Górny2017-02-171-21/+1
|
* distutils-r1.eclass: Reject EAPI=4 explicitlyMichał Górny2017-02-171-2/+2
|
* python-r1.eclass: Wipe obsolete EAPI=4 exceptionsMichał Górny2017-02-171-15/+1
|
* python-utils-r1.eclass: Require pypy{,3} >= 5, #609292Michał Górny2017-02-171-2/+2
| | | | | Bump the dependency on PyPy to require relatively recent versions, to ease package maintenance.
* mozconfig-v6.45.eclass: remove gstreamer:0.10 capabilityIan Stakenvicius2017-02-151-11/+2
|
* mozconfig.eclass: remove old/unused v5.31, v6.38, v6.42Ian Stakenvicius2017-02-153-756/+0
|
* llvm.eclass: An eclass to handle dependencies on slotted LLVMMichał Górny2017-02-151-0/+139
| | | | | | | | | | | | | | Introduce an eclass to support dependencies building against slotted LLVM. It provides a function to find the newest installed LLVM version that is not newer than the max supported slot, and a trivial pkg_setup() implementation that adds executable directory of this install to PATH. This ensures that: a) build systems will find the correct llvm-config and use it to use the correct version of LLVM, b) CMake's find_package() will find the correct LLVMConfig / ClangConfig files.
* flag-o-matic.eclass: Mark has_m64() as dead.Ulrich Müller2017-02-131-21/+2
| | | | The function is not used by any ebuild.
* cargo.eclass: ensure man pages are installedDoug Goldstein2017-02-121-0/+2
| | | | | | If man pages are shipped with a crate, let's install them. Signed-off-by: Doug Goldstein <cardoe@gentoo.org>
* Revert "gnome2.eclass: we cannot rely on default phases involving emake ↵Mart Raudsepp2017-02-111-8/+9
| | | | | | because they don't allow to pass extra variables, bug #606826" This reverts commit c84c8b8d0bccb14e20ed6d3336f0e6f80e7936a4.
* gnome2.eclass: we cannot rely on default phases involving emake because they ↵Pacho Ramos2017-02-111-9/+8
| | | | don't allow to pass extra variables, bug #606826
* twisted-r1.eclass: Replace TEST_DIR eqawarn with fatal errorMichał Górny2017-02-111-3/+4
|
* kde5-functions.eclass: Raise QT_MINIMAL to 5.7.1 for Plasma liveAndreas Sturmlechner2017-02-111-1/+4
|
* multiprocess.eclass: makeopts_{jobs,loadavg}: fix implicit handling of ↵Mike Frysinger2017-02-093-8/+19
| | | | | | | | $MAKEOPTS #608242 We missed quoting on ${MAKEOPTS} to set it as the first arg which meant we might load invalid values into the second arg which is the "infinite" scenario.
* eclass/ros-catkin.eclass: Set PYTHON_INSTALL_DIR when building python packages.Alexis Ballier2017-02-091-1/+6
|