summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* games-emulation/dolphin: Keyword 5.0_p20220520 arm64, #846533Arthur Zamarin5 days1-1/+1
| | | | Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
* games-emulation/dolphin: Do not remove mgba in 9999Michał Górny2022-05-202-2/+2
| | | | | | | Thanks to xarblu for the suggestion. Closes: https://bugs.gentoo.org/846578 Signed-off-by: Michał Górny <mgorny@gentoo.org>
* games-emulation/dolphin: Bump to 5.0_p20220520 snapshotMichał Górny2022-05-203-43/+271
| | | | | Closes: https://bugs.gentoo.org/845240 Signed-off-by: Michał Górny <mgorny@gentoo.org>
* games-emulation/dolphin: Don't use variable in LICENSEJames Le Cuirot2022-04-272-6/+2
| | | | | Closes: https://bugs.gentoo.org/840598 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
* games-emulation/dolphin: Remove oldMichał Górny2022-01-082-198/+0
| | | | Signed-off-by: Michał Górny <mgorny@gentoo.org>
* games-emulation/dolphin: Restrict libfmt due to build failureMichał Górny2022-01-081-2/+2
| | | | Signed-off-by: Michał Górny <mgorny@gentoo.org>
* games-emulation/dolphin: Set USE-defaults for mesa[egl,gbm]Matt Turner2021-10-313-3/+3
| | | | | Signed-off-by: Matt Turner <mattst88@gentoo.org> Signed-off-by: Sam James <sam@gentoo.org>
* games-emulation/dolphin: amd64 stable wrt bug #815028Agostino Sarubbo2021-09-271-1/+1
| | | | | | Package-Manager: Portage-3.0.20, Repoman-3.0.3 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* **/metadata.xml: Replace http by https in DOCTYPE elementUlrich Müller2021-09-111-1/+1
| | | | | Bug: https://bugs.gentoo.org/552720 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* games-emulation/dolphin: Fix running testsMichał Górny2021-08-082-0/+8
| | | | Signed-off-by: Michał Górny <mgorny@gentoo.org>
* games-emulation/dolphin: Fix LICENSEMichał Górny2021-08-082-77/+81
| | | | | | | Adjust the package's license to GPL-2+, plus add licenses for the bundled deps. Signed-off-by: Michał Górny <mgorny@gentoo.org>
* games-emulation/dolphin: Update HOMEPAGEMichał Górny2021-08-082-2/+2
| | | | Signed-off-by: Michał Górny <mgorny@gentoo.org>
* games-emulation/dolphin: USE={qt5 → gui}Michał Górny2021-08-082-12/+12
| | | | | | | The Qt5 GUI is the only supported GUI in the ebuild, so use the generic flag for it. Signed-off-by: Michał Górny <mgorny@gentoo.org>
* games-emulation/dolphin: Remove USE=ltoMichał Górny2021-08-082-4/+6
| | | | Signed-off-by: Michał Górny <mgorny@gentoo.org>
* games-emulation/dolphin: Make bundled dep removal less reverseMichał Górny2021-08-082-17/+19
| | | | Signed-off-by: Michał Górny <mgorny@gentoo.org>
* games-emulation/dolphin: Wrap long lines in ebuildMichał Górny2021-08-082-4/+10
| | | | Signed-off-by: Michał Górny <mgorny@gentoo.org>
* games-emulation/dolphin: Remove vcs-snapshot.eclassMichał Górny2021-08-082-7/+7
| | | | Signed-off-by: Michał Górny <mgorny@gentoo.org>
* games-emulation/dolphin: Add missing ||dieMichał Górny2021-08-082-4/+8
| | | | Signed-off-by: Michał Górny <mgorny@gentoo.org>
* games-emulation/dolphin: Remove use of plocale.eclassMichał Górny2021-08-082-16/+183
| | | | | | | Remove plocale.eclass usage. The tiny .mo files are not worth the added complexity. Signed-off-by: Michał Górny <mgorny@gentoo.org>
* games-emulation/dolphin: Add myself as maintainerMichał Górny2021-08-061-0/+4
| | | | Signed-off-by: Michał Górny <mgorny@gentoo.org>
* games-emulation/dolphin: adopt for games@Ionen Wolkens2021-08-051-3/+6
| | | | Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* games-emulation/dolphin: drop slyfox@ from maintainers down to m-nSergei Trofimovich2021-08-041-3/+1
| | | | | Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
* games-emulation/dolphin: add IUSE=mgbaSergei Trofimovich2021-07-302-1/+3
| | | | | | Fix-by: xarblu <xarblu@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/21829 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
* games-emulation/dolphin: enable mGBA supportTaylor C. Richberger2021-07-281-1/+4
| | | | | | | Closes: https://bugs.gentoo.org/804666 Reported-by: Taylor C. Richberger <taywee@gmx.com> Reviewed-by: Sergei Trofimovich <slyfox@gentoo.org> Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
* games-emulation/dolphin: Update from l10n.eclass to plocale.eclassUlrich Müller2021-07-042-8/+8
| | | | | Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* games-emulation/dolphin: add missing headers for muslSergei Trofimovich2021-07-022-0/+26
| | | | | | | Reported-by: ernsteiswuerfel Closes: https://bugs.gentoo.org/799281 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
* games-emulation/dolphin: drop oldSergei Trofimovich2021-06-192-182/+0
| | | | | Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
* games-emulation/dolphin: amd64 stable wrt bug #795552Agostino Sarubbo2021-06-131-1/+1
| | | | | | Package-Manager: Portage-3.0.13, Repoman-3.0.2 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* games-emulation/dolphin: bump up to 5.0_p20210506Sergei Trofimovich2021-05-122-0/+196
| | | | | | | Reported-by: Toralf Förster Closes: https://bugs.gentoo.org/789609 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
* games-emulation/dolphin: update cmake.eclass commentSam James2021-04-062-4/+4
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* games-emulation/dolphin: refresh live ebuildSamuel BAUER2021-03-281-2/+6
| | | | | | | Avoid -durty suffix to allow more netplay sessions. Make vulkan-loader optional. Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
* games-emulation/dolphin: raise libfmp up to >=7.1Sergei Trofimovich2020-12-181-1/+1
| | | | | Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
* games-emulation/dolphin: added ~arm64Roy Bamford2020-12-021-1/+1
| | | | | | Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Roy Bamford <neddyseagoon@gentoo.org> Signed-off-by: Sam James <sam@gentoo.org>
* games-emulation/dolphin: add USE=vulkanSergei Trofimovich2020-10-242-1/+6
| | | | | | Patch-by: Samuel BAUER Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
* games-emulation/dolphin: allow new rangeset dependSergei Trofimovich2020-09-111-0/+7
| | | | | | | While at it disable verbose dev cmake warnings. Package-Manager: Portage-3.0.6, Repoman-3.0.1 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
* games-emulation/dolphin: remove unused patch(es)Michael Mair-Keimberger2020-08-144-118/+0
| | | | | | | Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/17120 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
* games-emulation/dolphin: drop oldSergei Trofimovich2020-08-133-185/+0
| | | | | Package-Manager: Portage-3.0.2, Repoman-2.3.23 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
* games-emulation/dolphin: amd64 stable wrt bug #736176Agostino Sarubbo2020-08-101-1/+1
| | | | | | Package-Manager: Portage-2.3.99, Repoman-2.3.22 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* games-emulation/dolphin: use BDEPENDSergei Trofimovich2020-07-082-6/+4
| | | | | | | | | While at it drop unused dependencies. Fix-by: David Michael <fedora.dm0@gmail.com> Closes: https://bugs.gentoo.org/731116 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
* games-emulation/dolphin: make 5.0_p20200705 snapshot releaseSergei Trofimovich2020-07-053-1/+186
| | | | | Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
* games-emulation/dolphin: update to EAPI=7Sergei Trofimovich2020-07-051-7/+12
| | | | | Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
* games-emulation/dolphin: use bundled vulkan-headersSergei Trofimovich2020-06-271-1/+6
| | | | | | | | | | Gentoo's dev-util/vulkan-headers removed API that dolphin relied on. Let's sue bundled headers. Fix is proposed by Gabriel Marcano. Reported-by: Gabriel Marcano Closes: https://bugs.gentoo.org/729832 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
* games-emulation/dolphin: allow bundled zstdSergei Trofimovich2020-05-161-0/+2
| | | | | | | | | dolphin lacks zstd discovery code. Let's use bundled code for now. Reported-by: Michael Cook Closes: https://bugs.gentoo.org/723276 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
* games-emulation/dolphin: migrate from libavMikle Kolyada2020-04-252-10/+4
| | | | | Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
* games-emulation/dolphin: use system version of dev-libs/libfmtSergei Trofimovich2020-03-201-1/+1
| | | | | | | | | Follow the update pntroduced in https://github.com/dolphin-emu/dolphin/pull/8198 Reported-by: Samuel BAUER Package-Manager: Portage-2.3.94, Repoman-2.3.21 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
* games-emulation/dolphin: depend on mbedtls subslot, bug #705046Sergei Trofimovich2020-01-092-4/+4
| | | | | | | | | | It's a fix of regression introduced by https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=7a5765256c9a8cf089c304f1dc4b2fe8fc663842 Reported-by: Ben Kohler Closes: https://bugs.gentoo.org/705046 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
* games-emulation/dolphin: drop unused 'versionator' importSergei Trofimovich2019-11-101-1/+1
| | | | | Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
* games-emulation/dolphin: use '.tar.gz' instead of '.zip' archiveSergei Trofimovich2019-11-102-2/+2
| | | | | Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
* games-emulation/dolphin: added missing dependencyMohamad Issawi2019-10-121-0/+5
| | | | | | | | | Latest dev build requires media-libs/vulkan-loader to use vulkan backend at runtime in the UI. Package-Manager: Portage-2.3.76, Repoman-2.3.17 Closes: https://github.com/gentoo/gentoo/pull/13257 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
* games-emulation/dolphin: whitelist 'fmt' as bundled, bug #688122Sergei Trofimovich2019-06-161-0/+2
| | | | | | | | | | 'fmt' is a new 'dolphin' dependency. Currently build system does not support using system dependency. Reported-by: Michael Cook Closes: https://bugs.gentoo.org/688122 Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>