summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* games-emulation/mednafen: drop 0.9.46Ionen Wolkens12 days3-116/+0
| | | | Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* games-emulation/mednafen: add 1.26.1 with reworked ebuildIonen Wolkens2021-05-092-0/+75
| | | | | | | | | | | | | | | | | | | | | | | | | | | | Notable ebuild changes: - EAPI-7 - libsdl -> libsdl2 - finally use virtual/jack (jack2 tested fine) - use more aggressive sed for configure.ac's CFLAGS given upstream been adding yet more unnecessary compiler options such as attempts to disable spectre mitigation - tentatively removed strip-flags (referenced bug #539992 was only because of lacking -fwrapv, but strip was added with it) - tentatively removed ccache check (no explanation found, seems fine) - use new --with-external-{lzo,mpcdec,tremor,trio} to unbundle - pic/pie warning is now non-fatal but is repeated so much that used the new defines to disable anyway - IUSE changes: > altivec: converted to cpu_flags_ppc_altivec (untested) > sndfile: added for libsndfile to be optional > cjk/debugger: removed (these are enabled by default, have no dependencies, and don't have a big impact on size) - install html docs, the only viable source of usage information (README(s) are just build instructions) Closes: https://bugs.gentoo.org/670672 Closes: https://bugs.gentoo.org/684088 Signed-off-by: Ionen Wolkens <sudinave@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
* games-emulation/mednafen: Call pax-mark unconditionallyJames Le Cuirot2019-10-282-7/+3
| | | | | | | | This is what we normally do. Closes: https://bugs.gentoo.org/698276 Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
* games-emulation/mednafen: remove unused patchesMichael Mair-Keimberger2017-12-232-87/+0
|
* games-emulation/mednafen: Remove oldDavid Seifert2017-12-214-291/+0
| | | | Package-Manager: Portage-2.3.16, Repoman-2.3.6
* games-emulation/*: Update Manifest hashesMichał Górny2017-12-101-4/+4
|
* games-*/*: Remove stable keywordsDavid Seifert2017-11-181-1/+1
| | | | | | Gentoo currently does not have the manpower to maintain a ton of stable games packages. Closes: https://github.com/gentoo/gentoo/pull/5404
* games-emulation/mednafen: Version bump to 0.9.46David Seifert2017-08-132-0/+116
| | | | | | | * Also remove the annoying PIC checks Bug: https://bugs.gentoo.org/show_bug.cgi?id=624482 Package-Manager: Portage-2.3.6, Repoman-2.3.3
* *games*/*: Dekeyword ppc/ia64/sparcDavid Seifert2017-07-083-3/+3
| | | | Closes: https://github.com/gentoo/gentoo/pull/4614
* games-emulation/mednafen: Bump to 0.9.45.1David Seifert2017-06-112-0/+110
| | | | | | | | * Also depend on at least lzo-2.10 Bug: https://bugs.gentoo.org/show_bug.cgi?id=621214 Package-Manager: Portage-2.3.6, Repoman-2.3.2
* games-emulation/mednafen: Version bump to 0.9.45David Seifert2017-06-052-0/+110
| | | | | | | | | * Only use sed's instead of patches from now on, due to the bundling/CFLAGS insanity of upstream. Bug: https://bugs.gentoo.org/show_bug.cgi?id=612120 Bug: https://bugs.gentoo.org/show_bug.cgi?id=618380 Package-Manager: Portage-2.3.6, Repoman-2.3.2
* Drop $Id$ per council decision in bug #611234.Robin H. Johnson2017-02-281-1/+0
| | | | Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
* games-emulation/mednafen: Remove oldDavid Seifert2017-01-229-623/+0
| | | | | | Gentoo-bug: 515296 Package-Manager: Portage-2.3.3, Repoman-2.3.1
* games-emulation/mednafen: x86 stable wrt bug #515296Agostino Sarubbo2017-01-221-1/+1
| | | | | | Package-Manager: portage-2.3.0 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* games-emulation/mednafen: amd64 stable wrt bug #515296Agostino Sarubbo2017-01-221-1/+1
| | | | | | Package-Manager: portage-2.3.0 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* games-emulation/mednafen: Version bump to 0.9.41David Seifert2017-01-214-0/+159
| | | | | | Gentoo-bug: 515296 Package-Manager: Portage-2.3.3, Repoman-2.3.1
* games-emulation/mednafen: Version bump to 0.9.39.2David Seifert2016-12-195-0/+221
| | | | | | | | | Gentoo-bug: 602268 * EAPI=6 * Remove games.eclass * Update patches Package-Manager: Portage-2.3.3, Repoman-2.3.1
* games-emulation/mednafen: clean oldMichael Sterrett2016-02-155-139/+0
| | | | Package-Manager: portage-2.2.26
* games-emulation/mednafen: x86 stable wrt bug #573226Agostino Sarubbo2016-02-141-1/+1
| | | | | | Package-Manager: portage-2.2.26 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* games-emulation/mednafen: amd64 stable wrt bug #573226Agostino Sarubbo2016-02-011-1/+1
| | | | | | Package-Manager: portage-2.2.26 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* Set appropriate maintainer types in metadata.xml (GLEP 67)Michał Górny2016-01-241-1/+1
|
* Replace all herds with appropriate projects (GLEP 67)Michał Górny2016-01-241-1/+4
| | | | | Replace all uses of herd with appropriate project maintainers, or no maintainers in case of herds requested to be disbanded.
* games-emulation/mednafen: version bumpMichael Sterrett2015-12-295-0/+402
| | | | Package-Manager: portage-2.2.24
* Revert DOCTYPE SYSTEM https changes in metadata.xmlMike Gilbert2015-08-241-1/+1
| | | | | | | repoman does not yet accept the https version. This partially reverts eaaface92ee81f30a6ac66fe7acbcc42c00dc450. Bug: https://bugs.gentoo.org/552720
* Use https by defaultJustin Lecher2015-08-241-1/+1
| | | | | | Convert all URLs for sites supporting encrypted connections from http to https Signed-off-by: Justin Lecher <jlec@gentoo.org>
* proj/gentoo: Initial commitRobin H. Johnson2015-08-086-0/+151
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed