summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* gnome-base/gnome-shell: remove oldMart Raudsepp9 days2-192/+0
| | | | | Package-Manager: Portage-2.3.103, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* gnome-base/gnome-shell: Stabilize 3.36.7 amd64, #755848Sam James9 days1-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* gnome-base/gnome-shell: x86 stable (bug #755848)Thomas Deutschmann10 days1-1/+1
| | | | | Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
* gnome-base/gnome-shell: bump to 3.36.7, fixes CVE-2020-12825Mart Raudsepp2020-11-142-0/+192
| | | | | Package-Manager: Portage-2.3.103, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* gnome-base/gnome-shell: Version bump to 3.38.1Matt Turner2020-11-102-0/+187
| | | | Signed-off-by: Matt Turner <mattst88@gentoo.org>
* gnome-base/gnome-shell: remove oldMart Raudsepp2020-11-076-994/+0
| | | | | Package-Manager: Portage-2.3.103, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* gnome-base/gnome-shell: Stabilize 3.36.5 amd64, #738728Sam James2020-08-301-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* gnome-base/gnome-shell: x86 stable (bug #738728)Thomas Deutschmann2020-08-301-1/+1
| | | | | Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
* gnome-base/gnome-shell: Stabilize 3.34.5-r1 x86, #736802Sam James2020-08-301-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* gnome-base/gnome-shell: Stabilize 3.34.5-r1 amd64, #736802Sam James2020-08-291-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* gnome-base/gnome-shell: remove oldMart Raudsepp2020-08-144-568/+0
| | | | | Package-Manager: Portage-2.3.103, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* gnome-base/gnome-shell: bump to 3.36.5Mart Raudsepp2020-08-142-0/+192
| | | | | | Bug: https://bugs.gentoo.org/736802 Package-Manager: Portage-2.3.103, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* gnome-base/gnome-shell: backport fix for CVE-2020-17489Mart Raudsepp2020-08-132-0/+245
| | | | | | Bug: https://bugs.gentoo.org/736802 Package-Manager: Portage-2.3.103, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* gnome-base/gnome-shell: update patchsetMart Raudsepp2020-07-162-0/+191
| | | | | | | | Might fix some libst crashes for some, plus a gnome-3-36 branch commit for some extension update check fix Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* gnome-base/gnome-shell-3.36.4: add patchset, fixing st_theme crasherMart Raudsepp2020-07-152-0/+191
| | | | | Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* gnome-base/gnome-shell: bump to 3.36.4Mart Raudsepp2020-07-133-0/+214
| | | | | Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* Revert "gnome-base/gnome-shell: don't pdepend on gnome-control-center on arm"Mart Raudsepp2020-06-021-2/+2
| | | | | | | | gnome-control-center has arm keywords now. This reverts commit 590cd73cad8063c687f9e526c121348669d3b19f. Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* gnome-base/gnome-shell: add missing libnma dependencyMart Raudsepp2020-04-261-0/+1
| | | | | | | | | | | Most people got it via gnome-control-center -> nm-applet, but nothing ensured USE=introspection on there before. It has to be able to successfully import with gjs if Config.HAVE_NETWORKMANAGER is set at runtime, which it is if built with USE=networkmanager. Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* gnome-base/gnome-shell: don't pdepend on gnome-control-center on armMart Raudsepp2020-04-261-2/+2
| | | | | | | | arm still hasn't re-keyworded gnome-control-center; drop the pdepend as an emergency main tree breakage fix for now Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* gnome-base/gnome-shell: remove oldMart Raudsepp2020-04-258-935/+0
| | | | | Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* gnome-base/gnome-shell: drop alpha keywordsMart Raudsepp2020-04-251-1/+1
| | | | | | | Re-keyword requests didn't see any action for 14 months. Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* gnome-base/gnome-shell: x86 stable wrt bug #717144Agostino Sarubbo2020-04-201-1/+1
| | | | | | Package-Manager: Portage-2.3.89, Repoman-2.3.20 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* gnome-base/gnome-shell: amd64 stable wrt bug #717144Agostino Sarubbo2020-04-201-1/+1
| | | | | | Package-Manager: Portage-2.3.89, Repoman-2.3.20 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* */*: restore ~ia64 gnome-base/gnome-shell keywordsSergei Trofimovich2020-04-161-1/+1
| | | | | | | | | | | | | | | | | | Émeric Maschino and Mart Raudsepp noted that gnome-extra/evolution-data-server has no hard dependency on webkit-gtk and we can just mask USE=oauth there. This change does exactly that and restores keywords for the following packages: - gnome-base/gdm - gnome-base/gnome-shell - nome-extra/chrome-gnome-shell - nome-extra/evolution-data-server Reported-by: Émeric Maschino Closes: https://bugs.gentoo.org/717550 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
* */*: dekeyword ruby on ia64Sergei Trofimovich2020-04-121-1/+1
| | | | | | | | | | | | | | ruby-2.7 removed support for coroutines on ia64 (requires a bit of manual stack management): https://github.com/ruby/ruby/commit/d17344cfc56edc4599252041b3ec0d46af0851fd Previous ruby versions were not very stable. The change dekeywords ruby. As a result webkit-gtk got dekeyworded and pulled out a few gnome packages as well. Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
* gnome-base/gnome-shell: bump to 3.34.5Mart Raudsepp2020-04-042-0/+196
| | | | | Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* gnome-base/gnome-shell: try to fix a custom_stylesheet crasherMart Raudsepp2020-03-152-0/+722
| | | | | | | | | | Seems to happen to me when upgrading some package that installs desktop files; probably the desktop database update triggers an update in gnome-shell which stumbles on this crash. This upstream pending patch seems to solve this for me, so try it out in a revbump more widespread in ~arch for now. Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* gnome-base/gnome-shell: bump to 3.34.4Mart Raudsepp2020-03-013-0/+255
| | | | | Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* gnome-base/gnome-shell-3.32: disallow eds-3.34 due to libecal API changeMart Raudsepp2020-02-292-0/+2
| | | | | Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* gnome-base/gnome-shell: Switch to PYTHON_MULTI_USEDEP APIMichał Górny2020-02-092-3/+7
| | | | Signed-off-by: Michał Górny <mgorny@gentoo.org>
* */*: Clean PYTHON_COMPAT of obsolete implsMichał Górny2020-01-052-4/+4
| | | | | Closes: https://github.com/gentoo/gentoo/pull/14246 Signed-off-by: Michał Górny <mgorny@gentoo.org>
* gnome-base/gnome-shell: remove oldMart Raudsepp2019-12-232-190/+0
| | | | | Package-Manager: Portage-2.3.79, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* gnome-base/gnome-shell: x86 stable wrt bug #702260Mikle Kolyada2019-12-081-1/+1
| | | | | | Package-Manager: Portage-2.3.79, Repoman-2.3.16 RepoMan-Options: --include-arches="x86" Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
* gnome-base/gnome-shell: amd64 stable wrt bug #702260Mikle Kolyada2019-12-081-1/+1
| | | | | | Package-Manager: Portage-2.3.79, Repoman-2.3.16 RepoMan-Options: --include-arches="amd64" Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
* gnome-base/gnome-shell: bump to 3.32.2Mart Raudsepp2019-09-073-0/+247
| | | | | Package-Manager: Portage-2.3.69, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* */*: Depend on media-libs/mesa[X(+)]Philipp Ammann2019-08-172-2/+2
| | | | | | | | | This changes any package that depends on media-libs/mesa (though not virtual/opengl) to depend on media-libs/mesa[X(+)] instead. Bug: https://bugs.gentoo.org/560096 Signed-off-by: Philipp Ammann <philipp.ammann@posteo.de> Signed-off-by: Matt Turner <mattst88@gentoo.org>
* gnome-base/gnome-shell: arm64 keywordedAaron Bauman2019-08-031-1/+1
| | | | | Signed-off-by: Aaron Bauman <bman@gentoo.org> Package-Manager: Portage-2.3.70, Repoman-2.3.16
* gnome-base/gnome-shell: remove oldMart Raudsepp2019-05-186-468/+0
| | | | | Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* gnome-base/gnome-shell: x86 stable wrt bug #685254Mikle Kolyada2019-05-101-1/+1
| | | | | | Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11 RepoMan-Options: --include-arches="x86"
* gnome-base/gnome-shell: amd64 stable wrt bug #685254Mikle Kolyada2019-05-081-1/+1
| | | | | | Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11 RepoMan-Options: --include-arches="amd64"
* gnome-base/gnome-shell: remove oldMart Raudsepp2019-05-053-249/+0
| | | | | Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* gnome-base/gnome-shell: add a dialog ellipsizing fixMart Raudsepp2019-05-052-0/+189
| | | | | Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* */*: Remove python3_4 PYTHON_COMPAT correctlyMichał Górny2019-04-173-3/+3
| | | | Signed-off-by: Michał Górny <mgorny@gentoo.org>
* gnome-base/gnome-shell: fix crash, EAPI-7, python3.7Mart Raudsepp2019-04-102-0/+189
| | | | | | | | | | | | | | | | | | Refreshed patchset that contains (compared to previous): * a new commit from gnome-3-30 branch, which fixes some issues related to workspace finger gesture on wayland; * backport of a public API safeguard which downgrades a mysterious crasher (that may happen on suspend resume, or just trying to unlock) to an API misuse warning; * includes the bluetooth optionality patch in the patchset. Port to EAPI-7. Add python:3.7 support for the odd installed tools; not fully tested, as they are complicated to use and really only shell developers use them, but we install them for now still. Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* gnome-base/gnome-shell: remove oldMart Raudsepp2019-03-313-254/+0
| | | | | Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* gnome-base/gnome-shell: raise gjs requirementMart Raudsepp2019-03-311-1/+1
| | | | | | | | | | | | 3.30 needs at least gjs-1.49.4 for Object.values() methods, probably more. Just bump the req to 1.54.0, released in the same cycle as gnome-shell-3.30, as there may be other runtime requirements. gnome-shell-3.32 has the req bumped to 1.54.0 already, so nothing to upstream. Closes: https://bugs.gentoo.org/681712 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* gnome-base/gnome-shell: bump to 3.30.2Mart Raudsepp2019-03-183-1/+192
| | | | | Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* gnome-base/gnome-shell: restrict to older gjsMart Raudsepp2019-03-173-2/+5
| | | | | | | | | | | | | | | 3.28 and older crash without upstream commit e36ba874 "Stop using conditional catch statements It is a mozilla extension that is going away in SpiderMonkey 60." It trivially applies to 3.28, after which 3.28 appears to work fine with newer gjs, but we'll be bumping gnome-shell to 3.30 very soon anyways. Plus there seem to be non-crashing issues from using newer gjs with gnome-shell-3.28 (missing labels in GPG/SSH password dialogs for example). Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* gnome-base/gnome-shell: add explicit Cantarell font depMart Raudsepp2019-03-031-1/+3
| | | | | | | | | | | | gnome-shell uses Cantarell as its global font-family CSS setting, so pull it in explicitly. This is also the main font used by GNOME overall for its design looks, etc, and we removed the explicit dep from lower of the stack. Thus it's important to have it somewhere like gnome-shell for that reason as well. Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
* gnome-base/gnome-shell: keyworded 3.28.3 for ppc/ppc64, bug #677176Sergei Trofimovich2019-03-021-1/+1
| | | | | | Package-Manager: Portage-2.3.62, Repoman-2.3.12 RepoMan-Options: --include-arches="ppc ppc64" Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>