summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* kde-frameworks/kdelibs: 4.14.35 bump w/ USE plasma,qt3support; drop cryptAndreas Sturmlechner19 min.6-0/+467
| | | | | | | | | | Add fix for unused HAVE_X86_3DNOW variable. USE=crypt actually only enabled remote plasmoid support in kdelibs. USE=-plasma accidentally also fixes file collision w/ sci-libs/plasma. Migrate from fdo-mime to xdg-utils, relative dosym. Gentoo-bug: 610668 Package-Manager: Portage-2.3.7, Repoman-2.3.3
* kde-frameworks/kdelibs: QT3SUPPORT_REQUIRED="true", SQL_REQUIRED="always"Andreas Sturmlechner19 min.2-0/+4
| | | | | | Prepare for eclass update. Package-Manager: Portage-2.3.7, Repoman-2.3.3
* kde-frameworks/kdelibs: Drop oldAndreas Sturmlechner2017-07-232-292/+0
| | | | Package-Manager: Portage-2.3.6, Repoman-2.3.1
* kde-frameworks/kdelibs: 4.14.34 bump, fix USE=opengl, build w/ cmake-3.9Andreas Sturmlechner2017-07-234-0/+364
| | | | | | | | | Drop obsolete pkg_pretend minimum GCC check. Remove Nepomuk headers, nothing should be using them. Gentoo-bug: 504012, 625506 Package-Manager: Portage-2.3.6, Repoman-2.3.1
* kde-frameworks/kdelibs: keyword ~arm64Alexis Ballier2017-07-171-1/+1
| | | | Package-Manager: Portage-2.3.6, Repoman-2.3.2
* kde-frameworks/kdelibs: Version bump 4.14.33Johannes Huber2017-06-082-0/+292
| | | | Package-Manager: Portage-2.3.6, Repoman-2.3.2
* kde-frameworks/kdelibs: Drop vulnerableAndreas Sturmlechner2017-05-163-334/+0
| | | | | | Gentoo-bug: 618108 Package-Manager: Portage-2.3.5, Repoman-2.3.1
* kde-frameworks/kdelibs: x86 stable wrt bug #618108Agostino Sarubbo2017-05-161-1/+1
| | | | | | Package-Manager: Portage-2.3.5, Repoman-2.3.1 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* kde-frameworks/kdelibs: amd64 stable wrt bug #618108Agostino Sarubbo2017-05-121-1/+1
| | | | | | Package-Manager: Portage-2.3.5, Repoman-2.3.1 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* kde-frameworks/kdelibs: Drop oldAndreas Sturmlechner2017-05-113-323/+0
| | | | Package-Manager: Portage-2.3.5, Repoman-2.3.1
* kde-frameworks/kdelibs: 4.14.32 version bumpAndreas Sturmlechner2017-05-112-0/+292
| | | | | | | Fixes CVE-2017-8422 Gentoo-bug: 618108 Package-Manager: Portage-2.3.5, Repoman-2.3.1
* kde-frameworks/kdelibs: Remove PREFIX setting for CMakeDavid Seifert2017-05-072-2/+2
| | | | | Package-Manager: Portage-2.3.5, Repoman-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/4555
* kde-frameworks/kdelibs: 4.14.31 version bumpAndreas Sturmlechner2017-04-214-3/+326
| | | | | | | Use bump for a little cleanup of dependencies. epatch -> eapply Package-Manager: Portage-2.3.3, Repoman-2.3.1
* kde-frameworks/kdelibs: remove 4.14.28Michael Palimaka2017-03-022-299/+0
| | | | Package-Manager: Portage-2.3.4, Repoman-2.3.2
* kde-frameworks/kdelibs: x86 stable wrt bug #611254Agostino Sarubbo2017-03-021-1/+1
| | | | | | Package-Manager: portage-2.3.3 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* kde-frameworks/kdelibs: amd64 stable wrt bug #611254Agostino Sarubbo2017-03-021-1/+1
| | | | | | Package-Manager: portage-2.3.3 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* kde-frameworks/kdelibs: Remove 4.14.29 (r0)Johannes Huber2017-02-281-298/+0
| | | | Package-Manager: Portage-2.3.3, Repoman-2.3.1
* kde-frameworks/kdelibs: Fix information leakJohannes Huber2017-02-282-0/+333
| | | | | | | | | | Revision bump backports upstream patch to fix a information leak when accessing https when using a malicious PAC file https://www.kde.org/info/security/advisory-20170228-1.txt Gentoo-bug: 611254 Package-Manager: Portage-2.3.3, Repoman-2.3.1
* Drop $Id$ per council decision in bug #611234.Robin H. Johnson2017-02-282-2/+0
| | | | Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
* kde-frameworks/kdelibs: Remove 4.14.24Johannes Huber2017-02-123-325/+0
| | | | Package-Manager: Portage-2.3.3, Repoman-2.3.1
* kde-frameworks/kdelibs: x86 stable wrt bug #608782Agostino Sarubbo2017-02-121-1/+1
| | | | | | Package-Manager: portage-2.3.3 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* kde-frameworks/kdelibs: amd64 stable wrt bug #608782Agostino Sarubbo2017-02-121-1/+1
| | | | | | Package-Manager: portage-2.3.3 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* kde-frameworks/kdelibs: Remove 4.14.27Johannes Huber2017-02-092-300/+0
| | | | Package-Manager: Portage-2.3.3, Repoman-2.3.1
* kde-frameworks/kdelibs: Version bump 4.14.29Johannes Huber2017-02-092-0/+300
| | | | Package-Manager: Portage-2.3.3, Repoman-2.3.1
* kde-frameworks/kdelibs: Version bump 4.14.28Johannes Huber2017-01-122-0/+300
| | | | Package-Manager: Portage-2.3.3, Repoman-2.3.1
* kde-frameworks/kdelibs: Drop CMAKE_MIN_VERSIONJohannes Huber2017-01-012-4/+2
| | | | | | Covered by cmake-utils eclass now. Package-Manager: Portage-2.3.3, Repoman-2.3.1
* kde-base/kdelibs -> kde-frameworks/kdelibsJohannes Huber2016-12-2417-0/+1019