summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* mail-client/neomutt: Remove duplicated global flag descMichał Górny2019-08-111-2/+0
| | | | Signed-off-by: Michał Górny <mgorny@gentoo.org>
* mail-client/neomutt: amd64 stable wrt bug #661436Mikle Kolyada2018-10-071-1/+1
| | | | | Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.11
* mail-client/neomutt: x86 stable (bug #661436)Thomas Deutschmann2018-10-071-2/+2
| | | | | Package-Manager: Portage-2.3.50, Repoman-2.3.11 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
* mail-client/neomutt: Version bump to neomutt-20180716Nicolas Bock2018-07-245-3/+134
| | | | | | Also fix slot warning for libidn Package-Manager: Portage-2.3.40, Repoman-2.3.9
* mail-client/neomutt: x86 stable (bug #658628)Thomas Deutschmann2018-06-261-1/+1
| | | | Package-Manager: Portage-2.3.40, Repoman-2.3.9
* mail-client/neomutt: amd64 stable wrt bug #658628Mikle Kolyada2018-06-231-1/+1
| | | | Package-Manager: Portage-2.3.40, Repoman-2.3.9
* mail-client/neomutt: Version bump neomutt-20180622Nicolas Bock2018-06-222-0/+131
| | | | | Signed-off-by: Nicolas Bock <nicolasbock@gentoo.org> Package-Manager: Portage-2.3.40, Repoman-2.3.9
* mail-client/neomutt: Remove old versionsNicolas Bock2018-06-065-525/+0
| | | | Package-Manager: Portage-2.3.40, Repoman-2.3.9
* mail-client/neomutt: Deprecate old crypt USE flagsNicolas Bock2018-06-061-26/+11
| | | | Package-Manager: Portage-2.3.40, Repoman-2.3.9
* mail-client/neomutt: Fix build with '-doc'Nicolas Bock2018-06-061-4/+9
| | | | | | Closes-Bug: https://bugs.gentoo.org/657282 Closes-Bug: https://bugs.gentoo.org/657384 Package-Manager: Portage-2.3.40, Repoman-2.3.9
* mail-client/neomutt: Fix build with '-doc'Nicolas Bock2018-06-061-4/+9
| | | | Package-Manager: Portage-2.3.40, Repoman-2.3.9
* mail-client/neomutt: Fix live ebuild versionNicolas Bock2018-06-061-1/+1
| | | | Package-Manager: Portage-2.3.40, Repoman-2.3.9
* mail-client/neomutt: Fix webpageNicolas Bock2018-06-041-2/+2
| | | | Package-Manager: Portage-2.3.40, Repoman-2.3.9
* mail-client/neomutt: Version bump to neomutt-20180512Nicolas Bock2018-06-032-0/+141
| | | | Package-Manager: Portage-2.3.40, Repoman-2.3.9
* mail-client/neomutt: Bump live ebuild versionNicolas Bock2018-04-041-0/+0
| | | | | | | | | | | | On unstable systems (or once a regular version of neomutt is made stable) the live ebuild version of '9999' will not be the latest version and a user will not be able to easily install the live ebuild. This change renames it to `99999999`. Thanks to contact@ryper.org for pointing this out! Closes: https://bugs.gentoo.org/650434 Package-Manager: Portage-2.3.24, Repoman-2.3.6
* mail-client/neomutt: Version bump neomutt-20180323Nicolas Bock2018-04-032-0/+141
| | | | | Closes: https://bugs.gentoo.org/651656 Package-Manager: Portage-2.3.24, Repoman-2.3.6
* mail-client/neomutt: remove unused patch.Michael Mair-Keimberger2018-02-271-25/+0
| | | | Closes: https://github.com/gentoo/gentoo/pull/7287
* mail-client/neomutt: Remove old versionsNicolas Bock2018-02-234-337/+0
| | | | Package-Manager: Portage-2.3.19, Repoman-2.3.6
* mail-client/neomutt: Version bump to 2018-02-23Nicolas Bock2018-02-232-0/+141
| | | | Package-Manager: Portage-2.3.19, Repoman-2.3.6
* mail-client/neomutt: Fix berkdb slotsNicolas Bock2018-01-242-1/+148
| | | | | | | | | | | | The generic DEPEND on berkdb can lead to build failures for `berkdb:6.0`. Upstream specifies specific versions [1] and this change translates these versions into a more specific DEPEND. [1] https://github.com/neomutt/neomutt/blob/ae61285/auto.def#L630 Co-Authored-By: Floyd Anderson <bts+gentoo@31c0.net> Closes: https://bugs.gentoo.org/642692 Package-Manager: Portage-2.3.19, Repoman-2.3.6
* mail-client/neomutt: Fix fake man pagesNicolas Bock2018-01-242-11/+143
| | | | | | | | | This change restores and updates the old 'fake manpage' code when neomutt is built without the `doc` USE flag. Co-Authored-By: Floyd Anderson <bts+gentoo@31c0.net> Closes: https://bugs.gentoo.org/645520 Package-Manager: Portage-2.3.19, Repoman-2.3.6
* mail-client/neomutt: remove unused patches.Michael Mair-Keimberger2018-01-082-729/+0
| | | | Closes: https://github.com/gentoo/gentoo/pull/6761
* mail-client/neomutt: remove unused files.Michael Mair-Keimberger2018-01-032-28/+0
| | | | Closes: https://github.com/gentoo/gentoo/pull/6640
* mail-client/neomutt: Remove old versionsNicolas Bock2018-01-033-230/+0
| | | | Package-Manager: Portage-2.3.13, Repoman-2.3.3
* mail-client/neomutt: Build man pages unconditionallyNicolas Bock2017-12-271-14/+1
| | | | | | | Man pages are built without additional dependencies. Closes: https://bugs.gentoo.org/641132 Package-Manager: Portage-2.3.13, Repoman-2.3.3
* mail-client/neomutt: Version bump to neomutt-20171215Nicolas Bock2017-12-152-0/+135
| | | | | | | | | Starting with this release, upstream deprecated the `autotools` build system and replaced it with one based on `autosetup`. This change introduces a build dependency (dev-lang/tcl) and changes a few arguments from `--with` to `--enable`. Package-Manager: Portage-2.3.13, Repoman-2.3.3
* mail-client/neomutt: Update crypto USE flagsNicolas Bock2017-12-141-16/+30
| | | | | | | | | | | | | During the transition period between the old and the new crypto related flags, the neomutt package needs to support both sets. Currently the ebuild emits crypto '--enable' flags twice, with the second flag overriding the first. This can lead to unwanted settings. This change adds some logic around those flags to emit the configure option only once. Related: https://bugs.gentoo.org/640824 Package-Manager: Portage-2.3.13, Repoman-2.3.3
* mail-client/neomutt: Switch build systemNicolas Bock2017-12-131-23/+14
| | | | | | | | | | | | Upstream changed the build system from autotools to autosetup [1]. The new build system requires Tcl at configure time and this change adds this dependency. The configuration option syntax for `--with` flags without arguments has changed to `--enable` flags. This change updates the relevant flags. [1] https://msteveb.github.io/autosetup/ Package-Manager: Portage-2.3.13, Repoman-2.3.3
* mail-client/neomutt: Version bump to neomutt-20121208Nicolas Bock2017-12-092-0/+130
| | | | Package-Manager: Portage-2.3.13, Repoman-2.3.3
* mail-client/neomutt: Updated metadata.xmlNicolas Bock2017-12-031-4/+6
| | | | Package-Manager: Portage-2.3.13, Repoman-2.3.3
* mail-client/neomutt: Workaround Bug 614746Nicolas Bock2017-12-031-2/+1
| | | | | | | | | | | | | Currently a conditional in the ebuild such as if [[ ${PV} =~ 9999$ ]] is not recognized by `ekeyword` [1]. A workaround is to omit the `KEYWORDS` assignment in the live ebuild branch. [1] https://bugs.gentoo.org/614746 Package-Manager: Portage-2.3.13, Repoman-2.3.3
* mail-client/neomutt: Add warning about changed USE flagsNicolas Bock2017-12-031-3/+17
| | | | | | | | | As part of https://bugs.gentoo.org/637176 the crypto related USE flags were renamed. This change adds a warning to the user that this has happened. The old flags are still usable, but their use is deprecated and will be removed at some point. Package-Manager: Portage-2.3.13, Repoman-2.3.3
* mail-client/neomutt: Make ebuild more genericNicolas Bock2017-12-031-7/+12
| | | | | | | This change introduces a check on the package version so that the same ebuild can be used for live and versioned ebuilds. Package-Manager: Portage-2.3.13, Repoman-2.3.3
* mail-client/neomutt: Update crypto USE flagsNicolas Bock2017-12-023-16/+23
| | | | | | | | | Rename the crypto USE flags to make their naming more consistent and clearer to the user. Co-Authored-By: brunoboclair@fake-box.com Closes: https://bugs.gentoo.org/637176 Package-Manager: Portage-2.3.13, Repoman-2.3.3
* mail-client/neomutt: Description of USE flagsNicolas Bock2017-11-201-6/+14
| | | | | | | | The database backend use flags have inconsistent descriptions. They are all used for header caches and the descriptions should say so. Closes: https://bugs.gentoo.org/637264 Package-Manager: Portage-2.3.13, Repoman-2.3.3
* mail-client/neomutt: Remove obsolete USE flagNicolas Bock2017-11-206-12/+6
| | | | | | | | The USE flag 'symlink' is not used by the ebuild. Remove it. Closes: https://bugs.gentoo.org/637174 Package-Manager: Portage-2.3.13, Repoman-2.3.3
* mail-client/neomutt: Version bump to neomutt-20171027Nicolas Bock2017-10-272-0/+113
| | | | Package-Manager: Portage-2.3.8, Repoman-2.3.3
* mail-client/neomutt: Version bump to neomutt-20171013Nicolas Bock2017-10-133-4/+113
| | | | Package-Manager: Portage-2.3.8, Repoman-2.3.3
* mail-client/neomutt: Fix QA issueNicolas Bock2017-10-062-2/+1
| | | | | | The patch for the live ebuild is not needed and can be removed. Package-Manager: Portage-2.3.8, Repoman-2.3.3
* mail-client/neomutt: Update live ebuild patchNicolas Bock2017-10-061-25/+0
| | | | Package-Manager: Portage-2.3.8, Repoman-2.3.3
* mail-client/neomutt: Updated patch for 20171006Nicolas Bock2017-10-061-59/+3
| | | | Package-Manager: Portage-2.3.8, Repoman-2.3.3
* mail-client/neomutt: Update patch file for live ebuildNicolas Bock2017-10-061-60/+4
| | | | Package-Manager: Portage-2.3.8, Repoman-2.3.3
* mail-client/neomutt: Version bump to 20171006Nicolas Bock2017-10-066-2/+197
| | | | Package-Manager: Portage-2.3.8, Repoman-2.3.3
* mail-client/neomutt: Rename smime_keysNicolas Bock2017-10-041-11/+39
| | | | | | | | In order to avoid a file collision with the mutt package, rename the smime_keys helper script to neomutt_smime_keys. Fixes: #633454 Package-Manager: Portage-2.3.8, Repoman-2.3.3
* mail-client/neomutt: Fix indentation of metadataNicolas Bock2017-10-041-10/+10
| | | | Package-Manager: Portage-2.3.8, Repoman-2.3.3
* mail-client/neomutt: Strip empty metadata.xml elementsMichał Górny2017-10-041-2/+0
|
* mail-client/neomutt: Add new packageNicolas Bock2017-10-0310-0/+1178
The neomutt package provides an alternative to the mutt package. It can be installed at the same time as mutt. Package-Manager: Portage-2.3.8, Repoman-2.3.1