summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* mail-client/roundcube: security cleanupSam James6 days1-2/+0
| | | | | | Bug: https://bugs.gentoo.org/726944 Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Sam James <sam@gentoo.org>
* mail-client/roundcube: Bump to 1.4.7Philippe Chaintreuil11 days1-0/+1
| | | | | | | | | | | | - 1.4.7 ebuild is just a copy of 1.4.6's. - Added <stabilize-allarches/> to metadata.xml Bug: https://bugs.gentoo.org/731080 Closes: https://github.com/gentoo/gentoo/pull/16660 Package-Manager: Portage-2.3.99, Repoman-2.3.23 Signed-off-by: Philippe Chaintreuil <gentoo_bugs_peep@parallaxshift.com> Closes: https://github.com/gentoo/gentoo/pull/16660 Signed-off-by: Aaron W. Swenson <titanofold@gentoo.org>
* mail-client/roundcube: CleanupAaron W. Swenson11 days1-7/+0
| | | | | | | | Bug: https://bugs.gentoo.org/720876 Bug: https://bugs.gentoo.org/726944 Closes: https://bugs.gentoo.org/705388 Package-Manager: Portage-2.3.99, Repoman-2.3.23 Signed-off-by: Aaron W. Swenson <titanofold@gentoo.org>
* mail-client/roundcube: 1.4.6 version bumpPhilippe Chaintreuil2020-06-121-0/+1
| | | | | | | | | | Just a copy of 1.4.4. Closes: https://bugs.gentoo.org/727534 Closes: https://github.com/gentoo/gentoo/pull/16119 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Philippe Chaintreuil <gentoo_bugs_peep@parallaxshift.com> Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
* mail-client/roundcube: bump to v1.311Thomas Deutschmann2020-05-111-0/+1
| | | | | | | Bug: https://bugs.gentoo.org/720876 Closes: https://bugs.gentoo.org/720144 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
* mail-client/roundcube: 1.4.4 version bumpPhilippe Chaintreuil2020-05-081-0/+1
| | | | | | | | | Closes: https://bugs.gentoo.org/720142 Closes: https://github.com/gentoo/gentoo/pull/15582 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Philippe Chaintreuil <gentoo_bugs_peep@parallaxshift.com> Closes: https://github.com/gentoo/gentoo/pull/15582 Signed-off-by: Aaron W. Swenson <titanofold@gentoo.org>
* mail-client/roundcube: 1.4.3 version bumpPhilippe Chaintreuil2020-04-201-0/+1
| | | | | | | | | Closes: https://bugs.gentoo.org/710438 Closes: https://github.com/gentoo/gentoo/pull/14734 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Philippe Chaintreuil <gentoo_bugs_peep@parallaxshift.com> Closes: https://github.com/gentoo/gentoo/pull/14734 Signed-off-by: Aaron W. Swenson <titanofold@gentoo.org>
* mail-client/roundcube: 1.4.2 version bumpPhilippe Chaintreuil2020-02-091-0/+1
| | | | | | | | | | - Also bumped copyright date: Happy New Year! Closes: https://bugs.gentoo.org/704690 Closes: https://github.com/gentoo/gentoo/pull/14226 Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Philippe Chaintreuil <gentoo_bugs_peep@parallaxshift.com> Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
* mail-client/roundcube: Bump to 1.4.1Aaron W. Swenson2019-11-241-0/+1
| | | | | Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Aaron W. Swenson <titanofold@gentoo.org>
* mail-client/roundcube: 1.4.0 version bumpPhilippe Chaintreuil2019-11-171-0/+1
| | | | | | | | | | | | | | | | - Embrace upstream's complete-dist, which includes PEAR, etc dependancies as compsoser would have installed them. We just seem like we cannot keep up with the needed dependency ebuilds. - Removes use flags which aren't needed due to complete-dist. - Adds ${MY_PV} which adjusts for gentoo vs upstream formatting of _rc1/_beta/etc. Closes: https://bugs.gentoo.org/666718 Closes: https://github.com/gentoo/gentoo/pull/13662 Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Philippe Chaintreuil <gentoo_bugs_peep@parallaxshift.com> Closes: https://github.com/gentoo/gentoo/pull/13662 Signed-off-by: Aaron W. Swenson <titanofold@gentoo.org>
* mail-client/roundcube: 1.3.10 version bumpPhilippe Chaintreuil2019-10-061-0/+1
| | | | | | | | | | Just a rename of the 1.3.9 ebuild. Closes: https://bugs.gentoo.org/693142 Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Philippe Chaintreuil <gentoo_bugs_peep@parallaxshift.com> Closes: https://github.com/gentoo/gentoo/pull/12822 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
* mail-client/roundcube: 1.3.9 version bumpPhilippe Chaintreuil2019-04-041-0/+1
| | | | | | | | | Closes: https://bugs.gentoo.org/682374 Closes: 11573 Signed-off-by: Philippe Chaintreuil <gentoo_bugs_peep@parallaxshift.com> Package-Manager: Portage-2.3.62, Repoman-2.3.11 Closes: https://github.com/gentoo/gentoo/pull/11573 Signed-off-by: Aaron Bauman <bman@gentoo.org>
* mail-client/roundcube: Remove old, insecureAaron W. Swenson2018-11-261-2/+0
| | | | | | Bug: https://bugs.gentoo.org/669696 Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Aaron W. Swenson <titanofold@gentoo.org>
* mail-client/roundcube: Security Bump to 1.3.8Aaron W. Swenson2018-11-041-0/+1
| | | | | | | | | | | Resolves a XSS vulnerability. Additionally, contains updates to ensure compatibility with PHP 7.3 and recent versions of Courier-IMAP, Dovecot and MySQL 8. Bug: https://bugs.gentoo.org/669696 Package-Manager: Portage-2.3.49, Repoman-2.3.11 Signed-off-by: Aaron Swenson <titanofold@gentoo.org>
* mail-client/roundcube: Bump to 1.3.7Aaron W. Swenson2018-08-061-0/+1
| | | | | | | | | | | | | | | | | | | | | | | | Bump to 1.3.7 which addresses EFAIL (https://github.com/roundcube/roundcubemail/issues/6289). (Bug 662716) Add an elog statement that gives the location of the post-upgrade instructions in case the Roundcube update gets buried among many others. (Bug 462250) Make dev-php/PEAR-Net_Socket an optional module, and remove redundant dependencies. (Bug 650792) Remove references to PEAR modules. (Bug 650910) Update POST-INSTALL as step 7 is no longer required since we’re using the complete tarball. (Bug 650912) Bug: https://bugs.gentoo.org/462250 Bug: https://bugs.gentoo.org/650792 Bug: https://bugs.gentoo.org/650910 Bug: https://bugs.gentoo.org/650912 Closes: https://bugs.gentoo.org/662716 Package-Manager: Portage-2.3.40, Repoman-2.3.9
* mail-client/roundcube: Cleanup <1.3.6Aaron W. Swenson2018-05-021-3/+0
| | | | | | | Cleanup insecure versions. Bug: https://bugs.gentoo.org/653044 Package-Manager: Portage-2.3.24, Repoman-2.3.6
* mail-client/roundcube: Bump to 1.3.6Aaron W. Swenson2018-04-271-0/+1
| | | | | | | | | | Fixes a security issue related to IMAP command injection. Fixes a XSS concern. Bug: https://bugs.gentoo.org/651124 Bug: https://bugs.gentoo.org/653044 Package-Manager: Portage-2.3.24, Repoman-2.3.6
* mail-client/roundcube: Clean old and insecureAaron W. Swenson2018-01-231-4/+0
| | | | Package-Manager: Portage-2.3.19, Repoman-2.3.6
* mail-client/roundcube: Bump to 1.3.4Aaron W. Swenson2018-01-231-0/+1
| | | | | | | | | Now removes bundled PEAR libs/modules/whatever they’re called, and depends on the related ebuilds. Closes: https://bugs.gentoo.org/644896 Closes: https://bugs.gentoo.org/645374 Package-Manager: Portage-2.3.19, Repoman-2.3.6
* mail-client/roundcube: Don't depend on dev-lang/php[crypt]Craig Andrews2017-12-071-5/+5
| | | | | | | The crypt use flag was removed in dev-lang/php-7.2 and roundcube doesn't use it Closes: https://bugs.gentoo.org/639394 Package-Manager: Portage-2.3.16, Repoman-2.3.6
* mail-client/roundcube: stable 1.2.7 on amd64Aaron W. Swenson2017-12-041-1/+1
| | | | | Bug: https://bugs.gentoo.org/636970 Package-Manager: Portage-2.3.13, Repoman-2.3.3
* mail-client/roundcube: Security Bump (Bug 636970)Aaron W. Swenson2017-11-091-0/+2
| | | | | | | | | | | | | Security-related version bump to: * 1.3.3 * 1.2.7 CVE-2017-16651 (http://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-16651): Roundcube Webmail before 1.2.x before 1.2.7, and 1.3.x before 1.3.3 allows unauthorized access to arbitrary files on the host's filesystem. Gentoo-Bug: https://bugs.gentoo.org/636970 Package-Manager: Portage-2.3.8, Repoman-2.3.3
* mail-client/roundcube: version bumps to 1.2.6 and 1.3.1Tim Harder2017-10-181-0/+2
| | | | | Closes: https://bugs.gentoo.org/630144 Closes: https://bugs.gentoo.org/630504
* mail-client/roundcube: New 1.3.0 ebuildPhilippe Chaintreuil2017-07-071-0/+1
| | | | | | | | | | | | | - Increase deps versions - Add warnings about needing to run ./bin/install-jsdeps.sh post install or upgrade to pkg_postinstall and POST-UPGRADE.txt - Mask all arches - Add :TODO: note about missing qrcode ebuild dep Package-Manager: Portage-2.3.6, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/5031 Signed-off-by: Aaron W. Swenson <titanofold@gentoo.org>
* mail-client/roundcube: Remove Insecure 1.2.4Aaron W. Swenson2017-06-191-1/+0
| | | | | | Bug: 618322 Package-Manager: Portage-2.3.5, Repoman-2.3.1
* mail-client/roundcube: Security bump to v1.2.5 (bug #618322)Thomas Deutschmann2017-06-041-0/+1
| | | | Package-Manager: Portage-2.3.5, Repoman-2.3.2
* mail-client/roundcube: Removing insecure versionAaron W. Swenson2017-04-181-1/+0
| | | | Package-Manager: portage-2.3.0
* mail-client/roundcube: Bump to v1.2.4Thomas Deutschmann2017-03-181-0/+1
| | | | | | Gentoo-Bug: https://bugs.gentoo.org/612662 Gentoo-Bug: https://bugs.gentoo.org/612796 Package-Manager: Portage-2.3.3, Repoman-2.3.1
* mail-client/roundcube: Removing Insecure VersionsAaron W. Swenson2016-12-231-3/+0
| | | | | | Bug: 601410 Package-Manager: portage-2.3.0
* mail-client/roundcube: Bump to v1.2.3 (bug #601410)Thomas Deutschmann2016-12-131-0/+1
| | | | | | Gentoo-Bug: https://bugs.gentoo.org/601410 Package-Manager: portage-2.3.2
* mail-client/roundcube: Version Bump to 1.2.2Aaron W. Swenson2016-10-301-0/+1
| | | | | | | | | | Version bump fixes bug 596100. Thanks Philippe Chaintreuil and Mattias Merilai. Bug: 596100 Package-Manager: portage-2.2.28
* mail-client/roundcube: Drop OldAaron W. Swenson2016-09-221-2/+0
| | | | | | Cleaning out old versions. Package-Manager: portage-2.2.28
* mail-client/roundcube: Version BumpAaron W. Swenson2016-09-221-0/+1
| | | | | | | | | | | | | | Version bump fixes bug 590608. RDEPEND updated for dev-php/PEAR-Crypt_GPG-1.4.0 fixing bug 584728. Keywords dropped for ~hppa, ~ppc, ~ppc64, and ~sparc due to requirement on >=dev-php/PEAR-Crypt_GPG-1.4.0. (Related bugs: 574264, 594824) Bugs: 584728, 590608 Package-Manager: portage-2.2.28
* mail-client/roundcube: Fix Multiple VulnerabilitiesAaron W. Swenson2016-05-291-0/+1
| | | | | | | | | | | | | | | | | Many security issues/enhancements are resolved with this release. The most significant being: * Fix (again) security issue in DBMail driver of password plugin (CVE-2015-2181) * Fix path traversal vulnerability in setting a skin (CVE-2015-8770) * Fix XSS issue in SVG images handling * Fix XSS issue in href attribute on area tag You can find the complete list of changes in the included CHANGELOG or at: https://github.com/roundcube/roundcubemail/wiki/Changelog Bug: 580746, 584200, 584098 Package-Manager: portage-2.2.26
* mail-client/roundcube: Version BumpAaron W. Swenson2016-02-131-0/+1
| | | | | | | | | | | First version that can run under PHP7. Revised POST-UPGRADE text to include a couple additional steps that may be necessary. Bug: 574136 Package-Manager: portage-2.2.26
* mail-client/roundcube: Remove Insecure VersionsAaron W. Swenson2016-01-211-3/+0
| | | | | | | | Removed insecure versions 1.0.5, 1.0.6, and 1.1.3. Bug: 554866, 564476, 570336 Package-Manager: portage-2.2.26
* mail-client/roundcube: Version BumpAaron W. Swenson2016-01-141-0/+1
| | | | | | | | Version bump fixes bug 570834 and addresses multiple security bugs. Bug: 570834,564476,570336 Package-Manager: portage-2.2.20.1
* mail-client/roundcube: Version bump, security, and bug fixesAaron W. Swenson2015-12-091-0/+1
| | | | | | | | | | | | | | | | | | | | Added two use flags controlling optional dependencies to support the enigma and and sieverules plugins. Added REQUIRED_USE as one of postgres, mysql, or sqlite must be enabled. Rouncube requires a database to operate. As the ebuild uses this now, removed the default enable on the mysql USE flag. Added POST-UPGRADE.txt which is just a shortened version of the UPGRADE text from upstream. Dropped arm and ppc64 keywords as one dependency, dev-php/PEAR-Net_LDAP2, currently lacks matching keywords for those architectures. Bug: 541172, 545096, 524192, 564476, 565204, 53284 Package-Manager: portage-2.2.20.1
* mail-client/roundcube: security bump to 1.0.6 (bug #554866)Tim Harder2015-08-251-0/+1
|
* proj/gentoo: Initial commitRobin H. Johnson2015-08-081-0/+1
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed