summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* media-libs/mlt: fix build for muslAlfred Persson Forsberg26 hours2-0/+38
| | | | | | | | | | | | | | | | | | | | There is no gurantee that either HAVE_STRTOD_L or HAVE_LOCALE_H will be defined at compile-time. Try for example building this project :) The locale usage is now defined in POSIX and therefore we can now assume it will be available on Linux, except for ancient systems. https://pubs.opengroup.org/onlinepubs/9699919799/basedefs/locale.h.html Another way of dealing with this would be to have a global mlt_config.h where HAVE_LOCALE_H and HAVE_STRTOD_L are defined to values determined when mlt is installed. See-also: https://git.alpinelinux.org/aports/tree/community/mlt/musl-locale.patch, https://github.com/mltframework/mlt/pull/803 Closes: https://bugs.gentoo.org/829608 Signed-off-by: Alfred Persson Forsberg <cat@catcream.org> Closes: https://github.com/gentoo/gentoo/pull/26083 Signed-off-by: Sam James <sam@gentoo.org>
* media-libs/mlt: add 7.8.0Sam James5 days2-0/+159
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* media-libs/mlt: add 7.6.0Sam James2022-04-293-0/+177
| | | | | Closes: https://bugs.gentoo.org/841512 Signed-off-by: Sam James <sam@gentoo.org>
* media-libs/mlt: Keyword 7.4.0 riscv, #837059Yixun Lan2022-04-101-1/+1
| | | | Signed-off-by: Yixun Lan <dlan@gentoo.org>
* media-libs/mlt: Drop 7.2.0-r1Andreas Sturmlechner2022-01-212-157/+0
| | | | | Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* media-libs/mlt: Stabilize 7.4.0 arm64, #831590Sam James2022-01-211-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* media-libs/mlt: Stabilize 7.4.0 amd64, #831590Jakov Smolić2022-01-201-1/+1
| | | | Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
* media-libs/mlt: Stabilize 7.4.0 x86, #831590Jakov Smolić2022-01-201-1/+1
| | | | Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
* media-libs/mlt: remove implicit kernel_linuxDavid Seifert2022-01-042-4/+4
| | | | Signed-off-by: David Seifert <soap@gentoo.org>
* media-libs/mlt: 7.4.0 version bumpAndreas Sturmlechner2021-12-202-0/+157
| | | | | Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* media-libs/mlt: unconditionally enable FFTW (PLUS)Sam James2021-12-021-5/+4
| | | | | | Closes: https://bugs.gentoo.org/603168 Closes: https://bugs.gentoo.org/796557 Signed-off-by: Sam James <sam@gentoo.org>
* media-libs/mlt: Drop 6.26.1-r1Andreas Sturmlechner2021-11-294-285/+0
| | | | | Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* media-libs/mlt: Stabilize 7.2.0 x86, #822177Sam James2021-11-291-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* media-libs/mlt: Stabilize 7.2.0 amd64, #822177Sam James2021-11-281-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* media-libs/mlt: Stabilize 7.2.0 arm64, #822177Sam James2021-11-281-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* media-libs/mlt: Drop 7.0.1-r2Andreas Sturmlechner2021-11-262-158/+0
| | | | | Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* media-libs/mlt: min java 1.8:*Volkmar W. Pogatzki2021-11-063-4/+4
| | | | | | | | | https://archives.gentoo.org/gentoo-dev/message/71ec6a505f3245496d343c506ad21717 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/22846 Signed-off-by: Sam James <sam@gentoo.org>
* media-libs/mlt: fix UnusedInheritsSam James2021-11-041-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* media-libs/mlt: add 7.2.0Sam James2021-11-042-0/+158
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* **/metadata.xml: Replace http by https in DOCTYPE elementUlrich Müller2021-09-111-1/+1
| | | | | Bug: https://bugs.gentoo.org/552720 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* media-libs/mlt: Drop 7.0.1-r1Andreas Sturmlechner2021-08-311-154/+0
| | | | | Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* media-libs/mlt: Add missing IUSE=movit dep on media-libs/libglvndAndreas Sturmlechner2021-08-311-0/+157
| | | | | Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* media-libs/mlt: Require media-libs/opencv[contrib]Andreas Sturmlechner2021-08-151-9/+9
| | | | | | | Reported-by: Michelangelo Scopelliti <kernelpanic@gmx.com> Closes: https://bugs.gentoo.org/808180 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* media-libs/mlt: drop obsolete SWIG comments/referencesSam James2021-08-131-22/+8
| | | | | | | | We're only building the Python bindings now, so no need to be so general. Bug: https://bugs.gentoo.org/807903 Signed-off-by: Sam James <sam@gentoo.org>
* media-libs/mlt: drop Lua bindings in 7.xSam James2021-08-131-44/+7
| | | | | | | | | | | | After spending far too long messing around with the Lua bindings, I realised I should really check whether anything in the tree actually needs them. It seems no such consumer exists. Dropping the bindings rather than complicating the ebuild for an apparently unneeded feature in our case. Closes: https://bugs.gentoo.org/807903 Signed-off-by: Sam James <sam@gentoo.org>
* media-libs/mlt: fix build for USE=pythonFelix Neumärker2021-08-051-7/+3
| | | | | | | | | Closes: https://bugs.gentoo.org/806484 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Felix Neumärker <xdch47@posteo.de> Closes: https://github.com/gentoo/gentoo/pull/21889 Signed-off-by: Sam James <sam@gentoo.org>
* media-libs/mlt: add 7.0.1Sam James2021-08-053-0/+224
| | | | | Closes: https://bugs.gentoo.org/796557 Signed-off-by: Sam James <sam@gentoo.org>
* media-libs/mlt: Drop 6.24.0-r1Andreas Sturmlechner2021-06-102-232/+0
| | | | | Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* media-libs/mlt: Stabilize 6.26.1-r1 arm64, #791454Sam James2021-06-041-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* media-libs/mlt: Stabilize 6.26.1-r1 x86, #791454Sam James2021-06-031-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* media-libs/mlt: Stabilize 6.26.1-r1 amd64, #791454Sam James2021-06-031-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* media-libs/mlt: Drop 6.26.1 (r0)Andreas Sturmlechner2021-04-241-231/+0
| | | | | Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* media-libs/mlt: Fix ogg crash, set min media-libs/opencv to 4.5.1Andreas Sturmlechner2021-04-242-0/+282
| | | | | | Closes: https://bugs.gentoo.org/783030 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* media-libs/mlt: Drop 6.26.0Andreas Sturmlechner2021-04-172-232/+0
| | | | | Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* media-libs/mlt: 6.26.1 version bumpAndreas Sturmlechner2021-04-172-0/+232
| | | | | Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* media-libs/mlt: 6.26.0 version bumpAndreas Sturmlechner2021-04-112-0/+232
| | | | | | Bug: https://bugs.gentoo.org/761975 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* media-libs/mlt: Drop 6.22.1-r1Andreas Sturmlechner2021-01-274-227/+0
| | | | | Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* media-libs/mlt: Stabilize 6.24.0-r1 arm64, #766528Sam James2021-01-231-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* media-libs/mlt: Restrict IUSE=opencv to <media-libs/opencv-4.5.1Andreas Sturmlechner2021-01-231-1/+1
| | | | | | Closes: https://bugs.gentoo.org/761975 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* media-libs/mlt: Stabilize 6.24.0-r1 x86, #766528Sam James2021-01-231-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* media-libs/mlt: Stabilize 6.24.0-r1 amd64, #766528Sam James2021-01-231-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* media-libs/mlt: Drop 6.22.1-r100 and 6.24.0Andreas Sturmlechner2021-01-032-468/+0
| | | | | Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* media-libs/mlt: Drop IUSE="kdenlive,melt" and enable unconditionallyAndreas Sturmlechner2021-01-031-9/+5
| | | | | | | No extra dependencies. Also drop python3_6. Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* media-libs/mlt: Fix media-libs/rubberband automagic w/ IUSE=rubberbandAndreas Sturmlechner2021-01-032-2/+239
| | | | | | | Reported-by: Marc Schiffbauer <mschiff@gentoo.org> Closes: https://bugs.gentoo.org/763222 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* media-libs/mlt: 6.24.0 version bumpAndreas Sturmlechner2020-12-282-0/+234
| | | | | | Bug: https://bugs.gentoo.org/761975 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* media-libs/mlt: migrate to lua.eclassMarek Szuba2020-12-222-0/+246
| | | | | | | | | Multi-impl. Uses a custom build system for all language bindings but fortunately one that has been simple enough to adapt. Builds fine against all Lua implementations currently in the tree. Closes: https://bugs.gentoo.org/752753 Signed-off-by: Marek Szuba <marecki@gentoo.org>
* */*: limit pkgs not migrated to lua eclasses to dev-lang/lua:0Marek Szuba2020-12-151-1/+1
| | | | | | | | | | | Only ebuilds which previously were happy with any slot (those which explicitly specify one of the 5.x slots are allowed to keep doing so until they have been migrated to the eclasses) and which do not require a version of Lua higher than 5.1 (to prevent CI from complaining about non-existent dependencies; all of these should have been masked or USE-masked by now anyway). Signed-off-by: Marek Szuba <marecki@gentoo.org>
* media-libs/mlt: Drop 6.20.0-r2Andreas Sturmlechner2020-11-0210-883/+0
| | | | | | Bug: https://bugs.gentoo.org/749810 Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* media-libs/mlt: Stabilize 6.22.1-r1 amd64, #749810Sam James2020-11-021-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* media-libs/mlt: Stabilize 6.22.1-r1 arm64, #749810Sam James2020-10-191-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>