summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* */*: fix NonexistentDeps post ffmpeg cleanupJohn Helmert III12 days2-12/+2
| | | | | | Signed-off-by: John Helmert III <jchelmert3@posteo.net> Closes: https://github.com/gentoo/gentoo/pull/16793 Signed-off-by: Sam James <sam@gentoo.org>
* media-video/obs-studio: sync live ebuild keywordsGeorgy Yakovlev2020-05-191-1/+1
| | | | | Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
* media-video/obs-studio: add ~ppc64 keywordGeorgy Yakovlev2020-05-191-1/+1
| | | | | Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
* media-video/obs-studio: install additional headerRick Farina2020-05-142-0/+14
| | | | | | | needed for media-video/obs-v4l2sink Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
* media-video/obs-studio: remove version 24.0.5Jimi Huotari2020-05-102-133/+0
| | | | | | | Closes: https://bugs.gentoo.org/708628 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* media-video/obs-studio: fix build with GCC-10Jimi Huotari2020-05-102-0/+32
| | | | | | | | Bug: https://bugs.gentoo.org/708628 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/15736 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* media-video/obs-studio: tiny bumpRick Farina2020-05-042-1/+1
| | | | | Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
* media-video/obs-studio: remove version 25.0.3Jimi Huotari2020-05-022-146/+0
| | | | | | Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* media-video/obs-studio: add version 25.0.7Jimi Huotari2020-05-022-0/+146
| | | | | | | | Closes: https://bugs.gentoo.org/718958 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/15488 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* media-video/obs-studio: remove versions 24.0.3 and 25.0.1Jimi Huotari2020-04-033-279/+0
| | | | | | Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* media-video/obs-studio: add version 25.0.3Jimi Huotari2020-04-032-0/+146
| | | | | | | | | Closes: https://bugs.gentoo.org/715736 Closes: https://bugs.gentoo.org/716048 Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/15219 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* media-video/obs-studio: bumpRick Farina2020-03-242-1/+1
| | | | | Package-Manager: Portage-2.3.95, Repoman-2.3.21 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
* media-video/obs-studio: mostly simple bumpRick Farina2020-03-193-0/+160
| | | | | | | | add a few directly linked things to DEPEND minor harmonization to keep release and live ebuilds the same Package-Manager: Portage-2.3.94, Repoman-2.3.21 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
* media-video/obs-studio: add slot operator dep on mbedtlsBen Kohler2020-02-263-3/+3
| | | | | | Closes: https://bugs.gentoo.org/705042 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
* */*: Clean PYTHON_COMPAT of obsolete implsMichał Górny2020-01-053-6/+6
| | | | | Closes: https://github.com/gentoo/gentoo/pull/14246 Signed-off-by: Michał Górny <mgorny@gentoo.org>
* media-video/obs-studio: remove unused patch(es)Michael Mair-Keimberger2019-12-271-50/+0
| | | | | | Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/14139 Signed-off-by: Aaron Bauman <bman@gentoo.org>
* media-video/obs-studio: remove version 23.2.1Jimi Huotari2019-12-262-133/+0
| | | | | | Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* media-video/obs-studio: add version 24.0.5Jimi Huotari2019-12-262-0/+133
| | | | | | | Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/13991 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* media-video/obs-studio: add version 24.0.3Jimi Huotari2019-11-032-0/+133
| | | | | | Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* media-video/obs-studio: remove 'dev-qt/qttest' dependencyJimi Huotari2019-11-031-1/+0
| | | | | | | | This doesn't seem to be actually needed/used for anything here. Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* media-video/obs-studio: add USE="ssl vlc"Jimi Huotari2019-11-032-4/+10
| | | | | | | | | | | | | When enabled, 'ssl' will allow for secure connections to servers supporting RTMPS via 'net-libs/mbedtls' (previously automagic). When enabled, 'vlc' will allow for 'media-video/vlc' to be used as a media source in OBS Studio (previously automagic). Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/12969 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* media-video/obs-studio: remove older versionsJimi Huotari2019-06-223-261/+0
| | | | | | Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* media-video/obs-studio: version bump to 23.2.1Jimi Huotari2019-06-223-0/+183
| | | | | | | | | | | | | Comes with a patch to correct the 'libdir' for 'libobs.pc'. Upstream PR: https://github.com/obsproject/obs-studio/pull/1932 Bug: https://bugs.gentoo.org/644538 Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/12246 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* media-video/obs-studio: drop 23.1.0 (r0)Jimi Huotari2019-05-091-129/+0
| | | | | | Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* media-video/obs-studio: add missing 'dev-qt/qtsvg' dependencyJimi Huotari2019-05-092-0/+131
| | | | | | | | | | | | | | Upstream started depending on this in '80875768'. - https://github.com/obsproject/obs-studio/commit/80875768 Closes: https://bugs.gentoo.org/684906 Closes: https://github.com/gentoo/gentoo/pull/11652 Suggested-by: Jiří Helebrant <jiri.helebrant@nic.cz> Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/11886 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* media-video/obs-studio: version bump to 23.1.0Jimi Huotari2019-04-062-0/+130
| | | | | | | Closes: https://bugs.gentoo.org/681100 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* media-video/obs-studio: drop python3_4Jimi Huotari2019-04-062-2/+2
| | | | | | Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* media-video/obs-studio: switch from 'gnome2-utils' to 'xdg-utils'Jimi Huotari2019-04-062-6/+6
| | | | | | | Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/11313 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* media-video/obs-studio: remove old version and unused patches.Jimi Huotari2019-02-284-354/+0
| | | | | | Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
* media-video/obs-studio: version bump to 23.0.1.Jimi Huotari2019-02-282-0/+130
| | | | | | Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
* media-video/obs-studio: bump to EAPI="7".Jimi Huotari2019-02-281-8/+8
| | | | | | | Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/11160 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
* media-video/obs-studio: fix build with USE="fdk"Jimi Huotari2018-12-162-1/+56
| | | | | | | | | Upstream: https://github.com/obsproject/obs-studio/commit/cf73fa6d Closes: https://bugs.gentoo.org/672430 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* media-video/obs-studio: clean up older version and a patch with itJimi Huotari2018-12-163-163/+0
| | | | | | | Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Package-Manager: Portage-2.3.52, Repoman-2.3.12 Closes: https://github.com/gentoo/gentoo/pull/10621 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* media-video/obs-studio: add python3_7Jonathan Callen2018-12-022-2/+2
| | | | | Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Jonathan Callen <jcallen@gentoo.org>
* media-video/obs-studio: Support ffmpeg 4Craig Andrews2018-11-133-3/+18
| | | | | | | | | The USE="nvenc" in '>=media-video/ffmpeg-4' has been replaced with 'video_cards_nvidia'. Closes: https://bugs.gentoo.org/671084 Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Craig Andrews <candrews@gentoo.org>
* media-video/obs-studio: fix building without Python targetsJimi Huotari2018-10-093-3/+15
| | | | | | | | | | | | Only call 'python-single-r1_pkg_setup' if USE="python" is set, since without supported Python targets, things will go bad even if USE="-python" is being used. Closes: https://bugs.gentoo.org/667896 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Package-Manager: Portage-2.3.50, Repoman-2.3.11 Closes: https://github.com/gentoo/gentoo/pull/10109 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* media-video/obs-studio: remove upstreamed patch from 9999Jimi Huotari2018-10-041-2/+0
| | | | | | | Closes: https://bugs.gentoo.org/665766 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.10 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* media-video/obs-studio: remove older versionJimi Huotari2018-10-042-112/+0
| | | | | | Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Package-Manager: Portage-2.3.48, Repoman-2.3.10 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* media-video/obs-studio: version bump to 22.0.3Jimi Huotari2018-10-042-0/+123
| | | | | | Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Package-Manager: Portage-2.3.48, Repoman-2.3.10 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* media-video/obs-studio: rename USE="speexdsp" to "speex"Jimi Huotari2018-10-043-7/+7
| | | | | | | | The use of the flag is similar enough to the existing one. Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.10 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* media-video/obs-studio: remove no longer needed 'CMAKE_MIN_VERSION'Jimi Huotari2018-10-042-2/+0
| | | | | | Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.10 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* media-video/obs-studio: switch to python-single-r1 eclassJimi Huotari2018-10-042-2/+4
| | | | | | | | | | | Previously, the fact that 'python-any-r1.eclass' is intended for build-time dependent packages only was completely missed, while Python is required at run-time when used for OBS Studio scripting. Closes: https://bugs.gentoo.org/662702 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Package-Manager: Portage-2.3.48, Repoman-2.3.10 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* media-video/obs-studio: adjust USE="nvenc" on 21.1.2Jimi Huotari2018-10-041-1/+1
| | | | | | | | | | | Since FFmpeg 4 is still masked, depending on a USE-flag specific to that version is a QA violation, so for now only the 9999 version will be compatible with it. Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Package-Manager: Portage-2.3.48, Repoman-2.3.10 Closes: https://github.com/gentoo/gentoo/pull/9689 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* media-video/obs-studio: remove older versionsJimi Huotari2018-07-133-226/+0
| | | | Package-Manager: Portage-2.3.41, Repoman-2.3.9
* media-video/obs-studio: version bump to 21.1.2Jimi Huotari2018-07-132-0/+126
| | | | Package-Manager: Portage-2.3.41, Repoman-2.3.9
* media-video/obs-studio: support FFmpeg 4Jimi Huotari2018-07-131-1/+1
| | | | | | | The USE="nvenc" in '>=media-video/ffmpeg-4' has been replaced with 'video_cards_nvidia'. Package-Manager: Portage-2.3.42, Repoman-2.3.9
* media-video/obs-studio: update source URIsJimi Huotari2018-07-133-5/+5
| | | | Package-Manager: Portage-2.3.41, Repoman-2.3.9
* media-video/obs-studio: fix build with Qt 5.11Jimi Huotari2018-07-132-0/+30
| | | | | | | Upstream commit: https://github.com/obsproject/obs-studio/commit/4fd06b98 Closes: https://bugs.gentoo.org/660350 Package-Manager: Portage-2.3.41, Repoman-2.3.9
* media-video/obs-studio: add USE="speexdsp"Jimi Huotari2018-07-132-9/+5
| | | | | | | This can be used to enable/disable support for the SpeexDSP-based Noise Suppression filter Package-Manager: Portage-2.3.41, Repoman-2.3.9
* media-video/obs-studio: add support for scriptingJimi Huotari2018-07-133-4/+193
| | | | | | | | | | | Scripting support for Lua and Python 3 is enabled by automagic, if the required libraries are found. This commit adds USE-flags and a patch that give the user control on whether or not to do so. Closes: https://bugs.gentoo.org/656956 Package-Manager: Portage-2.3.41, Repoman-2.3.9 Closes: https://github.com/gentoo/gentoo/pull/9151 Closes: https://bugs.gentoo.org/656956