summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* net-analyzer/nrpe: new revision adding the command-args flag back.Michael Orlitzky2017-08-241-1/+10
| | | | | | | | | After some discussion on the mailing list, I've decided to add back the "command-args" USE flag, but to mask it in package.use.mask. Gentoo-Bug: 628596 Package-Manager: Portage-2.3.6, Repoman-2.3.1
* net-analyzer/nrpe: new revision to fix the systemd service.Michael Orlitzky2017-07-161-1/+1
| | | | | | | | | | | The systemd unit file we were shipping no longer works with nrpe-3.x. Fortunately, upstream has their own service file which will work for us. We now use upstream's copy instead. Thanks to Nemunaire for the report, fix, and testing. Gentoo-Bug: 620020 Package-Manager: Portage-2.3.6, Repoman-2.3.1
* net-analyzer/nrpe: bump to 3.2.0, drop oldTomas Mozes2017-07-153-2/+2
| | | | | | Package-Manager: Portage-2.3.6, Repoman-2.3.2 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
* net-analyzer/nrpe: bump to 3.1.1, drop oldTomas Mozes2017-06-073-1/+1
| | | | | | Package-Manager: Portage-2.3.6, Repoman-2.3.2 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
* net-analyzer/nrpe: Fix broken SRC_URI for 3.0.1Tobias Klausmann2017-05-151-1/+1
| | | | Package-Manager: Portage-2.3.5, Repoman-2.3.2
* net-analyzer/nrpe: new version 3.1.0.Michael Orlitzky2017-05-123-0/+81
| | | | | | | | | | | | | | | | | | | | | | | | | | | | This new ebuild is missing a lot of the custom patching of the 2.x series, ultimately because I just don't have time to forward-port a bunch of patches. Here's a quick summary of the changes: * Command arguments are unconditionally disabled, because they're a security risk. This flag would be easy to bring back, but it should be masked if we do. * The daemon and tcp wrappers are no longer optional. While I admit that having them be optional is useful, a giant patch to the build system is not the way to go about it. Send that mess upstream! * The nrpe_check_control tool is not installed. This is "contrib" upstream, and doesn't use the correct paths from the build system. Needs to be fixed upstream. Thanks to Tomáš Mózes for the heads-up about the new version, and for testing the ebuild and init script. It looks like our nrpe-2.x and nrpe-3.x have some incompatibilities, possibly due to our patches against the 2.x series. I've added an elog recommending that users not mix major versions on the client/server. Gentoo-Bug: 616092 Package-Manager: Portage-2.3.3, Repoman-2.3.1
* net-analyzer/nrpe: remove unused version 2.15-r2.Michael Orlitzky2017-05-011-128/+0
| | | | Package-Manager: Portage-2.3.3, Repoman-2.3.1
* net-analyzer/nrpe: ppc64 stable wrt bug #608596Agostino Sarubbo2017-04-301-1/+1
| | | | | | Package-Manager: Portage-2.3.3, Repoman-2.3.1 RepoMan-Options: --include-arches="ppc64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* net-analyzer/nrpe: ppc stable wrt bug #608596Agostino Sarubbo2017-04-291-1/+1
| | | | | | Package-Manager: Portage-2.3.3, Repoman-2.3.1 RepoMan-Options: --include-arches="ppc" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* net-analyzer/nrpe: sparc stable wrt bug #608596Agostino Sarubbo2017-04-271-1/+1
| | | | | | Package-Manager: Portage-2.3.3, Repoman-2.3.1 RepoMan-Options: --include-arches="sparc" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* net-analyzer/nrpe: x86 stable wrt bug #608596Agostino Sarubbo2017-04-271-1/+1
| | | | | | Package-Manager: Portage-2.3.3, Repoman-2.3.1 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* net-analyzer/nrpe: Stable for HPPA (bug #608596).Jeroen Roovers2017-04-251-1/+1
| | | | | Package-Manager: Portage-2.3.5, Repoman-2.3.2 RepoMan-Options: --ignore-arches
* net-analyzer/nrpe-2.15-r3: add alpha keywordTobias Klausmann2017-04-241-1/+1
| | | | Gentoo-Bug: 608596
* net-analyzer/nrpe: amd64 stable wrt bug #608596Agostino Sarubbo2017-04-231-2/+2
| | | | | | Package-Manager: Portage-2.3.3, Repoman-2.3.1 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* Drop remaining $Id$ and $Header$ from files.Ulrich Müller2017-02-281-1/+0
| | | | Bug: 611234
* Drop $Id$ per council decision in bug #611234.Robin H. Johnson2017-02-282-2/+0
| | | | Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
* net-analyzer/nrpe: use #!/sbin/openrc-run instead of #!/sbin/runscriptAustin English2016-05-181-1/+1
|
* Set appropriate maintainer types in metadata.xml (GLEP 67)Michał Górny2016-01-241-1/+1
|
* Replace all herds with appropriate projects (GLEP 67)Michał Górny2016-01-241-1/+4
| | | | | Replace all uses of herd with appropriate project maintainers, or no maintainers in case of herds requested to be disbanded.
* net-analyzer/nrpe: revbump to add selinux and no-ssl support.Michael Orlitzky2015-08-312-0/+176
| | | | | | | | | | | Add a conditional dep on sec-policy/selinux-nagios, and pull in an (unreleased) upstream patch to fix the build when USE="-ssl". Also add a slot on the openssl dependency to make repoman happy. Bug: 462572 Bug: 554536 Package-Manager: portage-2.2.20.1
* net-analyzer/nrpe: remove old ebuilds and patches.Michael Orlitzky2015-08-316-576/+0
| | | | Package-Manager: portage-2.2.20.1
* Revert DOCTYPE SYSTEM https changes in metadata.xmlMike Gilbert2015-08-241-1/+1
| | | | | | | repoman does not yet accept the https version. This partially reverts eaaface92ee81f30a6ac66fe7acbcc42c00dc450. Bug: https://bugs.gentoo.org/552720
* Use https by defaultJustin Lecher2015-08-241-1/+1
| | | | | | Convert all URLs for sites supporting encrypted connections from http to https Signed-off-by: Justin Lecher <jlec@gentoo.org>
* proj/gentoo: Initial commitRobin H. Johnson2015-08-0816-0/+1104
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed