summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* net-libs/nodejs: Fix llhttp/http_parser in live ebuildJeroen Roovers4 days2-0/+21
| | | | | Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
* net-libs/nodejs: src/node_metadata.cc: Include node_internals.hJeroen Roovers4 days1-0/+10
| | | | | | Fixes: https://bugs.gentoo.org/673068 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
* net-libs/nodejs: Include stdarg.hJeroen Roovers4 days2-0/+11
| | | | | | Bug: https://bugs.gentoo.org/673068 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
* net-libs/nodejs: Version 10.14.2Jeroen Roovers5 days2-0/+206
| | | | | Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
* net-libs/nodejs: Version 11.4.0Jeroen Roovers8 days3-0/+227
| | | | | Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
* net-libs/nodejs: Version 6.15.1Jeroen Roovers11 days2-1/+1
| | | | | | | | | | | | | "This is a patch release to address a bad backport of the fix for "Slowloris HTTP Denial of Service" (CVE-2018-12122). Node.js 6.15.0 misapplies the headers timeout to an entire keep-alive HTTP session, resulting in prematurely disconnected sockets." https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V6.md#6.15.1 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Bug: https://bugs.gentoo.org/672136 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
* net-libs/nodejs: OldJeroen Roovers2018-11-297-1161/+0
| | | | | | Package-Manager: Portage-2.3.52, Repoman-2.3.12 Bug: https://bugs.gentoo.org/672136 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
* net-libs/nodejs: Versions 6.15.0 8.14.0 10.14.0 11.3.0Jeroen Roovers2018-11-296-1/+822
| | | | | | Package-Manager: Portage-2.3.52, Repoman-2.3.12 Bug: https://bugs.gentoo.org/672136 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
* net-libs/nodejs: Fix more dev-libs/openssl version dep specsJeroen Roovers2018-11-222-2/+2
| | | | | | Fixes: https://bugs.gentoo.org/671658 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
* net-libs/nodejs: Revision bumpsJeroen Roovers2018-11-214-1/+1
| | | | | | | | | | 1. The dev-libs/openssl change broke crypto functions, so everyone affected needs to recompile and record proper deps again. 2. The net-dns/c-ares dependency needs a revision bump, too. Bug: https://bugs.gentoo.org/670574 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
* net-libs/nodejs: Adjust patch for live ebuildJeroen Roovers2018-11-211-1/+1
| | | | | Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
* net-libs/nodejs: Revert dev-libs/openssl-1.1* dep changeJeroen Roovers2018-11-215-6/+10
| | | | | | | | | | | | | With openssl-1.1.1a I see lots and lots of test failures that I do not see with 1.1.0* -- these reflect actual errors in using crypto functions. While there, resolve an implicit dependency on net-dns/c-ares that was missed in the 8, 9, 10 and 11 branch version bumps. Fixes: 64bc534bf4412e0088839c628ff79fa456ae60bb Bug: https://bugs.gentoo.org/670574 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
* net-libs/nodejs: Version 8.13.0Jeroen Roovers2018-11-212-0/+207
| | | | | Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
* net-libs/nodejs: adjust dev-lib/openssl requirementThomas Deutschmann2018-11-183-4/+4
| | | | | | | | | | | | - We are patching dev-libs/openssl to ship some EC curves even with dev-libs/openssl[bindist] so it is no longer required to enforce dev-libs/openssl[-bindist]. - NodeJS >=10 requires OpenSSL 1.1 or newer. Closes: https://bugs.gentoo.org/670574 Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
* net-libs/nodejs: drop oldThomas Deutschmann2018-11-187-1221/+0
| | | | | Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
* net-libs/nodejs: bump to v11.2.0Thomas Deutschmann2018-11-182-0/+205
| | | | | Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
* net-libs/nodejs: arm stable wrt bug #665656Mikle Kolyada2018-11-172-4/+4
| | | | | Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
* net-libs/nodejs: Version 11.1.0Jeroen Roovers2018-11-022-0/+205
| | | | | Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
* net-libs/nodejs: Version 10.13.0Jeroen Roovers2018-10-302-0/+206
| | | | | Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
* net-libs/nodejs: Fix dev-libs/libuv versionJeroen Roovers2018-10-241-1/+1
| | | | | Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
* net-libs/nodejs: Version 11.0.0Jeroen Roovers2018-10-242-0/+205
| | | | | Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
* net-libs/nodejs: Version 10.12.0Jeroen Roovers2018-10-112-0/+205
| | | | | Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
* net-libs/nodejs: Fix maintainerPatrick Lauer2018-09-231-4/+0
| | | | Package-Manager: Portage-2.3.49, Repoman-2.3.11
* net-libs/nodejs: Fix dev-libs/openssl dependency.Jeroen Roovers2018-09-231-1/+1
| | | | Package-Manager: Portage-2.3.49, Repoman-2.3.10
* net-libs/nodejs: Version 10.11.0.Jeroen Roovers2018-09-222-0/+202
| | | | Package-Manager: Portage-2.3.49, Repoman-2.3.10
* net-libs/nodejs: Old.Jeroen Roovers2018-09-192-203/+0
| | | | Package-Manager: Portage-2.3.49, Repoman-2.3.10
* net-libs/nodejs: Drop ppc/ppc64 keywords on old versions, bug 665656Matt Turner2018-09-174-4/+4
| | | | | | net-libs/nodejs-8.12.0 passes its test suite on ppc/ppc64 but version 6 doesn't. Since nothing requires older versions, let's just drop their keywords.
* net-libs/nodejs-8.12.0: ppc64 stable, bug 665656Matt Turner2018-09-171-1/+1
|
* net-libs/nodejs-8.12.0: ppc stable, bug 665656Matt Turner2018-09-171-1/+1
|
* net-libs/nodejs: amd64 stable wrt bug #665656Agostino Sarubbo2018-09-141-1/+1
| | | | | Package-Manager: Portage-2.3.40, Repoman-2.3.9 RepoMan-Options: --include-arches="amd64"
* net-libs/nodejs: x86 stable (bug #665656)Thomas Deutschmann2018-09-122-2/+2
| | | | Package-Manager: Portage-2.3.49, Repoman-2.3.10
* net-libs/nodejs: Old.Jeroen Roovers2018-09-112-203/+0
| | | | Package-Manager: Portage-2.3.49, Repoman-2.3.10
* net-libs/nodejs: Old.Jeroen Roovers2018-09-112-198/+0
| | | | Package-Manager: Portage-2.3.49, Repoman-2.3.10
* net-libs/nodejs: Stable for AMD64 too.Jeroen Roovers2018-09-111-1/+1
| | | | | Package-Manager: Portage-2.3.49, Repoman-2.3.10 RepoMan-Options: --ignore-arches
* net-libs/nodejs: Version 8.12.0.Jeroen Roovers2018-09-112-0/+203
| | | | Package-Manager: Portage-2.3.49, Repoman-2.3.10
* net-libs/nodejs: Version 10.10.0.Jeroen Roovers2018-09-072-0/+202
| | | | Package-Manager: Portage-2.3.49, Repoman-2.3.10
* net-libs/nodejs: Old.Jeroen Roovers2018-08-165-805/+0
| | | | Package-Manager: Portage-2.3.46, Repoman-2.3.10
* net-libs/nodejs: Versions 6.14.4 8.11.4 10.9.0.Jeroen Roovers2018-08-164-0/+603
| | | | | Package-Manager: Portage-2.3.46, Repoman-2.3.10 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
* net-libs/nodejs: Set REQUIRED_USE for USE=npm (bug #662736).Jeroen Roovers2018-08-075-0/+5
| | | | Package-Manager: Portage-2.3.44, Repoman-2.3.10
* net-libs/nodejs: Old.Jeroen Roovers2018-08-072-201/+0
| | | | Package-Manager: Portage-2.3.44, Repoman-2.3.10
* net-libs/nodejs: Version 10.8.0.Jeroen Roovers2018-08-072-0/+201
| | | | Package-Manager: Portage-2.3.44, Repoman-2.3.10
* net-libs/nodejs: normalize indentation in metadata.xmlMike Gilbert2018-07-231-7/+7
|
* net-libs/nodejs: Old.Jeroen Roovers2018-07-232-201/+0
| | | | Package-Manager: Portage-2.3.43, Repoman-2.3.10
* net-libs/nodejs: Fix npm patch (bug #660450).Jeroen Roovers2018-07-233-2/+2
| | | | Package-Manager: Portage-2.3.43, Repoman-2.3.10
* net-libs/nodejs: Version 10.7.0.Jeroen Roovers2018-07-192-0/+201
| | | | Package-Manager: Portage-2.3.43, Repoman-2.3.10
* net-libs/nodejs: Old.Jeroen Roovers2018-07-052-201/+0
| | | | Package-Manager: Portage-2.3.41, Repoman-2.3.9
* net-libs/nodejs: Version 10.6.0.Jeroen Roovers2018-07-052-0/+201
| | | | Package-Manager: Portage-2.3.41, Repoman-2.3.9
* net-libs/nodejs: Version 10.5.0.Jeroen Roovers2018-06-212-0/+201
| | | | Package-Manager: Portage-2.3.40, Repoman-2.3.9
* net-libs/nodejs: Depend on net-libs/nghttp2-1.32.0.Jeroen Roovers2018-06-201-1/+1
| | | | Package-Manager: Portage-2.3.40, Repoman-2.3.9
* net-libs/nodejs: Old.Jeroen Roovers2018-06-193-399/+0
| | | | Package-Manager: Portage-2.3.40, Repoman-2.3.9