summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* net-p2p/deluge: Cleanup old versionsKristian Fiskerstrand7 days4-234/+0
| | | | | | Gentoo-Bug: 612144 Package-Manager: Portage-2.3.3, Repoman-2.3.1
* net-libs/rb_libtorrent: pkgmove to libtorrent-rasterbarAndreas Sturmlechner10 days5-6/+6
| | | | | | | Gentoo-bug: 576126 Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/4241
* net-p2p/deluge: x86 stable wrt bug #612144Agostino Sarubbo12 days1-2/+2
| | | | | | Package-Manager: Portage-2.3.3, Repoman-2.3.1 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* net-p2p/deluge: amd64 stable wrt bug #612144Agostino Sarubbo2017-03-141-2/+2
| | | | | | Package-Manager: Portage-2.3.3, Repoman-2.3.1 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* net-p2p/deluge: Version bump to 1.3.14Kristian Fiskerstrand2017-03-142-0/+144
| | | | | | | | | Straight version bump for security vulns Proxied-Maintainer: Paolo Pedroni Gentoo-Bug: 612144 Package-Manager: Portage-2.3.3, Repoman-2.3.1
* net-p2p/deluge: x86 stable wrt bug #530720Agostino Sarubbo2017-03-101-2/+2
| | | | | | Package-Manager: Portage-2.3.3, Repoman-2.3.1 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* net-p2p/deluge: amd64 stable wrt bug #530720Agostino Sarubbo2017-03-101-2/+2
| | | | | | Package-Manager: Portage-2.3.3, Repoman-2.3.1 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* Drop remaining $Id$ and $Header$ from files.Ulrich Müller2017-02-283-3/+0
| | | | Bug: 611234
* Drop $Id$ per council decision in bug #611234.Robin H. Johnson2017-02-284-4/+0
| | | | Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
* net-p2p/deluge: Fix dependency on net-libs/rb_libtorrent.Kristian Fiskerstrand2017-01-051-2/+2
| | | | | | | | | | | The newer version of the library is not strictly necessary and requires additional stabilization if to be used, so reducing the version requirement for 1.3.13 in order to stabilize the point version. Proxied-Maintainer: Paolo Pedroni Gentoo-Bug: 601048 Package-Manager: Portage-2.3.3, Repoman-2.3.1
* net-p2p/deluge: Clean up old testing versionsKristian Fiskerstrand2016-12-222-281/+0
| | | | Package-Manager: Portage-2.3.3, Repoman-2.3.1
* net-p2p/deluge: Optional dep on monolithic or modular twistedKristian Fiskerstrand2016-12-223-4/+150
| | | | | | Gentoo-Bug: 602424 Package-Manager: Portage-2.3.3, Repoman-2.3.1
* net-p2p/deluge: Version bump 1.3.13Kristian Fiskerstrand2016-08-061-0/+1
| | | | | | | Proxy-commit Gentoo-Bug: 589376 Package-Manager: portage-2.3.0
* net-p2p/deluge: version bump to 1.3.13PPed722016-08-061-0/+140
|
* net-p2p/deluge: Add stable live ebuildPPed722016-06-223-4/+145
| | | | Also fixes some tabs vs spaces issues
* net-p2p/deluge: Sync live ebuild to latest changesPPed722016-06-221-21/+61
|
* net-p2p/deluge: Remove oldPPed722016-06-221-100/+0
|
* net-p2p/deluge: Make UI installation USE-conditionalPPed722016-06-223-2/+147
| | | | | | Gentoo-bug: 381837 New ebuild, EAPI=6, add local use flags and new languages to metadata.xml, fix patch for EAPI=6
* net-p2p/deluge: Override esetup.pyMike Gilbert2016-06-093-7/+13
| | | | | | | | Resolves a build failure triggered by a change in distutils-r1.eclass. Bug: https://bugs.gentoo.org/585454 Package-Manager: portage-2.3.0_rc1_p20
* net-p2p/deluge: use #!/sbin/openrc-run instead of #!/sbin/runscriptAustin English2016-05-181-1/+1
|
* net-p2p/deluge: fix scheduler pluginPPed722016-03-212-0/+23
| | | | | | Reporter: Giacomo Tazzari <giacomo.tazzari@gmail.com> Gentoo-Bug: https://bugs.gentoo.org/577848 Closes: https://github.com/gentoo/gentoo/pull/1103
* net-p2p/deluge: sync live ebuildPPed722016-03-101-4/+13
| | | | | | | | This series of commits closes #1010. Pull-Request: https://github.com/gentoo/gentoo/pull/1010 Gentoo-Bug: https://bugs.gentoo.org/566806 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
* net-p2p/deluge: remove oldPPed722016-03-101-88/+0
| | | | Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
* net-p2p/deluge: improved systemd supportPPed722016-03-101-0/+97
| | | | | | | The ebuild now creates deluge user and group (fix Gentoo bug #566806) Give notice to systemd users of change in configuration files. Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
* net-p2p/deluge: Improved systemd unitsPPed722016-03-102-0/+22
| | | | | | | No more sourcing of /etc/conf.d/deluge* (QA violation). Systemd units are now configured in drop-in files. Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
* net-p2p/deluge: Add systemd drop-insPPed722016-03-102-0/+9
| | | | | | These files allow configuration of systemd units Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
* net-p2p/deluge: improve configuration defaultsPPed722016-03-102-5/+5
| | | | Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
* net-p2p/deluge: remove unused patchPaolo Pedroni2016-02-291-60/+0
| | | | This file is no longer needed
* net-p2p/deluge: sync live ebuild with latest changesPaolo Pedroni2016-02-291-17/+29
| | | | Fixes bug #476382, #293513 and #518354
* net-p2p/deluge: change shebang to #!/sbin/openrc-runPaolo Pedroni2016-02-282-2/+2
|
* net-p2p/deluge: split startup script for daemon and web insterfacePaolo Pedroni2016-02-281-0/+0
| | | | | | Rename ebuild to force upgrade for ~arch users. Fixes bug #350213. Thanks to Cameron Tacklind <cameron@tacklind.com> for bug report and inspiration.
* net-p2p/deluge: Small fixes to configuration filesPaolo Pedroni2016-02-282-2/+2
|
* net-p2p/deluge: unbundle startup scripts for daemon and web interfacePaolo Pedroni2016-02-281-2/+4
| | | | Fixes bug #350213 (thanks to Cameron Tacklind <cameron@tacklind.com>)
* net-p2p/deluge: unbundle startup scripts for deluge-webPaolo Pedroni2016-02-284-0/+121
| | | | | | Different startup scripts for daemon and web server. This fixes bug #350213 (thanks to Cameron Tacklind <cameron@tacklind.com> for inspiration, even though implemented slightly differently)
* net-p2p/deluge: New revisionKristian Fiskerstrand2016-02-161-0/+86
| | | | Package-Manager: portage-2.2.27
* net-p2p/deluge: fix manifestPaolo Pedroni2016-02-161-1/+0
| | | | Fix qa warning
* net-p2p/deluge: fix bug #468340 for real, this timePaolo Pedroni2016-02-161-1/+1
|
* net-p2p/deluge: Use "/run" instead of "/var/run" for pidfilesPaolo Pedroni2016-02-161-3/+3
| | | | Fixes bug #468340
* net-p2p/deluge: unquote ${DELUGED_OPTS} in openrc init filePaolo Pedroni2016-02-161-1/+1
| | | | Fixes bug #437350. Thanks to Alex Belykh <albel727@ngs.ru>
* net-p2p/deluge: add umask values to openrc script (Fixes bug #566862)Paolo Pedroni2016-02-162-0/+2
| | | | Thanks to Scott Jones <morbidsvt@gmail.com>
* net-p2p/deluge: remove oldPaolo Pedroni2016-02-161-74/+0
|
* net-p2p/deluge: x86 stable wrt bug #566206Agostino Sarubbo2016-02-141-1/+1
| | | | | | Package-Manager: portage-2.2.26 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* net-p2p/deluge: Assign maintainership to proxied maintainerKristian Fiskerstrand2016-02-101-0/+14
| | | | Package-Manager: portage-2.2.27
* net-p2p/deluge: PYTHON_REQUIRED_USE neededPacho Ramos2016-01-301-0/+1
| | | | Package-Manager: portage-2.2.27
* Replace all herds with appropriate projects (GLEP 67)Michał Górny2016-01-241-1/+0
| | | | | Replace all uses of herd with appropriate project maintainers, or no maintainers in case of herds requested to be disbanded.
* Unify quoting in metadata.xml files for machine processingMichał Górny2016-01-241-2/+2
| | | | | | | Force unified quoting in all metadata.xml files since lxml does not preserve original use of single and double quotes. Ensuring unified quoting before the process allows distinguishing the GLEP 67-related metadata.xml changes from unrelated quoting changes.
* net-p2p/deluge: amd64 stable wrt bug #566206Agostino Sarubbo2016-01-151-1/+1
| | | | | | Package-Manager: portage-2.2.26 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* Fix manifest.Robin H. Johnson2015-11-231-1/+1
| | | | Package-Manager: portage-2.2.24
* net-p2p/deluge: Version bump. Fixes bug 561398.Paolo Pedroni2015-11-231-0/+1
| | | | Gentoo-Bug: 561398
* Revert DOCTYPE SYSTEM https changes in metadata.xmlMike Gilbert2015-08-241-1/+1
| | | | | | | repoman does not yet accept the https version. This partially reverts eaaface92ee81f30a6ac66fe7acbcc42c00dc450. Bug: https://bugs.gentoo.org/552720