summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* net-p2p/retroshare: Remove local USE="gui"David Seifert2020-01-121-1/+0
| | | | | Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
* */*: Fix obsolete copyrightsMichał Górny2019-10-101-1/+1
| | | | Signed-off-by: Michał Górny <mgorny@gentoo.org>
* net-p2p/retroshare: version bump to 0.6.5Gioacchino Mazzurco2019-05-153-2/+148
| | | | | Signed-off-by: Gioacchino Mazzurco <gio@eigenlab.org> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* net-p2p/retroshare: Drop 0.6.9999 ebuildGioacchino Mazzurco2019-05-152-121/+3
| | | | | | | | Remove un-maintainable ebuild Signed-off-by: Gioacchino Mazzurco <gio@eigenlab.org> Closes: https://github.com/gentoo/gentoo/pull/11029 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* net-p2p/retroshare: remove myself from maintainersSergey Popov2018-11-071-4/+0
| | | | | Signed-off-by: Sergey Popov <pinkbyte@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.10
* net-p2p/retroshare: amd64 stable wrt bug #664564Mikle Kolyada2018-09-091-1/+1
| | | | Package-Manager: Portage-2.3.40, Repoman-2.3.9
* net-p2p/retroshare: x86 stable (bug #664564)Thomas Deutschmann2018-09-091-1/+1
| | | | Package-Manager: Portage-2.3.49, Repoman-2.3.10
* net-p2p/retroshare: Drop obsolete gnome2_icon_savelistAndreas Sturmlechner2018-08-211-1/+0
| | | | Package-Manager: Portage-2.3.47, Repoman-2.3.10
* net-p2p/retroshare: eutils -> desktopAndreas Sturmlechner2018-08-212-2/+2
| | | | Package-Manager: Portage-2.3.47, Repoman-2.3.10
* net-p2p/retroshare: Fix build with Qt 5.11Andreas Sturmlechner2018-08-212-2/+67
| | | | | Closes: https://bugs.gentoo.org/661742 Package-Manager: Portage-2.3.47, Repoman-2.3.10
* net-p2p/retroshare update development ebuildGioacchino Mazzurco2018-06-092-89/+61
| | | | | | | | | | | | | | | Development version of retroshare expose qmake flags that permit easier build customization without crufty patching, improve development ebuild to take advantage of that and have a cleaner ebuild. Removed VoIP and feedreader plugins are not maintained. For future stable versions this ebuild should be used as reference and not the older ones. Development version depends on rapidjson. Closes: https://github.com/gentoo/gentoo/pull/8115
* net-p2p/retroshare: drop old versionSergey Popov2018-04-232-150/+0
| | | | Package-Manager: Portage-2.3.31, Repoman-2.3.9
* net-p2p/retroshare-0.6.3: stable on amd64/x86Sergey Popov2018-04-231-1/+1
| | | | Package-Manager: Portage-2.3.31, Repoman-2.3.9
* net-p2p/retroshare: revision bumpSergey Popov2018-04-231-1/+2
| | | | | | | Add missing dependency on media-libs/speexdsp Closes: https://bugs.gentoo.org/646502 Package-Manager: Portage-2.3.31, Repoman-2.3.9
* net-p2p/retroshare: add proxied maintainerSergey Popov2018-04-231-0/+8
|
* net-p2p/retroshare: version bumpSergey Popov2018-04-232-0/+155
| | | | | Closes: https://bugs.gentoo.org/650450 Package-Manager: Portage-2.3.31, Repoman-2.3.9
* net-p2p/*: Update Manifest hashesMichał Górny2017-12-101-2/+2
|
* net-p2p/retroshare: version bumpSergey Popov2017-08-074-6/+189
| | | | | | | | | | Fix comment type to prevent compile error. Sync live ebuild Reported-by: Gleb <gleb@fastmail.com> Gentoo-Bug: 627150 Package-Manager: Portage-2.3.6, Repoman-2.3.1
* net-p2p/retroshare: make gnome-base/libgnome-keyring dependency optional, ↵Sergey Popov2017-08-023-6/+7
| | | | | | fix autologin Package-Manager: Portage-2.3.6, Repoman-2.3.1
* net-p2p/retroshare: drop Qt4 support, drop old versionSergey Popov2017-07-284-167/+16
| | | | Package-Manager: Portage-2.3.6, Repoman-2.3.1
* net-p2p/retroshare: drop old versionsSergey Popov2017-06-134-488/+0
| | | | Package-Manager: Portage-2.3.6, Repoman-2.3.1
* net-p2p/retroshare-0.6.2: stable on amd64 and x86Sergey Popov2017-06-131-1/+1
| | | | Package-Manager: Portage-2.3.6, Repoman-2.3.1
* net-p2p/retroshare-0.6.9999: drop Qt4 supportSergey Popov2017-06-131-36/+16
| | | | | | | Suggested-by: Andreas Sturmlechner <asturm@gentoo.org> Gentoo-Bug: 621502 Package-Manager: Portage-2.3.6, Repoman-2.3.1
* Globally add missing remote ID references to metadata.xmlJustin Lecher2017-04-291-1/+2
| | | | Signed-off-by: Justin Lecher <jlec@gentoo.org>
* net-p2p/retroshare: version bump. Sync live ebuildSergey Popov2017-03-273-2/+172
| | | | | | Gentoo-Bug: 612532 Package-Manager: portage-2.3.3
* Drop $Id$ per council decision in bug #611234.Robin H. Johnson2017-02-284-4/+0
| | | | Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
* fix quoting to a lot of patch callsMike Frysinger2017-01-201-1/+1
|
* net-p2p/retroshare: correct dependency on net-libs/libupnpSergey Popov2017-01-124-6/+6
| | | | | | | Reported-by: <shinydoofy@gmail.com> Gentoo-Bug: 604886 Package-Manager: portage-2.3.3
* net-p2p/retroshare: correct dependency on media-libs/opencv in 0.6.1 and ↵Sergey Popov2017-01-122-6/+6
| | | | | | | | live ebuilds Reported-by: Vadim A. Misbakh-Soloviov <gentoo@mva.name> Package-Manager: portage-2.3.3
* net-p2p/retroshare: restore accidentally deleted dependency on dev-qt/designerSergey Popov2016-12-152-0/+4
| | | | | | | Reported-by: Amadeusz Żołnowski <aidecoe@gentoo.org> Gentoo-Bug: 602566 Package-Manager: portage-2.3.2
* net-p2p/retroshare: drop redundant description for qt4 USE-flagSergey Popov2016-12-061-1/+0
| | | | Package-Manager: portage-2.3.2
* net-p2p/retroshare: version bumpSergey Popov2016-12-064-27/+196
| | | | | | | | | | | | Implement optional(enabled by default) 'gui' USE-flag: now it is possible to build only CLI version of RetroShare. Rearrange dependencies, thanks to Gioacchino Mazzurco and Amadeusz Żołnowski. Sync live ebuild with this changes. Reported-by: Gioacchino Mazzurco <gio@eigenlab.org> Gentoo-Bug: 593718 Package-Manager: portage-2.3.2
* net-p2p/retroshare: drop old versionSergey Popov2016-08-172-151/+0
| | | | Package-Manager: portage-2.2.28
* net-p2p/retroshare-0.6.0: stable on amd64/x86Sergey Popov2016-08-171-1/+1
| | | | | | Gentoo-Bug: 584832 Package-Manager: portage-2.2.28
* net-p2p/retroshare: backport upstream fixes for building with Qt5 and new ↵Sergey Popov2016-07-272-0/+148
| | | | | | | | C++ ABI Gentoo-Bug: 584832 Package-Manager: portage-2.3.0
* net-p2p/retroshare: fix wrong assumption that REPLACING_VERSION is a stringSergey Popov2016-07-272-16/+23
| | | | | | Gentoo-Bug: 589502 Package-Manager: portage-2.3.0
* sourceforge: switch to https:// URIsMike Frysinger2016-07-271-1/+1
|
* net-p2p/retroshare: stable on x86Sergey Popov2016-06-181-2/+2
| | | | | | Gentoo-Bug: 570746 Package-Manager: portage-2.3.0_rc1
* net-p2p/retroshare: fix web files installation in live ebuildSergey Popov2016-04-261-2/+1
| | | | | | | Reported-by: Alan Neilan <ANeilan@student.bridgew.edu> Gentoo-Bug: 578974 Package-Manager: portage-2.2.28
* net-p2p/retroshare: amd64 stable wrt bug #570746Mikle Kolyada2016-03-051-1/+1
| | | | Package-Manager: portage-2.2.26
* net-p2p/retroshare: version bumpSergey Popov2016-02-082-0/+167
| | | | Package-Manager: portage-2.2.27
* net-p2p/retroshare: add support for building with Qt4Sergey Popov2016-02-081-11/+30
| | | | | | | Reported-by: Stanislav Nikitin <pztrn@pztrn.name> Gentoo-Bug: 568176 Package-Manager: portage-2.2.27
* Set appropriate maintainer types in metadata.xml (GLEP 67)Michał Górny2016-01-241-1/+1
|
* net-p2p/retroshare: add live ebuildSergey Popov2015-09-221-0/+145
| | | | Package-Manager: portage-2.2.20
* net-p2p/retroshare: fix segfault in VOIP plugin, drop old versionSergey Popov2015-09-223-152/+1
| | | | | | | | | When OpenCV is built with Qt4 support, Retroshare VOIP plugin, that links to it causes segfault during application loading. Gentoo-Bug: 556132 Package-Manager: portage-2.2.20
* net-p2p/retroshare: simplify Qt dependenciesSergey Popov2015-09-211-5/+3
| | | | Package-Manager: portage-2.2.20
* Revert DOCTYPE SYSTEM https changes in metadata.xmlMike Gilbert2015-08-241-1/+1
| | | | | | | repoman does not yet accept the https version. This partially reverts eaaface92ee81f30a6ac66fe7acbcc42c00dc450. Bug: https://bugs.gentoo.org/552720
* Use https by defaultJustin Lecher2015-08-241-1/+1
| | | | | | Convert all URLs for sites supporting encrypted connections from http to https Signed-off-by: Justin Lecher <jlec@gentoo.org>
* net-p2p/retroshare: fix MY_PV, which is non-portable across bash versions ↵Sergey Popov2015-08-121-1/+1
| | | | | | | | wrt bug #557276 Reported-by: dwfreed <dwfreed AT mtu.edu> Suggested-by: Ulrich Müller <ulm AT gentoo.org> Package-Manager: portage-2.2.20
* Explicitly quote the ~ in the replacement, so that it does not get expanded ↵Robin H. Johnson2015-08-091-1/+1
| | | | | | to a homedir. Package-Manager: portage-2.2.18