summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* sci-geosciences/gpsd: Keyword 3.21 arm64, #739562Sam James2020-10-061-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* sci-geosciences/gpsd: cleanup oldSam James2020-09-259-787/+0
| | | | | | | Bug: https://bugs.gentoo.org/743766 Bug: https://bugs.gentoo.org/743556 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
* sci-geosciences/gpsd: Stabilize 3.21 arm, #743556Sam James2020-09-251-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* sci-geosciences/gpsd: misc fixesSam James2020-09-251-6/+9
| | | | | | | | | - Add missing || dies - Guard python-bindings build system workaround with USE=python (issue uncovered by added || die) Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
* sci-geosciences/gpsd: call python_setup uncondiitonallySam James2020-09-251-1/+6
| | | | | | | | | | | | python_setup is called by the distutils machinery when USE=python, but wasn't in the USE=-python case until now. We need this because we're using (e)scons to build. Closes: https://bugs.gentoo.org/734352 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
* sci-geosciences/gpsd: Stabilize 3.21 x86, #743556Sam James2020-09-251-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* sci-geosciences/gpsd: Stabilize 3.21 amd64, #743556Sam James2020-09-251-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* sci-geosciences/gpsd: drop old EAPI=5Aaron Bauman2020-09-243-386/+0
| | | | Signed-off-by: Aaron Bauman <bman@gentoo.org>
* sci-geosciences/gpsd-3.21: add GPL-2 to LICENSEMarek Szuba2020-09-101-1/+1
| | | | | | | | It's the first time I heard about it but it turns out we do have to include the licence of our own init scripts and suchlike in LICENSE... If it has to be this way, it has to be this way. Signed-off-by: Marek Szuba <marecki@gentoo.org>
* sci-geosciences/gpsd: bump to 3.21Marek Szuba2020-09-103-0/+257
| | | | | | | | | | Also fixes a few of the outstanding bugs. Invoking maintainer timeout. Closes: https://bugs.gentoo.org/show_bug.cgi?id=734364 Closes: https://bugs.gentoo.org/show_bug.cgi?id=735554 Closes: https://bugs.gentoo.org/show_bug.cgi?id=735964 Signed-off-by: Marek Szuba <marecki@gentoo.org>
* sci-geosciences/gpsd: keywords for 3.20Rick Farina2020-07-281-1/+1
| | | | | Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
* sci-geosciences/gpsd: pull keywords on 3.20Rick Farina2020-07-281-1/+1
| | | | | | | pending review by the geosciences team Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
* sci-geosciences/gpsd: adjust subslotsRick Farina2020-07-282-2/+2
| | | | | | | match solib version Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
* sci-geosciences/gpsd: migrate to glep 81Rick Farina2020-07-282-16/+6
| | | | | | | | | | | | | add acct-user/gpsd and use it migrate from uucp/gpsd groups to dialout Interestingly I can't actually find gpsd group ever being created, but I find it being used. As such, I simply dropped it. https://bugs.gentoo.org/704580 https://bugs.gentoo.org/691746 https://bugs.gentoo.org/667410 Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
* sci-geosciences/gpsd: fix systemd unitsRick Farina2020-07-282-0/+10
| | | | | Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
* sci-geosciences/gpsd: more dieRick Farina2020-07-281-1/+1
| | | | | Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
* sci-geosciences/gpsd: bumpity bumpRick Farina2020-07-283-34/+225
| | | | | | | | | | | bumping eapi bumping version various cleanups for same Much work contributed by michael AT weiser.dinsnail.net Significant work on bug #704580 which I am still going through all of Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
* sci-geosciences/gpsd: update python compatMatthias Maier2020-05-121-1/+1
| | | | | Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
* sci-geosciences/gpsd: Remove py2.7Michał Górny2020-05-073-3/+3
| | | | Signed-off-by: Michał Górny <mgorny@gentoo.org>
* */*: Clean PYTHON_COMPAT of obsolete implsMichał Górny2020-01-053-6/+6
| | | | | Closes: https://github.com/gentoo/gentoo/pull/14246 Signed-off-by: Michał Górny <mgorny@gentoo.org>
* */*: [QA] Fix trivial cases of MissingTestRestrictMichał Górny2019-12-112-0/+2
| | | | | | | | | | | | | | | | | | The result was achieved via the following pipeline: pkgcheck scan -c RestrictTestCheck -R FormatReporter \ --format '{category}/{package}/{package}-{version}.ebuild' | xargs -n32 grep -L RESTRICT | xargs -n32 sed -i -e '/^IUSE=.*test/aRESTRICT="!test? ( test )"' The resulting metadata was compared before and after the change. Few Go ebuilds had to be fixed manually due to implicit RESTRICT=strip added by the eclass. Two ebuilds have to be fixed because of multiline IUSE. Suggested-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/13942 Signed-off-by: Michał Górny <mgorny@gentoo.org>
* sci-geosciences/gpsd: python_export_best → python_setupMichał Górny2019-11-292-2/+2
| | | | Signed-off-by: Michał Górny <mgorny@gentoo.org>
* sci-geosciences/gpsd: update 9999 bugsRobin H. Johnson2019-10-041-2/+2
| | | | | | | | Package-Manager: Portage-2.3.76, Repoman-2.3.17 Fixes: https://bugs.gentoo.org/658834 Fixes: https://bugs.gentoo.org/693136 Fixes: https://bugs.gentoo.org/695110 Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
* sci-geosciences/gpsd: fix DuplicateFilesRobin H. Johnson2019-10-042-13/+1
| | | | | Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
* sci-geosciences/gpsd: sync 9999 ebuildRobin H. Johnson2019-10-041-21/+36
| | | | | Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
* sci-geosciences/gpsd: cleanup USE=latency_timingRobin H. Johnson2019-10-044-7/+7
| | | | | | | | Cleanup USE flag s/latency_timing/latency-timing/ Reference: https://bugs.gentoo.org/695110 Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
* sci-geosciences/gpsd: bump, partial cleanupsRobin H. Johnson2019-10-045-0/+408
| | | | | | | | | | Bump for security vulnerability, start cleanups. Fixes: https://bugs.gentoo.org/673372 Fixes: https://bugs.gentoo.org/673382 Fixes: https://bugs.gentoo.org/678474 Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
* sci-geosciences/gpsd: fix building with Python 3 as defaultMike Frysinger2019-09-113-0/+218
| | | | | | Pull in upstream fixes for running scons when Python 3 is default. Signed-off-by: Mike Frysinger <vapier@gentoo.org>
* sci-geosciences/gpsd: fix xgps python shebangsMike Frysinger2019-09-112-0/+174
| | | | | | | | The logic to pull the python scripts out misses the dynamic xps scripts leading them to not be wrapped as Python 2-specific. Closes: https://bugs.gentoo.org/666734 Signed-off-by: Mike Frysinger <vapier@gentoo.org>
* sci-geosciences/gpsd: permit net-misc/ntpsec for USE=ntpRobin H. Johnson2019-01-192-2/+4
| | | | | Package-Manager: Portage-2.3.53, Repoman-2.3.12 Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
* sci-geosciences/gpsd: Drop 3.17-r2Andreas Sturmlechner2018-10-041-168/+0
| | | | | Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.50, Repoman-2.3.11
* sci-geosciences/gpsd-3.17-r3: keyword for sparcRolf Eike Beer2018-10-041-1/+1
| | | | | | Signed-off-by: Rolf Eike Beer <eike@sf-mail.de> Package-Manager: Portage-2.3.49, Repoman-2.3.10 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
* sci-geosciences/gpsd: missing automagic dep on timepps.h from pps-toolsRobin H. Johnson2018-09-303-1/+4
| | | | | Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.10
* sci-geosciences/gpsd: fix USE=qt5, add USE=cxxRolf Eike Beer2018-09-042-4/+173
| | | | | Closes: https://bugs.gentoo.org/663458 Closes: https://github.com/gentoo/gentoo/pull/9551
* sci-geosciences/gpsd: arm stable wrt bug #632372Mikle Kolyada2018-04-151-1/+1
| | | | Package-Manager: Portage-2.3.24, Repoman-2.3.6
* sci-geosciences/gpsd: Drop oldAndreas Sturmlechner2018-02-0614-908/+0
| | | | | Closes: https://bugs.gentoo.org/632372 Package-Manager: Portage-2.3.24, Repoman-2.3.6
* sci-geosciences/gpsd: x86 stable (bug #632372)Thomas Deutschmann2018-01-291-1/+1
| | | | Package-Manager: Portage-2.3.20, Repoman-2.3.6
* sci-geosciences/gpsd-3.17-r2: amd64 stableTobias Klausmann2018-01-151-1/+1
| | | | Gentoo-Bug: http://bugs.gentoo.org/632372
* sci-geosciences/gpsd: Drop 3.17-r1Andreas Sturmlechner2018-01-121-172/+0
| | | | Package-Manager: Portage-2.3.19, Repoman-2.3.6
* sci-geosciences/gpsd: Fix USE=X DEPEND, add missing xgps switchAndreas Sturmlechner2018-01-121-0/+167
| | | | | Closes: https://bugs.gentoo.org/642326 Package-Manager: Portage-2.3.19, Repoman-2.3.6
* sci-geosciences/gpsd: Sync liveAndreas Sturmlechner2017-12-281-5/+6
| | | | Package-Manager: Portage-2.3.19, Repoman-2.3.6
* sci-geosciences/gpsd: Fix install with USE=-X,pythonAndreas Sturmlechner2017-12-281-1/+1
| | | | | | Thanks-to: Philippe Trottier <tchiwam@gmail.com> Bug: https://bugs.gentoo.org/640998 Package-Manager: Portage-2.3.19, Repoman-2.3.6
* sci-geosciences/gpsd: Drop USE=cxx, fix USE=qt5Andreas Sturmlechner2017-12-281-4/+5
| | | | | Closes: https://bugs.gentoo.org/642154 Package-Manager: Portage-2.3.19, Repoman-2.3.6
* sci-geosciences/gpsd: Switch USE qt4 to qt5Andreas Sturmlechner2017-12-212-10/+189
| | | | | | See also: https://savannah.nongnu.org/bugs/?52299 Package-Manager: Portage-2.3.19, Repoman-2.3.6
* sci-geosciences/gpsd-3.17-r0: amd64 stableTobias Klausmann2017-12-161-1/+1
| | | | Gentoo-Bug: http://bugs.gentoo.org/632372
* sci-geosciences: Update Manifest hashes.Ulrich Müller2017-12-101-2/+2
|
* sci-geosciences/gpsd: x86 stable (bug #632372)Thomas Deutschmann2017-12-082-2/+2
| | | | Package-Manager: Portage-2.3.16, Repoman-2.3.6
* sci-geosciences/gpsd: Expose SONAME major version as subslotThomas Deutschmann2017-09-244-7/+11
| | | | Package-Manager: Portage-2.3.10, Repoman-2.3.3
* sci-geosciences/gpsd: Version bump. Fixes build with gcc-6, bug 595382.Andreas K. Hüttel2017-09-213-0/+176
| | | | | Closes: https://bugs.gentoo.org/595382 Package-Manager: Portage-2.3.10, Repoman-2.3.3
* sci-geosciences/gpsd: x86 stable (bug #576006)Thomas Deutschmann2017-08-201-1/+1
| | | | Package-Manager: Portage-2.3.8, Repoman-2.3.3