summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* sci-misc/repsnapper: Added patch to fix compilation error with newer gccSlawomir Lis2016-09-213-0/+15
| | | | | | | | | | This bug is issued in newer gcc's because of abs() method is moved into std namespace. Added a patch to fix the issue. Reported in bug 594474 Reported-By: Toralf Förster <toralf.foerster@gmx.de> Package-Manager: portage-2.3.0
* sci-misc/repsnapper: dropped oldest version 2.2.0b_p3Slawomir Lis2016-09-192-35/+0
| | | | Package-Manager: portage-2.3.0
* sci-misc/repsnapper: updated deps to use correct libxmlpp slotSlawomir Lis2016-09-192-3/+3
| | | | | | | | | As reported in bug 594324 repsnapper is not compatible with latest libxmlpp-3.0 There is a need to use explicit slot to solve this problem Reported-By: Toralf Förster <toralf.foerster@gmx.de> Package-Manager: portage-2.3.0
* sci-misc/mendeleydesktop: Version bump.Michael Weber2016-08-312-2/+2
| | | | Package-Manager: portage-2.2.28
* sci-misc/mendeleydesktop: Version bump to 1.16.2; Drop python3_3 supportMarius Brehler2016-08-252-3/+3
| | | | | | | Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/2141 Signed-off-by: David Seifert <soap@gentoo.org>
* sourceforge: switch to https:// URIsMike Frysinger2016-07-271-1/+1
|
* sci-misc/mendeleydesktop: Update ManifestMarius Brehler2016-06-271-2/+2
| | | | | | | Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/1769 Signed-off-by: David Seifert <soap@gentoo.org>
* sci-misc/boinc: New ebuild for boinc-7.6.33Sven Eden2016-06-142-0/+157
| | | | | | | Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/1629 Signed-off-by: David Seifert <soap@gentoo.org>
* sci-misc/boinc: New ebuild for boinc-7.4.43Sven Eden2016-06-141-0/+154
| | | | | | | Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/1629 Signed-off-by: David Seifert <soap@gentoo.org>
* sci-misc/boinc: New ebuild for boinc-7.2.44Sven Eden2016-06-141-0/+154
| | | | | | | Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/1629 Signed-off-by: David Seifert <soap@gentoo.org>
* sci-misc/mendeleydesktop: Cleanup due to #231915Pacho Ramos2016-05-211-4/+0
| | | | Package-Manager: portage-2.3.0_rc1
* sci-misc/repsnapper: Fix QA MissingSlotDepDavid Seifert2016-05-151-2/+2
| | | | Package-Manager: portage-2.2.28
* sci-misc/h5utils: Fix QA MissingSlotDepDavid Seifert2016-05-151-2/+2
| | | | Package-Manager: portage-2.2.28
* sci-misc/boinc: Fix VSYSCALL check for boinc-7.6.31Sven Eden2016-05-081-21/+13
| | | | | | | | | | | | | | | | | | | Gentoo-Bug: 578750 The configuration options were misunderstood. - CONFIG_X86_VSYSCALL_EMULATION only enables a dmesg message if any legacy application tries to use any vsyscall. If disabled, these applications simply segfault with no output in dmesg. - To make the old calls available, either CONFIG_LEGACY_VSYSCALL_NATIVE or CONFIG_LEGACY_VSYSCALL_EMULATE must be used. Therefore the ebuild was reverted to check against the CONFIG_LEGACY_VSYSCALL_NONE option, and warns the user if this is set. Package-Manager: portage-2.2.28
* sci-misc/boinc: Fix VSYSCALL check for boinc-7.4.42Sven Eden2016-05-081-21/+13
| | | | | | | | | | | | | | | | | | | Gentoo-Bug: 578750 The configuration options were misunderstood. - CONFIG_X86_VSYSCALL_EMULATION only enables a dmesg message if any legacy application tries to use any vsyscall. If disabled, these applications simply segfault with no output in dmesg. - To make the old calls available, either CONFIG_LEGACY_VSYSCALL_NATIVE or CONFIG_LEGACY_VSYSCALL_EMULATE must be used. Therefore the ebuild was reverted to check against the CONFIG_LEGACY_VSYSCALL_NONE option, and warns the user if this is set. Package-Manager: portage-2.2.28
* sci-misc/boinc: Fix VSYSCALL check for boinc-7.2.42Sven Eden2016-05-081-21/+13
| | | | | | | | | | | | | | | | | | | Gentoo-Bug: 578750 The configuration options were misunderstood. - CONFIG_X86_VSYSCALL_EMULATION only enables a dmesg message if any legacy application tries to use any vsyscall. If disabled, these applications simply segfault with no output in dmesg. - To make the old calls available, either CONFIG_LEGACY_VSYSCALL_NATIVE or CONFIG_LEGACY_VSYSCALL_EMULATE must be used. Therefore the ebuild was reverted to check against the CONFIG_LEGACY_VSYSCALL_NONE option, and warns the user if this is set. Package-Manager: portage-2.2.28
* sci-misc/boinc: Fix variable default statements in init scriptsDavid Seifert2016-05-054-6/+7
| | | | Package-Manager: portage-2.2.28
* sci-misc/boinc: Upgraded init scriptSven Eden2016-05-052-25/+70
| | | | | | | | | | | | | | | | | | | Gentoo-Bug: 574260 After hot-fixing bug 574260, the following fixes/additions, suggested by Jan Chren were made: - #!/sbin/runscript -> #!/sbin/openrc-run - Variables from /etc/conf.d/boinc are checked, and empty variables are pre-filled with sane defaults. - split start() to start_pre() and start() - removed check_baselayout() - replaced /etc/init.d/boinc with ${RC_SERVICE} - replaced echo with einfo "" - replaced ${SVCNAME} with ${RC_SVCNAME} - removed unset for local vars Package-Manager: portage-2.2.28
* sci-misc/boinc: Removed obsolete ebuild for boinc-7.6.31Sven Eden2016-05-051-127/+0
| | | | | | | | Gentoo-Bug: 577490, 578750 Made obsolete by the 7.6.31-r1 ebuild, that has an important fix. Package-Manager: portage-2.2.28
* sci-misc/boinc: New r1 ebuild for boinc-7.6.31 with vsyscall fixSven Eden2016-05-051-0/+158
| | | | | | | | | | | | | | | Gentoo-Bug: 577490, 578750 A check against VSYSCALL kernel options was added. Russell Knighton found out, that some projects segfault if VSYSCALL mappings are completely disabled, and reported the issue in bug 578750. The check against CONFIG_LEGACY_VSYSCALL_NONE and CONFIG_X86_VSYSCALL_EMULATION is based on his patch submitted in the bug reported by him. Package-Manager: portage-2.2.28
* sci-misc/boinc: Removed obsolete ebuild for boinc-7.4.42-r1Sven Eden2016-05-051-141/+0
| | | | | | | | Gentoo-Bug: 577490, 578750 Made obsolete by the 7.4.42-r2 ebuild, that has an important fix. Package-Manager: portage-2.2.28
* sci-misc/boinc: New r2 ebuild for boinc-7.4.42 with vsyscall fixSven Eden2016-05-051-0/+158
| | | | | | | | | | | | | | | Gentoo-Bug: 577490, 578750 A check against VSYSCALL kernel options was added. Russell Knighton found out, that some projects segfault if VSYSCALL mappings are completely disabled, and reported the issue in bug 578750. The check against CONFIG_LEGACY_VSYSCALL_NONE and CONFIG_X86_VSYSCALL_EMULATION is based on his patch submitted in the bug reported by him. Package-Manager: portage-2.2.28
* sci-misc/boinc: Removed obsolete ebuild for boinc-7.2.0-r1Sven Eden2016-05-051-147/+0
| | | | | | | | Gentoo-Bug: 577490 Made obsolete by the addition of the versioned 7.2.42 ebuild. Package-Manager: portage-2.2.28
* sci-misc/boinc: Removed obsolete ebuild for boinc-7.2.0Sven Eden2016-05-051-146/+0
| | | | | | | | Gentoo-Bug: 577490 Made obsolete by the addition of the versioned 7.2.42 ebuild. Package-Manager: portage-2.2.28
* sci-misc/boinc: New ebuild for boinc-7.2.42 with vsyscall checkSven Eden2016-05-052-0/+159
| | | | | | | | | | | | | | | | | | | | | Gentoo-Bug: 577490, 578750 The ebuild is essentially the same as for the new boinc-7.6.31 with the following exception: The 7.2 series can not be built with wxGTK:3.0, therefore this ebuild uses wxGTK:2.8. Further a check against VSYSCALL kernel options has been added. Russell Knighton found out, that some projects segfault if VSYSCALL mappings are completely disabled, and reported the issue in bug 578750. The check against CONFIG_LEGACY_VSYSCALL_NONE and CONFIG_X86_VSYSCALL_EMULATION is based on his patch submitted in the bug reported by him. Package-Manager: portage-2.2.28
* sci-misc/boinc: Migrated boinc.init to use start-stop-daemonSven Eden2016-04-261-3/+6
| | | | | | | | | | | | | | | | | | The boinc init script can no longer start, attach or stop the boinc manager if openrc-0.20 and newer is used, because openrc no longer passes $SHELL to init scripts. To solve the issue the init script has been migrated to use start-stop-daemon instead of using 'su' directly. This change should have no impact for users of previous openrc versions. Gentoo-Bug: https://bugs.gentoo.org/574260 Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/1244 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
* sci-misc/fitsverify: Version bumpSébastien Fabbro2016-04-212-0/+36
| | | | Package-Manager: portage-2.2.28
* sci-misc/cdfplayer: New application, fetch-restrictedAndreas K. Hüttel2016-04-093-0/+90
|
* sci-misc/mendeleydesktop: Version bumpMarius Brehler2016-04-022-2/+2
| | | | Package-Manager: portage-2.2.26
* sci-misc/fitscut: initial importSébastien Fabbro2016-03-224-0/+87
| | | | Package-Manager: portage-2.2.28
* sci-misc/fitsverify: fixed license, switched to EAPI6 and astronomy projectSébastien Fabbro2016-03-222-7/+8
| | | | Package-Manager: portage-2.2.28
* sci-misc/boinc: New ebuild boinc-7.6.31.ebuildSven Eden2016-03-203-2/+135
| | | | | | Gentoo-Bug: 577490 Package-Manager: portage-2.2.28
* metadata.xml: Add maintainer-needed comment to packages without maintainer.Ulrich Müller2016-02-281-0/+1
| | | | Bug: 575810
* sci-misc/flashdot: Port to dev-ml/gsl-ocamlDavid Seifert2016-02-142-0/+59
| | | | | | Gentoo-Bug: 574564 Package-Manager: portage-2.2.27
* sci-misc/mendeleydesktop: Version bump, enable python3_5, bump to EAPI=6Marius Brehler2016-02-022-5/+7
| | | | Package-Manager: portage-2.2.26
* Set appropriate maintainer types in metadata.xml (GLEP 67)Michał Górny2016-01-2416-19/+19
|
* Replace all herds with appropriate projects (GLEP 67)Michał Górny2016-01-2412-12/+48
| | | | | Replace all uses of herd with appropriate project maintainers, or no maintainers in case of herds requested to be disbanded.
* Remove explicit notion of maintainer-needed, for GLEP 67Michał Górny2016-01-241-3/+0
| | | | | | GLEP 67 removes the explicit notion of maintainer-needed@g.o being used for packages lacking maintainers, in favor of assuming maintainer-needed whenever the package has no maintainers.
* Unify quoting in metadata.xml files for machine processingMichał Górny2016-01-242-2/+2
| | | | | | | Force unified quoting in all metadata.xml files since lxml does not preserve original use of single and double quotes. Ensuring unified quoting before the process allows distinguishing the GLEP 67-related metadata.xml changes from unrelated quoting changes.
* Drop myself as maintainerJustin Lecher2016-01-091-5/+0
| | | | Signed-off-by: Justin Lecher <jlec@gentoo.org>
* sci-misc/nco: antlr-cpp should be in RDEPENDJames Le Cuirot2016-01-021-2/+2
| | | | | | | I commented that antlr should have been in RDEPEND before and forgot to put antlr-cpp there myself. D'oh! Package-Manager: portage-2.2.26
* fixed patch lost #569976, #569628Slawomir Lis2015-12-281-0/+31
| | | | Package-Manager: portage-2.2.26
* version bump, #569628Slawomir Lis2015-12-282-0/+37
| | | | Package-Manager: portage-2.2.26
* sci-misc/ViSP-images: bump to 3.0.0Alexis Ballier2015-12-232-0/+26
| | | | | Package-Manager: portage-2.2.26 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
* sci-misc/mendeleydesktop: Version bumpMarius Brehler2015-11-272-2/+2
| | | | Package-Manager: portage-2.2.20.1
* sci-misc/flashdot: Move use() call to local scopeJustin Lecher2015-11-232-19/+18
| | | | | | | | | bump EAPI to 5 Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=566554 Package-Manager: portage-2.2.25 Signed-off-by: Justin Lecher <jlec@gentoo.org>
* sci-misc/mendeleydesktop: Version bumpMarius Brehler2015-11-032-2/+2
| | | | Package-Manager: portage-2.2.20.1
* sci-misc/nco: Remove oldJames Le Cuirot2015-10-143-102/+0
| | | | Package-Manager: portage-2.2.20.1
* sci-misc/nco: Use dev-cpp/antlr-cpp instead of dev-java/antlrJames Le Cuirot2015-10-141-0/+50
| | | | | | | The old dependency was wrong anyway because it was missing from RDEPEND and didn't include the cxx USE flag. Package-Manager: portage-2.2.20.1
* sci-misc/mendeleydesktop: Version bumpMarius Brehler2015-10-142-2/+2
| | | | Package-Manager: portage-2.2.20.1