summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* sys-apps/shadow: Stabilize 4.11.1 ppc64, #831980Arthur Zamarin7 hours1-1/+1
| | | | Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
* sys-apps/shadow: Stabilize 4.11.1 hppa, #831980Sam James27 hours1-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* sys-apps/shadow: Stabilize 4.11.1 amd64, #831980Sam James28 hours1-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* sys-apps/shadow: Stabilize 4.9-r4 hppa, #830484Arthur Zamarin2022-01-061-1/+1
| | | | Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
* sys-apps/shadow: Stabilize 4.9-r4 sparc, #830484Sam James2022-01-031-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* sys-apps/shadow: Stabilize 4.9-r4 arm, #830484Sam James2022-01-031-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* sys-apps/shadow: Stabilize 4.9-r4 arm64, #830484Sam James2022-01-031-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* sys-apps/shadow: Stabilize 4.9-r4 ppc, #830484Sam James2022-01-031-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* sys-apps/shadow: Stabilize 4.9-r4 ppc64, #830484Sam James2022-01-031-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* sys-apps/shadow: Stabilize 4.9-r4 x86, #830484Sam James2022-01-031-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* sys-apps/shadow: Stabilize 4.9-r4 amd64, #830484Sam James2022-01-031-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* sys-apps/shadow: add 4.11.1Sam James2022-01-032-0/+257
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* sys-apps/shadow: remove uclibcDavid Seifert2022-01-014-12/+4
| | | | Signed-off-by: David Seifert <soap@gentoo.org>
* sys-apps/shadow: check for invalid passwd entriesSam James2021-12-271-3/+9
| | | | | | | | | | | | | | - In pkg_postinst, check for invalid ${EROOT}/etc/passwd entries by running 'pwck' in read-only mode. In the referenced bug, this manifested as the man cronjob failing. - Also fix another check for empty ${EROOT} (broken since EAPI 7 port). Closes: https://bugs.gentoo.org/829872 Signed-off-by: Sam James <sam@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/23534 Signed-off-by: Sam James <sam@gentoo.org>
* sys-apps/shadow: don't install 'su' man page with USE=-suSam James2021-12-201-1/+5
| | | | | Reported-by: josef64 Signed-off-by: Sam James <sam@gentoo.org>
* sys-apps/shadow: update libsubid patch to match upstream-submitted versionSam James2021-12-202-2/+12
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* sys-apps/shadow: fix PkgMetadataXmlIndentationSam James2021-12-201-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* sys-apps/shadow: fix libsubid SONAME, add subslot for libsubidSam James2021-12-203-4/+36
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* sys-apps/shadow: disable static libsubidMike Gilbert2021-12-191-0/+2
| | | | | Closes: https://bugs.gentoo.org/829686 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
* sys-apps/shadow: fix IndirectInheritsSam James2021-12-191-1/+1
| | | | | | Whoops. Signed-off-by: Sam James <sam@gentoo.org>
* sys-apps/shadow: add 4.10Sam James2021-12-192-0/+246
| | | | | | | | | | | | | Note that 'su' is now disabled by default (IUSE="su", not IUSE="+su"), see from the release notes: ``` Note: From this release forward, su from this package should be considered deprecated. Please replace any users of it with su from util-linux. Please open an issue if there is a problem with that. We intend to remove it in an upcoming release. ``` Signed-off-by: Sam James <sam@gentoo.org>
* sys-apps/shadow: backport upstream patch for crashSam James2021-11-143-0/+305
| | | | | | Also throw in a configure typo patch, given we're calling eautoreconf anyway. Signed-off-by: Sam James <sam@gentoo.org>
* sys-apps/shadow: stable 4.9-r3 for hppa, bug #813687Rolf Eike Beer2021-11-051-1/+1
| | | | | | | Package-Manager: Portage-3.0.28, Repoman-3.0.3 RepoMan-Options: --include-arches="hppa" Signed-off-by: Rolf Eike Beer <eike@sf-mail.de> Signed-off-by: Sam James <sam@gentoo.org>
* sys-apps/shadow: drop libsubid.laMike Gilbert2021-10-201-6/+1
| | | | Signed-off-by: Mike Gilbert <floppym@gentoo.org>
* sys-apps/shadow: Stabilize 4.9-r2 arm64, #813687Sam James2021-10-021-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* sys-apps/shadow: Stabilize 4.9-r2 ppc, #813687Sam James2021-09-211-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* sys-apps/shadow: Stabilize 4.9-r2 arm, #813687Sam James2021-09-201-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* sys-apps/shadow: x86 stable wrt bug #813687Agostino Sarubbo2021-09-191-1/+1
| | | | | | Package-Manager: Portage-3.0.20, Repoman-3.0.3 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* sys-apps/shadow: Stabilize 4.9-r2 sparc, #813687Sam James2021-09-181-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* sys-apps/shadow: Stabilize 4.9-r2 ppc64, #813687Sam James2021-09-181-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* sys-apps/shadow: Stabilize 4.9-r2 amd64, #813687Sam James2021-09-181-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* **/metadata.xml: Replace http by https in DOCTYPE elementUlrich Müller2021-09-111-1/+1
| | | | | Bug: https://bugs.gentoo.org/552720 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* sys-apps/shadow: fix SHA hash behavior with USE=-pamMike Gilbert2021-08-142-0/+58
| | | | | Closes: https://bugs.gentoo.org/808195 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
* sys-apps/shadow: fix build with cracklib enabledMike Gilbert2021-08-042-0/+28
| | | | | Closes: https://bugs.gentoo.org/806124 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
* sys-apps/shadow: destabilize 4.9-r1Sam James2021-07-271-1/+1
| | | | | | | Was pushed as stable. Fixes: 094b04485ed2967a788dc20912de0cc76d2f47ab Signed-off-by: Sam James <sam@gentoo.org>
* sys-apps/shadow: Consolidate blocker against man-pages-jaUlrich Müller2021-07-272-2/+2
| | | | | Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* sys-apps/shadow: Revbump to install man pagesLars Wendler2021-07-251-0/+3
| | | | Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
* sys-apps/shadow: Bump to version 4.9Lars Wendler2021-07-254-0/+387
| | | | Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
* sys-apps/shadow: Fix whitespaceUlrich Müller2021-07-241-1/+1
| | | | | Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* sys-apps/shadow: Add blockers against app-i18n/man-pages-*Ulrich Müller2021-07-241-0/+5
| | | | | | | | File collision for passwd.5 man page Bug: https://bugs.gentoo.org/803587 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* sys-apps/shadow: Install the passwd.5 man pageUlrich Müller2021-07-231-2/+5
| | | | | | | | | This needs a somewhat awkward blocker against sys-apps/man-pages, which can be simplified when >=man-pages-5.12-r2 becomes stable. Bug: https://bugs.gentoo.org/776787 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* sys-apps/shadow: remove unused patchMichael Mair-Keimberger2021-07-101-15/+0
| | | | | | | Closes: https://github.com/gentoo/gentoo/pull/20873 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
* sys-apps/shadow: ...and sparcMikle Kolyada2021-05-151-1/+1
| | | | | Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
* sys-apps/shadow: Drop oldMikle Kolyada2021-05-152-242/+0
| | | | | Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
* sys-apps/shadow: mark stableMikle Kolyada2021-05-151-1/+1
| | | | | Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
* sys-apps/shadow: libtool--Sam James2021-04-212-5/+5
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* sys-apps/shadow: drop s390 to ~s390 (unstable)Sam James2021-04-051-2/+2
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* Revert "sys-apps/shadow: require the mail group at runtime"Mike Gilbert2020-09-082-2/+0
| | | | | | | | | | The acct-{user,group} eclasses call useradd and groupadd to create users and groups. This is esentually a circular dependency that needs to be resolved somehow. Bug: https://bugs.gentoo.org/720948 Reverts: f065b54fc2420c72d1d248b6a96c52c81f00d141 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
* sys-apps/shadow: require the mail group at runtimeDavid Michael2020-09-072-0/+2
| | | | | | | Closes: https://bugs.gentoo.org/720948 Package-Manager: Portage-3.0.4, Repoman-2.3.23 Signed-off-by: David Michael <fedora.dm0@gmail.com> Signed-off-by: Mike Gilbert <floppym@gentoo.org>
* sys-apps/shadow: fix cracklib dictonary pathMikle Kolyada2020-08-212-2/+2
| | | | | | Closes: https://bugs.gentoo.org/714012 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>