summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* sys-auth/pambase: Drop oldMikle Kolyada2020-11-043-200/+0
| | | | | Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
* sys-auth/pambase: merge stable keywordsMikle Kolyada2020-11-041-1/+1
| | | | | Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
* sys-auth/pambase: regenerate manifestSam James2020-11-031-1/+1
| | | | | Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
* sys-auth/pambase: bump to 20201103Sam James2020-11-032-0/+101
| | | | | | Bug: https://bugs.gentoo.org/751946 Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
* sys-auth/pambase: advance stable keywordsMikle Kolyada2020-10-291-1/+1
| | | | | Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
* sys-auth/pambase: Version bump (v20201028.1)Mikle Kolyada2020-10-282-1/+1
| | | | | Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
* sys-auth/pambase: Version bump (v20201028)Mikle Kolyada2020-10-282-1/+1
| | | | | Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
* sys-auth/pambase: cleanup redundant versionSam James2020-10-272-100/+0
| | | | | Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
* sys-auth/pambase: bump to 20201026Sam James2020-10-272-0/+100
| | | | | | | | | | | | Sam James (3): templates/system-login.tpl: always need faillock templates/system-auth.tpl: skip pam_unix with krb5 templates/system-auth.tpl: fix libcap module name Bug: https://bugs.gentoo.org/750524 Bug: https://bugs.gentoo.org/748405 Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
* sys-auth/pambase: add 20201020Sam James2020-10-202-0/+100
| | | | | | | | Includes faillock in minimal case. Bug: https://bugs.gentoo.org/748405 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
* sys-auth/pambase: Drop oldMikle Kolyada2020-10-133-200/+0
| | | | | Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
* sys-auth/pambase: Version bump (v20201013)Mikle Kolyada2020-10-132-0/+100
| | | | | Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
* sys-auth/pambase: Version bump (v20201010)Mikle Kolyada2020-10-102-0/+100
| | | | | | | | pam_faillock.so can now be managed via the /etc/security/faillock.conf file Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
* sys-auth/pambase: Drop oldMikle Kolyada2020-10-103-91/+0
| | | | | Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
* sys-auth/pambase: mark stableMikle Kolyada2020-10-101-1/+1
| | | | | Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
* sys-auth/pambase: define DOC_CONTENTS var as localMikle Kolyada2020-10-101-1/+1
| | | | | Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
* sys-auth/pambase: remove consolekit supportMikle Kolyada2020-10-042-9/+2
| | | | | Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
* sys-auth/pambase: Drop oldMikle Kolyada2020-09-202-80/+0
| | | | | Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
* sys-auth/pambase: improve readme handelingMikle Kolyada2020-09-201-2/+2
| | | | | Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
* sys-auth/pambase: change README callSam James2020-09-181-3/+3
| | | | | | Closes: https://bugs.gentoo.org/743202 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
* sys-auth/pambase: Version bump (v20200917)Mikle Kolyada2020-09-183-5/+110
| | | | | | | | * swith pam_passwdqc and pam_pwquality to its config files * add optional pam_pwhistory module Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
* sys-auth/pambase: Drop oldMikle Kolyada2020-08-292-73/+0
| | | | | Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
* sys-auth/pambase: Version bump (v20200817)Mikle Kolyada2020-08-172-2/+4
| | | | | Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
* profiles/riscv: mask pambase[gnome-keyring]Mikle Kolyada2020-08-171-0/+0
| | | | Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
* sys-auth/pambase: Version bump (v20200815)Mikle Kolyada2020-08-163-4/+85
| | | | | | | This version introduces pam_pwquality support Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
* sys-auth/pambase: fix cross-installMikle Kolyada2020-08-101-1/+1
| | | | | | Closes: https://bugs.gentoo.org/736631 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
* sys-auth/pambase: Drop oldMikle Kolyada2020-08-092-85/+0
| | | | | Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
* sys-auth/pambase: bump to 20200806Sam James2020-08-072-1/+1
| | | | | | | Fixes OpenRC compatibility. Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Sam James <sam@gentoo.org>
* sys-auth/pambase: join as co-maintainerSam James2020-08-061-0/+4
| | | | | | | | Zlogene and I rewrote pambase in Python, so I'm now involved here! Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Sam James <sam@gentoo.org>
* sys-auth/pambase: Version bump (v20200805)Mikle Kolyada2020-08-052-0/+73
| | | | | Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
* sys-auth/pambase: Drop oldMikle Kolyada2020-08-052-73/+0
| | | | | Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
* sys-auth/pambase: install files via pam.eclassMikle Kolyada2020-08-041-4/+2
| | | | | Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
* sys-auth/pambase: go back to underscored flagsMikle Kolyada2020-08-041-2/+2
| | | | | | | will be fixed once old versions are gone Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
* sys-auth/pambase: Version bump (v20200804)Mikle Kolyada2020-08-042-0/+75
| | | | | Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
* sys-auth/pambase: Drop oldMikle Kolyada2020-08-043-178/+0
| | | | | Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
* sys-auth/pambase: ALLARCHES stable (via amd64, bug #733584)Sam James2020-07-281-1/+1
| | | | | | Closes: https://bugs.gentoo.org/733584 Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Sam James <sam@gentoo.org>
* sys-auth/pambase: amd64 stable (bug #733584)Sam James2020-07-281-1/+1
| | | | | Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Sam James <sam@gentoo.org>
* sys-auth/pambase: Remove unnecessary CPP args in src_installDavid Seifert2020-07-034-4/+4
| | | | | Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: David Seifert <soap@gentoo.org>
* sys-auth/pambase: Fix USE="native-symlinks"David Seifert2020-07-034-4/+16
| | | | | | | Closes: https://bugs.gentoo.org/719212 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Suggested-by: Sergei Trofimovich <slyfox@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
* sys-auth/pambase: version bump (v20200618)Mikle Kolyada2020-06-182-1/+1
| | | | | Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
* sys-auth/pambase: Drop oldMikle Kolyada2020-06-172-82/+0
| | | | | Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
* sys-auth/pambase: Version bump (v20200617)Mikle Kolyada2020-06-172-0/+82
| | | | | Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
* sys-auth/pambase: remanifestMikle Kolyada2020-06-161-1/+1
| | | | | Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
* sys-auth/pambase: Version bump (v20200616)Mikle Kolyada2020-06-162-0/+82
| | | | | Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
* sys-auth/pambase: enable pam[cracklib] if only possibleMikle Kolyada2020-06-093-3/+3
| | | | | Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
* */*: downgrade m68k down to ~m68kSergei Trofimovich2020-04-211-1/+1
| | | | | | | | | m68k and ~m68k trees are inconsistent. Let's drop keywords down to ~m68k only. Profiles already accept both keywords: ACCEPT_KEYWORDS="m68k ~m68k" Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
* */*: Drop stable ia64 keywordsMatt Turner2020-04-031-1/+1
| | | | Signed-off-by: Matt Turner <mattst88@gentoo.org>
* */*: Discontinue Gentoo SuperH portMikle Kolyada2020-03-263-4/+4
| | | | | | Package-Manager: Portage-2.3.89, Repoman-2.3.20 RepoMan-Options: --ignore-arches Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
* sys-auth/pambase: Version bump (v20200304)Mikle Kolyada2020-03-072-0/+84
| | | | | Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
* */*: Bump copyright on files touched this yearMichał Górny2020-02-111-1/+1
| | | | | | | Update the copyright notice on all files that were touched since January 1st but did not have the notice updated. Signed-off-by: Michał Górny <mgorny@gentoo.org>