summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* sys-cluster/ampi: keyword 0_pre20140616 for ~riscv, EAPI 5 -> 8Marek Szuba2021-07-141-3/+4
| | | | Signed-off-by: Marek Szuba <marecki@gentoo.org>
* sys-cluster/ceph-16.2.5: Version bumpPatrick McLean2021-07-132-0/+451
| | | | | Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
* sys-cluster/ceph: add missing libcrypt dependencySam James2021-07-102-0/+2
| | | | | Closes: https://bugs.gentoo.org/801181 Signed-off-by: Sam James <sam@gentoo.org>
* sys-cluster/zookeeper-bin: bump to new versionMarco Scardovi2021-07-102-0/+69
| | | | | | | | | | | Also fixed GLEP 81. Closes: https://github.com/gentoo/gentoo/pull/21204 Closes: https://bugs.gentoo.org/678310 Closes: https://bugs.gentoo.org/781503 Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Marco Scardovi <marco@scardovi.com> Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
* sys-cluster/charliecloud: Fix configure with dash shell.Oliver Freyermuth2021-07-083-0/+22
| | | | | | | | Closes: https://bugs.gentoo.org/799377 Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Oliver Freyermuth <o.freyermuth@googlemail.com> Closes: https://github.com/gentoo/gentoo/pull/21489 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* sys-cluster/charliecloud: Drop unnecessary patch from 0.24.Oliver Freyermuth2021-07-081-4/+0
| | | | | | | | | This patch is already upstream in this version and not needed anymore. Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Oliver Freyermuth <o.freyermuth@googlemail.com> Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* sys-cluster/slurm: keyword 20.11.0.1-r101 for ~riscvMarek Szuba2021-07-051-1/+1
| | | | Signed-off-by: Marek Szuba <marecki@gentoo.org>
* sys-cluster/slurm: only call lua-single_pkg_setup when USE=lua is setMarek Szuba2021-07-051-0/+4
| | | | | | | | Calling this unconditionally can be a problem when the default Lua target is not available on a certain architecture, as it is currently the case with lua5-1 on riscv. Signed-off-by: Marek Szuba <marecki@gentoo.org>
* sys-cluster/ucx: keyword 1.10.0_rc5 for -riscvMarek Szuba2021-07-051-1/+1
| | | | | | | | "#error: Unsupported architecture". According to the source code (i.e. git master on GitHub), ucx currently only supports amd64, arm64 and ppc64. Signed-off-by: Marek Szuba <marecki@gentoo.org>
* sys-cluster/torque: keyword 6.0.4-r1 for ~riscvMarek Szuba2021-07-051-1/+1
| | | | Signed-off-by: Marek Szuba <marecki@gentoo.org>
* sys-cluster/openmpi: keyword 4.0.5-r1 for ~riscvMarek Szuba2021-07-051-1/+1
| | | | Signed-off-by: Marek Szuba <marecki@gentoo.org>
* sys-cluster/nullmpi: keyword 0.7 for ~riscvMarek Szuba2021-07-051-2/+2
| | | | | | | Not exactly the most useful MPI implementation out there - but at least now we've got SOMETHING to allow us to keyword virtual/mpi here. Signed-off-by: Marek Szuba <marecki@gentoo.org>
* sys-cluster/kops: Version bump (v1.21.0)Mikle Kolyada2021-07-032-0/+2365
| | | | | Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
* sys-cluster/ceph: revbumps, add libcrypt virtualPatrick McLean2021-06-303-1/+3
| | | | | Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
* sys-cluster/ceph-14.2.22: Version bumpPatrick McLean2021-06-305-0/+488
| | | | | Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
* sys-cluster/charliecloud: Drop old.Oliver Freyermuth2021-06-302-81/+0
| | | | | | Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Oliver Freyermuth <o.freyermuth@googlemail.com> Signed-off-by: Nicolas Bock <nicolasbock@gentoo.org>
* sys-cluster/charliecloud: Bump to version 0.24.Oliver Freyermuth2021-06-302-0/+81
| | | | | | Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Oliver Freyermuth <o.freyermuth@googlemail.com> Signed-off-by: Nicolas Bock <nicolasbock@gentoo.org>
* sys-cluster/lmod: keyworded 8.5.6 for ppc64Sergei Trofimovich2021-06-241-1/+1
| | | | | | | | keyworded wrt bug #773313 Package-Manager: Portage-3.0.20, Repoman-3.0.3 RepoMan-Options: --include-arches="ppc64" Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
* sys-cluster/ganglia: add virtual/libcrypt dependencySam James2021-06-221-2/+3
| | | | | | | | Needed for upcoming libcrypt migration. Acked-by: David Seifert <soap@gentoo.org> Reported-by: Ulrich Müller <ulm@gentoo.org> Signed-off-by: Sam James <sam@gentoo.org>
* sys-cluster/lmod: sync KEYWORDS with live ebuildGuilherme Amadio2021-06-221-1/+1
| | | | | Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
* sys-cluster/lmod: drop oldGuilherme Amadio2021-06-222-133/+0
| | | | | Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
* sys-cluster/lmod: version bump to 8.5.6Guilherme Amadio2021-06-222-0/+131
| | | | | | | | This version has a fix for the prefix issue that needed a workaround in 8.5.3. Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
* sys-cluster/lmod: fix on prefixGuilherme Amadio2021-06-211-0/+2
| | | | | | | | | Build system has CPPFLAGS="-I $TCL_INCLUDE", which breaks if the TCL_INCLUDE returned by pkg-config is empty. However, this only affects prefix. Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
* sys-cluster/lmod: version bump to 8.5.3Aisha Tammy2021-06-212-0/+131
| | | | | | | | Closes: https://github.com/gentoo/gentoo/pull/21274 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Aisha Tammy <gentoo@aisha.cc> Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
* profiles/package.mask: Remove some openstack-related packagesMatthew Thode2021-06-1953-3291/+0
| | | | | | | | Removed due to high-burden and unmaintainable python requirements. Closes: https://bugs.gentoo.org/793800 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
* sys-cluster/gmqtt: Remove old version 0.3.0Zac Medico2021-06-192-436/+0
| | | | | Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Zac Medico <zmedico@gentoo.org>
* sys-cluster/gmqtt: Bump to version 0.3.2Zac Medico2021-06-192-0/+436
| | | | | Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Zac Medico <zmedico@gentoo.org>
* sys-cluster/ceph: Depend on dev-libs/boost:=[threads(+)]David Seifert2021-06-184-4/+4
| | | | | | Closes: https://github.com/gentoo/gentoo/pull/21309 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: David Seifert <soap@gentoo.org>
* sys-cluster/glusterfs: rev bump for commit c34e8b1a0Thomas Deutschmann2021-06-186-0/+0
| | | | | Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
* sys-cluster/ganglia-web: rev bump for commit 04dfa1ac6Thomas Deutschmann2021-06-181-0/+0
| | | | | Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
* sys-cluster/glusterfs: Fix MissingUseDepDefault for dev-libs/openssl[bindist]Thomas Deutschmann2021-06-176-6/+6
| | | | | Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
* sys-cluster/ganglia-web: Fix MissingUseDepDefault for dev-lang/php[json]Thomas Deutschmann2021-06-171-2/+2
| | | | | Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
* sys-cluster/singularity: add 3.8.0Marek Szuba2021-06-162-0/+72
| | | | Signed-off-by: Marek Szuba <marecki@gentoo.org>
* sys-cluster/openmpi: drop defaulting on libompitraceJoonas Niilola2021-06-151-1/+1
| | | | Signed-off-by: Joonas Niilola <juippis@gentoo.org>
* sys-cluster/openmpi: add peruse and libompitrace useflagsAlessandro Barbieri2021-06-152-2/+180
| | | | | | | | Closes: https://bugs.gentoo.org/784278 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/20480 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
* sys-cluster/ucx: drop -WerrorSam James2021-06-152-4/+61
| | | | | | | Closes: https://bugs.gentoo.org/789762 Closes: https://bugs.gentoo.org/790341 Closes: https://bugs.gentoo.org/790332 Signed-off-by: Sam James <sam@gentoo.org>
* sys-cluster/mpe2: fix VariableScope (ROOT)Sam James2021-06-111-3/+3
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* sys-cluster/sanlock: fix VariableScope (EROOT)Sam James2021-06-111-6/+16
| | | | | | EROOT is not defined in src_install. Signed-off-by: Sam James <sam@gentoo.org>
* sys-cluster/galera: Stabilize 26.4.8 amd64, #789240Sam James2021-06-091-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* sys-cluster/kube-scheduler: remove old versionsWilliam Hubbs2021-06-095-159/+0
| | | | | Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: William Hubbs <williamh@gentoo.org>
* sys-cluster/kube-proxy: remove old versionsWilliam Hubbs2021-06-095-143/+0
| | | | | Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: William Hubbs <williamh@gentoo.org>
* sys-cluster/kubelet: remove old versionsWilliam Hubbs2021-06-095-151/+0
| | | | | Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: William Hubbs <williamh@gentoo.org>
* sys-cluster/kubectl: remove old versionsWilliam Hubbs2021-06-095-139/+0
| | | | | Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: William Hubbs <williamh@gentoo.org>
* sys-cluster/kube-controller-manager: remove old versionsWilliam Hubbs2021-06-095-159/+0
| | | | | Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: William Hubbs <williamh@gentoo.org>
* sys-cluster/kube-apiserver: remove old versionsWilliam Hubbs2021-06-095-163/+0
| | | | | | Bug: https://bugs.gentoo.org/791256 Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: William Hubbs <williamh@gentoo.org>
* sys-cluster/kubeadm: remove old versionsWilliam Hubbs2021-06-095-139/+0
| | | | | Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: William Hubbs <williamh@gentoo.org>
* sys-cluster/ceph-16.2.4-r1: Revbump, force snappy < 1.1.9 (bug #794514)Patrick McLean2021-06-081-1/+1
| | | | | | | Closes: https://bugs.gentoo.org/794514 Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
* sys-cluster/kube-scheduler: stabilize 1.18.19 on amd64William Hubbs2021-06-071-1/+1
| | | | Signed-off-by: William Hubbs <williamh@gentoo.org>
* sys-cluster/kube-proxy: stabilize 1.18.19 on amd64William Hubbs2021-06-071-1/+1
| | | | Signed-off-by: William Hubbs <williamh@gentoo.org>
* sys-cluster/kubelet: stabilize 1.18.19 on amd64William Hubbs2021-06-071-1/+1
| | | | Signed-off-by: William Hubbs <williamh@gentoo.org>