summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* sys-libs/libcap: stable 2.25 for ppc, bug #660334Sergei Trofimovich2018-09-081-1/+1
| | | | | | Tested-by: ernsteiswuerfel Package-Manager: Portage-2.3.49, Repoman-2.3.10 RepoMan-Options: --include-arches="ppc"
* sys-libs/glibc: version 2.26-r7 stable on ppc64, bug #657148Anthony G. Basile2018-09-051-1/+1
| | | | Package-Manager: Portage-2.3.40, Repoman-2.3.9
* sys-libs/glibc: version 2.26-r7 stable on ppc, bug #657148Anthony G. Basile2018-09-051-1/+1
| | | | Package-Manager: Portage-2.3.40, Repoman-2.3.9
* sys-libs/compiler-rt-sanitizers: Add missing dep on libtirpcMichał Górny2018-09-053-0/+3
|
* sys-libs/compiler-rt-sanitizers: Add new glibc fixes to live ebuildsMichał Górny2018-09-052-2/+10
|
* sys-libs/compiler-rt-sanitizers: Inline new glibc patchesMichał Górny2018-09-053-7/+171
| | | | | | Inline the patches needed for new glibc (with split tirpc) since they have not been merged upstream, and are appropriately needed for -9999 as well.
* Drop arm-linux keyword from tree.Benda Xu2018-08-3131-31/+31
| | | | | | | | "arm-linux" is considered deprecated, unmaintained and easily replaced by "arm". Closes: https://bugs.gentoo.org/664598 Reference: https://archives.gentoo.org/gentoo-dev/message/63bafa051cccd1eb3d2ade16823671fa
* sys-libs/libunwind: upstream lacks sparc platform supportRolf Eike Beer2018-08-303-4/+4
| | | | | Package-Manager: Portage-2.3.40, Repoman-2.3.9 RepoMan-Options: --include-arches="sparc"
* sys-libs/timezone-data: mark 2018e stable for allThomas Deutschmann2018-08-301-1/+1
| | | | Package-Manager: Portage-2.3.48, Repoman-2.3.10
* sys-libs/libomp: Bump to 7.0.0rc2Michał Górny2018-08-282-0/+116
|
* sys-libs/libcxx: Bump to 7.0.0rc2Michał Górny2018-08-282-0/+210
|
* sys-libs/libcxxabi: Bump to 7.0.0rc2Michał Górny2018-08-282-0/+121
|
* sys-libs/llvm-libunwind: Bump to 7.0.0rc2Michał Górny2018-08-282-0/+146
|
* sys-libs/compiler-rt-sanitizers: Bump to 7.0.0rc2Michał Górny2018-08-282-0/+178
|
* sys-libs/compiler-rt: Bump to 7.0.0rc2Michał Górny2018-08-282-0/+110
|
* sys-libs/binutils-libs: cut 2 patchset for 2.31.1Sergei Trofimovich2018-08-272-3/+3
| | | | | | | | | Single new patch to fix build failure against llvm: + 0013-Fix-type-checking-errors.patch Reported-by: David Carlos Manuelda Closes: https://bugs.gentoo.org/663194 Package-Manager: Portage-2.3.48, Repoman-2.3.10
* sys-libs/libudev-compat: Bump EAPI to 7, drop multilib.eclass (unused)Jonathan Callen2018-08-261-3/+3
| | | | Package-Manager: Portage-2.3.46, Repoman-2.3.10
* sys-libs/glibc: Stable for HPPA too.Jeroen Roovers2018-08-241-1/+1
| | | | | Package-Manager: Portage-2.3.48, Repoman-2.3.10 RepoMan-Options: --ignore-arches
* sys-libs/gdbm: Removed old.Lars Wendler2018-08-242-49/+0
| | | | Package-Manager: Portage-2.3.48, Repoman-2.3.10
* sys-libs/gdbm: Bump to version 1.18Lars Wendler2018-08-242-0/+49
| | | | Package-Manager: Portage-2.3.48, Repoman-2.3.10
* sys-libs/ldb: bump to v1.5.1Thomas Deutschmann2018-08-232-0/+106
| | | | Package-Manager: Portage-2.3.48, Repoman-2.3.10
* sys-libs/e2fsprogs-libs: bump to v1.44.4Thomas Deutschmann2018-08-222-0/+95
| | | | | | | - USE=nls dropped because package only installs libss and libcom-err which don't have native language support. Package-Manager: Portage-2.3.48, Repoman-2.3.10
* sys-libs/libcap: stable 2.25 for ppc64, bug #660334Sergei Trofimovich2018-08-181-1/+1
| | | | | Package-Manager: Portage-2.3.46, Repoman-2.3.10 RepoMan-Options: --include-arches="ppc64"
* sys-libs/nss_wrapper: Drop 1.1.2Andreas Sturmlechner2018-08-182-25/+0
| | | | | | 1.1.3 is stable for a long time. Package-Manager: Portage-2.3.47, Repoman-2.3.10
* sys-libs/talloc: mark s390 stableMikle Kolyada2018-08-171-1/+1
| | | | Package-Manager: Portage-2.3.40, Repoman-2.3.9
* sys-libs/compiler-rt: Drop 6.0.9999Michał Górny2018-08-151-111/+0
|
* sys-libs/compiler-rt-sanitizers: Drop 6.0.9999Michał Górny2018-08-151-171/+0
|
* sys-libs/llvm-libunwind: Drop 6.0.9999Michał Górny2018-08-151-146/+0
|
* sys-libs/libcxxabi: Drop 6.0.9999Michał Górny2018-08-151-122/+0
|
* sys-libs/libcxx: Drop 6.0.9999Michał Górny2018-08-151-221/+0
|
* sys-libs/libomp: Drop 6.0.9999Michał Górny2018-08-151-116/+0
|
* sys-libs/ldb: Removed old.Lars Wendler2018-08-152-106/+0
| | | | Package-Manager: Portage-2.3.46, Repoman-2.3.10
* sys-libs/ldb: Bump to versions 1.3.5, 1.4.2 and 1.5.0Lars Wendler2018-08-154-0/+316
| | | | Package-Manager: Portage-2.3.46, Repoman-2.3.10
* sys-libs/libblockdev: Removed old.Lars Wendler2018-08-132-98/+0
| | | | Package-Manager: Portage-2.3.46, Repoman-2.3.10
* sys-libs/libblockdev: Bump to version 2.19Lars Wendler2018-08-132-0/+96
| | | | Package-Manager: Portage-2.3.46, Repoman-2.3.10
* sys-libs/librtas: Version bumpLuca Barbato2018-08-122-0/+23
| | | | Package-Manager: Portage-2.3.40, Repoman-2.3.9
* sys-libs/libcxx: Use -print-libgcc-file-name to get clang_rt pathMichał Górny2018-08-095-50/+30
| | | | | Suggested-by: David Carlos Manuelda Bug: https://bugs.gentoo.org/592326
* sys-libs/binutils-libs: Restore keywords of 2.31.1Andreas K. Hüttel2018-08-071-0/+1
| | | | Package-Manager: Portage-2.3.44, Repoman-2.3.10
* sys-libs/gdbm: fix compilation with clang, bug #662840Guilherme Amadio2018-08-062-0/+13
| | | | | Closes: https://bugs.gentoo.org/662840 Package-Manager: Portage-2.3.44, Repoman-2.3.10
* sys-libs/glibc: Restore keywords of 2.27-r6Andreas K. Hüttel2018-08-061-1/+1
| | | | Package-Manager: Portage-2.3.44, Repoman-2.3.10
* sys-libs/glibc: 2.27 revision bump (patchlevel 3)Andreas K. Hüttel2018-08-052-0/+1419
| | | | | | Tests pass here Package-Manager: Portage-2.3.44, Repoman-2.3.10
* sys-libs/binutils-libs: Remove oldAndreas K. Hüttel2018-08-042-107/+0
| | | | Package-Manager: Portage-2.3.44, Repoman-2.3.10
* sys-libs/glibc: Version bump (2.28), untested, unkeywordedAndreas K. Hüttel2018-08-032-0/+1431
| | | | Package-Manager: Portage-2.3.44, Repoman-2.3.10
* sys-libs/glibc: Needs at least GNU Make 4 to buildAndreas K. Hüttel2018-08-031-0/+1
| | | | Package-Manager: Portage-2.3.44, Repoman-2.3.10
* sys-libs/glibc: Add rudimentary Intel CET support (since glibc-2.29)Andreas K. Hüttel2018-08-032-1/+8
| | | | | | | Before unmasking this flag we still need to add checks for binutils >=2.29 and gcc >=8 ... Package-Manager: Portage-2.3.44, Repoman-2.3.10
* sys-libs/glibc: Bump 9999 patchlevelAndreas K. Hüttel2018-08-032-2/+2
| | | | Package-Manager: Portage-2.3.44, Repoman-2.3.10
* sys-libs/musl: stable on arm64Anthony G. Basile2018-08-021-1/+1
| | | | Package-Manager: Portage-2.3.40, Repoman-2.3.9
* sys-libs/musl: remove older stable versionAnthony G. Basile2018-08-022-119/+0
| | | | Package-Manager: Portage-2.3.40, Repoman-2.3.9
* sys-libs/musl: keyword ~arm64Anthony G. Basile2018-08-022-2/+2
| | | | Package-Manager: Portage-2.3.40, Repoman-2.3.9
* sys-libs/libomp: Branch out LLVM 7.0Michał Górny2018-08-011-0/+116
|