summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* x11-drivers/nvidia-drivers: bump kernel max to 6.0 where possibleIonen Wolkens36 hours3-3/+3
| | | | | | Only minimal runtime testing, but all 515.x seem fine with final 6.0.0. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* x11-drivers/nvidia-drivers: prepare for atk migrationIonen Wolkens3 days6-6/+6
| | | | | | | | | Non-stable so can't remove deprecated atk yet, but given nvidia-drivers are rebuilt with every kernel upgrades can start propagating this without revbump and eventually cleanup the alternative. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* x11-drivers/nvidia-drivers: note link for >=5.18.13 sysfb issuesIonen Wolkens3 days6-0/+6
| | | | | | | | | Meant to add this in the first place but forgot. Not a super useful link given it's actually being handled on nvidia's private bug tracker, but can still get some random feedback. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* x11-drivers/nvidia-drivers: patch 515.65.01 for >=kernel-6.0-rc1Ionen Wolkens3 days2-0/+25
| | | | | | | | | | Mostly because the fixed 515.76 is masked. Meant to fix more versions, but older branches have other problems. Unlikely to break again between -rc7 and release, but still skipping updating NV_KERNEL_MAX until can try 6.0.0. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* x11-drivers/nvidia-drivers: note that the FB warning can be ignoredIonen Wolkens4 days6-18/+24
| | | | | | | | | | Varied configuration is part of why I haven't included these kind of warnings before (may be noisy for some) -- but getting a console to work with nvidia has become near nonsensial unless know exactly what still works (between my own kernel and gentoo-kernel-bin-5.15.x I didn't really notice these new issues). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* x11-drivers/nvidia-drivers: warn about simpledrm again + FB/nouveauIonen Wolkens4 days6-6/+372
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Thought SIMPLEDRM issues had improved. Last time I tried, X was still working just without tty console display so not "that" bad (that was with kernel 5.14.x or so). gentoo-kernel-bin uses Fedora's configs which enables SIMPLEDRM since 5.17.x or so. Formerly without FB_EFI then later re-enabled (was under the impression this improved things, but I only try -bin when stabilizing drivers, so 5.15.x), however SIMPLEDRM=y takes priority and X/wayland breaks entirely and then messes up the tty (worse than before). Difference between gentoo-kernel-bin and Fedora's is that they now patch their kernel to let this configuration work: https://src.fedoraproject.org/rpms/kernel/blob/e762b5dd/f/patch-5.19-redhat.patch#_882 (seems they do not do this for kernel-6.0, unsure for status with it) Have not found a (working) way to disable SIMPLEDRM from the kernel's commandline, so merely adding a warning for bug #840439 if it's builtin For FB_EFI or FB_VESA to work (aka get a console), also need to disable SYSFB_SIMPLEFB. FB_SIMPLE seems broken since kernel-5.18.13 due to another issue. Albeit this doesn't stop X from working. Ideal would be for gentoo-kernel* to do it by default, but non-bin gentoo-kernel users using the generic config can (tested with 5.19.12): mkdir -p /etc/kernel/config.d && cat <<EOF > /etc/kernel/config.d/50nvidia.config # CONFIG_DRM_SIMPLEDRM is not set # CONFIG_SYSFB_SIMPLEFB is not set EOF (this is what gentoo-kernel-bin-5.15.x has) While here also add an overdue warning for builtin nouveau (formerly skipped given CONFIG_CHECK was unsuitable), and try to inform about making the tty console work even though nvidia-drivers doesn't drive it. Bug: https://bugs.gentoo.org/840439 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* x11-drivers/nvidia-drivers: add 515.49.19:0/vulkan, drop 515.49.18Ionen Wolkens4 days2-2/+2
| | | | Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* x11-drivers/xf86-video-glint: Remove last-rited pkgJakov Smolić6 days3-24/+0
| | | | | Closes: https://bugs.gentoo.org/828426 Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
* x11-drivers/nvidia-drivers: depend on gtk+:3[X] with USE=toolsIonen Wolkens7 days6-6/+6
| | | | | | | | | | | | | | fatal error: gdk/gdkx.h: No such file or directory nvidia-settings is already barely functional on wayland and depends on other X libs, so users that want to skip X altogether are advised to USE=-tools (albeit remember lose xwayland support with -X). Skipping revbump given low-impact (even if built /then/ disable USE=X on gtk, nvidia-settings is currently unimportant on wayland). nvidia-drivers gets rebuild often on kernel upgrades too. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* x11-drivers/nvidia-drivers: add 515.49.18:0/vulkan, drop 515.49.15Ionen Wolkens8 days2-2/+2
| | | | Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* x11-drivers/nvidia-drivers: drop unnecessary patchesIonen Wolkens8 days8-83/+0
| | | | | | | | | | | | | Ended up using -Werror=strict-prototypes to test things, but as far as I'm aware this shouldn't be "needed" with clang16 either unless something passes that -Werror (so kernel module still need these fixes). Not that it'd hurt to fix but don't want to maintain patches on this end. Will revisit if needed. nvidia is aware of modules issues regarding this, so clang15 patches should be removable later Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* x11-drivers/nvidia-drivers: adjust clang, recognize KERNEL_CC/LDIonen Wolkens10 days6-18/+30
| | | | | | | | | | | | Still feels a bit crude (ideally this should be handled by the linux-mod eclass), but recognizing some env var will let users adjust themselves to some extend for now (e.g. to select different clang version). Also keep current CC value if it's clang, albeit not checking tc-ld-is-lld given -fuse-ld=lld means nothing here. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* x11-drivers/nvidia-drivers: fix clang15 patch for x86Ionen Wolkens13 days2-1/+30
| | | | | | Oops, differs given x86 dropped support for the uvm module. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* x11-drivers/nvidia-drivers: add 515.76Ionen Wolkens2022-09-202-0/+519
| | | | Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* x11-drivers/nvidia-drivers: early clang16 fixesIonen Wolkens2022-09-197-0/+82
| | | | | | | | | | | | Or more specifically, -Werror=strict-prototypes fixes. This is for the extras (settings/modprobe/persistenced) given modules already needed to be fixed with clang15 even post-revert given they pass -Werror=strict-prototypes themselves. Done as a separate patch given the clang15 one need to be re-applied without the extras to open source drivers. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* x11-drivers/nvidia-drivers: clarify clang15 patch notesIonen Wolkens2022-09-192-0/+4
| | | | | | | That this still fails regardless of 15.0.0-r1/15.0.1 revert may not have been clear, this is the makefiles requesting it. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* x11-drivers/nvidia-drivers: fix building modules with clang15Ionen Wolkens2022-09-167-0/+199
| | | | | Closes: https://bugs.gentoo.org/870238 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* */*: Standardize architecture team namesMatt Turner2022-09-081-1/+1
| | | | Signed-off-by: Matt Turner <mattst88@gentoo.org>
* x11-drivers/xf86-input-wacom: Stabilize 1.1.0 ppc64, #867796Matt Turner2022-09-021-1/+1
| | | | Signed-off-by: Matt Turner <mattst88@gentoo.org>
* x11-drivers/xf86-input-wacom: Stabilize 1.1.0 ppc, #867796Matt Turner2022-09-021-1/+1
| | | | Signed-off-by: Matt Turner <mattst88@gentoo.org>
* x11-drivers/nvidia-drivers: stabilize 515.65.01 for amd64Ionen Wolkens2022-09-021-1/+1
| | | | | | | | | | | | | Had a rocky start with egl-wayland, but no known issues anymore, and is a production branch. 510 branch on the other hand is getting behind fixes and will ultimately be removed (no known reasons to use over 515). Was tempted to mask kernel-open in stable, but it already comes with several warnings and would rather not complicate things for users that want to try it. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* x11-drivers/nvidia-drivers: add 515.49.15:0/vulkan, drop 515.49.14Ionen Wolkens2022-09-022-2/+2
| | | | Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* x11-drivers/xf86-input-wacom: Stabilize 1.1.0 sparc, #867796Arthur Zamarin2022-09-011-1/+1
| | | | Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
* x11-drivers/xf86-input-wacom: Stabilize 1.1.0 x86, #867796Jakov Smolić2022-09-011-1/+1
| | | | Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
* x11-drivers/xf86-input-wacom: Stabilize 1.1.0 amd64, #867796Jakov Smolić2022-09-011-1/+1
| | | | Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
* x11-drivers/xf86-input-wacom: Stabilize 1.1.0 arm, #867796Jakov Smolić2022-09-011-1/+1
| | | | Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
* x11-drivers/nvidia-drivers: drop 390.151, 470.129.06, 510.73.05-r1Ionen Wolkens2022-08-244-1389/+0
| | | | Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* x11-drivers/nvidia-drivers: add 515.49.14:0/vulkan, drop 515.49.10Ionen Wolkens2022-08-242-9/+4
| | | | Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* x11-drivers/xf86-video-mga: Drop old versionsMatt Turner2022-08-172-20/+0
| | | | Signed-off-by: Matt Turner <mattst88@gentoo.org>
* x11-drivers/xf86-input-synaptics: Drop old versionsMatt Turner2022-08-172-44/+0
| | | | Signed-off-by: Matt Turner <mattst88@gentoo.org>
* x11-drivers/nvidia-drivers: stabilize 510.85.02 for amd64Ionen Wolkens2022-08-171-1/+1
| | | | | | | Still keeping 0/510 over 0/515 in stable for now, although will probably look at replacing it soon'ish. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* x11-drivers/nvidia-drivers: stabilize 470.141.03 for amd64Ionen Wolkens2022-08-171-1/+1
| | | | Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* x11-drivers/nvidia-drivers: stabilize 390.154 for amd64, x86Ionen Wolkens2022-08-171-1/+1
| | | | | | | Note I barely test 390.xx runtime anymore, doesn't help that my old 560ti that I normally don't use keeps falling off the bus. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* x11-drivers/nvidia-drivers: note 0/470 wayland is a bit on abandonIonen Wolkens2022-08-171-1/+2
| | | | | | | | | e.g. pure wayland vulkan barely works, and seeing other oddities that I doubt will ever be resolved and EGLStream support may get dropped altogether. egl-wayland-1.1.7 is also unlikely to get updates and this doesn't work with 1.1.10. Best try to discourage for later. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* x11-drivers/xf86-input-synaptics: Stabilize 1.9.2 arm64, #861023Arthur Zamarin2022-08-171-1/+1
| | | | Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
* x11-drivers/xf86-video-mga: Stabilize 2.0.1 ppc, #861023Arthur Zamarin2022-08-151-1/+1
| | | | Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
* x11-drivers/xf86-input-synaptics: Stabilize 1.9.2 ppc, #861023Arthur Zamarin2022-08-151-1/+1
| | | | Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
* x11-drivers/xf86-video-mga: Stabilize 2.0.1 ppc64, #861023Arthur Zamarin2022-08-151-1/+1
| | | | Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
* x11-drivers/xf86-input-synaptics: Stabilize 1.9.2 ppc64, #861023Arthur Zamarin2022-08-151-1/+1
| | | | Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
* x11-drivers/xf86-input-synaptics: Stabilize 1.9.2 arm, #861023Arthur Zamarin2022-08-151-1/+1
| | | | Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
* x11-drivers/xf86-video-mga: Stabilize 2.0.1 sparc, #861023matoro2022-08-151-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* x11-drivers/nvidia-drivers: drop 515.57Ionen Wolkens2022-08-072-514/+0
| | | | Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* x11-drivers/nvidia-drivers: add 515.65.01Ionen Wolkens2022-08-022-0/+514
| | | | Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* x11-drivers/nvidia-drivers: add 510.85.02Ionen Wolkens2022-08-022-0/+478
| | | | Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* x11-drivers/nvidia-drivers: add 470.141.03Ionen Wolkens2022-08-022-0/+467
| | | | Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* x11-drivers/nvidia-drivers: add 390.154Ionen Wolkens2022-08-022-0/+444
| | | | Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* x11-drivers/xf86-video-nv: Version bump to 2.1.22Matt Turner2022-07-272-0/+12
| | | | Signed-off-by: Matt Turner <mattst88@gentoo.org>
* x11-drivers/xf86-video-mga: x86 stable wrt bug #861023Agostino Sarubbo2022-07-261-1/+1
| | | | Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* x11-drivers/xf86-input-synaptics: x86 stable wrt bug #861023Agostino Sarubbo2022-07-261-1/+1
| | | | Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* x11-drivers/xf86-video-mga: amd64 stable wrt bug #861023Agostino Sarubbo2022-07-261-1/+1
| | | | Signed-off-by: Agostino Sarubbo <ago@gentoo.org>