summaryrefslogtreecommitdiff
blob: fc28c68580d211f8f6257f88e8b0f1e091232d99 (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

# PPC Specific use flags
#

# Sergei Trofimovich <slyfox@gentoo.org> (18 Mar 20180)
# mongodb is not keyworded on ppc/ppc64 (broken)
mongodb

# David Seifert <soap@gentoo.org> (08 Jul 2017)
# Games are not keyworded anymore on ppc
capslib
fortune
nagios-game
physfs

# James Le Cuirot <chewi@gentoo.org> (29 Jun 2017)
# Unmask as this profile is big endian.
-big-endian

# Matt Turner <mattst88@gentoo.org> (24 Mar 2017)
# virtual/opencl is not keyworded
opencl

# Matt Turner <mattst88@gentoo.org> (24 Mar 2017)
# We don't have sys-devel/llvm
llvm
video_cards_amdgpu
video_cards_radeonsi
clang

# Jeroen Roovers <jer@gentoo.org> (22 Sep 2015)
# sci-libs/mkl is not supported on PPC
mkl

# Jeroen Roovers <jer@gentoo.org> (25 May 2015)
# PowerPC has no support for this bootloader (bug #550322)
gnuefi

# Patrick Lauer <patrick@gentoo.org> (28 Apr 2015)
# dependencies not keyworded yet
ayatana

#Klibc does not work
klibc

# These flags should only be used for ppc
-ppcsha1
-power8
# Unmask the Altivec instruction set
-altivec

# Incompatible Use Flags
#
# These use-flags are x86/amd64 only, please feel free to make a bug report if
# this is in error!
#
3dfx
acpi
lm_sensors
rar
hdf
xvmc
# cg is only provided by nvidia's binary only cg toolkit
cg
# dmi depends on PC BIOSes, we don't have those
dmi
#2006/10/11 - corsair - bug #150925
lcd_devices_graphlcd
# Masked vaapi for PowerPC until it works on hardware available to PowerPC users (cell, etc.)
vaapi
# User Mode Linux isn't supported on ppc yet
uml


### Other flags -- Please put additional maskings below here

# No keyworded versions of openafs
afs

# Masking mbrola for bug #84322, if a new version is released, remove this
mbrola

# Modular X: unmask for architectures on which they are available
-input_devices_synaptics
-input_devices_wacom

# Diego Pettenò <flameeyes@gentoo.org> (6 Dec 2006)
# Mask ALSA drivers for ISA cards
alsa_cards_msnd-pinnacle
alsa_cards_sb16
alsa_cards_sbawe
alsa_cards_sscape
alsa_cards_wavefront

# George Shapovalov <george@gentoo.org> (8 Apr 2007)
# supported on ppc
-ada

# Joseph Jezak <josejx@gentoo.org> (28 Jun 2007)
# Masked Parallel LCD devices for bug #180683
# app-misc/lcd4linux
lcd_devices_lph7508
lcd_devices_m50530
lcd_devices_noritake
lcd_devices_routerboard
# app-misc/lcdproc
lcd_devices_sed1330
lcd_devices_sed1520
lcd_devices_stv5730
# Both
lcd_devices_t6963

# 2006/08/18 - Donnie Berkholz <dberkholz@gentoo.org>
# Modular X: mask for architectures on which they aren't available
video_cards_vesa

# Intel Integrated Primitive (sci-libs/ipp) support
ipp

# dev-lang/orc doesn't play nice
schroedinger

# This will need >=media-libs/libgpod-0.8.0 keyworded and stabilized on both ppc/ppc64, bugs 313691 and 325839
ipod
ios

# Christian Faulhammer <fauli@gentoo.org> (01 Nov 2010)
# app-misc/lirc fails to compile on PPC64, see bug 275872 for example
# Samuli Suominen <ssuominen@gentoo.org> (03 Nov 2010)
# and it's also masked in arch/powerpc/ppc64/32ul/package.mask
lirc

# Kacper Kowalik <xarthisius@gentoo.org> (26 Jul 2011)
# ppc keywords were dropped for dev-libs/prelude
prelude

# Julian Ospald <hasufell@gentoo.org> (25 Apr 2012)
# Masked because nvidia-texture-tools is not (tested) for PowerPC
nvtt

# fdk-aac is already keyworded here
-fdk

# Samuli Suominen <ssuominen@gentoo.org> (18 Jan 2013)
# libdlm and cman are not keyworded
cman
clvm

# Pacho Ramos <pacho@gentoo.org> (08 Jan 2014)
# Unmask systemd since it is keyworded here.
-systemd