summaryrefslogtreecommitdiff
blob: 55908ad495ba2fd783e447d0e241ced37d51a042 (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
267
268
269
270
271
272
273
274
275
276
277
278
279
280
281
282
283
284
285
286
287
288
289
290
291
292
293
294
295
296
297
298
299
300
301
302
303
304
305
306
307
308
309
310
311
312
313
314
315
316
317
318
319
320
321
322
323
324
325
326
327
328
329
330
331
332
333
334
335
336
337
338
339
340
341
342
343
344
345
346
347
348
349
350
351
352
353
354
355
356
357
358
359
360
361
362
363
364
365
366
367
368
369
370
371
372
373
374
375
376
377
378
379
380
381
382
383
384
385
386
387
388
389
390
391
392
393
394
395
396
397
398
399
400
401
402
403
404
405
406
407
408
409
410
411
412
413
414
415
416
417
418
419
420
421
422
423
424
425
426
427
428
429
430
431
432
433
434
435
436
437
438
439
440
441
442
443
444
445
446
447
448
449
450
451
452
453
454
455
456
457
458
459
460
461
462
463
464
465
466
467
468
469
470
471
472
473
474
475
476
477
478
479
480
481
482
483
484
485
486
487
488
489
490
491
492
493
494
495
496
497
498
499
500
501
502
503
504
505
506
507
508
509
510
511
512
513
514
515
516
517
518
519
520
521
522
523
524
525
526
527
528
529
530
531
532
533
534
535
536
537
538
539
540
541
542
543
544
545
546
547
548
549
550
551
552
553
554
555
556
557
558
559
560
561
562
563
564
565
566
567
568
569
570
571
572
573
574
575
576
577
578
579
580
581
582
583
584
585
586
587
588
589
590
591
592
593
594
595
596
597
598
599
600
601
602
603
604
605
606
607
608
609
610
611
612
613
614
615
616
617
618
619
620
621
622
623
624
625
626
627
628
629
630
631
632
633
634
635
636
637
638
639
640
641
642
643
644
645
646
647
648
649
650
651
652
653
654
655
656
657
658
659
660
661
662
663
664
665
666
667
668
669
670
671
672
673
674
675
676
677
678
679
680
681
682
683
684
685
686
687
688
689
690
691
692
693
694
695
696
697
698
699
700
701
702
703
704
705
706
707
708
709
710
711
712
713
714
715
716
717
718
719
720
721
722
723
724
725
726
727
728
729
730
731
732
733
734
735
736
737
738
739
740
741
742
743
744
745
746
747
748
749
750
751
752
753
754
755
756
757
758
759
760
761
762
763
764
765
766
767
768
769
770
771
772
773
774
775
776
777
778
779
780
781
782
783
784
785
786
787
788
789
790
791
792
793
794
795
796
797
798
799
800
801
802
803
804
805
806
807
808
809
810
811
812
813
814
815
816
817
818
819
820
821
822
823
824
825
826
827
828
829
830
831
832
833
834
835
836
837
838
839
840
841
842
843
844
845
846
847
848
849
850
851
852
853
854
855
856
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

####################################################################
#
# When you add an entry to the top of this file, add your name, the date
# in the UTC timezone, and an explanation of why something is getting masked.
# Please be extremely careful not to commit atoms that are not valid, as it can
# cause large-scale breakage, especially if it ends up in the daily snapshot.
#
## Example:
##
## # Dev E. Loper <developer@gentoo.org> (2019-07-01)
## # Masking  these versions until we can get the
## # v4l stuff to work properly again
## =media-video/mplayer-0.90_pre5
## =media-video/mplayer-0.90_pre5-r1
#
# - Best last rites (removal) practices -
# Include the following info:
# a) reason for masking
# b) bug # for the removal (and yes you should have one)
# c) date of removal (either the date or "in x days")
#
## Example:
##
## # Dev E. Loper <developer@gentoo.org> (2019-07-01)
## # Masked for removal in 30 days.  Doesn't work
## # with new libfoo. Upstream dead, gtk-1, smells
## # funny. (bug #987654)
## app-misc/some-package

#--- END OF EXAMPLES ---

# Andreas Sturmlechner <asturm@gentoo.org> (2020-07-01)
# Depends on dead gnome-base/libgnomeui, bug #726816, dead upstream. Big Debian
# patch exists, but we won't become new upstream. Masked for removal in 30 days.
games-board/teg

# Aaron Bauman <bman@gentoo.org> (2020-06-29)
# More Py2 only stuff. Plz see -dev ML for discussions
# Remove bindings, port to Py3, etc
# Removal in 30 days
app-dicts/opendict
app-editors/editra
app-office/taskcoach
app-backup/holland
app-backup/holland-backup-example
app-backup/holland-backup-pgdump
app-backup/holland-backup-random
app-backup/holland-backup-sqlite
app-backup/holland-lib-common
app-backup/holland-lib-lvm
app-cdr/burn-cd
app-editors/leo
app-emulation/playonlinux
app-text/bibus
dev-db/SchemaSync
dev-python/squaremap
dev-util/wxglade
media-gfx/fontypython
media-gfx/fr0st
sci-chemistry/apbs
sci-chemistry/autodock
sci-chemistry/eden
sci-chemistry/p3d
sci-chemistry/pdb2pqr
sci-chemistry/pdb-tools
sci-chemistry/prodecomp
sci-chemistry/pymol-plugins-caver
sci-chemistry/pymol-plugins-dssp
sci-chemistry/pymol-plugins-promol
sci-chemistry/relax
sci-chemistry/sparky
www-apps/viewvc
x11-misc/nts

# Stephan Hartmann <stha09@googlemail.com> (2020-06-29)
# Dev channel releases are only for people who
# are developers or want more experimental features
# and accept a more unstable release.
>=www-client/chromium-85

# Michał Górny <mgorny@gentoo.org> (2020-06-29)
# Unmaintained in Gentoo.  Multiple unresolved vulnerabilities.
# Suggested replacement: sys-apps/portage (just kidding).
# Removal in 30 days.  Bug #711134.
sys-apps/pacman

# Aaron Bauman <bman@gentoo.org> (2020-06-28)
# More Py2 only stuff. Plz see -dev ML for discussions
# Remove bindings, port to Py3, etc
# Removal in 30 days
app-arch/deltarpm
app-crypt/virtualsmartcard
app-text/duali
app-text/duali-data
app-dicts/duali-data
app-text/mftrace
app-text/queequeg
app-text/referencer
dev-libs/libmacaroons
dev-libs/tut
dev-python/elib-intl
dev-python/eunuchs
dev-python/medusa
dev-python/python-iwscan
dev-util/confix
dev-util/qmtest
dev-util/unrpyc
games-engines/gemrb
media-sound/lilycomp
media-video/tovid
net-irc/irker
net-mail/archivemail
net-mail/getmail
net-wireless/airpwn
sci-chemistry/bkchem
sci-chemistry/pymol-plugins-bni-tools
sci-chemistry/pymol-plugins-emovie
sci-chemistry/viewmol
sci-libs/chemkit
www-misc/surl
x11-wm/plwm

# Andreas Sturmlechner <asturm@gentoo.org> (2020-06-28)
# WIP PipeWire ebuild, breaks all current revdeps in ebuild repository
# sys-apps/xdg-desktop-portal-1.7.2 depends on masked PipeWire >=0.3
~media-video/pipewire-0.3.6
~sys-apps/xdg-desktop-portal-1.7.2

# Mikle Kolyada <zlogene@gentoo.org> (2020-06-28)
# Obsolete package.
# Does not build.
# Dead upstream and only gentoo ships it.
# Removal in 30 days.
app-misc/scope

# Mart Raudsepp <leio@gentoo.org> (2020-06-27)
# Disappeared upstream and download locations. Potential replacements:
# media-sound/quimup, xfce-extra/xfce4-mpc-plugin, media-sound/xfmpc
# Bug 729822. Removal in 30 days.
media-sound/guimup

# Mikle Kolyada <zlogene@gentoo.org> (2020-06-26)
# Has been a part of dev-texlive/texlive-pictures
# for a long time. Removal in 30 days.
dev-tex/circuit_macros

# Andreas Sturmlechner <asturm@gentoo.org> (2020-06-25)
# Stuck on Python 2, no maintainer; rgain3 fork available for sb. taking over
# at https://github.com/chaudum/rgain - masked for removal in 30 days.
media-sound/rgain

# Andreas Sturmlechner <asturm@gentoo.org> (2020-06-25)
# Stuck on Python 2, m-n, we have no shortage on note taking applications.
# Masked for removal in 30 days.
x11-misc/nts

# Ulrich Müller <ulm@gentoo.org> (2020-06-25)
# Included with TeX Live. Last version bump in 2003.
# Use dev-texlive/texlive-latexextra as replacement.
# Removal in 30 days. Bug #729470.
dev-tex/cdcover

# Ulrich Müller <ulm@gentoo.org> (2020-06-25)
# Included with TeX Live. Last version bump in 2008.
# Use dev-texlive/texlive-latexrecommended as replacement.
# Removal in 30 days. Bug #729470.
dev-tex/translator

# Ulrich Müller <ulm@gentoo.org> (2020-06-24)
# Included with TeX Live. The separate Gentoo package is
# unmaintained and had its last version bump in 2004.
# Use dev-texlive/texlive-bibtexextra as replacement.
# Removal in 30 days. Bug #729470.
dev-tex/harvard

# Ulrich Müller <ulm@gentoo.org> (2020-06-24)
# Included with TeX Live. Last version bump in 2005.
# Use dev-texlive/texlive-fontsrecommended as replacement.
# Removal in 30 days. Bug #729470.
dev-tex/tipa

# Ulrich Müller <ulm@gentoo.org> (2020-06-24)
# Included with TeX Live. Last version bump in 2006 or earlier.
# Use dev-texlive/texlive-latexextra as replacement.
# Removal in 30 days. Bug #729470.
dev-tex/flabels
dev-tex/floatflt
dev-tex/lazylist
dev-tex/newlfm
dev-tex/polytable

# Ulrich Müller <ulm@gentoo.org> (2020-06-24)
# Included with TeX Live. Last version bump in 2011.
# Use dev-texlive/texlive-pictures as replacement.
# Removal in 30 days. Bug #729470.
dev-tex/curve

# Ulrich Müller <ulm@gentoo.org> (2020-06-24)
# Included with TeX Live. Last version bump in 2006. Fails to build.
# Use dev-texlive/texlive-latexextra as replacement.
# Removal in 30 days. Bug #719304.
dev-tex/ellipsis

# Ulrich Müller <ulm@gentoo.org> (2020-06-24)
# Included with TeX Live. Fails to install.
# Use dev-texlive/texlive-latexextra as replacement.
# Removal in 30 days. Bug #708870.
dev-tex/rcsinfo

# Ulrich Müller <ulm@gentoo.org> (2020-06-24)
# Included with TeX Live. Last version bump in 2005. Fails to build.
# Use dev-texlive/texlive-latexextra as replacement.
# Removal in 30 days. Bug #709310.
dev-tex/texpower

# Ulrich Müller <ulm@gentoo.org> (2020-06-24)
# Included with TeX Live. The separate Gentoo packages are
# unmaintained and had their last version bump in 2010 or earlier.
# Use >=dev-texlive/texlive-latexextra-2020-r2 as replacement.
# Removal in 30 days. Bug #729394.
dev-tex/currvita
dev-tex/envlab
dev-tex/europecv
dev-tex/g-brief
dev-tex/leaflet
dev-tex/svninfo

# Ulrich Müller <ulm@gentoo.org> (2020-06-24)
# Included with TeX Live. The separate Gentoo package is
# unmaintained and had its last version bump in 2008.
# Use >=dev-texlive/texlive-pictures-2020-r2 as replacement.
# Removal in 30 days. Bug #729394.
dev-tex/dot2texi

# Michał Górny <mgorny@gentoo.org> (2020-06-24)
# A thin wrapper to run pytest via setup.py that must not be used
# in Gentoo packages.  Calling 'setup.py test' is deprecated upstream
# anyway.  Just call 'pytest' directly.  The last revdep is last rited.
# Removal in 30 days.  Bug #729376.
dev-python/pytest-runner

# Michał Górny <mgorny@gentoo.org> (2020-06-23)
# Python 2 only.
#
# Relax involves implementation conflicts between dependencies.  Even
# if you can get past them, it requires Numdifftools, and...
#
# Numdifftools fails with modern versions of setuptools, most likely
# because it uses pyscaffold that is broken.  There are newer versions
# that removed pyscaffold support but they have new dependencies that
# do not support py2 and porting them back is just not worth the effort.
# Its only revdep is relax.
#
# Pyscaffold is just broken and required only by old versions
# of Numdifftools.
#
# Removal in 30 days.  Bug #704032.
dev-python/Numdifftools
dev-python/pyscaffold
sci-chemistry/relax

# Sergei Trofimovich <slyfox@gentoo.org> (2020-06-21)
# virtual/libstdc++ has only one sys-libs/libstdc++-v3 provider.
# Use that instead. Or even better use none of them. It's a
# library from 2005. Removal in 30 days.
virtual/libstdc++

# Andreas Sturmlechner <asturm@gentoo.org> (2020-06-20)
# Stuck on Python 2, depends on deprecated dev-python/pygobject:2
# Masked for removal in 30 days.
media-libs/pymemphis

# Ulrich Müller <ulm@gentoo.org> (2020-06-20)
# Unmaintained upstream, included with TeX Live.
# Use >=dev-texlive/texlive-metapost-2020-r1 as replacement.
# Removal in 30 days. Bug #728904.
dev-tex/feynmf

# Aaron Bauman <bman@gentoo.org> (2020-06-20)
# Py2 only
# Removal in 14 days
app-crypt/openvpn-blacklist
app-forensics/volatility
<=dev-libs/distorm64-3.4.2
app-misc/yagtd
app-text/pylize
app-vim/easytags
app-vim/notes
dev-db/metakit
dev-python/backports-ssl-match-hostname
dev-python/backports-shutil_get_terminal_size
dev-python/backports-shutil_which
dev-python/python-wpactrl
dev-util/bakefile
dev-vcs/git-deps
dev-vcs/git-remote-hg
games-emulation/openmsx
games-kids/childsplay
games-mud/lyntin
games-sports/ski
mail-filter/tmda
media-video/subdl
media-sound/cplay
media-sound/tunapie
net-firewall/dshieldpy
net-mail/offlineimap
net-misc/switzerland
net-wireless/multimode
sci-biology/last
sci-chemistry/hollow
sci-chemistry/modeller
sci-chemistry/pymol-plugins-msms
sci-geosciences/tilecache
sci-libs/deap
sci-libs/pycifrw
www-apps/curator
x11-apps/whyteboard
x11-plugins/purple-plugin_pack

# Andreas Sturmlechner <asturm@gentoo.org> (2020-06-18)
# Games depending on dead gnome-base/libgnomeui.
# games-board/gnono: Bug #726788, last release 2007, abandoned upstream.
# games-puzzle/gtetrinet: Bug #726798 last release 2006, abandoned upstream.
# games-board/mt_gtk_client: Bug #726808, last commit 17 years ago.
# games-board/sirius: Bug #726814, last release 15 years ago, dead upstream.
# Masked for removal in 30 days.
games-board/gnono
games-puzzle/gtetrinet
games-board/mt_gtk_client
games-board/sirius

# Andreas Sturmlechner <asturm@gentoo.org> (2020-06-18)
# Depends on dead gnome-base/libgnomeui. Really, no one else is packaging
# this, last (and only) release in 2006, abandoned upstream. Bug #726790
# Masked for removal in 30 days.
dev-embedded/gnome-avrdude

# Michał Górny <mgorny@gentoo.org> (2020-06-14)
# Maintainer unresponsive.  Stuck on py3.6.  Pending version bump.
# Failing tests.
# Removal in 30 days.  Bug #718990.
dev-python/hglib

# Michał Górny <mgorny@gentoo.org> (2020-06-14)
# Unmaintained since at least 2014.  The current release is 1.5 dev
# branch from 2010.  Upstream had a few stable 1.4 releases since
# but 1.5 seems to be dead.  Multiple build failures reported,
# and an ebuild vulnerability.
# Removal in 30 days.  Bug #728186.
app-mobilephone/kannel
app-mobilephone/kannel-sqlbox

# Hans de Graaff <graaff@gentoo.org> (2020-06-14)
# Ruby 2.4 is no longer supported by upstream and no longer gets
# security updates since the 2.4.10 release. Use ruby 2.5 or later
# instead.
dev-lang/ruby:2.4
dev-ruby/did_you_mean:2.4

# Mikle Kolyada <zlogene@gentoo.org> (2020-06-13)
# multiple forks.
# Merged into the app-text/texlive-core package
# Removal in 30 days.
app-text/xindy

# Jonas Stein <jstein@gentoo.org> (2020-06-07)
# Last rite unusable package.
# Removal after 2020-08-01
# Bug 727360
app-misc/ifp-line

# Mart Raudsepp <leio@gentoo.org> (2020-06-06)
# Meson port does not handle multilib yet and has issues
# regarding runstatedir (not using /run).
=net-misc/networkmanager-1.22.10-r11

# Michał Górny <mgorny@gentoo.org> (2020-06-05)
# Replaced by dev-util/ydiff, after upstream rename.
# Removal in 30 days.  Bug #710538.
dev-util/cdiff

# Sam James <sam@cmpct.info> (2020-06-04)
# Large number of vulnerabilities (Bug #692398, Bug #664326)
# Unmaintained.
# Masked for removal in 30 days.
www-apps/otrs

# Sam James <sam@cmpct.info> (2020-06-04)
# Multiple vulnerabilities (Bug #655176, Bug #701812)
# Misc. other bugs, out of date, no maintainer.
# Masked for removal in 30 days.
net-nds/389-ds-base
dev-libs/389-adminutil
dev-libs/svrcore

# Stefan Strogin <steils@gentoo.org> (2020-06-03)
# Masked for testing
>=dev-libs/libressl-3.2.0

# Michał Górny <mgorny@gentoo.org> (2020-06-03)
# Very bad quality (upstream) package.  Stuck on py3.6.  No revdeps.
# Removal in 30 days.  Bug #718762.
dev-python/dnslib

# Aaron Bauman <bman@gentoo.org> (2020-06-02)
# py2 only. dead upstream. m-n.
# Masked for removal in 30 days
app-misc/webcomics-collector
net-misc/pytvshows
net-news/rawdog

# Andreas Sturmlechner <asturm@gentoo.org> (2020-06-02)
# libgnomeui revdeps with no sign of upstream porting away or doing anything.
# No maintainer. Bugs #726826, #726822. Masked for removal in 30 days.
app-misc/cbrpager
app-misc/ignuit

# Jonas Stein <jstein@gentoo.org> (2020-06-01)
# Last rite package due to missing/unclear license.
# Removal after 2020-08-01
# Bug 687664
app-dicts/stardict-quick-eng-fra

# Michał Górny <mgorny@gentoo.org> (2020-06-01)
# Effectively unmaintained, Python 2 only game and its dependencies.
# Removal in 30 days.
games-action/slune
dev-python/editobj
dev-python/py2play
dev-python/pyopenal
dev-python/soya

# James Le Cuirot <chewi@gentoo.org> (2020-05-31)
# Now merged into media-libs/dumb with the allegro USE flag. This
# package was added before EAPI 2 and USE-dependencies. Removal in 30
# days.
media-libs/aldumb

# Michał Górny <mgorny@gentoo.org> (2020-05-31)
# The following packages are either unmaintained, or their deps
# are unmaintained.  They are stuck on Python 3.6 and have no reverse
# dependencies outside the list.
#
# app-admin/dxf: #718178
# dev-python/fastparquet: #718820
# dev-python/numba: #719286
# dev-python/raven: #719522
# dev-python/sphinxcontrib-documentedlist: #719564
# dev-python/thriftpy: #719590
# dev-python/toro: #719592
#
# Removal in 30 days.
app-admin/dxf
dev-python/fastparquet
dev-python/numba
dev-python/raven
dev-python/sphinxcontrib-documentedlist
dev-python/thriftpy
dev-python/toro

# Michał Górny <mgorny@gentoo.org> (2020-05-31)
# Outdated.  Not touched since the initial commit.  Lacks py3.7 support.
# No reverse dependencies outside the three packages.
# Removal in 30 days.  Bug #708270.
dev-python/graphql-core
dev-python/gql

# Hans de Graaff <graaff@gentoo.org> (2020-05-24)
# No releases since 2011, upstream is gone, fails tests,
# no reverse dependencies.
# Masked for removal in 30 days.
dev-ruby/rack-mount

# Hans de Graaff <graaff@gentoo.org> (2020-05023)
# Masked for removal in 30 days.
# Not useful anymore now that metasploit has been removed.
app-eselect/eselect-metasploit

# Aaron W. Swenson <titanofold@gentoo.org> (2020-05-15)
# PostgreSQL 9.4 series is EOL. Migrate your database cluster to a more recent
# version.
# Removal after 2020-06-14.
<dev-db/postgresql-9.5

# Thomas Deutschmann <whissi@gentoo.org> (2020-04-30)
# Requires <OpenSSL-1.1.x. Please migrate to
# >=dev-db/mysql-5.7. Masked for removal in 30 days.
<dev-db/mysql-5.7

# Matt Turner <mattst88@gentoo.org> (2020-04-29)
# Masked for testing
>=dev-libs/gjs-1.64

# Michael Orlitzky <mjo@gentoo.org> (2020-04-19)
# Stuck on Python 3.6, support for which already required
# backporting patches to a release from 2014. Upstream's git
# HEAD works fine, but they can't be bothered to make a new
# release. Bug 718326. Removal whenever it becomes an issue.
mail-filter/pyzor

# Georgy Yakovlev <gyakovlev@gentoo.org> (2020-04-18)
# Unmaintained, vulnerable oracle java ebuilds, even fetching distfiles
# requires agreement to restrictive license
# Revdeps that still depend on oracle variants require javafx
# javafx package  for icedtea or openjdk is in the works and
# will be commited before oracle-jdk is removed.
# Oracle JDK Removal in 30 days.
# Packages will get unmasked after switch to openjfx.
# https://bugs.gentoo.org/681828
dev-java/oracle-jdk-bin
dev-java/oracle-jre-bin
app-text/jabref-bin
dev-java/netbeans-platform
dev-java/netbeans-harness
games-util/pogo-manager-bin
net-p2p/bisq
sci-mathematics/geogebra

# Georgy Yakovlev <gyakovlev@gentoo.org> (2020-03-27)
# Vulnerable old version of icedtea-web #711392
# new version is not packaged yet
# package is not going away anytime soon, just masked
# for security. unmask as needed.
dev-java/icedtea-web

# Andreas Sturmlechner <asturm@gentoo.org> (2020-03-14)
# Breaks at least dev-games/simgear right now, bug #709878.
~dev-games/openscenegraph-3.6.5

# Eray Aslan <eras@gentoo.org> (2020-03-09)
# Mask experimental software
=mail-mta/postfix-3.6*

# Miroslav Šulc <fordfrog@gentoo.org> (2020-02-27)
# Depends on dev-java/eclipse-ecj:4.13 which
# depends on >=virtual/{jdk,jre}-11 which is masked
www-servers/tomcat:9

# Mart Raudsepp <leio@gentoo.org> (2020-02-16)
# Fails to automatically launch pipewire for me. Help welcome figuring it out.
net-misc/gnome-remote-desktop

# Stefan Strogin <steils@gentoo.org> (2020-02-12)
# Mask for testing revdeps.
>=dev-games/mygui-3.4.0

# Patrick McLean <chutzpah@gentoo.org> (2020-02-07)
# Mask until sys-libs/libxcrypt[system] is unmasked
>=virtual/libcrypt-2

# Mart Raudsepp <leio@gentoo.org> (2020-02-03)
# Known breakages that need to be handled first, bug 698922
>=x11-libs/pango-1.43

# Robin H. Johnson <robbat2@gentoo.org> (2020-01-26)
# EAPI conversion caused some regressions, need to redesign old ebuilds.
=dev-lang/lua-5.1.5-r5

# Andrew Ammerlaan <andrewammerlaan@riseup.net> (2020-01-26)
# Proxy Maintainers <proxy-maint@gentoo.org>
# v3.6.4 uses huge amounts of memory: Bug #705682
# v3.6.1 is the latest version without this issue
>=dev-libs/libsass-3.6.2

# Georgy Yakovlev <gyakovlev@gentoo.org> (2020-01-26)
# Starting with Firefox 74 Mozilla removes xpi sideloading support
# install from addons.mozilla.org
# passff-host remains in the tree
www-plugins/passff

# Victor Payno <vpayno+gentoo@gmail.com> (2020-01-23)
# Requires slotted lua.
=dev-lang/lua-5.1.5-r103
=dev-lang/lua-5.2.4-r2
=dev-lang/lua-5.3.5-r2

# Michał Górny <mgorny@gentoo.org> (2020-01-16)
# The new version loses Python 2 support but does not introduce any real
# changes.  Let's mask it to reduce the noise, and hopefully try to get
# python2_7 out of default PYTHON_TARGETS first.
~dev-python/setuptools-46.1.3
>=dev-python/setuptools-47

# Ulrich Müller <ulm@gentoo.org> (2020-01-06)
# Snapshots from Git and pretest versions, masked for testing.
=app-editors/emacs-27.0.50_pre*
~app-editors/emacs-27.0.90

# Lars Wendler <polynomial-c@gentoo.org> (2019-11-14)
# Breaks archives containing relative paths
# when being called with --no-absolute-filenames
# https://bugs.gentoo.org/700020
=app-arch/cpio-2.13

# Michał Górny <mgorny@gentoo.org> (2019-10-20)
# Testing version that breaks multiple plugins.  Let's keep it masked
# until upstream releases fixed versions.
~xfce-base/xfce4-panel-4.15.2

# Lars Wendler <polynomial-c@gentoo.org> (2019-10-16)
# Depends on apache-2.2
dev-libs/OpenSRF

# Miroslav Šulc <fordfrog@gentoo.org> (2019-10-16)
# Depends on >=virtual/{jdk,jre}-11 which is masked
dev-java/ant-eclipse-ecj:4.13
dev-java/eclipse-ecj:4.13

# Stefan Strogin <steils@gentoo.org> (2019-09-27)
# Requires >=dev-lang/lua-5.3 which is masked
>=dev-util/bam-0.5.0

# Matt Turner <mattst88@gentoo.org> (2019-09-01)
# TeXmacs is the only remaining package in tree that requires guile-1.8, which
# is unsupported upstream. A TeXmacs port to Guile-2 has been in progress for a
# few years. Bug #436400
app-office/texmacs
<dev-scheme/guile-2

# Robin H. Johnson <robbat2@gentoo.org> (2019-07-08)
# Needs LOTS of testing, broke boot on my laptop in early attempts, maybe needs
# matching genkernel work?
>=sys-fs/lvm2-2.03

# Daniel Pielmeier <billie@gentoo.org> (2019-07-06)
# Requires >=dev-lang/lua-5.2 which is masked
>=app-admin/conky-1.11.4

# Georgy Yakovlev <gyakovlev@gentoo.org> (2019-04-17)
# The Oracle JDK License has changed for releases starting 2019-04-16
# While it may be fine to use for some usecases it's not comepletely clear
# what is considered "personal use" and if we can legally distribute it.
# License states:
# "You may not:
# make the Programs available in any manner to any third party"
# masking all future versions, removal will follow soon.
# Alternatives: icedtea, icedtea-bin, openjdk, openjdk-bin, openjdk-jre-bin
# Bug: https://bugs.gentoo.org/681828
>dev-java/oracle-jdk-bin-1.8.0.202:1.8
>dev-java/oracle-jre-bin-1.8.0.202:1.8

# Robin H. Johnson <robbat2@gentoo.org> (2019-03-25)
# Requires >=dev-lang/lua-5.3 which is masked
sys-apps/likwid

# Matt Turner <mattst88@gentoo.org> (2019-03-16)
# Previously packaged drivers, now removed from Gentoo.
# Keep this mask in place so users are aware, but can also easily unmask them
# in an overlay if so desired.
x11-drivers/xf86-input-citron
x11-drivers/xf86-video-apm
x11-drivers/xf86-video-ark
x11-drivers/xf86-video-chips
x11-drivers/xf86-video-cirrus
x11-drivers/xf86-video-cyrix
x11-drivers/xf86-video-i128
x11-drivers/xf86-video-i740
x11-drivers/xf86-video-impact
x11-drivers/xf86-video-mach64
x11-drivers/xf86-video-neomagic
x11-drivers/xf86-video-newport
x11-drivers/xf86-video-nsc
x11-drivers/xf86-video-rendition
x11-drivers/xf86-video-s3
x11-drivers/xf86-video-s3virge
x11-drivers/xf86-video-savage
x11-drivers/xf86-video-sis
x11-drivers/xf86-video-sisusb
x11-drivers/xf86-video-sunbw2
x11-drivers/xf86-video-suncg14
x11-drivers/xf86-video-suncg3
x11-drivers/xf86-video-suncg6
x11-drivers/xf86-video-sunffb
x11-drivers/xf86-video-sunleo
x11-drivers/xf86-video-suntcx
x11-drivers/xf86-video-tdfx
x11-drivers/xf86-video-tga
x11-drivers/xf86-video-trident
x11-drivers/xf86-video-tseng
x11-drivers/xf86-video-voodoo

# Miroslav Šulc <fordfrog@gentoo.org> (2019-01-23)
# Depends on >=virtual/{jdk,jre}-11 which is masked
dev-java/ant-eclipse-ecj:4.10
dev-java/eclipse-ecj:4.10

# Thomas Deutschmann <whissi@gentoo.org> (2018-12-10)
# Requires >=dev-lang/lua-5.2 which is masked
>=app-admin/lsyncd-2.2.3

# Andreas Sturmlechner <asturm@gentoo.org> (2018-11-25)
# Masked per security vulnerability CVE-2018-14345, bug #661510
# Keeping it masked while users have unsolved issues with >0.15.0.
<x11-misc/sddm-0.18.0

# Ian Stakenvicius <axs@gentoo.org> (2018-11-07)
# on behalf of Mozilla Project <mozilla@gentoo.org>
# Mask old/vuln thunderbird for removal by 2019,
# see security bug 670102
<mail-client/thunderbird-60.0
<mail-client/thunderbird-bin-60.0

# Thomas Deutschmann <whissi@gentoo.org> (2018-10-12)
# EOL and has known vulnerabilities. Please move to
# Firefox 60 or newer if you can.
<www-client/firefox-60
<www-client/firefox-bin-60

# Andreas Sturmlechner <asturm@gentoo.org> (2018-10-07)
# Masked for more testing especially of reverse-deps.
>=dev-games/ogre-1.11.2

# Andreas K. Hüttel <dilfridge@gentoo.org> (2018-09-11)
# Mask transition ebuilds that were needed only for <glibc-2.26
# We will keep them in the tree as long as we have masked
# <glibc-2.26.
~net-libs/libnsl-0
~net-libs/rpcsvc-proto-0

# James Le Cuirot <chewi@gentoo.org> (2017-12-17)
# Java 9+ is not yet fully supported on Gentoo. Packages cannot depend
# on it so these virtuals are not yet required. If you wish to use
# Java 9+ then install oracle-(jdk|jre)-bin or openjdk(-bin) directly.
virtual/jdk:11
virtual/jre:11

# Andreas K. Hüttel <dilfridge@gentoo.org> (2017-10-18)
# sys-devel/automake versions 1.4, 1.5, 1.6, 1.7, 1.8
# have known security vulnerabilities, are broken with
# recent Perl (>=5.26.0), and are not used by anything in
# the Gentoo repository. Please uninstall.
sys-devel/automake:1.4
sys-devel/automake:1.5
sys-devel/automake:1.6
sys-devel/automake:1.7
sys-devel/automake:1.8
sys-devel/automake:1.9
sys-devel/automake:1.10

# Nicolas Bock <nicolasbock@gentoo.org> (2017-10-31)
# There are multiple unresolved upstream issues with >=jabref-bin-4.0 (#636036).
# If you still would like to use this version, please report any issues to
# upstream.
>=app-text/jabref-bin-4.0

# Michał Górny <mgorny@gentoo.org> (2017-05-22)
# for Maciej S. Szmigiero <mail@maciej.szmigiero.name>
# Any version above 5.100.138 breaks b43 driver in various ways.
# Also, b43 wiki page says to use 5.100.138. Bug #541080.
>=sys-firmware/b43-firmware-6.30.163.46

# Michał Górny <mgorny@gentoo.org>, Andreas K. Hüttel <dilfridge@gentoo.org>,
# Matthias Maier <tamiko@gentoo.org> (2017-05-21 and later updates)
# These old versions of toolchain packages (binutils, gcc, glibc) are no
# longer officially supported and are not suitable for general use. Using
# these packages can result in build failures (and possible breakage) for
# many packages, and may leave your system vulnerable to known security
# exploits.
# If you still use one of these old toolchain packages, please upgrade (and
# switch the compiler / the binutils) ASAP. If you need them for a specific
# (isolated) use case, feel free to unmask them on your system.
<sys-devel/gcc-5.4
<sys-libs/glibc-2.30-r8
<sys-devel/binutils-2.33.1-r1
<sys-devel/binutils-hppa64-2.33.1
<sys-libs/binutils-libs-2.33.1-r1

# Michał Górny <mgorny@gentoo.org> (2017-05-20)
# Old versions of CUDA and their reverse dependencies. They do not
# support GCC 5+, and are really old.
# (updated 2017-12-27 with cuda < 8 because of gcc < 5 mask)
<dev-util/nvidia-cuda-sdk-8
<dev-util/nvidia-cuda-toolkit-8
net-wireless/cpyrit-cuda

# Michael Orlitzky <mjo@gentoo.org> (2017-01-07)
# This package has some dangerous quality and security issues, but
# people may still find it useful. It is masked to prevent accidental
# use. See bugs 603346 and 604998 for more information.
app-admin/amazon-ec2-init

# Robin H. Johnson <robbat2@gentoo.org> (2017-01-05)
# Masking for testing
=app-emulation/ganeti-2.16*
=app-emulation/ganeti-2.17*

# Michał Górny <mgorny@gentoo.org> (2016-11-17)
# New version masked for testing. It supports source-window buffer size
# over 2G but it 'currently performs 3-5% slower and has 1-2% worse
# compression'.
>=dev-util/xdelta-3.1.0

# Andreas K. Hüttel <dilfridge@gentoo.org> (2016-04-03)
# Can exhaust all available memory depending on task
# but is made available for experts who heed this warning
# as newer versions produce different output. Contact
# the proxied maintainer Matthew Brewer <tomboy64@sina.cn>
# for questions.
<=media-gfx/slic3r-1.1.9999

# Robin H. Johnson <robbat2@gentoo.org> (2014-08-04)
# Masked for testing, presently fails upstream testsuite:
# FAIL:07:02:35 (00:00:00) db_dump/db_load(./TESTDIR.3/recd001.db:child killed: kill signal): expected 0, got 1
# FAIL:07:02:35 (00:00:00) Dump/load of ./TESTDIR.3/recd001.db failed.
# FAIL:07:02:35 (00:00:00) db_verify_preop: expected 0, got 1
# Lars Wendler <polynomial-c@gentoo.org> (2019-01-25)
# Also masked because of mostly incompatible license (AGPL-3)
=sys-libs/db-6.1*
=sys-libs/db-6.2*
=sys-libs/db-18.1*

# Mikle Kolyada <zlogene@gentoo.org> (2014-06-27)
# Masked for proper testing. (Major updates in the code).
~dev-perl/PortageXS-0.2.12

# Matti Bickel <mabi@gentoo.org> (2014-04-22)
# Masked slotted lua for testing
# William Hubbs <williamh@gentoo.org> (2016-08-07)
# Taking this mask since Mabi is retired
# Rafael Martins <rafaelmartins@gentoo.org> (2016-12-04)
# Adding Lua 5.3 to mask
app-eselect/eselect-lua
=dev-lang/lua-5.1.5-r100
=dev-lang/lua-5.1.5-r101
=dev-lang/lua-5.1.5-r102
=dev-lang/lua-5.2.3
=dev-lang/lua-5.2.3-r1
=dev-lang/lua-5.2.3-r2
=dev-lang/lua-5.2.3-r3
=dev-lang/lua-5.2.4
=dev-lang/lua-5.2.4-r1
=dev-lang/lua-5.3.3
=dev-lang/lua-5.3.3-r1
=dev-lang/lua-5.3.3-r2
=dev-lang/lua-5.3.5
=dev-lang/lua-5.3.5-r1

# Samuli Suominen <ssuominen@gentoo.org> (2012-03-06)
# Masked for testing since this is known to break nearly
# every reverse dependency wrt bug 407091
>=dev-lang/lua-5.2.0

# Mike Gilbert <floppym@gentoo.org> (2014-03-04)
# Dev channel releases are only for people who are developers or want more
# experimental features and accept a more unstable release.
www-plugins/chrome-binary-plugins:unstable

# Diego E. Pettenò <flameeyes@gentoo.org> (2009-01-03)
# These packages are not supposed to be merged directly, instead
# please use sys-devel/crossdev to install them.
dev-util/mingw64-runtime
sys-libs/newlib
dev-embedded/avr-libc