summaryrefslogtreecommitdiff
blob: b20e9932cbbc040d0952b060326b7e20cc68af1c (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
267
268
269
270
271
272
273
274
275
276
277
278
279
280
281
282
283
284
285
286
287
288
289
290
291
292
293
294
295
296
297
298
299
300
301
302
303
304
305
306
307
308
309
310
311
312
313
314
315
316
317
318
319
320
321
322
323
324
325
326
327
328
329
330
331
332
333
334
335
336
337
338
339
340
341
342
343
344
345
346
347
348
349
350
351
352
353
354
355
356
357
358
359
360
361
362
363
364
365
366
367
368
369
370
371
372
373
374
375
376
377
378
379
380
381
382
383
384
385
386
387
388
389
390
391
392
393
394
395
396
397
398
399
400
401
402
403
404
405
406
407
408
409
410
411
412
413
414
415
416
417
418
419
420
421
422
423
424
425
426
427
428
429
430
431
432
433
434
435
436
437
438
439
440
441
442
443
444
445
446
447
448
449
450
451
452
453
454
455
456
457
458
459
460
461
462
463
464
465
466
467
468
469
470
471
472
473
474
475
476
477
478
479
480
481
482
483
484
485
486
487
488
489
490
491
492
493
494
495
496
497
498
499
500
501
502
503
504
505
506
507
508
509
510
511
512
513
514
515
516
517
518
519
520
521
522
523
524
525
526
527
528
529
530
531
532
533
534
535
536
537
538
539
540
541
542
543
544
545
546
547
548
549
550
551
552
553
554
555
556
557
558
559
560
561
562
563
564
565
566
567
568
569
570
571
572
573
574
575
576
577
578
579
580
581
582
583
584
585
586
587
588
589
590
591
592
593
594
595
596
597
598
599
600
601
602
603
604
605
606
607
608
609
610
611
612
613
614
615
616
617
618
619
620
621
622
623
624
625
626
627
628
629
630
631
632
633
634
635
636
637
638
639
640
641
642
643
644
645
646
647
648
649
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

####################################################################
#
# When you add an entry to the top of this file, add your name, the date
# in the UTC timezone, and an explanation of why something is getting masked.
# Please be extremely careful not to commit atoms that are not valid, as it can
# cause large-scale breakage, especially if it ends up in the daily snapshot.
#
## Example:
##
## # Dev E. Loper <developer@gentoo.org> (2019-07-01)
## # Masking  these versions until we can get the
## # v4l stuff to work properly again
## =media-video/mplayer-0.90_pre5
## =media-video/mplayer-0.90_pre5-r1
#
# - Best last rites (removal) practices -
# Include the following info:
# a) reason for masking
# b) bug # for the removal (and yes you should have one)
# c) date of removal (either the date or "in x days")
#
## Example:
##
## # Dev E. Loper <developer@gentoo.org> (2019-07-01)
## # Masked for removal in 30 days.  Doesn't work
## # with new libfoo. Upstream dead, gtk-1, smells
## # funny. (bug #987654)
## app-misc/some-package

#--- END OF EXAMPLES ---

# Michał Górny <mgorny@gentoo.org> (2021-03-30)
# Too strict entry_points.txt parsing causes revdeps to crash when
# dev-python/paste is installed.
>=dev-python/importlib_metadata-3.9

# Craig Andrews <candrews@gentoo.org> (2021-03-29)
# Unmaintained upstream.
# Project is also not useful due to changes in cryptocurrency mining.
# Open security issue, bug #779004
# Removal on 2021-04-29, bug #779166
net-p2p/xmr-stak

# Jonas Stein <jstein@gentoo.org> (2021-03-29)
# Depends on gtk-2, no release since 2010. 
# Removal on 2021-05-01.  
# Bug #779148.
app-editors/beaver

# Andreas Sturmlechner <asturm@gentoo.org> (2021-03-27)
# Dead upstream. Bugs #437056, #453964, #550592, #768303
# Removal on 2021-04-26.
app-eselect/eselect-infinality
app-eselect/eselect-lcdfilter
media-libs/fontconfig-ultimate
media-libs/fontconfig-infinality

# Andreas Sturmlechner <asturm@gentoo.org> (2021-03-28)
# No release since 2012, depends on deprecated dev-ml/lablgtk:2, no more
# revdeps in Gentoo ebuild repository.
# Removal on 2021-04-07, bug #769326
dev-ml/cairo-ocaml

# Jonas Stein <jstein@gentoo.org> (2021-03-27)
# Upstream is gone. Open bugs. Removal after 2021-05-01.
# Bug #778800
x11-themes/nimbus

# Jimi Huotari <chiitoo@gentoo.org> (2021-03-26)
# No consumers since 2020-09-05 (dev-libs/liboobs), and no known
# stand-alone use.
# Removal on 2021-04-25.
app-admin/system-tools-backends

# Michał Górny <mgorny@gentoo.org> (2021-03-26)
# Pins to a vulnerable version of dev-python/urllib3.  No maintainer
# in Gentoo.
# Removal on 2021-04-25.  Bug #714860.
dev-python/elasticsearch-curator

# Lars Wendler <polynomial-c@gentoo.org> (2021-03-22)
# Has unidentified race condition on very fast CPUs that causes maintainer-
# mode to be triggered.
# Most likely caused by the following upstream commit:
#   https://git.savannah.gnu.org/cgit/autoconf.git/commit/?id=aba75f6d4a9c875a9d5d90a07c6b3678db66a4bf
sys-devel/autoconf:2.71

# Sam James <sam@gentoo.org> (2021-03-22)
# Many reverse dependencies need to be ported due to changes in new glib
# Masking until they've been updated, see tracker bug for details
# bug #777675
=dev-libs/gobject-introspection-common-1.68.0
=dev-libs/gobject-introspection-1.68.0
=dev-util/gdbus-codegen-2.68.0
=dev-util/glib-utils-2.68.0
=dev-libs/glib-2.68.0
=net-libs/glib-networking-2.68.0

# Marek Szuba <marecki@gentoo.org> (2021-03-19)
# Depends on bundled out-of-date Qt5 libraries, and even with those
# installed recent upstream versions fail to run. Moreover, we have now
# got a source variant in the tree which, while still CLI-only for now,
# is up to date and actually works.
# Removal in 30 days. Bug #768228.
mail-mta/protonmail-bridge-bin

# Joonas Niilola <juippis@gentoo.org> (2021-03-16)
# A library without consumers, unbuildable for years, ebuilds not
# touched in years either. Bugs #664776, #747592. Removal in ~30 days.
dev-libs/zookeeper-c

# Sergei Trofimovich <slyfox@gentoo.org> (2021-03-15)
# Needs a port to network-3. No revdeps. Mask for removal
# in a month.
dev-haskell/network-protocol-xmpp

# Sergei Trofimovich <slyfox@gentoo.org> (2021-03-15)
# Needs a port to ghc-8.10. No revdeps. Mask for removal
# in a month.
dev-haskell/test-framework-th-prime

# Sergei Trofimovich <slyfox@gentoo.org> (2021-03-15)
# Needs a port to ghc-8.10. No revdeps. Mask for removal
# in a month.
dev-haskell/encoding

# Andreas Sturmlechner <asturm@gentoo.org> (2021-03-15)
# Unmaintained for >1 year, blocking cleanup of deprecated libraries.
# Succeeded by LXQt many years ago (see also: lxqt-base/lxqt-meta).
# Removal on 2021-04-14 or replacement by GTK3-based versions available
# in ~arch. No more stabilisation is going to happen without the packages
# getting a new maintainer. Bugs #708188, #751076, #769524
<lxde-base/lxappearance-0.6.3-r2
<lxde-base/lxappearance-obconf-0.2.3-r1
<lxde-base/lxde-icon-theme-0.5.1-r1
<lxde-base/lxde-common-0.99.2-r1
<lxde-base/lxde-meta-0.5.5-r7
<lxde-base/lxmenu-data-0.1.5
<lxde-base/lxinput-0.3.5-r2
<lxde-base/lxlauncher-0.2.5-r1
<lxde-base/lxpanel-0.10.1
<lxde-base/lxrandr-0.3.2-r1
<lxde-base/lxsession-0.5.5
<lxde-base/lxtask-0.1.10
<lxde-base/lxterminal-0.3.2-r1
<x11-misc/pcmanfm-1.3.2

# Sergei Trofimovich <slyfox@gentoo.org> (2021-03-15)
# Needs a port to ghc-8.10. No release for past 6 years.
# No revdeps. Mask for removal.
dev-haskell/geniplate

# Göktürk Yüksek <gokturk@gentoo.org> (2021-03-14)
# Dead upstream. No revdeps.
# Removal in 60 days to allow people extra time
# for transitioning out. Bug #776262.
app-admin/lastpass-cli

# Sam James <sam@gentoo.org> (2021-03-13)
# Stuck on oasis.eclass, out of date
# No reverse dependencies
# (For ounit: please port your applications to dev-ml/ounit2
# Should be a case of just a sed in most cases.)
# Removal in 14 days. Nothing should really
# be able to use any of these right now anyway.
# bug #775785, bug #749696, bug #711414
dev-ml/qcheck
dev-ml/macaque
dev-ml/pgocaml
dev-ml/csv
dev-ml/gen
dev-ml/tyxml
dev-ml/stringext
dev-ml/deriving
dev-ml/type-conv
dev-ml/optcomp
dev-ml/lwt_react
dev-ml/batteries
dev-ml/ocaml-magic-mime
dev-ml/iTeML
dev-ml/ocaml-re
dev-ml/ocamlify
dev-ml/ocamlmod
dev-ml/ocaml-expect
dev-ml/oasis
dev-ml/ounit

# Hans de Graaff <graaff@gentoo.org> (2021-03-12)
# Requires a (proxy) maintainer with access to Oracle development
# libraries. Please express your interest on bug 772128 if you can
# help.
# Masked for removal in 30 days.
dev-ruby/ruby-oci8

# Hans de Graaff <graaff@gentoo.org> (2021-03-11)
# Last upstream release in 2018, uses outdated dependencies.  No
# longer works with dev-ruby/parser, bug 775206. No reverse
# dependencies.
# Masked for removal in 30 days.
dev-ruby/astrolabe

# Hans de Graaff <graaff@gentoo.org> (2021-03-09)
# Last upstream release in 2013, ruby25-only.
# Masked for removal in 30 days.
dev-ruby/shorturl

# Brian Evans <grknight@gentoo.org> (2021-03-08)
# No longer consistently maintained, severely broken with PHP 8
# No reverse dependencies, fails tests
# Removal in 30 days.
dev-php/PEAR-Config

# Hans de Graaff <graaff@gentoo.org> (2021-03-08)
# Last litc upstream release in 2010, no reverse dependencies,
# ruby25-only. Includes fakeweb test dependency which is also
# ruby25-only and has no other reverse dependencies.
# Masked for removal in 30 days.
dev-ruby/litc
dev-ruby/fakeweb

# Hans de Graaff <graaff@gentoo.org> (2021-03-08)
# Last upstream release in 2009, no reverse dependencies,
# no test suite.
# Masked for removal in 30 days.
dev-ruby/metaid

# Hans de Graaff <graaff@gentoo.org> (2021-03-08)
# Last upstream release in 2018, no reverse dependencies,
# stuck on ruby25.
# Masked for removal in 30 days.
dev-ruby/nexpose

# Hans de Graaff <graaff@gentoo.org> (2021-03-08)
# No longer maintained upstream, last release in 2014.
# ruby25-only.
# Masked for removal in 30 days.
dev-ruby/session

# Hans de Graaff <graaff@gentoo.org> (2021-03-08)
# gitsh is maintainer-needed and stuck on ruby25.
# parslet is only needed for gitsh and also ruby25-only.
# Masked for removal in 30 days.
dev-vcs/gitsh
dev-ruby/parslet

# Hans de Graaff <graaff@gentoo.org> (2021-03-08)
# Old ruby25-only slots. Use the newer slot instead.
# Masked for removal in 30 days.
dev-ruby/i18n:0.7
dev-ruby/pcaprub:0.12
dev-ruby/pg:0

# Andreas Sturmlechner <asturm@gentoo.org> (2021-03-07)
# Unresolved build issue since 2019, QA issues, bugs #697870 and #705236
# Blocks cleanup of equally broken sci-physics/looptools-2.8, bug #770796
# Masked for removal on 2021-04-06.
sci-physics/herwig++

# Conrad Kostecki <conikost@gentoo.org> (2021-03-07)
# Upstream since 2004 gone, does not supportnon-English characters,
# multiple bugs open and unmaintained.
# Removal in 30 days.
app-portage/splat

# David Seifert <soap@gentoo.org> (2021-03-06)
# Unmaintained, abandoned upstream, tests fail, broken USE=doc, no revdeps
# in tree. Removal on 2021-04-03.  Bug #623488, #697804, #774447.
dev-libs/libgpuarray

# Andreas K. Hüttel <dilfridge@gentoo.org> (2021-03-06)
# Fails to build, multiple bugs, outdated, nontrival, unmaintained
# Bug 729876 and several others; removal in 30days
dev-libs/klibc

# Alfredo Tupone <tupone@gentoo.org> (2021-03-07)
# unbuildable
# Removal on 2021-04-05
www-servers/ocsigenserver
dev-ml/eliom
dev-ml/js_of_ocaml
dev-ml/ocaml-conduit
dev-ml/dns
dev-ml/ocaml-cohttp
dev-ml/ocaml-dispatch
dev-ml/ocaml-cstruct
dev-ml/ocaml-ipaddr
dev-ml/ocaml-uri
dev-ml/re2
dev-ml/bin-prot
dev-ml/configurator
dev-ml/ppx_traverse
dev-ml/ppx_type_conv
dev-ml/bin-prot
dev-ml/ppx_driver
dev-ml/ppx_core
dev-ml/ppx_ast
dev-ml/ppx_traverse_builtins
dev-ml/jbuilder

# Conrad Kostecki <conikost@gentoo.org> (2021-03-05)
# Deprecated by upstream and unsupported due EOL.
# Multiple bugs open and unmaintained.
# Removal in 30 days.
sys-apps/newrelic-sysmond

# Conrad Kostecki <conikost@gentoo.org> (2021-03-05)
# Dead upstream, multiple bugs open and unmaintained.
# Removal in 30 days.
app-mobilephone/smsclient

# Conrad Kostecki <conikost@gentoo.org> (2021-03-05)
# Dead upstream, multiple bugs open and unmaintained.
# Removal in 30 days.
net-misc/capi4hylafax

# Conrad Kostecki <conikost@gentoo.org> (2021-03-05)
# Dead upstream and unmaintained.
# Removal in 30 days.
app-misc/towitoko

# Conrad Kostecki <conikost@gentoo.org> (2021-03-04)
# Dead upstream and unmaintained.
# Removal in 30 days.
app-misc/logserial

# Conrad Kostecki <conikost@gentoo.org> (2021-03-04)
# Dead upstream, open bugs and unmaintained.
# Removal in 30 days.
net-dns/sheerdns

# Sam James <sam@gentoo.org> (2021-03-03)
# Declared abandoned upstream and stuck
# on Python 3.7.
# Removal in 30 days.
app-office/moneyguru

# Sam James <sam@gentoo.org> (2021-03-03)
# Doesn't seem to sync clock correctly
# in some cases.
# bug #772998
~net-misc/openntpd-6.8_p1

# Alfredo Tupone <tupone@gentoo.org> (2021-03-03)
# no package uses it
# Removal on 2021-04-02
dev-ml/core_extended

# Sam James <sam@gentoo.org> (2021-03-01)
# Mask new proj 8.x as it removes deprecated
# API. Likely to break several consumers
# which haven't yet ported.
# bug #729098
~sci-libs/proj-8.0.0

# Bernd Waibel <waebbl-gentoo@posteo.net> (2021-02-27)
# Mask until removal of media-gfx/openexr_viewers.
# Version has several vulnerabilities. See #717474
=media-libs/ilmbase-2.3.0

# Bernd Waibel <waebbl-gentoo@posteo.net> (2021-02-27)
# Mask until removal of media-gfx/openexr_viewers.
# Version has several vulnerabilities. See #717474
=media-libs/openexr-2.3.0

# Bernd Waibel <waebbl-gentoo@posteo.net> (2021-02-27)
# No longer actively supported upstream.
# Removal needed to clean-up {ilmbase,openexr}-2.3.0
# Masked for removal in 30 days.
media-gfx/openexr_viewers

# Sam James <sam@gentoo.org> (2021-02-18)
# 0.9.27 included a regression wrt deletes
# bug #768948
=dev-db/lmdb-0.9.27

# Lars Wendler <polynomial-c@gentoo.org> (2021-02-15)
# Mask development versions now that they were bumped...
=net-misc/kea-1.9*

# Sergei Trofimovich <slyfox@gentoo.org> (2021-02-08)
# Abandoned upstream. Was never ported from gtk-2.
# A possible alternative is media-gfx/geeqie (gqview fork).
# Removal in 3 months. Bug #769440.
media-gfx/gqview

# Michał Górny <mgorny@gentoo.org> (2021-02-01)
# LibreSSL support is discontinued.  Please read the relevant news item
# and either migrate to dev-libs/openssl, or use the unsupported
# user-maintained libressl overlay.
# Removal on 2021-05-01.  Bug #762847.
dev-libs/libressl

# Marek Szuba <marecki@gentoo.org> (2021-01-21)
# Masked for testing and further work - the golang-vcs-snapshot variant
# seems to be incompatible with revdeps using go-module, the variant
# using the latter is still broken.
dev-go/qt

# Michał Górny <mgorny@gentoo.org> (2020-11-10)
# This old Kodi version requires vulnerable dev-python/pillow
# and prevents users from upgrading.  Masked for the time being.
# Bug #729672.
media-plugins/kodi-game-libretro-nestopia
media-plugins/kodi-game-libretro-dosbox

# Alfredo Tupone <tupone@gentoo.org> (2020-11-05)
# will be upgraded after new lua release
www-apps/liquid_feedback_frontend
www-apps/webmcp

# Georgy Yakovlev <gyakovlev@gentoo.org> (2020-10-30)
# broken acl handling, possible broken chattr handling
# needs more testing
# https://bugs.gentoo.org/751739
=sys-apps/opentmpfiles-0.3.1

# Stephan Hartmann <sultan@gentoo.org> (2021-03-21)
# Dev channel releases are only for people who
# are developers or want more experimental features
# and accept a more unstable release.
>=www-client/chromium-91

# Andreas Sturmlechner <asturm@gentoo.org> (2020-10-26)
# Historical metapackage that exists in slot 5 only for transition from KDE SC4.
# Masked for removal on 2021-08-31. Replaced by:
# emerge --noreplace kde-plasma/plasma-meta kde-apps/kde-apps-meta
kde-apps/kde-meta:5

# Andreas Sturmlechner <asturm@gentoo.org> (2020-10-26)
# Historical metapackage that exists in slot 5 only for transition from KDE SC4.
# Masked for removal on 2021-08-31. Replaced by:
# emerge --noreplace kde-plasma/plasma-meta kde-apps/kdecore-meta
kde-apps/kdebase-meta:5

# Sam James <sam@gentoo.org> (2020-10-05)
# Masked for testing. New major versions of Guile
# often break reverse dependencies.
# Guile in Gentoo is not slotted, so let's be cautious.
# bug #705554, bug #689408.
>=dev-scheme/guile-3.0.4

# Ulrich Müller <ulm@gentoo.org> (2020-10-04)
# Version 1.11 introduced different startup conventions for the server
# which breaks the OpenRC init script. Bug #746227.
>=net-misc/tigervnc-1.11.0

# Arfrever Frehtes Taifersar Arahesis <arfrever.fta@gmail.com> (2020-09-01)
# Mismatched version (bug #695022). Masked to force upgrade to 2.0.4_pre20200306162733.
# (Mask should remain after ebuilds are deleted, until 2021-03-01 or
# until new upstream release with proper versioning.)
~app-i18n/sunpinyin-3.0.0_rc1
~app-i18n/ibus-sunpinyin-3.0.0_rc1
~app-i18n/scim-sunpinyin-3.0.0_rc1
~app-i18n/xsunpinyin-3.0.0_rc1

# Alfredo Tupone <tupone@gentoo.org> (2020-08-23)
# Ported to py3 but not yet released
# Masked to allow py2.7 removal
dev-lang/spark

# Mart Raudsepp <leio@gentoo.org> (2020-08-15)
# Development release, needs testing to ensure valac-0.50
# works for existing packages
>=dev-libs/vala-common-0.49
dev-lang/vala:0.50

# Sam James <sam@gentoo.org> (2020-07-20)
# Serious security vulnerabilities, including
# remote code execution. Upstream have not yet
# made a stable release in response to numerous
# CVEs. Applying patches is not a workable
# solution for now because of the fragility
# of reverse dependencies.
# Indefinitely masking until we have a solution
# for this.
# bug #719084
# Furthermore, ntopng ebuilds depending directly on dev-lang/lua{,jit}
# must be migrated to lua eclasses before unmasking (bug #752777).
net-analyzer/ntopng
net-analyzer/pmacct
net-libs/nDPI

# Mart Raudsepp <leio@gentoo.org> (2020-06-06)
# Meson port does not handle multilib yet and has issues
# regarding runstatedir (not using /run).
=net-misc/networkmanager-1.22*

# Georgy Yakovlev <gyakovlev@gentoo.org> (2020-03-27)
# Vulnerable old version of icedtea-web #711392
<dev-java/icedtea-web-1.8.4

# Eray Aslan <eras@gentoo.org> (2020-03-09)
# Mask experimental software
=mail-mta/postfix-3.6*

# Miroslav Šulc <fordfrog@gentoo.org> (2020-02-27)
# >=dev-java/ant-eclipse-ecj-4.10 depends on masked >=virtual/{jdk,jre}-11
# www-servers/tomcat >= 9 depends on masked dev-java/eclipse-ecj
>=dev-java/ant-eclipse-ecj-4.10
>=dev-java/eclipse-ecj-4.10
>=www-servers/tomcat-9

# Mart Raudsepp <leio@gentoo.org> (2020-02-16)
# Fails to automatically launch pipewire for me. Help welcome figuring it out.
net-misc/gnome-remote-desktop

# Stefan Strogin <steils@gentoo.org> (2020-02-12)
# Mask for testing revdeps.
>=dev-games/mygui-3.4.0

# Patrick McLean <chutzpah@gentoo.org> (2020-02-07)
# Mask until sys-libs/libxcrypt[system] is unmasked
>=virtual/libcrypt-2

# Mart Raudsepp <leio@gentoo.org> (2020-02-03)
# Needs news item, known breakages that need to be handled first, bug 698922
>=x11-libs/pango-1.43
>=dev-cpp/pangomm-2.48

# Andrew Ammerlaan <andrewammerlaan@riseup.net> (2020-01-26)
# v3.6.4 uses huge amounts of memory: Bug #705682
# v3.6.1 is the latest version without this issue
>=dev-libs/libsass-3.6.2

# Lars Wendler <polynomial-c@gentoo.org> (2019-11-14)
# Breaks archives containing relative paths
# when being called with --no-absolute-filenames
# https://bugs.gentoo.org/700020
=app-arch/cpio-2.13

# Lars Wendler <polynomial-c@gentoo.org> (2019-10-16)
# Joonas Niilola <juippis@gentoo.org> (2021-03-18)
# Depends on apache-2.2
# Removal on 2021-04-01. Bug #655502
dev-libs/OpenSRF

# Matt Turner <mattst88@gentoo.org> (2019-09-01)
# TeXmacs is the only remaining package in tree that requires guile-1.8, which
# is unsupported upstream. A TeXmacs port to Guile-2 has been in progress for a
# few years. Bug #436400
app-office/texmacs
<dev-scheme/guile-2

# Robin H. Johnson <robbat2@gentoo.org> (2019-07-08)
# Needs LOTS of testing, broke boot on my laptop in early attempts, maybe needs
# matching genkernel work?
>=sys-fs/lvm2-2.03

# Andreas Sturmlechner <asturm@gentoo.org> (2018-11-25)
# Masked per security vulnerability CVE-2018-14345, bug #661510
# Keeping it masked while users have unsolved issues with >0.15.0.
<x11-misc/sddm-0.18.0

# Andreas Sturmlechner <asturm@gentoo.org> (2018-10-07)
# Masked for more testing especially of reverse-deps.
>=dev-games/ogre-1.11.2

# Andreas K. Hüttel <dilfridge@gentoo.org> (2018-09-11)
# Mask transition ebuilds that were needed only for <glibc-2.26
# We will keep them in the tree as long as we have masked
# <glibc-2.26.
~net-libs/libnsl-0
~net-libs/rpcsvc-proto-0

# James Le Cuirot <chewi@gentoo.org> (2017-12-17)
# Java 11 is not yet fully supported on Gentoo. Packages cannot depend
# on it so these virtuals are not yet required. If you wish to use
# Java 11 then install openjdk-(jdk|jre)-bin directly.
virtual/jdk:11
virtual/jre:11

# Andreas K. Hüttel <dilfridge@gentoo.org> (2017-10-18)
# sys-devel/automake versions 1.4, 1.5, 1.6, 1.7, 1.8
# have known security vulnerabilities, are broken with
# recent Perl (>=5.26.0), and are not used by anything in
# the Gentoo repository. Please uninstall.
sys-devel/automake:1.4
sys-devel/automake:1.5
sys-devel/automake:1.6
sys-devel/automake:1.7
sys-devel/automake:1.8
sys-devel/automake:1.9
sys-devel/automake:1.10

# Nicolas Bock <nicolasbock@gentoo.org> (2017-10-31)
# There are multiple unresolved upstream issues with >=jabref-bin-4.0 (#636036).
# If you still would like to use this version, please report any issues to
# upstream.
>=app-text/jabref-bin-4.0

# Michał Górny <mgorny@gentoo.org> (2017-05-22)
# for Maciej S. Szmigiero <mail@maciej.szmigiero.name>
# Any version above 5.100.138 breaks b43 driver in various ways.
# Also, b43 wiki page says to use 5.100.138. Bug #541080.
>=sys-firmware/b43-firmware-6.30.163.46

# Andreas K. Hüttel <dilfridge@gentoo.org> (2017-05-21)
# (and others, updated later)
# These old versions of toolchain packages (binutils, gcc, glibc) are no
# longer officially supported and are not suitable for general use. Using
# these packages can result in build failures (and possible breakage) for
# many packages, and may leave your system vulnerable to known security
# exploits.
# If you still use one of these old toolchain packages, please upgrade (and
# switch the compiler / the binutils) ASAP. If you need them for a specific
# (isolated) use case, feel free to unmask them on your system.
<sys-libs/glibc-2.32-r3
<sys-devel/binutils-2.34
<sys-devel/binutils-hppa64-2.34

# Michael Orlitzky <mjo@gentoo.org> (2017-01-07)
# This package has some dangerous quality and security issues, but
# people may still find it useful. It is masked to prevent accidental
# use. See bugs 603346 and 604998 for more information.
app-admin/amazon-ec2-init

# Michał Górny <mgorny@gentoo.org> (2016-11-17)
# New version masked for testing. It supports source-window buffer size
# over 2G but it 'currently performs 3-5% slower and has 1-2% worse
# compression'.
>=dev-util/xdelta-3.1.0

# Robin H. Johnson <robbat2@gentoo.org> (2014-08-04)
# Masked for testing, presently fails upstream testsuite:
# FAIL:07:02:35 (00:00:00) db_dump/db_load(./TESTDIR.3/recd001.db:child killed: kill signal): expected 0, got 1
# FAIL:07:02:35 (00:00:00) Dump/load of ./TESTDIR.3/recd001.db failed.
# FAIL:07:02:35 (00:00:00) db_verify_preop: expected 0, got 1
=sys-libs/db-6.1*
=sys-libs/db-6.2*
=sys-libs/db-18.1*

# Mikle Kolyada <zlogene@gentoo.org> (2014-06-27)
# Masked for proper testing. (Major updates in the code).
~dev-perl/PortageXS-0.2.12

# Mike Gilbert <floppym@gentoo.org> (2014-03-04)
# Dev channel releases are only for people who are developers or want more
# experimental features and accept a more unstable release.
www-plugins/chrome-binary-plugins:unstable

# Diego E. Pettenò <flameeyes@gentoo.org> (2009-01-03)
# These packages are not supposed to be merged directly, instead
# please use sys-devel/crossdev to install them.
dev-util/mingw64-runtime
sys-libs/newlib
dev-embedded/avr-libc