summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-04-04 08:52:52 +0000
committerMichał Górny <mgorny@gentoo.org>2015-04-04 08:52:52 +0000
commitc8351e87eb68ac500c057d8d40fc172d1becad62 (patch)
treea5c6245793462e17bc932ec8217f27aaa7824e0b /net-wireless/blueman/blueman-9999.ebuild
parentrm oldest (diff)
downloadhistorical-c8351e87eb68ac500c057d8d40fc172d1becad62.tar.gz
historical-c8351e87eb68ac500c057d8d40fc172d1becad62.tar.bz2
historical-c8351e87eb68ac500c057d8d40fc172d1becad62.zip
Sync -9999. Remove conf file path patch and GConf magic, GSettings are used for config now. Pass proper --docdir.
Package-Manager: portage-2.2.18/cvs/Linux x86_64 Manifest-Sign-Key: 0xEFB4464E!
Diffstat (limited to 'net-wireless/blueman/blueman-9999.ebuild')
-rw-r--r--net-wireless/blueman/blueman-9999.ebuild29
1 files changed, 15 insertions, 14 deletions
diff --git a/net-wireless/blueman/blueman-9999.ebuild b/net-wireless/blueman/blueman-9999.ebuild
index 4c145ebfce1c..8fbf71607b11 100644
--- a/net-wireless/blueman/blueman-9999.ebuild
+++ b/net-wireless/blueman/blueman-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/blueman/blueman-9999.ebuild,v 1.7 2015/01/05 19:56:01 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/blueman/blueman-9999.ebuild,v 1.8 2015/04/04 08:52:43 mgorny Exp $
EAPI="5"
@@ -21,16 +21,13 @@ fi
LICENSE="GPL-3"
SLOT="0"
-IUSE="gconf sendto network nls policykit pulseaudio"
+IUSE="gconf gnome network nls policykit pulseaudio thunar"
CDEPEND="dev-libs/glib:2=
x11-libs/gtk+:3=
x11-libs/startup-notification:=
dev-python/dbus-python[${PYTHON_USEDEP}]
- || (
- dev-python/pygobject:2
- dev-python/pygobject:3
- )
+ dev-python/pygobject:3
>=net-wireless/bluez-4.61:=
${PYTHON_DEPS}"
DEPEND="${CDEPEND}
@@ -42,12 +39,17 @@ RDEPEND="${CDEPEND}
sys-apps/dbus
x11-themes/hicolor-icon-theme
gconf? ( dev-python/gconf-python[${PYTHON_USEDEP}] )
- sendto? ( gnome-base/nautilus )
+ gnome? ( gnome-base/nautilus )
network? ( || ( net-dns/dnsmasq
net-misc/dhcp
>=net-misc/networkmanager-0.8 ) )
policykit? ( sys-auth/polkit )
- pulseaudio? ( media-sound/pulseaudio )"
+ pulseaudio? ( media-sound/pulseaudio )
+ !net-wireless/gnome-bluetooth
+ x11-themes/gnome-icon-theme
+ thunar? ( xfce-base/thunar )
+"
+# See bug 455320 and https://github.com/blueman-project/blueman/issues/112 for reason for gnome-icon-theme dep
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
@@ -57,18 +59,18 @@ src_prepare() {
data/blueman-manager.desktop.in || die "sed failed"
epatch \
- "${FILESDIR}/${PN}-9999-plugins-conf-file.patch" \
"${FILESDIR}/${PN}-9999-set-codeset-for-gettext-to-UTF-8-always.patch"
eautoreconf
}
src_configure() {
econf \
+ --docdir=/usr/share/doc/${PF} \
--disable-static \
$(use_enable policykit polkit) \
- $(use_enable sendto) \
- --disable-hal \
- $(use_enable nls)
+ $(use_enable gnome nautilus-sendto) \
+ $(use_enable nls) \
+ $(use_enable thunar thunar-sendto)
}
src_install() {
@@ -77,10 +79,9 @@ src_install() {
python_fix_shebang "${D}"
rm "${D}"/$(python_get_sitedir)/*.la || die
- use sendto && { rm "${D}"/usr/lib*/nautilus-sendto/plugins/*.la || die; }
+ use gnome && { rm "${D}"/usr/lib*/nautilus-sendto/plugins/*.la || die; }
# Note: Python 3 support would need __pycache__ file removal too
- use gconf || { rm "${D}"/$(python_get_sitedir)/${PN}/plugins/config/Gconf.py* || die; }
use policykit || { rm -rf "${D}"/usr/share/polkit-1 || die; }
use pulseaudio || { rm "${D}"/$(python_get_sitedir)/${PN}/{main/Pulse*.py*,plugins/manager/Pulse*.py*} || die; }
}