aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/granite/Manifest1
-rw-r--r--dev-libs/granite/files/granite-0.3.0-build-fix-vala.patch12
-rw-r--r--dev-libs/granite/files/granite-0.3.0-build-fix.patch22
-rw-r--r--dev-libs/granite/files/granite-0.3.0-build-fix2.patch13
-rw-r--r--dev-libs/granite/files/granite-0.3.0-build-fix3.patch24
-rw-r--r--dev-libs/granite/granite-0.3.0.ebuild65
-rw-r--r--dev-libs/granite/metadata.xml23
7 files changed, 160 insertions, 0 deletions
diff --git a/dev-libs/granite/Manifest b/dev-libs/granite/Manifest
new file mode 100644
index 0000000..2eee50a
--- /dev/null
+++ b/dev-libs/granite/Manifest
@@ -0,0 +1 @@
+DIST granite-0.3.0.tar.gz 285072 BLAKE2B 21cb3d7216fd18d18f96e50b69a75db5127319c36129bd584b29cb359905cf4439163969b727dfa1decc642d03902390fbb656a5a76da6ad474475694d122590 SHA512 3ebbb7453b770f8b5b98cee0f96db8443d7583af0117b2d34c9daa82bf36d25418e0fcf61118e7551ced91e751d8b032998dc9cca2569e61c7227666c4383872
diff --git a/dev-libs/granite/files/granite-0.3.0-build-fix-vala.patch b/dev-libs/granite/files/granite-0.3.0-build-fix-vala.patch
new file mode 100644
index 0000000..fa7ff1a
--- /dev/null
+++ b/dev-libs/granite/files/granite-0.3.0-build-fix-vala.patch
@@ -0,0 +1,12 @@
+--- granite-0.3.0/lib/Widgets/ContractorView.vala 2014-05-25 21:42:24.000000000 +0200
++++ granite-0.3.0/lib/Widgets/ContractorView.vala 2017-09-30 18:19:03.980547473 +0200
+@@ -181,7 +181,7 @@
+ string text = value.get_string ();
+
+ if (text[3:text.index_of ("</b>")] in names) {
+- list.remove (it);
++ list.remove (ref it);
+ blacklisted_pos += cur_pos;
+ }
+ if (!check)
+
diff --git a/dev-libs/granite/files/granite-0.3.0-build-fix.patch b/dev-libs/granite/files/granite-0.3.0-build-fix.patch
new file mode 100644
index 0000000..f93a3c6
--- /dev/null
+++ b/dev-libs/granite/files/granite-0.3.0-build-fix.patch
@@ -0,0 +1,22 @@
+=== modified file 'lib/Widgets/ContractorView.vala'
+--- lib/Widgets/ContractorView.vala 2014-09-04 12:39:00 +0000
++++ lib/Widgets/ContractorView.vala 2015-03-23 05:21:46 +0000
+@@ -35,7 +35,7 @@
+ public delegate void ContractCallback ();
+ private Gee.HashMap<int, DelegateWrapper?> outsiders;
+ private int[] blacklisted_pos;
+- private ListStore list;
++ private Gtk.ListStore list;
+
+ private struct DelegateWrapper { unowned ContractCallback method; }
+
+@@ -73,7 +73,7 @@
+ */
+ public ContractorView (string filename, string mime, int icon_size = 32, bool show_contract_name = true) {
+ /* Setup the ListStore */
+- list = new ListStore (2, typeof (Gdk.Pixbuf), typeof (string));
++ list = new Gtk.ListStore (2, typeof (Gdk.Pixbuf), typeof (string));
+ outsiders = new Gee.HashMap<int, DelegateWrapper?> ();
+ this.model = list;
+
+
diff --git a/dev-libs/granite/files/granite-0.3.0-build-fix2.patch b/dev-libs/granite/files/granite-0.3.0-build-fix2.patch
new file mode 100644
index 0000000..7c6bcb9
--- /dev/null
+++ b/dev-libs/granite/files/granite-0.3.0-build-fix2.patch
@@ -0,0 +1,13 @@
+=== modified file 'lib/Widgets/DynamicNotebook.vala'
+--- lib/Widgets/DynamicNotebook.vala 2014-08-30 13:28:37 +0000
++++ lib/Widgets/DynamicNotebook.vala 2014-09-23 13:43:11 +0000
+@@ -941,7 +941,7 @@
+ notebook.create_window.connect (on_create_window);
+ }
+
+- ~Notebook () {
++ ~DynamicNotebook () {
+ notebook.switch_page.disconnect (on_switch_page);
+ notebook.page_added.disconnect (on_page_added);
+ notebook.page_removed.disconnect (on_page_removed);
+
diff --git a/dev-libs/granite/files/granite-0.3.0-build-fix3.patch b/dev-libs/granite/files/granite-0.3.0-build-fix3.patch
new file mode 100644
index 0000000..145d552
--- /dev/null
+++ b/dev-libs/granite/files/granite-0.3.0-build-fix3.patch
@@ -0,0 +1,24 @@
+=== modified file 'lib/Widgets/DynamicNotebook.vala'
+--- lib/Widgets/DynamicNotebook.vala 2014-07-31 12:41:52 +0000
++++ lib/Widgets/DynamicNotebook.vala 2014-08-30 13:28:37 +0000
+@@ -658,10 +658,19 @@
+ /**
+ * The text shown in the add button tooltip
+ */
++#if VALA_0_26
++ public string add_button_tooltip {
++ get { _add_button_tooltip = add_button.tooltip_text; return _add_button_tooltip; }
++ set { add_button.tooltip_text = value; }
++ }
++ // Use temporary field to avoid breaking API this can be dropped while preparing for 0.4
++ string _add_button_tooltip;
++#else
+ public string add_button_tooltip {
+ get { return add_button.tooltip_text; }
+ set { add_button.tooltip_text = value; }
+ }
++#endif
+
+ public Tab current {
+ get { return tabs.nth_data (notebook.get_current_page ()); }
+
diff --git a/dev-libs/granite/granite-0.3.0.ebuild b/dev-libs/granite/granite-0.3.0.ebuild
new file mode 100644
index 0000000..3f6e945
--- /dev/null
+++ b/dev-libs/granite/granite-0.3.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+VALA_MIN_API_VERSION="0.24"
+
+inherit cmake-utils gnome2-utils multilib vala versionator
+
+DESCRIPTION="A development library for elementary development"
+HOMEPAGE="https://launchpad.net/granite"
+SRC_URI="https://launchpad.net/${PN}/$(get_version_component_range 1-2)/$(get_version_component_range 1-2)/+download/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/glib-2.32:2
+ dev-libs/gobject-introspection:=
+ dev-libs/libgee:0.8[introspection]
+ >=x11-libs/gtk+-3.11.6:3
+"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+DOCS=( AUTHORS )
+PATCHES=(
+ # https://bugs.launchpad.net/granite/+bug/1453526
+ "${FILESDIR}"/${P}-build-fix{,2,3}.patch
+ "${FILESDIR}"/${P}-build-fix-vala.patch
+)
+
+src_prepare() {
+ vala_src_prepare
+ sed -i -e "/NAMES/s:valac:${VALAC}:" cmake/FindVala.cmake || die
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ mycmakeargs=(
+ -DLIB_INSTALL_DIR=$(get_libdir)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ HTML_DOCS=( doc/. )
+ cmake-utils_src_install
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/dev-libs/granite/metadata.xml b/dev-libs/granite/metadata.xml
new file mode 100644
index 0000000..1071e73
--- /dev/null
+++ b/dev-libs/granite/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>herb@hlmjr.com</email>
+ <name>Herb Miller Jr. (herbmillerjr)</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">
+ Granite is a companion library for GTK+ and GLib. Among other things,
+ it provides complex widgets and convenience functions designed for
+ use in apps built for elementary OS.
+ </longdescription>
+ <use>
+ <flag name="demo">Build the Granite demo application (to present all available UI features provided by the library)</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">elementary/granite</remote-id>
+ </upstream>
+</pkgmetadata>