aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorcnd <cynede@gentoo.org>2019-05-12 23:17:58 +0400
committerGitHub <noreply@github.com>2019-05-12 23:17:58 +0400
commit595e8cceadfcbbc6cc4c4dd7301040f17ecc9400 (patch)
tree9262d5f7be8141523a34dc0928baee086c38d9a4
parentMerge pull request #423 from GregBowyer/libressl (diff)
parentRevert "Allow things to be built with libressl support" (diff)
downloaddotnet-595e8cceadfcbbc6cc4c4dd7301040f17ecc9400.tar.gz
dotnet-595e8cceadfcbbc6cc4c4dd7301040f17ecc9400.tar.bz2
dotnet-595e8cceadfcbbc6cc4c4dd7301040f17ecc9400.zip
Merge pull request #425 from gentoo/revert-423-libressl
Revert "Allow things to be built with libressl support"
-rw-r--r--dev-dotnet/dotnetcore-aspnet-bin/dotnetcore-aspnet-bin-2.0.3.ebuild3
-rw-r--r--dev-dotnet/dotnetcore-runtime-bin/dotnetcore-runtime-bin-2.0.4.ebuild3
-rw-r--r--dev-dotnet/dotnetcore-runtime-bin/dotnetcore-runtime-bin-2.0.6.ebuild3
-rw-r--r--dev-dotnet/dotnetcore-runtime-bin/dotnetcore-runtime-bin-2.0.7.ebuild3
-rw-r--r--dev-dotnet/dotnetcore-sdk-bin/dotnetcore-sdk-bin-2.1.102.ebuild3
-rw-r--r--dev-dotnet/dotnetcore-sdk-bin/dotnetcore-sdk-bin-2.1.105.ebuild3
-rw-r--r--dev-dotnet/dotnetcore-sdk-bin/dotnetcore-sdk-bin-2.1.3.ebuild3
-rw-r--r--dev-dotnet/dotnetcore-sdk-bin/dotnetcore-sdk-bin-2.1.302.ebuild3
-rw-r--r--dev-dotnet/dotnetcore-sdk-bin/dotnetcore-sdk-bin-2.2.105.ebuild3
-rw-r--r--dev-dotnet/dotnetcore-sdk/dotnetcore-sdk-1.0.0_pre2_p003121.ebuild3
-rw-r--r--dev-dotnet/dotnetcore-sdk/dotnetcore-sdk-1.0.0_pre2_p003131.ebuild3
-rw-r--r--dev-dotnet/dotnetcore-sdk/dotnetcore-sdk-1.1.1-r1.ebuild3
-rw-r--r--dev-dotnet/dotnetcore-sdk/dotnetcore-sdk-1.1.1-r2.ebuild3
-rw-r--r--dev-dotnet/dotnetcore-sdk/dotnetcore-sdk-1.1.1.ebuild3
14 files changed, 14 insertions, 28 deletions
diff --git a/dev-dotnet/dotnetcore-aspnet-bin/dotnetcore-aspnet-bin-2.0.3.ebuild b/dev-dotnet/dotnetcore-aspnet-bin/dotnetcore-aspnet-bin-2.0.3.ebuild
index 7dac32f..d0ed835 100644
--- a/dev-dotnet/dotnetcore-aspnet-bin/dotnetcore-aspnet-bin-2.0.3.ebuild
+++ b/dev-dotnet/dotnetcore-aspnet-bin/dotnetcore-aspnet-bin-2.0.3.ebuild
@@ -23,8 +23,7 @@ RDEPEND="
>=sys-libs/libunwind-1.1-r1
>=dev-libs/icu-57.1
>=dev-util/lttng-ust-2.8.1
- !libressl? ( dev-libs/openssl:0 )
- libressl? ( dev-libs/libressl )
+ >=dev-libs/openssl-1.0.2h-r2
>=net-misc/curl-7.49.0
>=app-crypt/mit-krb5-1.14.2
>=sys-libs/zlib-1.2.8-r1
diff --git a/dev-dotnet/dotnetcore-runtime-bin/dotnetcore-runtime-bin-2.0.4.ebuild b/dev-dotnet/dotnetcore-runtime-bin/dotnetcore-runtime-bin-2.0.4.ebuild
index 6ef065d..960374f 100644
--- a/dev-dotnet/dotnetcore-runtime-bin/dotnetcore-runtime-bin-2.0.4.ebuild
+++ b/dev-dotnet/dotnetcore-runtime-bin/dotnetcore-runtime-bin-2.0.4.ebuild
@@ -26,8 +26,7 @@ RDEPEND="
>=sys-libs/libunwind-1.1-r1
>=dev-libs/icu-57.1
>=dev-util/lttng-ust-2.8.1
- !libressl? ( dev-libs/openssl:0 )
- libressl? ( dev-libs/libressl )
+ >=dev-libs/openssl-1.0.2h-r2
>=net-misc/curl-7.49.0
>=app-crypt/mit-krb5-1.14.2
>=sys-libs/zlib-1.2.8-r1
diff --git a/dev-dotnet/dotnetcore-runtime-bin/dotnetcore-runtime-bin-2.0.6.ebuild b/dev-dotnet/dotnetcore-runtime-bin/dotnetcore-runtime-bin-2.0.6.ebuild
index 6ef065d..960374f 100644
--- a/dev-dotnet/dotnetcore-runtime-bin/dotnetcore-runtime-bin-2.0.6.ebuild
+++ b/dev-dotnet/dotnetcore-runtime-bin/dotnetcore-runtime-bin-2.0.6.ebuild
@@ -26,8 +26,7 @@ RDEPEND="
>=sys-libs/libunwind-1.1-r1
>=dev-libs/icu-57.1
>=dev-util/lttng-ust-2.8.1
- !libressl? ( dev-libs/openssl:0 )
- libressl? ( dev-libs/libressl )
+ >=dev-libs/openssl-1.0.2h-r2
>=net-misc/curl-7.49.0
>=app-crypt/mit-krb5-1.14.2
>=sys-libs/zlib-1.2.8-r1
diff --git a/dev-dotnet/dotnetcore-runtime-bin/dotnetcore-runtime-bin-2.0.7.ebuild b/dev-dotnet/dotnetcore-runtime-bin/dotnetcore-runtime-bin-2.0.7.ebuild
index 6ef065d..960374f 100644
--- a/dev-dotnet/dotnetcore-runtime-bin/dotnetcore-runtime-bin-2.0.7.ebuild
+++ b/dev-dotnet/dotnetcore-runtime-bin/dotnetcore-runtime-bin-2.0.7.ebuild
@@ -26,8 +26,7 @@ RDEPEND="
>=sys-libs/libunwind-1.1-r1
>=dev-libs/icu-57.1
>=dev-util/lttng-ust-2.8.1
- !libressl? ( dev-libs/openssl:0 )
- libressl? ( dev-libs/libressl )
+ >=dev-libs/openssl-1.0.2h-r2
>=net-misc/curl-7.49.0
>=app-crypt/mit-krb5-1.14.2
>=sys-libs/zlib-1.2.8-r1
diff --git a/dev-dotnet/dotnetcore-sdk-bin/dotnetcore-sdk-bin-2.1.102.ebuild b/dev-dotnet/dotnetcore-sdk-bin/dotnetcore-sdk-bin-2.1.102.ebuild
index d7d9f39..572e61c 100644
--- a/dev-dotnet/dotnetcore-sdk-bin/dotnetcore-sdk-bin-2.1.102.ebuild
+++ b/dev-dotnet/dotnetcore-sdk-bin/dotnetcore-sdk-bin-2.1.102.ebuild
@@ -26,8 +26,7 @@ RDEPEND="
>=sys-libs/libunwind-1.1-r1
>=dev-libs/icu-57.1
>=dev-util/lttng-ust-2.8.1
- !libressl? ( dev-libs/openssl:0 )
- libressl? ( dev-libs/libressl )
+ >=dev-libs/openssl-1.0.2h-r2
>=net-misc/curl-7.49.0
>=app-crypt/mit-krb5-1.14.2
>=sys-libs/zlib-1.2.8-r1
diff --git a/dev-dotnet/dotnetcore-sdk-bin/dotnetcore-sdk-bin-2.1.105.ebuild b/dev-dotnet/dotnetcore-sdk-bin/dotnetcore-sdk-bin-2.1.105.ebuild
index 6f296b2..8ec5bbd 100644
--- a/dev-dotnet/dotnetcore-sdk-bin/dotnetcore-sdk-bin-2.1.105.ebuild
+++ b/dev-dotnet/dotnetcore-sdk-bin/dotnetcore-sdk-bin-2.1.105.ebuild
@@ -26,8 +26,7 @@ RDEPEND="
>=sys-libs/libunwind-1.1-r1
>=dev-libs/icu-57.1
>=dev-util/lttng-ust-2.8.1
- !libressl? ( dev-libs/openssl:0 )
- libressl? ( dev-libs/libressl )
+ >=dev-libs/openssl-1.0.2h-r2
>=net-misc/curl-7.49.0
>=app-crypt/mit-krb5-1.14.2
>=sys-libs/zlib-1.2.8-r1
diff --git a/dev-dotnet/dotnetcore-sdk-bin/dotnetcore-sdk-bin-2.1.3.ebuild b/dev-dotnet/dotnetcore-sdk-bin/dotnetcore-sdk-bin-2.1.3.ebuild
index 3c21fa7..05a044a 100644
--- a/dev-dotnet/dotnetcore-sdk-bin/dotnetcore-sdk-bin-2.1.3.ebuild
+++ b/dev-dotnet/dotnetcore-sdk-bin/dotnetcore-sdk-bin-2.1.3.ebuild
@@ -26,8 +26,7 @@ RDEPEND="
>=sys-libs/libunwind-1.1-r1
>=dev-libs/icu-57.1
>=dev-util/lttng-ust-2.8.1
- !libressl? ( dev-libs/openssl:0 )
- libressl? ( dev-libs/libressl )
+ >=dev-libs/openssl-1.0.2h-r2
>=net-misc/curl-7.49.0
>=app-crypt/mit-krb5-1.14.2
>=sys-libs/zlib-1.2.8-r1
diff --git a/dev-dotnet/dotnetcore-sdk-bin/dotnetcore-sdk-bin-2.1.302.ebuild b/dev-dotnet/dotnetcore-sdk-bin/dotnetcore-sdk-bin-2.1.302.ebuild
index d2b2332..82acb92 100644
--- a/dev-dotnet/dotnetcore-sdk-bin/dotnetcore-sdk-bin-2.1.302.ebuild
+++ b/dev-dotnet/dotnetcore-sdk-bin/dotnetcore-sdk-bin-2.1.302.ebuild
@@ -29,8 +29,7 @@ RDEPEND="
>=sys-libs/libunwind-1.1-r1
>=dev-libs/icu-57.1
>=dev-util/lttng-ust-2.8.1
- !libressl? ( dev-libs/openssl:0 )
- libressl? ( dev-libs/libressl )
+ >=dev-libs/openssl-1.0.2h-r2
>=net-misc/curl-7.49.0
>=app-crypt/mit-krb5-1.14.2
>=sys-libs/zlib-1.2.8-r1
diff --git a/dev-dotnet/dotnetcore-sdk-bin/dotnetcore-sdk-bin-2.2.105.ebuild b/dev-dotnet/dotnetcore-sdk-bin/dotnetcore-sdk-bin-2.2.105.ebuild
index bae93b9..5603cf3 100644
--- a/dev-dotnet/dotnetcore-sdk-bin/dotnetcore-sdk-bin-2.2.105.ebuild
+++ b/dev-dotnet/dotnetcore-sdk-bin/dotnetcore-sdk-bin-2.2.105.ebuild
@@ -26,8 +26,7 @@ RDEPEND="
>=sys-libs/libunwind-1.1-r1
>=dev-libs/icu-57.1
>=dev-util/lttng-ust-2.8.1
- !libressl? ( dev-libs/openssl:0 )
- libressl? ( dev-libs/libressl )
+ >=dev-libs/openssl-1.0.2h-r2
>=net-misc/curl-7.49.0
>=app-crypt/mit-krb5-1.14.2
>=sys-libs/zlib-1.2.8-r1
diff --git a/dev-dotnet/dotnetcore-sdk/dotnetcore-sdk-1.0.0_pre2_p003121.ebuild b/dev-dotnet/dotnetcore-sdk/dotnetcore-sdk-1.0.0_pre2_p003121.ebuild
index 5b2b5c9..534a473 100644
--- a/dev-dotnet/dotnetcore-sdk/dotnetcore-sdk-1.0.0_pre2_p003121.ebuild
+++ b/dev-dotnet/dotnetcore-sdk/dotnetcore-sdk-1.0.0_pre2_p003121.ebuild
@@ -36,8 +36,7 @@ RDEPEND="
>=sys-libs/libunwind-1.1-r1
>=dev-libs/icu-57.1
>=dev-util/lttng-ust-2.8.1
- !libressl? ( dev-libs/openssl:0 )
- libressl? ( dev-libs/libressl )
+ >=dev-libs/openssl-1.0.2h-r2
>=net-misc/curl-7.49.0
>=app-crypt/mit-krb5-1.14.2"
DEPEND="${RDEPEND}
diff --git a/dev-dotnet/dotnetcore-sdk/dotnetcore-sdk-1.0.0_pre2_p003131.ebuild b/dev-dotnet/dotnetcore-sdk/dotnetcore-sdk-1.0.0_pre2_p003131.ebuild
index 477bd8f..2d2637b 100644
--- a/dev-dotnet/dotnetcore-sdk/dotnetcore-sdk-1.0.0_pre2_p003131.ebuild
+++ b/dev-dotnet/dotnetcore-sdk/dotnetcore-sdk-1.0.0_pre2_p003131.ebuild
@@ -38,8 +38,7 @@ RDEPEND="
>=sys-libs/libunwind-1.1-r1
>=dev-libs/icu-57.1
>=dev-util/lttng-ust-2.8.1
- !libressl? ( dev-libs/openssl:0 )
- libressl? ( dev-libs/libressl )
+ >=dev-libs/openssl-1.0.2h-r2
>=net-misc/curl-7.49.0
>=app-crypt/mit-krb5-1.14.2
>=sys-libs/zlib-1.2.8-r1 "
diff --git a/dev-dotnet/dotnetcore-sdk/dotnetcore-sdk-1.1.1-r1.ebuild b/dev-dotnet/dotnetcore-sdk/dotnetcore-sdk-1.1.1-r1.ebuild
index 2862503..cdb5e2e 100644
--- a/dev-dotnet/dotnetcore-sdk/dotnetcore-sdk-1.1.1-r1.ebuild
+++ b/dev-dotnet/dotnetcore-sdk/dotnetcore-sdk-1.1.1-r1.ebuild
@@ -34,8 +34,7 @@ RDEPEND="
>=sys-libs/libunwind-1.1-r1
>=dev-libs/icu-57.1
>=dev-util/lttng-ust-2.8.1
- !libressl? ( dev-libs/openssl:0 )
- libressl? ( dev-libs/libressl )
+ >=dev-libs/openssl-1.0.2h-r2
>=net-misc/curl-7.49.0
>=app-crypt/mit-krb5-1.14.2
>=sys-libs/zlib-1.2.8-r1 "
diff --git a/dev-dotnet/dotnetcore-sdk/dotnetcore-sdk-1.1.1-r2.ebuild b/dev-dotnet/dotnetcore-sdk/dotnetcore-sdk-1.1.1-r2.ebuild
index ff624a7..f190a48 100644
--- a/dev-dotnet/dotnetcore-sdk/dotnetcore-sdk-1.1.1-r2.ebuild
+++ b/dev-dotnet/dotnetcore-sdk/dotnetcore-sdk-1.1.1-r2.ebuild
@@ -35,8 +35,7 @@ RDEPEND="
>=sys-libs/libunwind-1.1-r1
>=dev-libs/icu-57.1
>=dev-util/lttng-ust-2.8.1
- !libressl? ( dev-libs/openssl:0 )
- libressl? ( dev-libs/libressl )
+ >=dev-libs/openssl-1.0.2h-r2
>=net-misc/curl-7.49.0
heimdal? (
>=app-crypt/heimdal-1.5.3-r2
diff --git a/dev-dotnet/dotnetcore-sdk/dotnetcore-sdk-1.1.1.ebuild b/dev-dotnet/dotnetcore-sdk/dotnetcore-sdk-1.1.1.ebuild
index 8bf89d1..399b1db 100644
--- a/dev-dotnet/dotnetcore-sdk/dotnetcore-sdk-1.1.1.ebuild
+++ b/dev-dotnet/dotnetcore-sdk/dotnetcore-sdk-1.1.1.ebuild
@@ -34,8 +34,7 @@ RDEPEND="
>=sys-libs/libunwind-1.1-r1
>=dev-libs/icu-57.1
>=dev-util/lttng-ust-2.8.1
- !libressl? ( dev-libs/openssl:0 )
- libressl? ( dev-libs/libressl )
+ >=dev-libs/openssl-1.0.2h-r2
>=net-misc/curl-7.49.0
>=app-crypt/mit-krb5-1.14.2
>=sys-libs/zlib-1.2.8-r1 "