aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna Vyalkova <cyber@sysrq.in>2021-05-16 21:03:24 +0500
committerAnna Vyalkova <cyber@sysrq.in>2021-05-16 21:11:07 +0500
commit1045230137a61c862f8c8c7a15792b93b69659b6 (patch)
treede9be3efd66aa5cb7bb73332271904c16eae493a
parentmedia-gfx/azpainter: fix AR and paths, drop old (diff)
downloadguru-1045230137a61c862f8c8c7a15792b93b69659b6.tar.gz
guru-1045230137a61c862f8c8c7a15792b93b69659b6.tar.bz2
guru-1045230137a61c862f8c8c7a15792b93b69659b6.zip
games-emulation/melonds: fix AR, add noexecstack
Closes: https://bugs.gentoo.org/785022 Closes: https://bugs.gentoo.org/780969 Signed-off-by: Anna Vyalkova <cyber@sysrq.in>
-rw-r--r--games-emulation/melonds/Manifest1
-rw-r--r--games-emulation/melonds/melonds-0.9.1.ebuild55
-rw-r--r--games-emulation/melonds/melonds-0.9.2.ebuild16
-rw-r--r--games-emulation/melonds/melonds-9999.ebuild16
4 files changed, 30 insertions, 58 deletions
diff --git a/games-emulation/melonds/Manifest b/games-emulation/melonds/Manifest
index 292c4a972..439e3d062 100644
--- a/games-emulation/melonds/Manifest
+++ b/games-emulation/melonds/Manifest
@@ -1,2 +1 @@
-DIST melonDS-0.9.1.tar.gz 1311519 BLAKE2B 7d31f9de32799a28f9e179d05295fe7874f6d879ac63cebeaf7153f1cca553f816fd5fa2853d01b5ace1afe137f00fcd7b4526635ae9c8140ac348630225c745 SHA512 733a9f9352b7f61c76de761c7f632f5fca9c4ae2970a0235a7b5c0e6ca2ea550762472ff293f65ce29aaa63a610bb4f1a22b62e1957004606c2f85be60fbb8f2
DIST melonDS-0.9.2.tar.gz 1330793 BLAKE2B e504dd2e1344a9680b9820f7f0308fa30decb16f40675df5649babef7ab3fae9528042fc2737a36bafdd28b9125f94a79d20e5a5e791d485feb9dc26b64b1432 SHA512 3d099af675acdcb91431aaaf95bc27c10fd432ebd29aa81c7eb4e65dfad9c20cb4fd5de086d2162cbe4a6b41f7e140880a5742b1ec34eef0511fff052aa1baaa
diff --git a/games-emulation/melonds/melonds-0.9.1.ebuild b/games-emulation/melonds/melonds-0.9.1.ebuild
deleted file mode 100644
index 9e9589527..000000000
--- a/games-emulation/melonds/melonds-0.9.1.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 2019-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-MY_PN="melonDS"
-MY_P="${MY_PN}-${PV}"
-
-inherit xdg cmake
-
-DESCRIPTION="Nintendo DS emulator, sorta"
-HOMEPAGE="
- http://melonds.kuribo64.net
- https://github.com/Arisotura/melonDS
-"
-
-if [[ "${PV}" == *9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/Arisotura/${MY_PN}.git"
-else
- SRC_URI="https://github.com/Arisotura/${MY_PN}/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
- KEYWORDS="~amd64"
- S="${WORKDIR}/${MY_P}"
-fi
-
-LICENSE="GPL-3"
-SLOT="0"
-
-DEPEND="
- dev-qt/qtcore:5
- dev-qt/qtdeclarative:5
- dev-qt/qtgui:5
- dev-qt/qtwidgets:5
- media-libs/libsdl2[sound,video]
- net-libs/gnutls
- net-libs/libpcap
- net-libs/libslirp
- net-misc/curl
- x11-libs/cairo
-"
-RDEPEND="
- ${DEPEND}
-"
-
-pkg_postinst() {
- xdg_pkg_postinst
-
- elog "You need the following files in order to run melonDS:"
- elog "- bios7.bin"
- elog "- bios9.bin"
- elog "- firmware.bin"
- elog "- romlist.bin"
- elog "Place them in ~/.config/melonDS"
- elog "Those files can be found somewhere on the Internet ;-)"
-}
diff --git a/games-emulation/melonds/melonds-0.9.2.ebuild b/games-emulation/melonds/melonds-0.9.2.ebuild
index b567fa8d7..9113b2611 100644
--- a/games-emulation/melonds/melonds-0.9.2.ebuild
+++ b/games-emulation/melonds/melonds-0.9.2.ebuild
@@ -6,7 +6,7 @@ EAPI=7
MY_PN="melonDS"
MY_P="${MY_PN}-${PV}"
-inherit xdg cmake
+inherit cmake flag-o-matic toolchain-funcs xdg
DESCRIPTION="Nintendo DS emulator, sorta"
HOMEPAGE="
@@ -44,6 +44,20 @@ RDEPEND="
${DEPEND}
"
+src_prepare() {
+ cmake_src_prepare
+}
+
+src_configure() {
+ append-ldflags -Wl,-z,noexecstack
+ cmake_src_configure
+}
+
+src_compile() {
+ tc-export AR
+ cmake_src_compile
+}
+
pkg_postinst() {
xdg_pkg_postinst
diff --git a/games-emulation/melonds/melonds-9999.ebuild b/games-emulation/melonds/melonds-9999.ebuild
index b567fa8d7..9113b2611 100644
--- a/games-emulation/melonds/melonds-9999.ebuild
+++ b/games-emulation/melonds/melonds-9999.ebuild
@@ -6,7 +6,7 @@ EAPI=7
MY_PN="melonDS"
MY_P="${MY_PN}-${PV}"
-inherit xdg cmake
+inherit cmake flag-o-matic toolchain-funcs xdg
DESCRIPTION="Nintendo DS emulator, sorta"
HOMEPAGE="
@@ -44,6 +44,20 @@ RDEPEND="
${DEPEND}
"
+src_prepare() {
+ cmake_src_prepare
+}
+
+src_configure() {
+ append-ldflags -Wl,-z,noexecstack
+ cmake_src_configure
+}
+
+src_compile() {
+ tc-export AR
+ cmake_src_compile
+}
+
pkg_postinst() {
xdg_pkg_postinst